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Event Source Product Information:

Vendor: Symantec
Event Source: Endpoint Protection, AntiVirus Corporate Edition
Versions: 9.0, 10.x, 11, 11.0.5, 11.0.6, 12.x, 14, 15 (Syslog only)

 

RSA Product Information:

Supported On: NetWitness Platform 10.0 and later
Event Source Log Parser: symantecav
Collection Method: SNMP, Syslog, ODBC
Event Source Class.Subclass: Security.Antivirus
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This document describes how to configure the Symantec event source to communicate with 
the RSA NetWitness Platform.This document contains the following sections:

 l Symantec Collection Methods

 l Configure Syslog

 l Configure ODBC

 l Configure AntiVirus SNMP Traps

2



Event Source Log Configuration Guide

Symantec Collection Methods
To integrate Symantec Endpoint Protection with RSA NetWitness Platform, you can 
choose among several collection methods, depending on your environment and the types 
of messages that you want to collect.

Collect via SNMP
If you set up SNMP collection, you can collect antivirus messages.

Collect via Syslog
If you set up Syslog collection, you can collect the following logs:

 l Management Server Logs

 l System Administrative log

 l System Client-Server Activity log

 l Audit log

 l System Server Activity log

 l Client Logs

 l Activity log

 l Security log

 l Traffic log

 l Packet log

 l Control log

 l Scan log

 l Risk Log

 l Proactive Threat Protection log

Symantec Collection Methods 3



Event Source Log Configuration Guide

Collect via ODBC
If you set up ODBC collection, you can collect different logs, depending on your Symantec 
version.

Symantec Endpoint Protection version 12

If you set up ODBC collection, you can collect the following logs for Symantec Endpoint 
Protection version 12:

 l System Server activity logs

 l Scan logs

 l Client Activity log

 l Client Behavior logs

 l Client Security log

 l Client Traffic log

Symantec Endpoint Protection version 11

If you set up ODBC collection, you can collect the following logs for Symantec Endpoint 
Protection version 11:

 l System Server activity logs

 l Scan logs

4 Collect via ODBC
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Configure Syslog
To configure Syslog, perform the following tasks:

 l Configure Symantec Endpoint Protection for Syslog

 l Configure RSA NetWitness Platform for Syslog Collection

Configure Symantec Endpoint Protection for Syslog
Perform the following procedure to configure Symantec Endpoint Protection to collect 
Syslog.

To configure Symantec Endpoint Protection for Syslog:

 1. Log on to the Symantec Endpoint Protection Manager Console with    administrative 
credentials.

 2. Click the Admin icon.

 3. Click Servers.

 4. Click the local or remote site from which you want to export log data.

 5. Click Configure External Logging.

 6. On the General tab, select Enable Transmission of Logs    to a Syslog Server, and 
the parameters as follows.

Field Value

Syslog Server the IP address of the RSA NetWitness Log Decoder or Remote 
Log Collector

UDP Destination 
Port

514

Log Facility 6

 7. On the Log Filter tab, select the logs that you want to monitor.    Select any of the 
following logs:

Configure Syslog 5
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 l Management Server Logs

 n System Administrative Log

 n System Client-Server Activity Log

 n Audit Log

 n System Server Activity Log

 l Client Logs

 n Client Activity Log

 n Security Log

 n Traffic Log

 n Packet Log

 n Control Log

 n Scan Log

 n Risk Log

 n Proactive Threat Protection Log

 8. Click OK.

Configure RSA NetWitness Platform for Syslog Collection

Note: You only need to configure Syslog collection the first time that you set up an event 
source that uses Syslog to send its output to NetWitness.

You should configure either the Log Decoder or the Remote Log Collector for Syslog. You 
do not need to configure both.

To configure the Log Decoder for Syslog collection:

 1. In the NetWitness menu, select ADMIN > Services.

 2. In the Services grid, select a Log Decoder, and from the Actions menu, choose  View 
> System. 

 3. Depending on the icon you see, do one of the following:

6 Configure RSA NetWitness Platform for Syslog Collection



Event Source Log Configuration Guide

 l If you see , click the icon to start capturing Syslog.

 l If you see , you do not need to do anything; this Log Decoder is 

already capturing Syslog.

To configure the Remote Log Collector for Syslog collection:

 1. In the NetWitness menu, select ADMIN > Services.

 2. In the Services grid, select a Remote Log Collector, and from the Actions menu, 
choose  View > Config > Event Sources.

 3. Select Syslog/Config from the drop-down menu.

The Event Categories panel displays the Syslog event sources that are configured, if 
any.

 4. In the Event Categories panel toolbar, click  +.

The Available Event Source Types dialog is displayed.

 5. Select either syslog-tcp or syslog-udp. You can set up either or both, depending on 
the needs of your organization.

 6. Select the new type in the Event Categories panel and  click  +     in the Sources panel 
toolbar.

The Add Source dialog is displayed.

 7. Enter 514 for the port, and select Enabled. Optionally, configure any of the 
Advanced parameters as necessary.

Click OK to accept your changes and close the dialog box.

After you configure one or both syslog types, the Log Decoder or Remote Log Collector 
collects those types of messages from all available event sources. So, you can continue 
to add Syslog event sources to your system without needing to do any further 
configuration in NetWitness.

Configure RSA NetWitness Platform for Syslog Collection 7
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Configure ODBC Collection
To configure  the Internet Scanner or RealSecure for ODBC collection, perform the 
following tasks in RSA NetWitness Platform:

 I. Ensure the required parser is enabled

 II. Configure a DSN

 III. Add the Event Source Type

Ensure the Required Parser is Enabled
If you do not see your parser in the list while performing this procedure, you need to 
download it from RSA NetWitness Platform Live.

Ensure that the parser for your event source is enabled:

 1. In the NetWitness menu, select ADMIN > Services.

 2. In the Services grid, select a Log Decoder, and from the Actions menu, choose  View 
> Config. 

 3. In the Service Parsers Configuration panel, search for your event source, and ensure 
that the Config Value field for your event source is selected.

Note: The required parser is symantecav.

Configure a DSN

Configure a DSN (Data Source Name):

 1. In the NetWitness menu, select ADMIN > Services.

 2. In the Services grid, select a Log Collector service.

 3. Click  under Actions and select View > Config.

 4. In the Log Collector Event Sources tab, select ODBC/DSNs from the drop-down 
menu.

 5. The DSNs panel is displayed with the existing DSNs, if any.

 6. Click  + to open the Add DSN dialog.

8 Configure ODBC Collection
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Note: If you need to add a DSN template, see the "Configure DSNs" topic in the 
Log Collection Configuration Guide, available in RSA Link.

 7. Choose a DSN Template from the drop down menu and enter a name for the DSN. 
(You use the name when you set up the ODBC event source type.)

 8. Fill in the parameters and click Save.

Field Description

DSN Template Choose the correct template from the available choices.

DSN Name Enter a descriptive name for the DSN

Parameters section

Database Specify the database used by Symantec Endpoint Protection

PortNumber Specify the Port Number. The default port number is 1433

HostName Specify the hostname or IP Address of Symantec Endpoint Protection

Driver Depending on your NetWitness Log Collector version:

 l For 10.6.2 and newer, use /opt/netwitness/odbc/lib/R3sqls27.so

 l For 10.6.1 and older, use /opt/netwitness/odbc/lib/R3sqls26.so

Add the ODBC Event Source Type

Add the ODBC Event Source Type:

 1. In the NetWitness menu, select ADMIN > Services.

 2. In the Services grid, select a Log Collector service.

 3. Click  under Actions and select View > Config.

 4. In the Log Collector Event Sources tab, select ODBC/Config from the drop-down 
menu.

The Event Categories panel is displayed with the existing sources, if any.

 5. Click  + to open the Available Event Source Types dialog.

Add the ODBC Event Source Type 9
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 6. Choose the log collector configuration type for your event source type and click OK.

From the Available Event Source Types dialog, select the appropriate value for your 
version:

 l For version 11 and earlier, select symantecep

 l For version 12 and later, select symantecepv12

 7. In the Event Categories panel, select the event source type that you just added.

 8. In the Sources panel, click  + to open the Add Source dialog.

 9. Enter the DSN you configured during the Configure a DSN procedure.

10 Add the ODBC Event Source Type
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 10. For the other parameters, see the "ODBC Event Source Configuration Parameters" 
topic in the RSA NetWitness Platform  Log Collection Guide.

Add the ODBC Event Source Type 11
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Configure  SNMP Traps
To configure SNMP Traps, perform the following tasks:

 l Configure Symantec Endpoint Protection for SNMP

 l In RSA NetWitness Platform, Add the SNMP Event Source Type

 l In RSA NetWitness Platform, Configure SNMP Users

Configure Symantec Endpoint Protection for SNMP
You must configure Symantec Antivirus to send SNMP traps to the RSA NetWitness 
Platform Log Decoder or Remote Log Collector designated as the collector of Symantec 
events.

Note: The administrator performing this task must be familiar with the Symantec System 
Console.

Warning: Configure each physical device running Symantec Antivirus to send traps, in 
addition to the master server   running the Symantec System Center.

To configure Symantec AntiVirus for SNMP:

 1. On your Symantec Antivirus Corporate server, set up and configure the Symantec 
Antivirus and the Symantec Asset Management Suite (AMS) server according to the 
vendor’s instructions.

 2. On your Symantec Antivirus Corporate server, configure the NetWitness Platform Log 
Decoder or Remote Log Collector as the destination address of the SNMP Service. 
Follow these steps:

 a. Click START > All Programs > Administrative Tools > Services.

 b. Right-click SNMP Service, and select Properties.

 c. Click the Traps tab.

 d. In the Community Name field, type NetWitness Platform, and click Add to list.

 e. Click Add.

 f. Enter the IP address of the NetWitness Platform Log Decoder or Remote Log 
Collector, and click Add.

12 Configure SNMP Traps
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 g. Click Apply.

 h. Click OK.

 3. Ensure that the SNMP Service is Running and is set to Automatic.  

 4. To configure the AMS Admin Utility  to send SNMP traps to RSA NetWitness 
Platform, follow these steps:

 a. Start the AMS Admin Utility.

 b. Click Configure AMS.

 c. Expand Symantec Antivirus Corporate Edition, and select Virus Found.

 d. Click Configure.

 e. Select Send SNMP Trap and click Next.

 f. Select the Symantec Antivirus Server, and click Next.

 g. Clear the Alert Message Box field, and add the following message to the field:

<Actual Action>
<Alert Name>
<Computer Name>
<Date>
<File Path>
<Logger>
<Requested Action>
<Severity>
<Source>
<Time>
<User>
<Virus Name>

 h. Set Action Name to NetWitness Platform, and click Finish.

Add the SNMP Event Source Type

Note: If you have previously added the snmptrap type, you cannot add it again. You 
can edit it, or manage users.

Add the SNMP Event Source Type:

 1. In the RSA NetWitness Platform menu, select Administration > Services.

 2. In the Services grid, select a Log Collector service.

 3. Click 

Add the SNMP Event Source Type 13
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 under Actions and select View > Config.

 4. In the Log Collector Event Sources tab, select SNMP/Config from the drop-down 
menu.

The Sources panel is displayed with the existing sources, if any.

 5. Click  + to open the Available Event Source Types dialog.

 6. Select snmptrap from the Available Event Source Types dialog and click OK.

 7. Select snmptrap in the Event Categories panel.

 8. Select snmptrap in the Sources panel and then click the Edit icon to edit the 
parameters.

14 Add the SNMP Event Source Type
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 9. Update any of the parameters that you need to change.

(Optional) Configure SNMP Users
If you are using SNMPv3, follow this procedure to update and maintain the SNMP v3 
users.

Configure SNMP v3 Users

 1. In the RSA NetWitness Platform menu, select Administration > Services.

 2. In the Services grid, select a Log Collector service.

 3. Click  under Actions and select View > Config.

 4. In the Log Collector Event Sources tab, select SNMP/SNMP v3 User Manager 
from the drop-down menu.

The SNMP v3 User panel is displayed with the existing users, if any.

 5. Click  + to open the Add SNMP User dialog.

(Optional) Configure SNMP Users 15
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 6. Fill in the dialog with the necessary parameters. The available parameters are 
described below.

SNMP User Parameters
The following table describes the parameters that you need to enter when you create an 
SNMP v3 user.

Parameter Description

Username * User name (or more accurately in SNMP terminology, security name).  
RSA NetWitness Platform uses this parameter and the Engine ID 
parameter to create a user entry in the SNMP engine of the collection 
service.

The Username and Engine ID combination must be unique (for 
example, logcollector).

Engine ID (Optional) Engine ID of the event source. For all event sources sending 
SNMP v3 traps to this collection service, you must add the username 
and engine id of the sending event source.

For all event sources sending SNMPv3 informs, you must add just the 
username with a blank engine id.

Authentication
Type

(Optional) Authentication protocol. Valid values are as follows:

 l None (default) - only security level of noAuthNoPriv can be used 
for traps sent to this service

 l SHA - Secure Hash Algorithm

16 SNMP User Parameters
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Parameter Description

 l MD5 - Message Digest Algorithm

Authentication
Passphrase

Optional if you do not have the Authentication Type set.  
Authentication passphrase.

Privacy Type (Optional) Privacy protocol. You can only set this parameter if 
Authentication Type parameter is set.  Valid values are as follows:

 l  None (default)

 l  AES - Advanced Encryption Standard

 l  DES - Data Encryption Standard

Privacy
Passphrase

Optional if you do not have the Privacy Type set.  Privacy passphrase.

Close Closes the dialog without adding the SNMP v3 user  or saving 
modifications to the parameters.

Save Adds the SNMP v3 user parameters or saves modifications to the 
parameters.

Copyright © 2019 Dell Inc. or its subsidiaries. All Rights Reserved.

Trademarks

For a list of RSA trademarks, go to www.emc.com/legal/emc-corporation-
trademarks.htm#rsa.
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