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To configure the Kubernetes event source, you must complete these tasks::

I. Configure Kubernetes to Send Audit Logs to Logstash

II. Configure Filebeat DaemonSet

III. Deploy Logstash Kubernetes Pipeline Files from LIVE

IV. Deploy Kubernetes Parser from LIVE

V. Set Up Kubernetes Event Source in NetWitness Platform XDR

VI. Configure NetWitness Platform to Collect Events
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Configure Kubernetes to Send Audit Logs to Logstash

Kube-apiserver is a component of Kubernetes which performs auditing. Each request on each stage of its
execution generates an event, which is then pre-processed according to a certain policy and written to a
backend log files. The policy determines what's recorded and the log files persist the records.

To configure Kubernetes to send audit logs to Logstash:

1. On the Kubernetes appliance, create the directory /var/1ib/k8s audit on the master node.

2. Copy the provided audit-policy.yaml file into the directory /var/lib/k8s_ audit. (This
directory will have access to te audit log files since it is mounted to the API server.)

3. Edit the kube-apiserver.yaml manifest file which has configurations accessed by kube-
apiserver. The relevant section of the kube-apiserver.yaml will be as follows:

spec:

containers:

- command:

- kube-apiserver

--audit-log-path=/var/lib/k8s audit/audit.log
--audit-policy-file=/var/lib/k8s audit/audit-policy.yaml
-—audit-log-maxbackup=10

-—audit-log-maxsize=10

-—audit-dynamic-configuration

--feature-gates=DynamicAuditing=true

Note: Following table provides the explanation for each of the arguments. The customer can set
the values to the arguments based on their requirement.

Argument Description

audit-log-path If set, all requests coming to the apiserver will be logged to this file.

audit-policy-file Path to the file that defines the audit policy configuration

audit-log-maxbackup =~ The maximum number of old audit log files to retain.

audit-log-maxsize The maximum size of the audit log file (in Megabytes) before it gets
rotated.

audit-dynamic- Enables dynamic audit configuration. This feature also requires the

configuration DynamicAuditing feature flag.

feature- Set of "key=value" pairs that describe feature gates for alpha or

gates=DynamicAuditing experimental features.

4. Mount the directory containing policy file and log files onto the Kubernetes container.

6 Configure Kubernetes to Send Audit Logs to Logstash
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The relevant section for mounting the directory /var/1ib/k8s_audit where our policy file and
logs are located onto the kube-apiserver container will be as follows:

volumeMounts:
- mountPath: /var/lib/k8s audit/

name: k8s-audit

volumes:

- hostPath:

path: /var/lib/k8s audit
type: DirectoryOrCreate

name: k8s-audit

5. We have provided a sample audit-policy.yml file. The customer can create own policy file. For
information on creating own policy file, click here.

Note: The kube-apiserver should be in running state after the above configuration changes are
made.

Configure Kubernetes to Send Audit Logs to Logstash 7
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Configure Filebeat DaemonSet

Note: Deploy Filebeat as a DaemonSet to ensure there is a running instance on each node of the
cluster.

To configure the Filebeat DaemonSet:
1. Download the daemonset file filebeat-kubernetes.yaml.

2. The kubernetes audit logs host folder (/var/lib/k8s audit/) is mounted on the Filebeat
container. The sample is as follows:

volumeMounts:

- name: k8s-audit

mountPath: /var/lib/k8s audit/
readOnly: true

volumes:

- name: k8s-audit

hostPath:

path: /var/lib/k8s audit

type: DirectoryOrCreate

3. Filebeat starts an input for the files (/var/lib/k8s audit/*audit*.log) and begins harvesting
them as soon as they appear in the folder. The format of the log is provided as json.Following is the
filebeat input section:

filebeat.inputs:
- type: log
paths:

- /var/lib/k8s audit/*audit*.log

4. The kubernetes server logs host folder (/var/log/containers/) is mounted on the Filebeat
container. The sample is as follows:

volumeMounts:

- name: server

mountPath: /var/log/containers/
readOnly: true

volume:

- name: server

hostPath:

path: /var/log/containers/

8 Configure Filebeat DaecmonSet
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type: DirectoryOrCreate

5. Filebeat starts an input for the files (/var/log/containers/kube-apiserver-+*.log) and
begins harvesting them as soon as they appear in the folder. The format of the log is provided as
json.Following is the filebeat input section:

filebeat.inputs:
- type: log
paths:

- /var/log/containers/kube-apiserver-*.log

6. Everything is deployed under the kube-system namespace by default. To change the namespace,
modify the filebeat-kubernetes.yaml file. The sample is as follows:

metadata:
name: <name>

namespace: kube-system

7. Provide the output destination as logstash. This will route Kubernetes audit events to the Logstash
service. Edit the filebeat-kubernetes.yaml and enter the logstash ip address as follows:

output.logstash:
# The Logstash hosts

hosts: ["<logstash-ip-address>:5044"]

8. Deploy the filebeat-kubernetes.yaml to create the configMap, daemonset and service account.
and The role is created to provide the required permissions for Filebeat pods. Use the Kubectl for
deployment which allows you to run commands against Kubernetes clusters. The sample file
structure is Kubectl apply -f filebeat-kubernetes.yaml.

Configure Filebeat DaemonSet 9
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Deploy Logstash Kubernetes Pipeline Files from LIVE

Logstash Kubernetes Pipeline files requires resources available in Live to collect logs.
To deploy Logstash Kubernetes Pipeline files from Live:
1. In the NetWitness Platform XDR menu, select Configure > Live Content.

2. Browse Live for Logstash Kubernetes Pipeline files by typing 'Kubernetes' into the Keywords text
box and click Search.

3. Select the item returned from the search.

4. Click Deploy to deploy the Logstash Kubernetes Pipeline files to the appropriate Log Collector using
the Deployment Wizard.

NETWITNESS Investigate Respond Users Hosts Files Dashboard Reports admin v

LIVE CONTENT SUBSCRIPTIONS CAPTURE POLICIES POLICIES INCIDENT RULES INCIDENT NOTIFICATIONS ESA RULES CUSTOM FEEDS

Search Criteria Matching Resources
Keywords = show Results K Package
kubernetes Certain services are managed by Centralized Content Management(CCM). To manage content on those services, click hes
Category Subscribed Name Created Updated Type
I FEATURED [0 no Log Collector content for Logstash kubernetes Pipeline 2023-02-02 5:50 AM 2023-02-02 5:50 AM Log Collector
» O THREAT

10 Deploy Logstash Kubernetes Pipeline Files from LIVE
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Deploy Kubernetes Parser from LIVE

Kubernetes parser requires resources available in Live to parse logs.
To deploy Kubernetes content from Live:
1. In the NetWitness Platform XDR menu, select Configure > Live Content.

2. Browse Live for Kubernetes parser by typing kubernetes into the Keywords text box and click
Search.

3. Select the item related to the parser returned from the Search.

4. Click Deploy to deploy the Kubernetes parser to the appropriate Log Decoder using the Deployment
Wizard

NETWITNESS Investigate Respond Users Hosts Files Dashboard Reports admin

LIVE CONTENT SUBSCRIPTIONS CAPTURE POLICIES POLICIES INCIDENT RULES NCIDENT NOTIFICATIONS ESA RULES CUSTOM FEEDS LOG PARSER RULES

Search Criteria Matching Resources
Keywords & Show Results | [ Details B, Deploy 3 Subscribe | 3§ Package
kubernetes Certain services are managed by Centralized Content Management(CCM). To manage content on those services, cli
Category Subscribed Name Created Updated Type Description
[CJFEATURED no Log Collector ... 2023-02-025:5.. 2023-0202 5 Log Log Collector content for Logstash kubernetes Pipeline
» I THREAT ¥ no Kubernetes  2023-02-0312.. 2023-020312.. Log.. Logdevice content for event source Kubernetes - kubernetes, Parser Version: 2, Event Source Upda...

Deploy Kubernetes Parser from LIVE 11



Kubernetes Event Source Log Configuration Guide

Set Up Kubernetes Event Source in NetWitness
Platform XDR

To configure the Kubernetes Event Source:
1. In the NetWitness Platform XDR menu, select Admin > Services.

2. In the Services grid, select a Log Collector service, and from the Actions (* *') menu, choose View
> Config.

3. In the Event Sources view, select Logstash / Config from the drop-down menu.

NETWITNESS Investigate Respond Users Hosts Files Dashboard Reports admin v

HOSTS SERVICES EVENT SOURCES ENDPOINT SOURCES HEALTH & WELLNESS SYSTEM SECURITY

- Change Service | logdecoder1 - Log Collector | Config &

~eneral Remote Collectors Files AVIELII(El  Event Destinations  Settings  Appliance Service Configuration

v Config v [E8 Event Source Configuration Guids
Event Categories Sources
+ - + = [Z & importSource M ExportSource ¥ Test Configuration Filter by Name / Address X
Y Neme ¥ Name Enabled Description Port Number Event Desti ssL SSL  Additional Custon Required Plugins  Pipeline Workers
i DolEEes ¥ kubernetes true 5044 101252454 false true 0
4. In the Event Categories panel toolbar, click .
5. Select Kubernetes from the list and in the Sources panel, click .

The Add Source dialog is displayed.

12 Set Up Kubernetes Event Source in NetWitness Platform XDR
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Add Source

Basic
Name * kubernetes
Enabled T4
Description Enter description for Logstash pipeline
Port Number * 5044 °
Event Destination * logdecoder1 v
Advanced
@ Configuration can be saved only when the test configuration is successful
Test Configuration
& Test connection successful
Cancel oK

6. Define parameter values, as described in Kubernetes Collection Configuration Parameters.

7. Click Test Configuration.

The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the device or
service information and retry.

Note: The Log Collector takes approximately 60 seconds to return the test results. If it exceeds the
time limit, the test times out and NetWitness Platform displays an error message.

8. If the test is successful, click OK. The new event source is displayed in the Sources panel.

9. Save the configuration. From the Actions menu choose System.

Set Up Kubernetes Event Source in NetWitness Platform XDR 13
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NETWITNESS Investigate Respond Users Hosts Files Dashboard Reports admin v

HOSTS SERVICES EVENT SOURCES ENDPOINT SOURCES HEALTH & WELLNESS SYSTEM SECURITY

-+ Change Service | logdecoder1 - Log Collector |
System
Stats.

General  Remote Collectors Files stinations  Settings  Appliance Service Configuration

Logstash v Config 8 Event Source Configuration Guid:

Explore
. Logs
Event Categories Sources )
Security
+ - + = [Z & importsource P Export Source M Test Configuration Filter by Name / Address X
“
pang ¥ Name Enabled Description Port Number Event Destinati ssL ination SSL  Additional Custonr Required Plugins  Pipeline Workers
4 5
pbemete ¥ kubernetes true 5044 101252454  false true 0

10. In the Collection drop-down menu, select Logstash > Start, to start the log collection.

NETWITNESS \ e Respond Users Hosts Files ashboard Reports admin v

HOSTS  SERVICES VE CES RCES ~ HEALT ELLNESS SYSTEM  SECURITY

¢ Change Service | I logdecoder - Log Collector |  System @
8 Host Tasks & Shutdown Service () Shutdown Appliance Service & Reboot
File >
[ 0DBC > irvice Information Appliance Service Information
[ Check Point >
= wind oder (Log Collector) Name logdecoder (Host)
) Windows >
& VMware 5 0-15067.5.612c783f (Rev null) 12.2.0.0 (Rev null)
T spee > 3(0.42% of 32174 MB) Memory Usage 33640 KB (0.10% of 32174 MB)
[ Syslog > CPU 4%
@ sNwp 5 In-17 gA0:06 Running Since  2023-an-13 09:33:53
T Netflow » 10 hours 52 minutes 9 seconds Uptime 5 days 21 hours 28 minutes 23 seconds
m Plugins » In-19 07:02:15 Current Time ~ 2023-Jan-19 07:02:16

Host User Information

Name admin

admin

Sroups Administrators Administrators

Roles connections.manage, logcollection.manage, logs.manage, sdk.content, appliance.manage, connections.manage, logs.manage, services.manage,
sdk.manage, sdk.meta, services.manage, storedproc.execute, storedproc.execute, storedproc.manage, sys.manage, users.manage
storedproc.manage, sys.manage, users.manage

Kubernetes Collection Configuration Parameters

The tables below list the configuration parameters required for integrating Kubernetes with NetWitness
Platform XDR.

Note: Fields that are followed by an asterisk (*) are mandatory.

Basic Parameters

Description

Name * Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Enabled Select the check box to enable the event source configuration to start collection. The
check box is selected by default.

Description Enter a text description for the event source.

Port Number*  Enter the port number that you configured for your event sources. The default value
of port number is 5044.

14 Set Up Kubernetes Event Source in NetWitness Platform XDR
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e o

Event
Destination*

Test
Configuration

Advanced Parameters

Select the NetWitness Log Collector or Log Decoder to which event needs to be
send from the drop-down list.

Checks the configuration parameters specified in this dialog to make sure they are

R

Debug

Kubernetes SSL

Certificate *

Key *

Caution: Only enable debugging (set this parameter to On or
Verbose) if you have a problem with an event source and you need
to investigate this problem.

Caution: Enabling debugging will adversely affect the
performance of the Log Collector.

Enables or disables debug logging for the event source. Valid values
are:

¢ Off = (default) disabled
¢ On = enabled

¢ Verbose = enabled in verbose mode - adds thread information and
source context information to the messages.

This parameter is designed for debugging and monitoring isolated
event source collection issues. If you change this value, the change
takes effect immediately (no restart required). The debug logging is
verbose, so limit the number of event sources to minimize
performance impact.

Select this checkbox to communicate using Kubernetes SSL. The
security of data transmission is managed by encrypting information
and providing authentication with SSL certificates. This check box is
not selected by default.

Note: Ensure that you copy the server SSL certificate and the key
(generated in your system) to /etc/logstash/pki on Log
Collector, which is used during SSL connection.
/etc/logstash/pki is a path in the Log Collector node.

Select the name of a server SSL certificate located at
/etc/logstash/pki,

Select the name of a server SSL key located at
/etc/logstash/pki,

Set Up Kubernetes Event Source in NetWitness Platform XDR 15
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e o

Destination SSL Select the check box to communicate using SSL. The security of data
transmission is managed by encrypting information and providing
authentication with SSL certificates. This check box is selected by

default.
Additional Custom Use this text box for any additional configuration, in case you have
Configuration multiple inputs or another set of outputs to send somewhere in

addition to a NetWitness Log Collector or Log Decoder. For
example, you can configure the data to be sent to Elasticsearch. In
this case, each event that is sent to Netwitness Platform XDR will
also be send to Elasticsearch.

Required Plugins Specify the required plugins in a comma separated list.

Note:

- Backup and restore is not supported for custom plugins.

- If the test connection failed due to required plugin is not installed,
you must install the required plugin. For more information, see
Install or Manage Logstash Plugin.

Required Ports Enter the list of ports required for external access.

Pipeline Workers Number of pipeline worker threads allocated for logstash pipeline.

16 Set Up Kubernetes Event Source in NetWitness Platform XDR
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Configure NetWitness Platform to Collect Events

To configure NetWitness platform to collect events:

1. You must start capture on the Log Decoder to which you are sending the Logstash data. To start or
restart network capture on a Log Decoder:

i. In the NetWitness Platform XDR menu, select Admin > Services. The Services view is
displayed.

ii. Select a Log Decoder service.
iii. Under Actions, select View > System.

iv. In the toolbar, click Start Capture.

Note: If the toolbar is displaying the Stop Capture () icon, then capture has already started.

By default, Log Decoders support events that are up to 32 KB in size. If the events are getting
truncated on the Log Decoder, use the following procedure to change the event size:

1. Change LogDecoder REST config at http://LogDecoder
IP:50102/decoder/config, where LogDecoder IP is the IP address of your Log Decoder.

2. Set pool.packet.page.size to 64 KB.

3. Restart the Log Decoder. This is required after you change the pool.packet.page value.

Note: If you are collecting events larger than 64 KB in size, follow instructions above in the
Filter out unwanted logs section. You can drop unwanted logs or fields for a specific event
source to reduce the size of the incoming data.

Configure NetWitness Platform to Collect Events 17
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Getting Help with NetWitness Platform XDR

Self-Help Resources

There are several options that provide you with help as you need it for installing and using NetWitness:

e See the documentation for all aspects of NetWitness here:
https://community.netwitness.com/t5/netwitness-platform/ct-p/netwitness-documentation.

» Use the Search and Create a Post fields in NetWitness Community portal to find specific
information here: https://community.netwitness.com/t5/netwitness-discussions/bd-p/netwitness-
discussions.

» See the NetWitness Knowledge Base: https://community.netwitness.com/t5/netwitness-knowledge-
base/tkb-p/netwitness-knowledge-base.

» See Troubleshooting section in the guides.
* See also NetWitness® Platform Blog Posts.

e If you need further assistance, Contact NetWitness Support.

Contact NetWitness Support

When you contact NetWitness Support, please provide the following information:
* The version number of the NetWitness Platform XDR or application you are using.

o Logs information, even source version, and collection method.

« If you have problem with an event source, enable Debug parameter (set this parameter to On or
Verbose) and collect the debug logs to share with the NetWitness Support team.

Use the following contact information if you have any questions or need assistance.

NetWitness Community Portal https://community.netwitness.com
In the main menu, click Support > Case Portal > View My
Cases.

International Contacts (How to https://community.netwitness.com/t5/support/ct-p/support

Contact NetWitness Support)

Community https://community.netwitness.com/t5/netwitness-discussions/bd-
p/netwitness-discussions

18 Getting Help with NetWitness Platform XDR
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Feedback on Product Documentation

You can send an email to nwdocsfeedback@netwitness.com to provide feedback on NetWitness Platform
documentation.

Getting Help with NetWitness Platform XDR 19
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