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How Warehouse Connector Works

Warehouse Connector collects meta and events from Decoder and Log Decoder and writes them in
AVRO format into a Hadoop-based distributed computing system. You can set up the Warehouse
Connector as a service on existing Log Decoders or Decoders.

The Warehouse Connector contains the following components:
o Data Source
o Destination

o Data Stream

Data Source

Warehouse Connector collects data from the data source to store it in the destination. The supported data
sources are Log Decoder and Decoder.

Destination

Destination is the Hadoop-based distributed computing system that collects, manages, and enables
reporting on security data. The following are the supported destinations:

o RSA NetWitness Warehouse (MapR) deployments
o HortonWorks Data Platform

o Any Hadoop-based distributed computing system that supports WebHDFS or NFS mounting of HDFS
file systems.
Example: Commercial MapR M5 Enterprise Edition for Apache Hadoop

Data Streams

A data stream is a logical connection between the data source and destination. You can have multiple
streams for different subsets of data collected. You can setup streams to segregate data from multiple
Decoder and Log Decoder services. You can create a stream with a single data source and destination
or with multiple data sources and a single destination.

The Warehouse Connector:

o Aggregates session and raw log data from Decoders and Log Decoders.

o Transfers the aggregated data to supported destinations like Hadoop based deployments.
o Serializes the aggregated data that includes both schema and data into AVRO format.

Meta Filters

Meta filters enables you to filter the meta keys that should be written into the Warehouse. For more
information, see Specify Meta Filters for a Stream.
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Multi-Valued Meta Keys

RSA NetWitness Warehouse supports multi-valued meta keys. The multi-valued meta keys is the meta
field with the array type. You can use the meta keys library to determine the meta fields of type array
and write HIVE queries with the correct syntax for arrays. By default, the following meta keys are
treated as multi-valued and are defined in the file, multivalue-bootstrap.xml located at
/ete/netwitness/ng in the Warehouse Connector:

o alias.host
e action

e username
o alias.ip
o alias.ipv6
o cmail

o device.group

o event.class

Checksum Validation

You can validate the file integrity of the AVRO files that are transferred from the Warehouse Connector
to the data destinations. You need to enable checksum validation option when you configure the
Warehouse Connector.

Lockbox Support

Lockbox provides an encrypted file that Warehouse Connector uses to store and protect sensitive data.
You need to create the lockbox by providing a lockbox password while configuring the Warehouse
Connector for the first time.

Note: You can orchestrate Warehouse Connector on a Log Decoder or a Decoder appliance.

The following is an overview on how to install and configure the Warehouse Connector service on Log
Decoder or Decoder.

o Configuring the Warehouse Connector service on NetWitness,
o Configuring data sources,

o Destinations,

o Streams for Warehouse Connector,

o Configuring alert notifications on NetWitness.

Note: RSA NetWitness Platform has added a Health & Wellness stat for Warehouse Connector to
indicate the status of its Lockbox. Also, an out-of-the-box rule has been added so that a Health &
Wellness alarm is raised when the Lockbox does not exist or cannot be opened.

Warehouse Connector Configuration 5
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Install Warehouse Connector | Configure a Warehouse

Configure a Destination Add Warehouse as a Data
Service on a Log Decoder or Connector Service Source to Reporting
Decoder

Configure Destination ERERE
using NFS, SFTP, and

WebHDFS

Create a Lockbox

Analyze a Warehouse

Configure the Data Source Configure a Stream Repart

for Warehouse Connector
Create a Stream

Update the Port Number
and SSL Settings of the
Data Source

Finalize the Stream

Start the Stream

|

|

|

| Meonitor a Warehouse !
| Connector |
| |
| |
|

Manage a Stream and
| Lockbox

Edit a Stream

Reload the Stream

Specify Meta Filters for
a Stream

Define Multi-valued
Metas

Change or Refresh
Lockbox

To install and configure the Warehouse Connector service, perform the following:

1. Install Warehouse Connector Service on a Log Decoder or Decoder or Hybrid

Configure a Warehouse Connector Service

Configure the Data Source for Warehouse Connector

Configure the Destination

Configure a Stream

Monitor a Warehouse Connector

Add Warehouse as a Data Source to Reporting Engine

Analyze a Warehouse Report

o ® N N kWD

Manage a Stream
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Install Warehouse Connector Service on a Log

Decoder or Decoder or Hybrid

To install (fresh install) the Warehouse Connector service on a Log Decoder or Decoder or Hybrid:
1. Loginto NW Admin server

2. Enter the following command on NetWitness Server:
warehouse-installer --help
The command line interface (CLI) usage descriptions are displayed.

3. Install Warehouse Connector service by executing either one of the following commands:

warehouse-installer --host-addr 10.0.0.0
warehouse-installer --host-id 5928b9d8-83be-4143-9602-fa936debc4dle
warehouse-installer --host-name NWllLogDecoder

Where,
10.0.0.0 - IP address of the Host where the Warehouse Connector needs to be installed (Decoder
or Log Decoder)

5928b9d8-83be-4143-9602-fa936de5c4le - Host ID of Log Decoder or Decoder
NWllLogDecoder - Host name of Log Decoder or Decoder

4. Restart the Warehouse Connector using following command:

service nwwarehouseconnector restart

The Warehouse Connector service is successfully installed on the Log Decoder or Decoder or Hybrid.

Install Warehouse Connector Service on a Log Decoder or Decoder or Hybrid 7
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Configure a Warehouse Connector Service

You can configure the Warehouse Connector service using the following procedure.

To set the Lockbox password:
1. Log on to NetWitness Platform.
2. Go to ADMIN > Services.

3. Inthe Services view, select the added Warehouse Connector service, and select - > View

> Config.
4. In the Services Config view of Warehouse Connector, click the Lockbox Settings tab.

Admin @  admin v

VICES v OURC ENDPOINT SOURCES HEALTH & WELLNESS

% Change Service | Warehouse Connector | Config

Sources and Destinations ~ Streams [EITUSSIAT General  Appliance Service Configuration

Create New Lockbox

Set the lockbox password. The password should satisfy lockbox password strength.You will be required to enter this password to perform any lockbox management.

Lockbox Password Eiiarad
Confirm Lockbox Password il
Apply

Change Lockbox Password
Change the lockbox password. You will be required to enter current password and new password.The password should satisfy lockbox password strength.
Current Lockbox Password FREEAEAEE
[New Lockbox Password FkEREIEA

Confirm New Lockbox Password | **&*xxex

Apply

Refresh Lockbox
Reset the lockbox.You will be required to enter current lockbox password.

Lockbox Password FHkRERE

Apply

5. Inthe Create New Lockbox section, perform the following:

a. In the Lockbox Password field, enter the new lockbox password.

Note: The lockbox password must be at least eight characters in length and it must contain at
least three of the following groups: one uppercase character [A-Z], one lowercase character
[a-z], one numeral [0-9], and one special character.

b. Inthe Confirm Lockbox Password field, enter the added lockbox password to confirm.
c. Click Apply.

The Lockbox password is set.

8 Configure a Warehouse Connector Service
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Configure the Data Source for Warehouse Connector

There are two procedures for configuring the data source for the Warehouse Connector:

1.
2.

First, you must configure the data source.

Then, you need to update the Port Number and SSL Settings for the Data Source.

Configure the Data Source

To configure the data source:

1.
2.

Log on to NetWitness Platform.
Go to ADMIN > Services.

In the Services view, select the added Warehouse Connector service, and select - > View >
Config.

The Services Config view of Warehouse Connector is displayed.

On the Sources and Destinations tab, in the Source Configuration section, click +

Available Services

;ﬁ’ Name ~ Address Type
ﬂ Decoder Decoder
,9’ Log Decoder Log Decoder

Cancel 0K

Configure the Data Source for Warehouse Connector 9
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5. Inthe Available Services dialog, select the Log Decoder or Decoder services that you want to add
as a source to the Warehouse Connector service and click OK.
The selected Log Decoder and Decoder services are listed in the Source Configuration section.

Update the Port Number and SSL Settings of the Data Source

If there is change to the port number or SSL settings of the Warehouse Connect data sources, you can
update the changes in Explore view of the Warehouse Connector.

Make sure that:

e You have the changed port number or SSL settings of the data source.

e You have stopped the streams related to the data source that is updated with the port number or SSL
settings.

To update the port number or SSL settings:

1. Log on to NetWitness Platform.

2. Go to ADMIN > Services.

.ﬁv

3. Inthe Services view, select the added Warehouse Connector service and select
> Explore.

> View

The Service Explore view of Warehouse Connector is displayed.

RSA Respond Investigate Monitor Configure  Admin @  admin v

HOSTS  SERVICES  EVENT SOURCES  ENDPOINT SOURCES  HEALTH & WELLNESS

or | Explore

< >

RS /\ NETWITNESS' PLATFORM 1400

4. Navigate to warehouseconnector/sources, right-click the source, and click Properties.
The Properties of the source is displayed.

10 Configure the Data Source for Warechouse Connector
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RS/A  Respond Investi Monitor ~ Configure  Admin @ admin v

HOSTS  SERVICES  EVENT SOURCES  ENDPOINT SOURCES  HEALTH & WELLNESS

- Change Service | Warehouse Connector | Explore

- s Warehouse Connector (Warehouse Connector)
= Warehouse Connect...
connections
= 5 Warehouse Connector (WAREHOUSE_CO... \
ogs
B [ connections
B I0gs
[ Trest

[services

rest
services

storedproc

sys

Cstoredproc users

Clsys warehousaconnector

B users devicesppliance

[Jwarehouseconnector
Dconfig
B[ destinations I
B[ sources
]|
]
Ostars

B[ deviceappliance

Properties

< 2

5. In the drop-down menu, select update. In the Parameters field, perform the following:

o To update the port number of the source, enter port=<new source portnumber> and click
Send.

Parameters port=4432 Send

o To update the SSL settings of the source, enter ss1=<new ssl settings> and click Send.

Parameters ssl=on Send ‘

Note: You can also update the port number and ssl settings simultaneous by adding space
between the parameters.

Parameters port=443 ssl=on

Send ‘

6. Restart the Warehouse Connector service.

7. Start the streams.

Configure the Data Source for Warehouse Connector 11
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Configure the Destination

You can configure the destination using NFS, SFTP, and WebHDFS. Change the destination to which
the Warehouse Connector service needs to write the collected data using NFS:

o RSA NetWitness Warehouse (MapR) deployments
o Commercial MapR M5 Enterprise Edition for Apache Hadoop deployments

You can configure the Warehouse Connector to write to a remote destination using Secure File Transfer
Protocol (SFTP). The remote destination can be a remote server that is NFS mounted to the MapR
cluster or it can be a remote staging server.

By default, in the remote destination the Warehouse Connector writes data in the following directory
structure:

e /<staging
folder>/rsasoc/vl/sessions/data/<year>/<month>/<day>/<hour>/

e /<staging folder>/rsasoc/vl/logs/data/<year>/<month>/<day>/<hour>/
Where <staging folder> is the folder on the remote server where the Warehouse Connector writes the
data.

If you are using a remote staging server as the remote destination, you need to manually copy or move
the directory structure to any of the following deployments:

o RSA NetWitness Warehouse (MapR)

o Commercial MapR M5 Enterprise Edition for Apache Hadoop

o HortonWorks HD

To generate reports from the data written by Warehouse Connector, make sure that in your

Hadoop deployment you maintain a similar directory structure that is created by Warehouse Connector in
the remote destinations.

12 Configure the Destination
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The following illustration describes how you can use SFTP to write data from Warehouse Connector to a

remote destination.

|

!
! . [
WC writes data in the *Directory I l @ @ |
Structure mentioned below I ' |
| I
- | |
|

i MapR Cluster i
| Maintain the *Directory Structure i
| as mentioned below |
|

Remaote perver

Maintain the *Directory Structure
WOC writes data in the *Directory as mentioned below

Structure mentioned below

*Directory Structure: J
- [<staging_folder>/rsasoc/vl/sessions/data/<year>/<month>/
<day>{<hour>/

- [<staging_folder={rsasoc/vl/logs/dataf<year>f<month>/<day>/
<hour=>/

FSMounbed4l-E @ @ -i—"‘—|

Reporting

i
i
i
|
i Lo .4
Warehouse I
Connector (WC) ——5FTP : Reporting Engine

I e e s
i | |
! v
! [ |
e | O § O

. | b | : &

b Manuallval‘pgrammaticallv ; i Reporting

N — :

SFTP 3 MG RarC oy E16 Gare MapR Cluster / Pivotal HD -

Y ou can configure the Warehouse Connector service to write the collected data to a Hadoop-

based distributed computing system that supports WebHDFS.

Configure the Destination
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Configure the Destination Using NFS

Make sure that you have:

Installed the Warehouse Connector service or virtual appliance in your network environment.

Added the Warehouse Connector service to NetWitness. For more information, see "Add a Service to
a Host" in the Hosts and Services Getting Started Guide.

Set up NFS on Warehouse Connector. For more information on how to set up NFS on Warechouse
Connector, see "Configure Warehouse Connector to Write to Warehouse" in the Warehouse (MapR)
Configuration Guide.

To configure the destination using NFS:

1.

Log on to NetWitness Platform.

2. Go to ADMIN > Services.
3. Inthe Services view, select the Warehouse Connector service, and select - > View > Config.
The Services Config View of Warehouse Connector is displayed.
Admin
r | config
Sources and Destinations Streams Lockbox Settings General Appliance Service Configuration
Source Configuration Destination Configuration
+ +
7| asaress - 0| Name T Patn
| 1031125245 56004 O wnrFs nfs Iroot/test/kaushal
|| 1031125248 56002 O sFre sfip Iroot/test
4. On the Sources and Destinations tab, in the Destination Configuration section, click +
5. Inthe Add Destination dialog, from the Type drop-down list, select NFS.
6. Inthe Name field, enter a unique symbolic name for the destination.
Note: The Name field does not support spaces or special characters except underscore ().
7. In the Local Mount Path field, enter the locally mounted directory for HDFS where you want the
Warehouse Connector to write the data. For example:
If /saw is the local mount point for HDFS that you have configured while mounting the
14 Configure the Destination
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mapr NFS cluster on the host where you have installed the Warehouse Connector service to write to
RSA NetWitness Warehouse (MapR), create a directory named Ionsaw01 under /saw and the
corresponding Local Mount Path for the destination would be /saw/Ionsaw01.

For more information, see "Mount the Warehouse on the Warehouse Connector" topic in the
Warehouse (MapR) Configuration Guide.

Add Destination

Type * NFS| v

MName *

Local Mount Path *

Cancel Save

The /saw mount point implies to / as the root path for HDFS. The Warehouse Connector writes the
data to /Ionsaw01 in HDFS.

Click Save.

9. (Optional) If you want to enable checksum validation, perform the following:

a. Goto ADMIN > Services.
£~

> View

b. In the Services view, select the added Warehouse Connector service, and select
> Explore.
The Explore view of Warehouse Connector is displayed.

Warehouse Connector (Warehouse Connector)

< >

RS /\ NETWITNESS  PLATFORM 11.4.00

c. In the options panel, navigate to warehouseconnector/destinations/nfs/config. This is the name
of the destination and is dynamic.

d. Set the parameter 1 sChecksumValidationRequiredto 1.

Configure the Destination 15
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HOSTS  SERVICES  EVENT SOURCES  ENDPOINT SOURCES  HEALTH &

& ChangeService | Warehouse Connector | Explore &

Z=Warehouse Connect...
= &5 Warehouse Connector (WAREHOUSE_CO..

[ connections

logs

RSA nd Investigate  Moni Configure  Admin D) admin v
Iwarehousecomnector/Gestinations/NFS/config Warahouse Connactor (Warehouse Connector)
isChecksumValidationRequired 1
root Irootesukaushal
subtype nfs
type hafs

B Jrest
B[ services

&[T storedproc

s
B Jusers
B[] warehouseconnector
[Jconfig
B[] destinations
E[INFS
Ceonfig
algsFe
BT sources
[ stas
B devicesppliance

< >
RS/ANETWIT!

PLATFORM

11.40.0

e. Restart the respective stream.

16
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Configure the Destination Using SFTP

Make sure that you have:
o Installed the Warehouse Connector service or virtual appliance in your network environment.

o Added the Warchouse Connector service to NetWitness. For more information, see the "Add a
Service to a Host" in the Hosts and Services Getting Started Guide.

o For the SFTP destination type, the destination host should be listed in the /root/.ssh/known_hosts file

used by the ssh service (for example, sshd) running on the Warehouse Connector.

Add Destination from Warehouse Connector Host

To add the destination host to the /root/.ssh/known_hosts file, from the Warehouse Connector host,
initiate a secure connection to the destination host:

1. Log in to the Warehouse Connector.

2. Enter ssh root@<SAWIP> or ssh username@<SAWIP>.
3. Select Yes and enter the password.

4. Add the host key in the /root/.ssh/known_hosts file

Note: After you upgrade Warehouse Connector to 11.0, you must make sure that the destination
host is listed in the /root/.ssh/known hosts file used by the SSH service (i.e. sshd) running
on the Warehouse Connector. If you do not perform this action, the streams configured

with SFTP in Warehouse Connector will not start.

o If you want to use SFTP to write data into the destination using SSH key-based access, you need to
configure SSH key-based access between the Warehouse Connector and the Warehouse host
or Hadoop node. For more information, see Configure SSH Keys below.

Note: If you want to enable checksum validation to validate the integrity of the AVRO files that are
transferred from the Warehouse Connector to the destinations, make sure that you generate the keys
without setting the passphrase and do a key exchange between Warehouse Connector and the
warehouse nodes.

Configure the Destination 17
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Configure Warehouse Connector to use SFTP destination

To configure the destination:

1.
2.

Log on to NetWitness Platform
Go to ADMIN > Services.

e

> View

In the Services view, select the added Warehouse Connector service, and select
> Config.

The Services Config view of Warehouse Connector is displayed.

RS/ Respond  Investig Monitor ~ Configure  Admin

HOSTS  SERVICES  EVENT SOURCES ENDPOINT SOURCES HEALTH & WELLNESS

+ Change Service | Warehouse Connector | Config

Sources and Destinations Streams Lockbox Settings General Appliance Service Configuration

Source Configuration Destination Configuration

+ +

[ ndaress Fort [ name Type path

| 1031125245 56004 [ nFs nfs Iroot/test/kaushal
[0 1031425248 56002 [l sFre sfp Irootftest

4. On the Sources and Destinations tab, in the Destination Configuration section, click +

5. Inthe Add Destination dialog, select SFTP from the Type drop-down list.

Add Destination

Type * SFTP w
Mame *

Host #

Port * 22 o

Username *
Password/Passphrase Fk k& EIEE

Remote Path *

Cancel Save

18
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10.

11.
12.
13.

In the Name field, enter a unique symbolic name for the destination.

Note: The Name field does not support spaces or special characters except underscore ().

In the Host field, enter the remote server IP address.
In the Port field, retain the default port, 22.

In the Username field, enter the SSH username.

Note: In the case of HortonWorks HD, ensure that the username is gpadmin and for password
based access the password for gpadmin should be used. For passphrase-based access, the
passphrase used to generate the keys for gpadmin user should be used.

In the Password/Passphrase field, enter one of the following:

m SSH password - If you are using SFTP to write data into the destination using password-based
access.

m SSH passphrase - If you are using SFTP to write data into the destination using SSH key-based
access.

In the Remote Path field, enter the path of the directory present on the SFTP server.
Click Save.
(Optional) If you want to enable checksum validation, perform the following:

a. Goto ADMIN > Services.
£~

b. In the Services view, select the added Warehouse Connector service, and select > View
> Explore.

The Explore view of Warehouse Connector is displayed.

SERVICES

= Warehouse Connect...

[ = Warehouse Connector (WAREHOUSE C...

sssssss

[RS/\ NETWITNESS® PLATFORM

c. In the options panel, navigate to warehouseconnector/destinations/sftp/config.
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d. Set the parameter isChecksumValidationRequired to 1.

[RSA  Respond Investigate Monitor  Configure  Admin

HOSTS  SERVICES  EVENT S

RCES  ENDPOINT SOURCES  HEALTH &

& Changesenvice | Warehouse Connector | Explore

= Warehouse Connect...
[F & Warehouse Connector (WAREHOUSE_CO..
B connections
B Jlogs
B rest
@[T services
@[ storedproc
a0sys

/warenouseconnector/destinations/SFTP/config
known.hosts file

password

root

isChecksumValidationRequired

host

eeeeeeee

WELLNESS

10.31.204.44:22
hdfs
root

sftp

admin v

B users
B8 warehouseconnector
[ config
B[] destinstions
aanFs
a[dsFe
Bty

e. Restart the respective stream.
Aggregate Metas and Raw Logs for a Log Session

To aggregate raw logs and metas from Log Decoder into a single AVRO file instead of two folders.
1. Goto ADMIN > Services.

2. Select a Warehouse Connector service and click > View > Explore.

The Explore view for the Warehouse Connector is displayed.

3. Open warehouseconnector/streams/<stream name>/loader/config and in the right pane,
select the export.logAndsession.avro.enabled parameter.

4. Change the value to yes.

5. Restart the service.

6. Go to ADMIN > Services.

7. Select a Warehouse Connector service and click > View > Config.
8. On the Streams tab, select the stream that you want to reload.

9. Click Reload.

Configure SSH Keys

To configure SSH key-based access between the Warehouse Connector and the Warehouse host or
Hadoop node:

20 Configure the Destination
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1. Generate SSH keys on the Warehouse Connector at the default location. Perform the following:

a. Log on to the Warechouse Connector.

Type the following command and press ENTER:
$ OWB FORCE FIPS MODE OFF=1 ssh-keygen -t dsa

¢. The command prompts you to enter the file in which to save the generated key.
Enter file in which to save the key (/root/.ssh/id dsa):

d. Enter the file in which you want to save the key and press ENTER.

The command prompts you to enter and confirm the passphrase.

Note: If you want to enable checksum validation to validate the integrity of the AVRO files
that are transferred from the Warehouse Connector to the destinations, make sure that you do
not set the passphrase. Then, the below steps e, f, g, and h are not applicable.

Enter passphrase (empty for no passphrase):
Enter same passphrase again:

The public key is generated and is saved in the location that you provided.
e. Change the directory by entering the following command:

cd /root/.ssh/
f. Move the generated key to the below location:

mv id dsa id dsa.old
g. Type the following command and press ENTER:

$ OWB_FORCE FIPS MODE OFF=1 openssl pkcs8 -topk8 -v2 des3 -in id dsa.old
-out id dsa

The command prompts you to enter and confirm the passphrase.

h. Enter the encryption passphrase.

i. Run the following command to change the file permission:

chmod 600 id dsa

2. Append the generated public key to the remote Warehouse host or Hadoop node's authorized keys list
located at: ~/.ssh/authorized keys

Note: Make sure that you copy the public keys to the Hadoop node and while copying the public
key ensure that you provide the login details of the user using which the WebHDFS destination
would be added.

You can now securely communicate between Warehouse Connector and Warehouse nodes or Hadoop
nodes.

Configure the Destination 21
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Configure the Destination Using WebHDFS

Make sure that you have:

Installed the Warehouse Connector service or virtual appliance in your network environment.

Added the hostname (or FQDN) and IP address of the warehouse nodes and Warehouse Connector to
the DNS server. If the DNS server is not configured, add the hostname (or FQDN) and IP address of
the warehouse nodes and Warehouse Connector to the file in the host on which the Warehouse
Connector service is installed.

If you want Kerberos authentication between the warehouse connector and the warehouse cluster,
make sure that you perform the following:

o Kerberos Key Distribution Center (KDC) Server is configured in your network environment and
the Kerberos Keytab file is copied to the host on which you have installed Warehouse Connector.

o Kerberos authentication is enabled in the warehouse cluster.

If you want to enable checksum validation to validate the integrity of the AVRO files that are
transferred from the Warehouse Connector to the destinations, make sure that you generate the keys
without setting the passphrase and do a key exchange between the Warehouse Connector and the
warehouse nodes. You need to configure SSH key-based access between the Warehouse Connector
and the Warehouse host or hadoop node. For more information, see 'Configure SSH Keys' in
Configure the Destination Using SFTP.
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Configure Warehouse Connector to Write to SFTP destination
To configure the destination:

1. Log on to NetWitness Platform.

2. Go to ADMIN > Services.

3. Inthe Services view, select the added Warehouse Connector service and select - > View
> Config.

The Services Config view of Warehouse Connector is displayed.

e  Admin

or | Config

Sources and Destinations Streams Lockbox Settings General Appliance Service Configuration

Source Configuration Destination Configuration

+ +

[ nodress Port [ name Type patn

1 1031125245 56004 O nFs nfs froot/test/kaushal
[ 1031425248 56002 [ sFre sftp froot/test

4. On the Sources and Destinations tab, in the Destination Configuration section, click +

5. Inthe Add Destination dialog, select WebHDFS from the drop-down list.
Add Destination

Type * WebHDFS w
Mame *
Hadoop IP *

Hadoop Port #

L

Username *
Hadoop Path #

Kerberos Authentication []

Cancel Save
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6.

10.

11.

12.
13.

In the Name field, enter a unique symbolic name for the destination.

Note: The Name field does not support spaces or special characters except underscore ().

In the Hadoop IP field, enter the namenode IP address of the warehouse cluster.
In the Hadoop Port field, enter the base port that is used by the namenode web user interface.

In the Username field, enter the owner of the directory in the warehouse to which Warehouse
Connector should write the data.

In the Hadoop Path field, enter the path of the directory in the warehouse to which Warehouse
Connector should write the data.

Select the Kerberos Authentication checkbox, if you want the warehouse connector to securely
communicate with the warehouse using Kerberos authentication.

Add Destination

Type * WebHDFS v
Mame *

Hadoop IP *

Hadoop Port * o

Username *
Hadoop Path *

Kerberos Authentication [

Kerberos Principal *

Kerberos Keytab File
Path*

Cancel Save

Perform the following:
a. Inthe Kerberos Principal field, enter the KDC Principal used for Kerberos authentication.

b. Inthe Kerberos Keytab File Path ficld, enter the path of the Kerberos Keytab file in the
Warehouse Connector.

Click Save.
(Optional) If you want to enable checksum validation, perform the following:

a. Goto ADMIN > Services.

b. In the Services view, select the added Warehouse Connector service and select o > View

> Explore.
The Explore view of Warehouse Connector is displayed.
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RSA Respond  Investigate Monitor  Configure  Admin

admin v

HOSTS  SERVICES ENT SOURCES  ENDPOINT SOUR SECURITY

% Change Service | Warehouse Connector | Explore &

- Jr— Warehouse Connector (Warehouse Connector)
= Warehouse Connect...
|2 ) Warehouse Connector (WAREHOUSE C...

logs

B[ connections
rest

B logs
services

B rest
storedproc

ervices sys

users
warehouseconnector

deviceappliance

B[ Jwarehouseconnector
[Jconfig .
Cstas

B[ deviceappliance

< >
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c. In the options panel, navigate to warehouseconnector/destinations/webhdfs/config.

d. Set the parameter i sChecksumValidationRequired to 1.

RSA Respond  Investigate  Monitor  Configure  Admin admin v
HOSTS  SERVICES OURCES  ENDPOINT SOU HEALTH & WELLNESS
& Change Service | Warehouse Connector |  Explore &
- Iwarehouseconnectar/destinations/NFS/config Warehouse Cannector (Warehouse Connector)
= Warehouse Connect...
isChecksumValidationRequired 1

f= & Warehouse Connector (WAREHOUSE_CO..
root

B[ connections

BT logs

B rest

B3 services

& Jsteredproc

B 0sys

B Tusers

subtype nfs

ype hdfs

& Jwarehouseconnector
[T config “
B[ gestinations
BCINFS
aJsFe
B[ Jsources
[ stats

& devicesppliance

< >

RS /\ NETWITNESS' PLATFORM 11.40.0

e. Restart the respective stream.
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Configure a Stream

You can configure the data stream to define the data source and destination combinations.

Make sure that you have:

Installed the Warehouse Connector service or virtual appliance in your network environment.

Added the Warehouse Connector service to NetWitness. For more information, see "Add a Service to
a Host" in the Hosts and Services Getting Started Guide.

Configured the data source from which the Warehouse Connector service needs to collect data. For
more information, see Configure the Data Source for Warehouse Connector.

Configured the destination to which the Warehouse Connector service needs to write the collected
data. For more information, see Configure the Destination.

To configure the stream:

L.
2.
3.

Create a stream
Finalize the stream

Start the stream

Create a Stream

To create a stream:

1. Goto ADMIN > Services.

2. Inthe Services view, select the added Warehouse Connector service and select el > View >
Config.
The Services Config view of Warehouse Connector is displayed.

3. Click the Streams tab.
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RSA Respond Inve Monitor ~ Configure  Admin admin v

HOSTS  SERVICES  EVEN CES  ENDPOINT SOURCES  HEALTH & WELLNESS

& Change Service | Warehouse Connector |  Config @

Sources and Destinations UGN Lockbox Settings ~ General  Appliance Service Configuration

Status

Sources Destination
running

To configure the alert mechanisms related to the Warehouse Connector navigate here.
RS /\ NETWITNESS' PLATFORM 11.4.00

On the Streams tab, click +

Add Stream

Stream Mame *

Select Destination * Choose Destination ... -
Select Source *
L] Name Address Port Session 1D
U 56004 Enter Session
O 5e002 Enter Session

Cancel Save

5. Inthe Add Stream dialog, perform the following steps:

a. Inthe Stream Name field, enter a name for the stream.

Note: The Stream Name field does not support spaces or special characters except underscore
0.
b. Inthe Select Destination drop-down menu, select a destination from the list of destinations

added to the Warehouse Connector.
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c. Inthe Select Source field, select sources from the list of sources displayed.

d. In the Session ID column, enter the last session id.
If you provide any session id, the Warehouse Connector will start the aggregation from that
session, whereas if this is left blank, the aggregation will start from the current session.

e. Click Save.

Finalize a Stream

To finalize the stream:

1. Goto ADMIN > Services.

2. Inthe Services view, select the added Warehouse Connector service and select L > View >
Config.

The Services Config view of Warehouse Connector is displayed.
3. On the Streams tab, select the stream that you have created.

gure  Admin

HEALTH & WELLNESS

General  Appliance Service Configuration

O ] S0002 e iy g
To configure the alert mechanisms related to the Warehouse Connector navigate here.
RS /\ NETWITNESS’ PLATFORM 11.400

4. Click Finalize.

Start a Stream

Note: If you have deployed a Warehouse Connector Virtual Appliance, make sure that you change the
default value of the Maximum Message Hold Count parameter to 800000. For more information,
see General Tab Settings.
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To start the stream:

1. Goto ADMIN> Services.

2. In the Services view, select the added Warehouse Connector service and select o > View >
Config.

The Services Config view of Warehouse Connector is displayed.
3. On the Streams tab, select the stream that you have created.

Monitor  Configure ~ Admin @  admin v

ENDPOINT SOURCES ~ HEALTH & WELLNESS

 Change Service | Warehouse Connector [N

Sources and Destinations Streams Lockbox Settings General Appliance Service Configuration

=@ | sat | Change Configuration
¥ Name Sources Destination Status

4 (i} 50002 stopped

alert mechanisms rela

d to the Warehouse Con

4. Click Start.

or navigate here.
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Monitor a Warehouse Connector

By monitoring a Warehouse Connector, you can automatically generate notifications when critical
thresholds concerning Warechouse Connector and its storage have been met.

To monitor a Warehouse Connector:

Go to ADMIN > Services.

1.

In the Services view, select the added Warehouse Connector service and select

.ﬁ.v

> View

> Config.
The Services Config view of Warehouse Connector is displayed.

3. Click the Streams tab.

At the bottom of the Streams tab, click To configure the alert mechanisms related to the
Warehouse Connector navigate here.
The Warehouse Connector Monitoring view is displayed.

This page is deprecated and will be removed in a future release.

In the Source or Destination Status section, select the number of minutes or hours in the Notify
Offline For ficld.

You will receive a notification if the source or destination connection fails for the defined number of
minutes or hours.

In the Stream Status section, perform the following:

a.

In the Notify Stopped For field, define the number of minutes or hours after which you would
like to receive a notification when the stream goes offline.

In the Disk Is field, define the limit on the percentage of disk usage after which you would like to
receive a notification.

In the Source is Behind field, define the number of sessions. A notification is raised if the
source goes behind the defined number of sessions.

In the Rejected Folder Size is field, define the limit on the percentage of folder usage after
which would like to receive a notification.

In the Number Of Files in Permanent Failure Folder ficld, define the limit on the number of
files in the permanent failure folder after which you would like to receive a notification.

In the Notification Type field, perform the following:

a.

Click Configure email or distribution list to configure email so that you can receive
notifications in NetWitness. For more information, see the "Configure Email Server and
Notification Account" topic in the System Configuration guide.

b. Click Configure Syslog and SNMP Trap servers to configure audit logs. For more information,
see the "Configure Syslog and SNMP Settings" topic in the System Configuration guide.
c. Select the following notification mechanisms as per your requirement:
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NetWitness Console - To get notifications on the NetWitness Ul notification toolbar.

Email - To get email notifications.

Syslog Notification - To generate syslog events.

o SNMP Trap Notifications - To get audit events as SNMP traps.
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Add Warehouse as a Data Source to Reporting Engine

You must add Warehouse as a data source to Reporting Engine to make this data source available to
report against this Reporting Engine. For more information, see "Add Warehouse as a Data Source to
Reporting Engine" in the Reporting Engine Configuration Guide.



Analyze a Warehouse Report

The Warehouse modules provide analysts with reports of early indicators of compromise. The following
Warehouse reports can be analyzed in NetWitness:

o Suspicious Domains report
o Suspicious DNS Activity report
o Host Profile report

For more information, see "Step 4. Analyze a Warehouse Report" in the Warehouse Guide.



View the Warehouse Connector Service

While the information displayed in the Services System view is the same for all types of core services,
several options in the toolbar are relevant only for Warehouse Connector.

To access this view:

1. Goto ADMIN > Services.

2. Inthe Services view, select a Warehouse Connector and select i
The Systems view for the selected Warehouse Connector is displayed.

> View > System.

RS/A Respond In Monitor ~ Configure  Admin ® admin v

HOSTS  SERVICES  EVENT SOURCES  ENDPOINT SOURCES  HEALTH & WELLNESS

% Change Service | Warehouse Connector | System

B HostTasks  ® Shutdown Service () Shutdown Appliance Service @ Reboot

Warehouse Connector Service Information Appliance Service Information

Decoder (Warehouse Connector)
11.1.0.0 (Rev nul)

29640 KB (0.09% of 32176 MB)

14%

2018-Apr-26 09:33:59

3 days 23 hours 4 minutes 17 seconds

me  2018-Apr-30 08:38:16

Warehouse Connector User Information
admin
Administrators

connections.manage, logs.manage,
storedproc.manage, sys.manage, u

s.manage, storedproc.execute,
anage, warehouseconnector.manage

Session Information
Session User IP Address

admin

admin

escalateduser

Decoder (Host)

11.2.0.0 (Rev null)

26700 KB (0,08% of 32176 MB)
0%

2018-Apr-26 09:07:00

3 days 23 nours 31 minutes 23 seconds

me  2018-Apr-30 08:38:23

Host User Information

admin
Administrators

appliance.manage, connections.manage, logs.manage, services.manage,
storedproc.execute, storedproc.manage, sys.manage, users.manage

Login Time ~ Active Queries
2018-Apr-26 09:36:45 0
0
0

The following is an example of toolbar options for Warehouse Connectors.

B HostTasks () shutdown Service (U Shutdown Appliance Service () Reboot

Host Tasks, Shutdown Service, Shutdown Appliance Service or (Shutdown Appliance), and Reboot are
common to all services and are described in the Hosts and Services Getting Started Guide.



Troubleshoot the Warehouse Connector

The following information suggests the possible issues that NetWitness users may encounter when
adding a Warehouse service to the Reporting Engine as a data source for reporting in NetWitness. Look
for explanations and solutions in this section.

While adding a Warehouse service to the Reporting Engine as a data source for reporting, you may
observe some of the errors listed in this document. Information is provided on how to troubleshoot the
errors and add the data source successfully.

The following figure shows the New Service dialog.

Mew Service

Source Type * WAREHOUSE ~
Warehouse Source * HiveServer? w
Mame * PDHZ2.0-DCA

HDFS Path * !

Advanced |

Host #

Paort * 10000

Username * gpadmin

Pa ESWG'rd TEEELETEE

Kerberos Authentication [+

Server Principal *
User Principal *
Kerberos Keytab File *

Enable Jobs O

Test Connection

Cancel Save

For more information, see "Add Warehouse as a Data Source to Reporting Engine" in the Reporting
Engine Configuration Guide.




_ Possible Solutions

Could not open connection to e Ensure that the HiveServer2 is running on the Host.

HiveServer . . . .
o Check if the port provided can be accessible from the Reporting

Engine server.

No Schema found in HDFS  Ensure that meta avro data file(s) are available in the HDFS path
path (<HDFS Path>/rsasoc/vl/sessions/meta) mentioned.

The following figure shows an example of the command to check the
files in hdfs.

Could not open connection to  GSS initiate failed errors will be observed only in the case of Kerberos

HiveServer, GSS initiate enabled Hive.

failed Ensure that the proper keytab file is provided and it should have read
options for the rsasoc user (user on which the Reporting Engine Server
runs).
Ensure that the system time is synchronized between KDC, Hadoop
(HortonWorks) server, and the Reporting Engine system.

Add SFTP Destination

To add SFTP destination to Warehouse Connector, you need to follow the below steps:

1. SSH to NetWitness Host and run the following command to edit ssd_config file:
vi/etc/ssh/sshd config file

2. Do not comment HostKey/etc/ssh/ssh host rsa key

3. You must append KexAlgorithms +diffie-hellman-groupl4-shal,diffie-hellman-
group-exchange-shal

4. Run the following command to restart NetWitness Host:
systemctl restart sshd

5. On Warehouse Connector Host SSH to NetWitness Host and run the following command:
ssh -o "HostKeyAlgorithms ssh-rsa" root@<NWhost IP>
For example, ssh -o "HostKeyAlgorithms ssh-rsa" root@10.10.10.10

6. Run the following curl command on Warehouse Connector Host to authenticate:
curl -vvvv sftp://root:netwitness@<NWhost ip>:22/root/
For example, curl -vvvv sftp://root:netwitness@<10.10.10.10>:22/root/

7. You can now add SFTP Destination from Ul



Manage a Stream

You can manage a stream using the following procedures:
o Edit a Stream
o Reload the Stream

Specify meta filters for a Stream

o Define multi-valued metas

Edit a Stream
You can edit a stream to perform the following:
o Add data sources to the stream.

o Delete existing data sources from the stream.

To edit a stream:

1. Go to Admin > Services.

2. In the Services view, select the added Warehouse Connector service and select - > View

> Config.
The Services Config view of Warehouse Connector is displayed.

RS/ Respond In Monitor ¢ Admin @  admin v

HOSTS  SERVICES  EVENT SOURCES  ENDPOINT SOURCES  HEALTH & WELLNESS

& Change Service | Warehouse Connector | Config

CIMICEEN N ERIENGIEE  Streams  Lockbox Settings ~ General  Appliance Service Configuration
Source Configuration Destination Configuration
+ +
[~ Address Port O Name Type Path
1 1031.125.245 56004 O NFs nfs Irootitest/kaushal
1 1031125248 56002 O sre sftp Irootitest
7

3. On the Streams tab, click k=d.
4. In the Edit Stream dialog, you can perform the following:

o On the Available Sources tab, you can select the available data sources to add to the stream and
click Save.



Edit Stream

Stream Mame

Destination

Available Sources

D Mame Address Port Session 1D

] 50004 20004 Enter Session

Cancel Save

o On the Current Sources tab, you can delete an existing data source from the stream. Select the

data source and click = .

Edit Stream

5tream Mame

Destination

PR E o Sleli[ge= Current Sources

At least one source is required

] Name Address Port

U :50002 50002

Cancel Save



Reload the Stream

When you reload the stream, the Warehouse Connector updates the schema file for the stream. You
must reload the stream when you add a new custom meta to the Log Decoder or Decoder.

To reload the stream:

1. Go to Admin > Services.

2. In the Services view, select the added Warehouse Connector service and select - > View

> Config.
The Services Config view of Warehouse Connector is displayed.
3. On the Streams tab, select the stream that you want to reload.

4. Click Reload.

Specify Meta Filters for a Stream

You need to specify the filter for each stream in the export.session.meta.fields parameter in the
Explore view of the Warehouse Connector.

The following table lists the values that you can provide as a filter:

g All the collected metas are written to SAW.

* metal, meta2 All the metas except the defined metas are written to SAW.
For example,
Filter:*, ip.src
All the metas except ip.src is written to SAW.

metal, meta2, meta3 Only the defined metas are written to SAW.

Note: By default, the following metas are written to Warehouse even if you specify them in the filter:
- ng_source

- unique_id

- time

To specify meta filters for a Stream:

1. Go to Admin > Services.

2. In the Services view, select a Warehouse Connector services and select i > View > Config.

The Explore view of the Warehouse Connector service is displayed.



RSA Respond  Inv ate  Monitor  Configure  Admin @ admin »

HOSTS  SERVICES  EVEI CES  EMDPOINT SOURCES  HEALTH & WELLNESS

% Change Service | Warehouse Connector | Explore ©

undefined Warehouse Connector (Warehouse Connector)

= Warehouse Connect...

= = Warehouse Connector (WAREHOUSE C...

connections

logs
B[ connections
rest
B logs
services
BT rest
storedproc
[Jsenvices
s
B[ storedproc users
B0ss warehouseconnector
B Jusers deviceappliance

B[ Jwarehouseconnector
Deconfig
Ostars

B[] deviceappliance

< >

In the options panel, select warehouseconnector > streams > <stream_name> > loader > config.
4. Inthe export.session.meta.fields parameter, enter the filter.

Admin admin

HEALTH

= Warehouse Connect... Warehouse Connector (Warehouse Connector)
150002 10231
= £ Warehouse Connector (WAREHOUSE_C, A ~
auro.load.nterval 3
B[ connections bulkcopy 0
B[ Tlogs
€ destination nline 1
B0 rest export.logenabled yes
B0 senvces export.rollup hour
B storedproc export.session.enabled yes
B0ss export.session.meta fields *
B users hold.count 100000
B [Jwarehouseconnector hold.interval 60
Dconig < hold.size 512MB
B[] destinations Ioader.stats.interval 1
B[ 0sources page size 200000
Ostars permrejected.number 0
B[] streams rejectad size 0
BT Testing root Jesting
[config thread.count 4
B losder thread.pool.count 3
S use.compression deflate
[erms wait.thread.pool 2
[Jschema 9
< >
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5. Restart the stream.

Define Multi-valued Metas

You can also define an existing meta or a custom meta to be treated as multi-valued meta.
To define multi-valued metas:

Caution: Defining an existing meta to be treated as multi-valued may change the data type of the meta
and cause the associated reports to fail.



1. Create a new file with the filename multivalue-users.xml in the /etc/netwitness/ng directory.
2. Add the following entries:

<?xml version="1.0" encoding="utf-8"?>

<NetWitness>
<MultiValueMetas>
<Meta>NEWMETANAME</Meta>
</MultiValueMetas>
</NetWitness>

Where NEWMETANAME is the existing meta or a custom meta to be treated as multi-valued meta.
Caution: Make sure that you do not add metas that are by default treated as non multi-value.
3. Restart the stream.

View current schema

Note: This option is available only from version 11.4.1.2 and later.

You can view the current schema that is used by warehouse connector for writing in AVRO files.

To view the current schema:

1. Go to Admin > Services.

2. In the Services view, select a Warehouse Connector services and select i > View > Explore.

The Explore view of the Warehouse Connector service is displayed.
3. Inthe options panel, select warehouseconnector > streams > <stream_name> > config.

4. Set the value for refresh.schemanode.enabled parameter to true. By default, this value is set
to false.

admin v

SERVICES

% Change Service |

~ 4 ' config decoderi41 - Warehouse Connector
Edecoder141 - Wa
WA Jrese true
B[ TJservices 1000
B[ storedproc 10
BTy auro.startup off
B users destination Iwarehouseconnector/destinations/
B 5 warehouseconnector fresspecs
| £ handle.multivalue false
config
heartbeat.error 120
e[ destinations S ‘ =
eartbeat.incerval 10
B[ Jsources
o max.pending 80
stats
= refresh.schemanode.enabled true
B streams
rejected.maxusage 30 A configuration node whose value can alter system
-I'=] | behavior i
sources Iwarehouseconnector/sources/ 0. 10 e ———————
Iy hy I 10.10°
[CJconfig
state running
B[ Jloader
stream.data.path tness/warehouseconnector/bulk/
[schems
stream.id
stats
[~ stream.startpercent 50
» -
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5. Reload the stream. For more information see, Reload the Stream.

6. Restart the Warehouse Connector service.



7. Go to Admin > Services.

8. In the Services view, select a Warehouse Connector services and select o > View > Explore.

The Explore view of the Warehouse Connector service is displayed.

9. In the options panel, select warehouseconnector > streams > <stream_name> > schema, to view
the current schema.

Note: You must to reload the stream every time, before you want to view the current schema or you
can add a scheduler to reload the stream automatically at regular intervals as mentioned in step 10.

10. (Optional) To reload the stream automatically at regular intervals, follow the below steps.

a. Go to Admin > Services.

b. In the Services view, select a Warehouse Connector services and select & > View
> Explore.
The Explore view of the Warehouse Connector service is displayed.

c. In options panel, select warehouseconnector > sys > config > scheduler. Right click and select
properties.

d. In the property drop down select addInter and in the Parameters text box, add "hours=24

pathname=/warehouseconnector/streams/<stream name> msg=reload".

RSA Respond nv ate Monitor ~ Configure  Admin _AY admin v

HOSTS SERVICES EVENT SOURCES ENDPOINT 5 ES HEALTH & WELLNESS

- Change Senvice | decoder141 - Wareh Explore

decoder141 - Warehouse Connector

=decoder141

B T decoder141 - Wareho
B[ connections

B[ Jdeviceappliance

B legs
800rest
B0 services Properties for decoder141 - Warehouse Connector (WAREHOUSE_CONNECTOR) /sys/config/scheduler
B[ storedproc addinter ~| Parameters [nours=24 pathname=/wareheuseconnecior/streams/stass “sme msg=reload |
ES s <« Message Help
25 corfe Add a new scheduled task on an interval
[scheduler
o seconds - <uint32, optional, {range:1 to 31556926}> The number of seconds between executions, must provide one of seconds, minutes or hours -
stars
[tasks
Response Output
B users

[Qwarehousecannector

»
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Note: Standard time format used is hours. You can use seconds, minutes format in lieu of hours.

e. Then click Send.



Manage a Lockbox

You can change the lockbox password, as well as refresh the lockbox.

Lockbox Status

Note: RSA NetWitness Platform has added a Health & Wellness stat for Warehouse Connector to
indicate the status of its Lockbox. Also, an out-of-the-box rule has been added so that a Health &
Wellness alarm is raised when the Lockbox does not exist or cannot be opened.

To see the rule details, go to Admin > Health & Wellness > Policies > Warehouse Connector and
select Warehouse Connector Monitoring Policy.

Monitor  Configure  Admin admin v

SERVICES EVENT SOURCES ENDPOINT SOURCES HEALTH & WELLMNESS

Monitoring Policies System Stats Browser  Event Source Monitoring Settings

N
-
PO | |Cles Define the conditions under which you want to trigger an alarm for the NetWimness Platform health problems (definition includes
severity the alarm applies to, thresheld, and threshold at which the alarm clears). After you define the alarm rule, enable or
o v g R zzble the
+ #F B disable the alarm.
a
» [JlLog Collector (1]
» DLDg Decoder o Enable  Name ~ Severity Category Statistic
. O Lockbox Access Failure Criti.. Lockbox Lockbox Status
F (OMazlware Analysis o
O house Connector Service in Bad State Criti.. Processin...  Service State
¥ [ Orchestration Server (1]
O house Connector Service Stopped Criti.. Processin..  Service Status
» [JReporting Engine
o O house Connector Stream Behind High Streams Stream Behind
espond Server f - . A e . ; . .
¥ [ Respond Serve 0 O Warehouse Connector Stream Disk Utilization > 73 High Streams Disk Usage (Pending Destination
¥ [ Securiy Server o O Warehouse Connector Stream in Bad State Criti.. Streams Stream Status
» [JSource Server o O house Connector Stream Permanently Rejected Files > 3., High Streams MNumber of files in the permanen
- Warehaouse C cror Stre eje F r > 75% i Streams ejected folder usage in percentz
4 £ Warehousa Connectar o O hau: onnector Stream Rejected Folder » 75% Full High Stream: Rejecred folder usage in percent:
»
Warehouse Connector Monitori...
- -
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To change the Lockbox password:
1. Log on to NetWitness Platform.

2. Go to Admin > Services.

3. Inthe Services view, select a Warehouse Connector service, and select L > View > Config.

The Services Config view of Warehouse Connector is displayed.



RS/ Respond In ate  Monitor  Configure

HOSTS  SERVICES
& Change Service | Warehouse Connector | Config

Sources and Destinations [EESTEET) SEENETEGLE ) ES General

Source Configuration

ENDPOINT SOURCES

Admin

HEALTH & WELLNESS

Appliance Service Configuration

Destination Configuration

admin

+ +

| nodress Port 00 Name Type Path

1 1031125245 56004 O NFs nfs Jroot/test/kaushal
[ 1031125248 56002 0 s sftp Irootitest

4. Click the Lockbox Settings tab.

RS/  Respond Investigate Monitor  Configure  Admin @  admin v

HOSTS  SERVICES  EVENT 5OURCE ENDPOINT 50U R HEALTH & WELLNES!

% Change Service | Warehouse Connector | Config

Sources and Destinations ~ Streams [ESSGISSSUNESN  General  Appliance Service Configuration

Create New Lockbox

Set the lockbox password, The password should satisfy lockbox password strength You will be required to enter this password to perform any lockbox management.

Lockbox Password

|Confirm Lockbox Password

Apply

Change Lockbox Password

(Change the lackbox password. You will be required to enter current password and new password.The password should satisfy lockbox password strength,

Current Lockbox Password

[New Lockbox Password

Confirm New Lockbox Password  ##+#s+

Apply

Refresh Lockbox

Reset the lockbox.You will be required to enter current lockbox password.

Lockbox Password

Apply
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5. In the Change Lockbox Password section, perform the following:

a. Inthe Current Lockbox Password ficld, enter the current lockbox password.

b. Inthe New Lockbox Password ficld, enter the new lockbox password.

Note: The lockbox password must be at least eight characters in length and it must contain at
least three of the following groups: one uppercase character [A-Z], one lowercase character
[a-z], one numeral [0-9], and one special character.

c. Inthe Confirm New Lockbox Password ficld, enter the new lockbox password to confirm.

d. Click Apply.

The Lockbox password is successfully changed.



To refresh the Lockbox:
1. Log on to NetWitness Platform.

2. Go to Admin > Services.

&

3. Inthe Services view, select the added Warehouse Connector service, and select > View

> Config.

The Services Config view of Warehouse Connector is displayed.

admin

RSA n ate  Monitor e Admin
& WELLNESS

HOSTS  SERVICES  EVENT CES ENDPOINT 50 s HEALTH ¢

& Change Service | Warehouse Connector | Config &

Sources and Destinations Streams Lockbox Settings General Appliance Service Configuration

Source Configuration Destination Configuration

+ +

| noaress Port O name Type path

1 1031125245 56004 [mp nfs Jroot/test/kaushal
[ 1031125248 56002 [ srre sftp Irootitest

RS A\ NETWITNESS PLATFORM 11.4.00

4. Click the Lockbox Settings tab.

RS/  Respond Investi Monitor ~ Configure  Admin admin v

HO SERVICES  EV CES  ENDPOINT SOURCES  HEALTH

% Change Service | Warehouse Connector | Config

Sources and Destinations ~ Streams [EESGSYESUOESE  General  Appliance Service Configuration

Create New Lockbox

Set the lockbox password. The password should satisfy lockbox password strength You will be required to enter this password to perform any lockbox management.

Lockbox Password

Confirm Lockbox Password

Apply

Change Lockbox Password

(Change the lockbox password. You will be required to enter current password and new password.The passwerd should satisfy lockbox password strength.

Current Lockbox Password

[New Lockbox Password

Confirm New Lockbox Password | ### s

Apply

Refresh Lockbox

[Reset the lockbox.You will be required to enter current lockbox password,

Lockbox Password

Apply
RS /\ NETWITNESS' PLATFORM 11.40.0

5. Inthe Refresh Lockbox section, enter the current lockbox password in the Lockbox Password
field.

6. Click Apply.

The Lockbox is reset.
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This section contains descriptions of the user interface as well as other reference information.

General Tab Settings
The General tab displays the general configuration settings for Warehouse Connector service.

Workflow

You are here

Install Warehouse Connector Configure a Warehouse Configure a Destination Add Warehouse as a Data
Service on a Log Decoder or Connector Service Source to Reporting
Decoder Engine

Configure the Data Source Configure a Stream Analyze a Warehouse

for Warehouse Connector Report

Meonitor a Warehouse
Connector

Manage a Stream and
Lockbox

What do you want to do?
_m
Administrator Install Warehouse Connector Install Warehouse Connector Service
Service on a Log Decoder or on a Log Decoder or Decoder or
Decoder Hybrid

Administrator Configure a Warehouse Connector ~ Configure a Warehouse Connector
Service* Service

Administrator Configure the Data Source for Configure the Data Source for
Warehouse Connector Warehouse Connector

Administrator Configure the Destination using Configure the Destination Using NFS

NFS, SFTP, WebHDFS. Configure the Destination Using

SETP

Configure the Destination Using
WebHDFS




N T T

Administrator Configure a Stream Configure a Stream

Administrator Monitor a Warehouse Connector Monitor a Warehouse Connector

Administrator Add Warehouse as Data Source to For more information, see "Add
Reporting Engine Warehouse as a Data Source to

Reporting Engine" in the Reporting
Engine Configuration Guide.

Administrator Analyze a Warehouse Report For more information, see "Step 4.
Analyze a Warehouse Report" in the
Warehouse Guide.

Administrator Manage a Stream and Lockbox Manage a Stream

*You can perform this task in the current view

Related topics

o Configure a Warchouse Connector Service

Quick Look

The following figure shows the General tab on the Warehouse Connector Services Config view.

The General tab displays the system configuration parameters for the Warehouse Connector service.

admin v

Respond n e tol Admin

SERVICES c DFO s EALTH & WELLNESS

ce | Warehouse Connector | Config &

Sources and Destinations ~ Streams Lockbox Settings [\ Appliance Service Configuration

System Configuration

Name Config Value
Compression 0

Port 50020
SSLFIPS Mode [m}

S5L Port 56020

Stat Update Interval 1000
Threads 20

RS\ NETWITNESS PLATFORM 11.40.0

When you add a Warehouse Connector service, default values are in effect. RSA designed the default
values to accommodate most environments and recommends that you do not modify these values because
it may adversely affect performance.

The following table describes the System Configuration parameters:



m Config Value

Compression

Port

SSL

Stat Update
Interval

Threads

Determines the minimum amount of bytes before a message is compressed. If set to
zero, messages are not compressed.

Determines the port used by the service.

Note: If you change the port number, ensure that you restart the service.

If enabled, all the data transferred in the network will be encrypted using SSL.

Determines how often (in milliseconds) statistic nodes are updated in the system.

Determines the number of threads in the thread pool to handle incoming requests.
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Appliance Service Configuration Tab Settings

The Appliance Service Configuration tab displays the appliance configuration settings for Warehouse
Connector service. For more information, see "Appliance Service Configuration" in the Hosts and
Services Getting Started Guide.

Workflow

Install Warehouse Connector
Service on a Log Decoder or

You are here

Configure a Warehouse Configure a Destination Add Warehouse as a Data
Connector Service Source to Reporting

Decoder Engine
Configure the Data Source Configure a Stream Analyze a Warehouse
for Warehouse Connector Report
Menitor a Warehouse
Connector
Manage a Stream and
Lockbox
What do you want to do?

oS T T

Administrator Install Warehouse Connector Install Warehouse Connector Service
Service on a Log Decoder or on a Log Decoder or Decoder or
Decoder Hybrid
Administrator Configure a Warehouse Connector Configure a Warehouse Connector
Service* Service
Administrator Configure the Data Source for Configure the Data Source for
Warehouse Connector Warehouse Connector
Administrator Configure the Destination using Configure the Destination Using NFS
WIS, BIFVIE, WElelHIbIRS. Configure the Destination Using
SFTP
Configure the Destination Using
WebHDFS
Administrator Configure a Stream Configure a Stream
Administrator Monitor a Warehouse Connector Monitor a Warehouse Connector
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Administrator Add Warehouse as Data Source to For more information, see "Add
Reporting Engine Warehouse as a Data Source to
Reporting Engine" in the Reporting
Engine Configuration Guide.

Administrator Analyze a Warehouse Report For more information, see "Step 4.
Analyze a Warehouse Report" in the
Warehouse Guide.

Administrator Manage a Stream and Lockbox* Manage a Stream

*You can perform this task in the current view

Related topics

o Configure a Warehouse Connector Service

Quick Look
The following figure shows the different settings on the Appliance Service Configuration tab.

ure  Admin

Sources and Destinations Streams Lockbox Settings General Appliance Service Configuration

Name Config Value
Compression 0

Port 50006
SSLFIPS Mode: ()

SSLPort 56006

Stat Update Interval 1000

Threads 20

Apply

R'S /\ NETWITNESS PLATFORM

When you add a Warehouse Connector service, default values are in effect. RSA designed the default
values to accommodate most environments and recommends that you do not edit these values because it
may adversely affect performance.

The following table describes the Appliance Service Configuration parameters:

m Configuration Value

Compression  Determines the minimum amount of bytes before a message is compressed. If set to
zero, messages are not compressed.
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m Configuration Value

Port Determines the port used by the service.

Note: If you change the port number, ensure that you restart the service.

SSL FIPS If enabled, all the data transferred in the network will be encrypted using SSL FIPS.
Mode
SSL Port Determines the SSL port used by the service.

Stat Update Determines how often (in milliseconds) statistic nodes are updated in the system.
Interval

Threads Determines the number of threads in the thread pool to handle incoming requests.
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Sources and Destinations Configuration

The Sources and Destinations tab for a Warehouse Connector in the Services Config view provides a
way to manage basic service configuration and configure source and destination.

Workflow

Install Warehouse Connector Configure a Warehouse Configure a Destination Add Warehouse as a Data
Service on a Log Decoder or Connector Service Source to Reperting

Decoder

Engine

You are here
‘ Configure the Data Source Configure a Stream Analyze a Warehouse
‘ for Warehouse Connector Eaport

Meonitor a Warehouse
Connector

Manage a Stream and
Lockbox

What do you want to do?
_m
Administrator Install Warehouse Connector Install Warehouse Connector Service
Service on a Log Decoder or on a Log Decoder or Decoder or
Decoder Hybrid

Administrator Configure a Warehouse Connector ~ Configure a Warehouse Connector
Service Service

Administrator Configure the Data Source for Configure the Data Source for
Warehouse Connector™ Warehouse Connector

Administrator Configure the Destination using Configure the Destination Using NFS

NFS, SFTP, WebHDFS* Configure the Destination Using

SFTP
Configure the Destination Using
WebHDFS
Administrator Configure a Stream Configure a Stream
Administrator Monitor a Warehouse Connector Monitor a Warehouse Connector
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Administrator Add Warehouse as Data Source to For more information, see "Add
Reporting Engine Warehouse as a Data Source to

Reporting Engine" in the Reporting
Engine Configuration Guide.

Administrator Analyze a Warehouse Report For more information, see "Step 4.
Analyze a Warehouse Report" in the
Warehouse Guide.

Administrator Manage a Stream and Lockbox Manage a Stream

*Y ou can perform this task in the current view

Related topics

o Configure the Data Source for Warchouse Connector

o Configure the Destination

Quick Look

The following figure shows the Sources and Destinations tab on the Warehouse Connector Services
Config view.

onitor  Configure  Admin

ENDPOINT SOURCES HEA & WELLNESS

Warehouse Connector | Config

Sources and Destinations Streams 1 Lockbox Settings General Appliance Service Configuration

Source Configuration Destination Configuration

+ +

[ Adaress Port [ Name Type Path

| 56004 [ NFs nfs froot/test/kaushal
| 56002 O sAe sftp Irootitest

The Sources and Destinations tab includes the following two sections:

Source Configuration
Destination Configuration

Source Configuration

The Source Configuration section allows you to configure the data sources from which the Warehouse
Connector service needs to collect data.
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The following is an example of the Source Configuration section.

Source Configuration

+
O Address Port
Ol 56004
O 56002

The Source Configuration section allows you to perform the following:
M
Add the data source.

- Delete the data source.

Destination Configuration
The Destination Configuration section allows you to configure the destination to which the Warehouse
Connector service needs to write the collected data.

Destination Configuration
+
Ll name Type Path
[ NFs nfs froot/test/|
1 sFp sftp froot/test

The Destination Configuration section allows you to perform the following:

CTICT N

Add the destination.

= Delete the destination.

z Edit the destination.
Note: You can only edit the SFTP destination
type.
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Add Stream Dialog
You can configure and add a stream to a Warehouse Connector in this dialog

Workflow

Install Warehouse Connector Configure a Warehouse Configure a Destination Add Warehouse as a Data
Service on a Log Decoder or Connector Service Source to Reporting
Decoder Engine

Configure the Data Source Analyze a Warehouse
for Warehouse Connector Report

Meonitor a Warehouse
Connector

Manage a Stream and

Lockbox

What do you want to do?
_m
Administrator Install Warehouse Connector Install Warehouse Connector Service
Service on a Log Decoder or on a Log Decoder or Decoder or
Decoder Hybrid

Administrator Configure a Warehouse Connector Configure a Warehouse Connector
Service Service

Administrator Configure the Data Source for Configure the Data Source for
Warehouse Connector Warehouse Connector

Administrator Configure the Destination using Configure the Destination Using NFS

NFS, SFTP, WebHDFS. Configure the Destination Using

SFTP
Configure the Destination Using
WebHDFS
Administrator Configure a Stream* Configure a Stream
Administrator Monitor a Warehouse Connector Monitor a Warehouse Connector
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Refer to...

Administrator Add Warehouse as Data Source to For more information, see "Add
Reporting Engine Warehouse as a Data Source to
Reporting Engine" in the Reporting
Engine Configuration Guide.

Administrator Analyze a Warehouse Report For more information, see "Step 4.
Analyze a Warehouse Report" in the
Warehouse Guide.

Administrator Manage a Stream and Lockbox Manage a Stream

*You can perform this task in the current view

Related Topics

o Configure a Stream

Quick Look

The following figure is an example with the important features labeled.

onitor  Configure  Admin @ =t
SERVICES
+ e + ¥ © |Filter x
Name [} Licensed | Host Type Version Actions

[m] localhost.localdomain Event Stream Analysis IS

San (2= ~
[m] localhost.localdomain Entity Behavior Analytics Lo 2S
a localhost.localdomain Investigate Server TF o
a localhost.localdomain Log Collector -
a Log Collector localhost.localdomain Log Collector O
a Log Collector localhost.localdomain Log Collector - 38
a localhost.localdomain Log Decoder fo 38
O O LogDecoder o localhost.localdomain Log Decoder E- 38
a Orchestration Server localhost.localdomain Orchestration Server [ 28
a Reperting Engine localhest.localdomain Reparting Engine £ 28
a Response Server localhost.localdomain Response Server £ 28
a Sec Server localhost.localdomain Security Server £ 28
a ehouse Connector localhast.localdomain Warehouse Connector S

Delete
™ Warehouse Connector localhost. i Connector Edit l v
—
| Page 1 |of2 | } B I C Bl SHI 25 0f28
Logs stop
R'S /\ NETWITNESS® PLATFORM Security Restart 11.400

RS/\ Respond nwi e  Monitor Configure  Admin @ =

SERVICES  E\ ES ENDPOIL & WELLNESS

& ChangeService |  Warehouse Connector |  Config

Lockbox Settings ~ General  Appliance Service Configuration
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Add Stream

Stream Mame *

3 i * R N
Select Destination Choose Destination ... w

Select Source *

Ll Mame Address Port Session 1D
|:| 56004 Enter Session
|:| 56002 Enter Session

Cancel Save

Go to ADMIN > Services,
In the services view, select a Warehouse Connector service and select ¥ ~ >view>config

In the Streams tab, click + to view the add stream dialog.
The following table describes the fields in the Add Stream dialog:

Stream Type the name of the stream. The stream name may only contain alphanumeric
Name characters and underscores. It cannot exceed 20 characters in length.

Select Select a destination from the drop-down list.

Destination

Select Select a source from the grid at the bottom section of the dialog.

Source

Name The name of the source.

Address The address of the source.

Port The port of the source.

Session ID The session ID of the source.
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Streams Configuration

The Streams tab for a Warechouse Connector in the Services Config view provides a way to manage
stream configuration.

Workflow

Add Warehouse as a Data

Source to Reporting

Install Warehouse Connector
Service on a Log Decoder or
Decoder Engine

Analyze a Warehouse
Report

Configure a Warehouse
Connector Service

Configure a Destination

Configure a Stream

Configure the Data Source
for Warehouse Connector

You are here

Meonitor a Warehouse
| Connector

Manage a Stream and

Lockbox

What do you want to do?

S T T

Administrator Install Warehouse Connector Install Warehouse Connector Service
Service on a Log Decoder or on a Log Decoder or Decoder or
Decoder Hybrid
Administrator Configure a Warehouse Connector ~ Configure a Warehouse Connector
Service Service
Administrator Configure the Data Source for Configure the Data Source for
Warehouse Connector Warehouse Connector
Administrator Configure the Destination using Configure the Destination Using NFS
NFS, SFTP, WebHDES. Configure the Destination Using
SFTP
Configure the Destination Using
WebHDFS
Administrator Configure a Stream* Configure a Stream
Administrator Monitor a Warehouse Connector* Monitor a Warehouse Connector
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Administrator Add Warehouse as Data Source to For more information, see "Add
Reporting Engine Warehouse as a Data Source to
Reporting Engine" in the Reporting
Engine Configuration Guide.

Administrator Analyze a Warehouse Report For more information, see "Step 4.
Analyze a Warehouse Report" in the
Warehouse Guide.

Administrator Manage a Stream and Lockbox Manage a Stream

*Y ou can perform this task in the current view

Related topics
Configure a Stream

Quick Look

The following figure shows the Streams tab on the Warehouse Connector Services Config view.

Admin

EALTH & W

Lockbox Settings ~ General  Appliance Service Configuration

[To configure the alert mechanisms related to the Warehouse Connector navigate here.

RS /\ NETWITNESS® PLATFORM

The Streams tab allows you to perform the following:

T

Add a stream.

= Delete a stream.

E Edit the stream.
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T

Start the stream.

Stop Stop the stream.
Finalize Finalize the stream.

Reload Reload the stream.

If you have added a new meta or if a new meta is added as part of content update to any
of the sources, Log Decoder or Decoder, you need to reload the stream for the meta to be
visible in the schema for the Reporting Engine. Reloading a stream does not have any
impact on the data, but only the new meta list is fetched from the sources.

The following table describes the fields in the Streams tab:

Name Name of the stream.
Sources The sources associated with the stream.
Destination  The destinations associated with the stream.

Status Status of the stream.

Stream Statistics

You can view the statistics of a configured stream. Click the i icon next to the name of the stream.

gure  Admin

ALTH & W

Appliance Service Configuration

¥ Name Sources Destination Status

b 50002 - running

The following parameters are displayed in the Stream Statistics:

tn e o

Stream
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tn Jronme o

Destination

Source

Number of
files in the
permanent
rejected folder

Rejected
folder usage
in percentage

Session Rate

Status

Status

Sessions
Behind

Last Session
read

Determines the number of files in the permanent rejected folder
(named, permfail) in the Warehouse Connector. The permanent
rejected folder contains the files that Warehouse Connector failed to
write to the destination.

Determines the disk usage of the rejected folder.

Determines the rate at which the session is processed by the
Warehouse Connector for the source.

Indicates the status of the destination.

Indicate the status of the source.

Determines that number of sessions that needs to be processed by the
Warehouse Connector.

Determines the last session id processed by the Warehouse Connector.

Change Stream Configuration

You can change configuration of a stream in runtime. In the Streams tab, click Change Configuration
to change the configuration of the selected stream.

61
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Change Configuration :

Stream Configuration

Name Config Value -
=l Aggregation Configuration

Ageregate max sessions 1000

Agegregation Interval 10

= Loader Settings

Compress files on disk. deflate
Export Rellup Interval hour
Maxirmum Message Hold Count 100000
Maximum Message Hold Interval (Seconds) o0
Maxirmum Message Hold Size 512 ME
Page Size 200000
Remote Export Path /
Session Meta Fields Exported *
Session Remote Export ™

=l Stream Settings

Auto Startup ]

You can change the following parameters of the Stream Configuration:

Note: If you change the value of any parameter in stream configuration, make sure that you restart the
stream.

After upgrading, if the values of Maximum Message Hold Count, Maximum Message Hold Interval and
Maximum Message Hold Size are 3000000, 60 and 128 respectively, ensure that you assign the following
values to the streams:

o Maximum Message Hold Count - 2400000
o Maximum Message Hold Interval - 600
o Maximum Message Hold Size - 512

You can assign these values by modifying the existing Stream configuration.
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Aggregation Configuration

Aggregate max Determines the maximum number of sessions in a response for an
sessions aggregation request from the Warehouse Connector to the source .

Aggregation Interval Determines the time between the responses from the source.
Loader Settings

Compress files on disk Enable to compress files on disk.
Supported values:
o Deflate - Provides smaller compressed files and good performance while
generating reports.

o Off
By default, the parameter is set to deflate,

Export Rollup Interval Determines the roll-up interval for export files and also the directory structure
the Warehouse Connector writes to the destination.
For example:
If the parameter is set to:

Value Directory Structure

hour  /rsasoc/v1/[logs | sessions]/data/{year}/
{month}/{day}/{hour}

minute /rsasoc/v1/[logs | sessions]/data/{year}/
{month}/{day}/{hour}/{minute }
day /rsasoc/v1/[logs | sessions]/data/{year}/
{month}/{day}
If you change the value of the parameter, ensure that you restart the stream.
Recommended value is hour,

Maximum Message Determines the maximum number of sessions to store in the memory before
Hold Count processing.

Note: If you have deployed a Warehouse Connector Virtual Appliance,
make sure that you change the default value of the parameter to 800000.

Maximum Message Determines the maximum time (in seconds) to hold the sessions in memory
Hold Interval before processing.

(Seconds)

Maximum Message Determines the maximum size for the sessions to store in the memory before
Hold Size processing.

Remote Export Path Determines the remote local mount point for HDFES (nfs://) and the location

to export the data.

Page Size Determines the maximum pages.
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Stream Settings

Auto Startup Enable to automatically start the stream whenever the Warehouse connector
process is restarted. By default, the parameter is set to off,

Lockbox Settings

The Lockbox Settings tab for a Warechouse Connector in the Services Config view provide a way to
manage the lockbox settings.

Workflow

Install Warehouse Connector Configure a Warehouse Configure a Destination Add Warehouse as a Data
Service on a Log Decoder or Connector Service Source to Reporting
Decoder Engine

Configure the Data Source Configure a Stream Analyze a Warehouse
for Warehouse Connector Report

Meonitor a Warehouse
Connector

You are here

Manage a Stream and
Lockbox

What do you want to do?
_m
Administrator Install Warehouse Connector Install Warehouse Connector Service
Service on a Log Decoder or on a Log Decoder or Decoder or
Decoder Hybrid

Administrator Configure a Warehouse Connector ~ Configure a Warehouse Connector
Service* Service

Administrator Configure the Data Source for Configure the Data Source for
Warehouse Connector Warehouse Connector

Warehouse Connector Configuration References 64



Warehouse Connector Configuration Guide

S T T

Administrator Configure the Destination using Configure the Destination Using NFS
NEFES, SFTP, WebHDFS.

Configure the Destination Using

SFTP
Configure the Destination Using
WebHDEFS
Administrator Configure a Stream Configure a Stream
Administrator Monitor a Warehouse Connector Monitor a Warehouse Connector
Administrator Add Warehouse as Data Source to For more information, see "Add
Reporting Engine Warehouse as a Data Source to

Reporting Engine" in the Reporting
Engine Configuration Guide.

Administrator Analyze a Warehouse Report For more information, see "Step 4.

Analyze a Warehouse Report" in the
Warehouse Guide.

Administrator Manage a Stream and Lockbox* Manage a Stream

Manage a Lockbox

*Y ou can perform this task in the current view

Related topics

o Configure a Warehouse Connector Service

o Manage a Stream

Quick Look

The following figure shows the Lockbox settings tab on the Warehouse Connector Services Config view.
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Respond Inv gate Monitor Configure  Admin 7 admin v

SERVICES  EV SOURCES NDPOINT SOURCES HEALTH & WELLNESS

% Change Service | Warehouse Connector | Config

Sources and Destinations Streams Lockbox Settings General Appliance Service Configuration

Create New Lockbox

et the lockbox password. The password should satisfy leckbox passwerd strength You will be required to enter this password to perform any lockbox management.

Lockbox Password

[Confirm Lockbox Password

(Change Lockbox Password

fchange the lockbox password. You will be required to enter current password and new password.The password should satisfy lockbox password strength.
current Lockbox Password wEaTEES

[New Lockbox Password

[Confirm New Lockbox Password

Apply

Refresh Lockbox
Reset the lockbox.You will be required to enter current lockbox password.

Lockbox Password J———

Apply

RS /\ NETWITNESS' PLATFORM -

The Lockbox Settings tab allows you to set, change, or refresh the lockbox password of the Warehouse
Connector.
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