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Getting Started with ESA
This topic covers quick start topics for Event Stream Analysis (ESA)to help you get started in
using ESA. The following topics are designed to help enable you to work with ESA.

l This topic helps you to understand how to best set up, deploy, and create rules. See Best
Practices

l This topic helps you to troubleshoot different aspects of ESA, including rule writing and
deployment:Troubleshoot ESA

l This topic helps you to work with memory metrics to understand memory usage for
ESA services. See View Memory Metrics for Rules

Best Practices
Best practices provide guidelines to help you write and manage rules, deploy rules, and maintain
system health for your ESA services.

Understand Event Stream Analysis Rule Types

The Security Analytics Event Stream Analysis (ESA) service provides advanced stream
analytics such as correlation and complex event processing at high throughputs and low latency.
It is capable of processing large volumes of disparate event data from Concentrators. However,
when  working with Event Stream Analysis, you should be aware of the factors that affect
resource usage in order to create effective rules. 

Each event that is received by ESA is evaluated to determine if it may trigger a rule. There are
three types of rules that can be deployed in order to determine what the ESA engine should do
with the incoming event. Each of these rule types have different impacts on system resource
utilization. All three rule types may be created via the Rule Builder, Advanced EPL rules, or
downloaded via RSA Live. The table below lists the rule type and the impact this rule may have
on system resources.

9 Getting Started with ESA
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Rule Type Description

Simple Filter Rule This rule has no correlation to other events. At ingestion time, this
rule is evaluated against a set of conditions, and if those conditions
aremet an alert is generated. If no conditionsmatch, the event is
quickly released by the engine to free upmemory usage. These
rules do not take upmemory since the events are not retained
beyond the initial evaluation. Thememory resource usage does
not increase asmore simple filter rules are deployed. However, if
the filter condition is too generic, it is possible that this rule can
generate toomany alerts, which will strain the system resources
for the storage and retrieval of these alerts.
For example, youmight write a rule to generate an alert when
HTTP network activity arrives over a non-standard HTTP port.

EventWindow Rule This rule evaluates a set of events over a time period for specific

conditions. At ingestion time, the rule is evaluated against a set of

conditions. If those conditions aremet, the event is retained in

memory for a specific amount of time. After the specified time

passes, the events are removed from the time window if the num-

ber of events collected does not meet the threshold to trigger an

alert. Thememory consumption of such rules are highly depend-

ent on the incoming event rate (traffic), the amount of data per

event, and the time length specified in the event window. Each

matching event is retained inmemory until the time window has

passed, so the longer the time window, the greater the potential

volume. For example, youmight write a rule that generates an

alert if a user fails to log into any system five timeswithin a ten

minute time frame.

Getting Started with ESA 10



Alerting Using ESA

Rule Type Description

Followed ByRule This rule evaluates a chain of incoming events to determine if the
sequence of eventsmatches a particular condition. At ingestion
time, the rule is evaluated against a set of conditions. If the
conditions aremet, one of two actions occurs:

l If this is first event of the sequence, a new event thread is
started, and the event is retained as the head of the sequence.

l If the event belongs to an existing event thread, it is added to
that sequence.

In both cases, the event is retained inmemory. The amount of
resource usage is particularly sensitive to the customer
environment for this type of rule. If the filter condition generates
many event threads, resources are consumed for for each new
thread (in addition to the event). Additionally, if the end of the event
thread is never met (i.e. an alert is never generated), then the
entire event is saved inmemory indefinitely. For example, you
might write a rule to generate an alert when a user fails to log into a
server, then performs a successful login, and then creates a new
account.

In addition to the memory usage discussed above, alert generation also consumes system
resources. Each alert that is generated must be stored for retrieval and must also be processed
by Incident Management. This process uses disk space for storage, requires database memory to
be consumed, and increases CPU utilization running queries. 

When writing and deploying rules, you should be aware that each of these actions “cost” you
system resources. The sections below are designed to help you keep your usage at a healthy
level and monitor for problems if systems are becoming overloaded. 

Best Practices for Writing Rules

These are general guidelines for writing rules.

l Create alerts for actionable events.  The purpose of an alert should be to notify you of an
event that requires immediate and specific action. For events that do not require action, or
only require you to have awareness of the event, you can create a report. This helps to
prevent you from overloading the database that stores alerts.

l Configure new rules as trial rules so you can observe how they react in your
environment.  If you deploy new rules as trial rules, they will be disabled if the configured
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memory threshold is exceeded. You can also use the memory snapshot feature to see how
much memory was being used when a trial rule was disabled. For more details, see Work with

Trial Rules.

l Configure Alert notifications only after your rule testing and tuning is complete. This
can help ensure you do not get flooded with notifications if a rule behaves differently than you
expect. 

l Rules need to be specific so that you limit resource usage. Use the following guidelines to
limit usage:

l Make the filters on the rule exclude all but the necessary events for the rule to fire
accurately.

l Make the size of your windows (window time for correlation) as small as possible.

l Limit the events that you include in the window: For example, if you only want to see IDS
events, ensure that you only include those events in your time window. 

l Rules need to be tuned to an alert level that is manageable. If you are flooded with alerts,
then the purpose and utility of an alert is lost. In addition, it’s possible to flood the database
that stores alerts, which can slow or prevent your system from processing alerts. For
example, maybe you want to know about encrypted traffic to other countries. But, you could
limit the list to countries that are known risks. This limits the volume of alerts to a level you
can manage.

Best Practices for Working with RSA Live Rules

These are guidelines for RSA Live Rules.

l Deploy RSA Live rules in small batches. Not every rule is suited to every environment. The
best way to ensure your RSA Live rules are successful is to deploy them in small batches so
you can test them in your environment. If you deploy small batches, it's much easier to tell if
a particular rule has an issue. 

l Read the rule descriptions provided with RSA Live rules. ESA rules are not “one size fits
all.” Not all rules will work in your environment. The rule descriptions tell you which
parameters you will need to modify to successfully deploy a rule in your environment.

l Set your parameters. RSA Live rules have parameters that need to be modified.  If you do
not modify your parameters, the rule may not work or it may exhaust your memory.

Getting Started with ESA 12
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l Deploy new rules as trial rules so you can observe how they react in your environment.
If you deploy new rules as trial rules, they will be disabled if the configured memory
threshold is exceeded. For more details, see Work with Trial Rules.

Best Practices for Deploying Rules

These are general guidelines for deploying rules.

l Deploy rules in small batches so you can observe how they react in your environment.
Not all environments are the same, and a rule will need to be tuned for memory usage, alert
volume, and effective detection of events.

l Test rules before you configure alert notifications. Configure Alert notifications only after
your rule testing and tuning is complete. This can help ensure you do not get flooded with
alerts if a rule behaves differently than you expect.

l Monitor system health as a part of your deployment process. When you deploy rules,
monitor your system’s health as a part of your deployment process. You can view total
memory utilization for your ESA in the Health and Wellness tab. For more information, see
"Viewing Health and Wellness statistics" in Troubleshoot ESA.

Best Practices for System Health

These are general guidelines for system health.

l Configure the alerts database to maintain a healthy level of alerts. ESA uses MongoDB to
store alerts. If the MongoDB becomes flooded with alerts, it can slow or stop the database.
To ensure your database maintains a healthy level of alerts, configure settings to clear out
alerts regularly. To do this, see "Configure ESA Storage" in the Event Stream Analysis
(ESA) Configuration Guide.

l Set up new rules as trial rules. A common issue is that new rules may cause memory
issues. To prevent this, you can set up new rules as trial rules. If the configured memory
threshold is met, all trial rules are disabled to prevent the system from running out of memory.
For more information about trial rules, see Work with Trial Rules.

l Set up thresholds in the Health & Wellness module to alert you if memory usage is too
high. There are metrics in the Health & Wellness module that track memory usage. You can
set up alerts and notifications to send you an email if those thresholds are crossed. For more
information about the memory statistics you can view, see "Viewing Health and Wellness
statistics" in Troubleshoot ESA. 
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l Monitor memory metrics for each rule in the Health & Wellness module. For each rule,
you can view the estimated memory usage in the Health & Wellness module. You can use
this information to ensure that rules do not use too much memory.  For more information about
the memory statistics you can view, see "Viewing Health and Wellness statistics" in
Troubleshoot ESA. 

Troubleshoot ESA
This section describes common issues that may occur while using ESA, and it suggests common
solutions to these problems.

Troubleshoot ESA Services

Problem
Possible
Causes

Solutions

On the Security
Analytics Dashboard,
the ESA service
displays in red to
indicate it is offline.

On the Alerts >
Configure page, the
following message
displays: "The Service
is either offline or not
reachable."

Several When an ESA service is offline, there are many
possible causes. However, a common issue is that
you have created a rule that uses excessive memory
and causes the ESA service to fail. To troubleshoot
this problem, see "Steps to Troubleshoot Memory
Issues with an ESA Service Offline."

Other common causes might be that your firewall is
blocking the connection between the ESA
and Security Analytics, or the ESA service machine
may be down.  

To bring up ESA Services:

From Administration > Services, select the actions

icon for your ESA service,  and choose
start.

If your ESA service is stopping and restarting in a
loop, you may need to call Customer Support to get
the services to start.
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Problem
Possible
Causes

Solutions

After a recent upgrade,
the ESA service
displays in red on the
Security
Analytics Dashboard to
indicate it is offline.

On the Alerts >
Configure page, the
following message
displays: "The Service
is either offline or not
reachable."

Configuration

issues

If your system has been recently upgraded, you may

have made a configuration error. Under Admin-

istration > Services, select your ESA service, and

click on Edit Service. On the Edit Service field,

click Test Connection. If the connections fails,

you likely have a configuration error. Attempt to fix

your configuration error, and try again. 

The ESA appears to be

running slowly.

Configuration

issues

You may be able to improve performance by modi-

fying the buffer (the default value is 1048576 bytes),

or setting the TCP setting to TCPNoDelay to prevent

a delay in receiving TPC Acks. You can modify

these settings (readBufferSize and tcpNoDelay) by

going to

Explorer /Workflow/Source/nextgenAggregation .
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Troubleshoot ESA Database Issues

Problem
Possible
Causes

Solutions

 My ESA
Dashboard
doesn't
load. 

l Or, there
is an
error
getting
data.

l Or, it
loads
very
slowly. 

The data-

base that

stores alerts

has grown

too large.

You may need to configure Alert database settings so that the
database clears old alerts on a timely basis. For information on
configuring these settings, see "Configure ESA Storage" in the
Event Stream Analysis (ESA) Configuration Guide.

Once the database has become too large, you need to clear the
alerts. Contact Customer Support to do this. 

Troubleshoot RSA Live Rules for ESA

Problem Possible Causes Solutions

I imported a group

of rules from RSA

Live, and now my

ESA service is

crashing. Why?

You may not have

configured the para-

meters for the RSA

Live rule to tune it

for your environment. 

Each rule in RSA Live has a description that
includes the parameters you must configure and
prerequisites for your environment. Review this
description to see if the rule is appropriate for
your environment.

To ensure that you deploy rules safely in your
environment, configure new rules as trial rules
to test them in your environment. Trial rules add
a safeguard for testing new rules.  For details on
this, see Deploy Rules as Trial Rules.
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Problem Possible Causes Solutions

I imported a group
of rules from RSA
Live, and while the
rules deployed
without errors, they
were later
disabled.

Not all RSA Live
rules are meant for
every environment.
You may not have
the correct meta in
your ESA for the rule
to run.

You can verify that a rule was disabled by going
to Alerts> Services > Deployed Rule Stats. If
the rule is disabled, the green icon does not
display next to the rule. 

 If a rule deployed correctly but was disabled,
check the logs for exceptions related to the rule.
Specifically, check to see if the rules were
disabled due to missing meta. To do this, go
to Administration > Services, select your ESA
service and then   > View >Logs.

Then, search for a message similar to the
following:

"Property named ‘<meta_name>' is not valid in any
stream"

For example, you might see:
Failed to validate filter expression
'(medium=1 and streams=2 or
medium=3...(238 chars)': Property
named 'tcp_flags_seen' is not valid
in any stream

If a similar message displays, you may need to
add a custom meta key to the Log Decoder or
Concentrator. To do this, follow these
instructions: "Create Custom Meta Keys Using
Custom Feed " in the Decoder and Log
Decoder Configuration Guide.

Troubleshoot Deployments

Problem
Possible
Causes

Solutions

I created a rule, and I checked the syn-

tax. The rule looked fine. When I went to

deploy the rule, I got an error. Why?

You may not have

the correct meta

to deploy the rule. 

Check the Meta key ref-

erences. You may not have

the correct meta to deploy the

rule. 
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Troubleshoot Rules

Problem
Possible
Causes

Solutions

I created a custom

rule (via the Rule

Builder or

Advanced EPL),

and my rule is not

firing. Why?

You may

have con-

nectivity

issues.

Check the 'Offered Rate' statistic on the Alerts >
Configure > Services tab.

If the offered rate is zero, then the ESA service is not
receiving data from Concentrators. Validate the
Concentrator connectivity. Go to
Administration > Services, select your ESA and click on
View > Config.  Ensure the concentrator is enabled. Select
the concentrator and click on test connection.

If the offered rate is not zero, the meta key name and type
used in the rule likely doesn't match the meta key present
in events. Check to see if the meta key name and type used
in the rule is valid by searching for the meta key name in
Alerts > Configure > Settings tab (Meta key references
search).

There may

be a prob-

lem with

the rule.

If a specific rule is not firing, go to Alert > Configure >
Services to see if the rule was disabled. In the Deployed
Rule Stats section, a rule that is disabled displays a clear
enabled button (instead of the green enabled button).

You can also check Events Matched field. Go to Alerts >
Configure> Services. From there, you can see the
number of events that were matched in the Events
Matched column.

If no events matched, check the logic of your rule for
errors. For example, check the syntax for uppercase and
lowercase errors, and check the time window. If the rule
still doesn't fire, consider simplifying the logic of the rule
to see if it fires when there is less complexity. 

Steps to Troubleshoot Memory Issues with an ESA Service Offline

Step 1: Verify that your Host is Running

The first step to troubleshooting is to ensure that your host is running. To do this, go to
Administration > Hosts. If the host is down, the system parameters will not display (updating
host information can sometimes be delayed), the Services displays in red, and the Updates field
displays an error message. 
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If your host is down, contact your SA Administrator to restart it. Otherwise, go to Step 2. 

Step 2: View Detailed Statistics in Health & Wellness

Once you are sure your ESA service is down, you can go to Health & Wellness to see where
potential issues are occurring. The most common problem is that your ESA service is exceeding
memory thresholds which causes it to stop or fail.

1. Go to Health & Wellness> Alarms to see if the ESA triggered any alarms. Look for the
following alarms:

l ESA Overall Memory Utilization > 85%

l ESA Overall Memory Utilization > 95%

l ESA Service Stopped

2. Go toHealth & Wellness > System Stats Browser to see the memory metrics for each
rule's performance. To view the metrics, enter the following:

Host  Component Category

<your host> Event Stream Analysis esa-metrics
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The memory for each rule is displayed in the Value column, and the value is displayed in
bytes. You can view a historical view of memory usage in the Historical Graph column. 

3. Go to Health & Wellness > System Stats Browser to see details of your ESA
performance. Select your host, and use the following filters to view the following statistics:

Host  Component Category Statistic Example

<your
host>

Host SystemInfo CPU Utilization 1.08%

Getting Started with ESA 20
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Host  Component Category Statistic Example

<your
host>

Host SystemInfo Memory
Utilization

45.43%

<your
host>

Host SystemInfo Used Memory 7.08 GB

<your
host>

Host SystemInfo Total Memory 15.58 GB

<your
host>

Host SystemInfo Uptime 77758, 1 week, 2 day...

<your
host>

Event Stream
Analysis

ProcessInfo Memory
Utilization

7.07 GB

<your
host>

Event Stream
Analysis

ProcessInfo CPU Utilization 0.2%

<your
host>

Event Stream
Analysis

JVM.Memory all Committed Heap Memory
Usage 8.0 GB

<your
host>

Event Stream
Analysis

ESA-Metrics Total
ESA Memory
Usage %

4.64%

If you are having a problem with memory or CPU utilization, continue to step 3. 
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Step 3: Bring up your ESA Services

1. From Administration > Services, select the actions icon for your ESA service and

choose start. 

2. Return to the ESA Service to troubleshoot which rules have created memory issues. 

If your ESA service is stopping and restarting in a loop, you may need to call Customer Support
to get the services to start.

If you are able to start your ESA service without a shutdown, continue to step 4.

Step 4: Check the Alerts and Events Volume

Once you are able to restart your ESA service without an immediate shutdown, you can review
the stats for your rules to see which rules are consuming too many resources. Sometimes, ESA
services fail because a rule is generating too many alerts or a rule is matching too many events.
Check for both of these issues if you have determined that memory usage is causing your ESA
service to shut down. 

View Alert Summaries

 Rules that generate a high volume of alerts can overwhelm the system and cause it to fail or
restart. To view the alert summaries, go to Dashboard > Alerts > Summary. On the lower half
of the screen, you can see the number of alerts generated for each rule in the Count field. If the
number is significantly high for a particular rule, you need to disable the rule and rewrite it to be
more efficient.
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View Events Matched

Sometimes a rule matches too many events which can use up excessive memory.  This typically
occurs if you create a large event window where a great number of events accumulates without
triggering an alert. These are a problem because each event is stored in memory while the rule
waits for the alert to trigger. To check for this issue, go to Dashboard > Alerts > Services. 
From there, you can see the number of events that were matched in the Events Matched
column. If there was a high number of events matched for a given rule, you can investigate the
rule further to see if you can make it more efficient.

Step 5: Disable and Repair the Rule that Caused Issues

Once you have determined the rules that need to be rewritten, disable them and rewrite rules so
that they don't generate such a high volume of alerts or events. For pointers on how to write
more efficient rules, see Best Practices.

Disable Rules

1. To disable rules, go to Alerts > Services, and select the rules you want to disable in the
Deployed Rules Stats field.

2. Select Disable to disable the rules. 
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Edit Rules

1. To repair the rules, go to Alerts > Rules > Rule Library. Select the rule to edit, and click

the actions icon  .

2. Select Edit.

3. Edit the rule to be more efficient. For instructions on creating rules, see Add Rules to the Rule
Library

4. Once you are satisfied with your rule, you can save the rule as a trial rule to ensure that any
memory issues do not affect ESA services performance. To do this, follow the steps listed
in Work with Trial Rules.

Enable Rules

1. To enable rules, go to Alerts > Services, and select the rules you want to enable in the
Deployed Rules Stats field.

2. Select Enable to enable the rules. 

(Optional) Check the ESA Log Files for More Information

Once you verify that your services are down and some potential causes for the system going
down, check to see if the service is stopping and restarting in a loop. To do this, go to the
ESA logs. From the Administration > Services module, select your ESA service and click the

actions icon  and select View > Logs. 

If you cannot access the ESA logs from the Security Analytics interface, you can SSH into the
system and go to:opt/rsa/esa/logs/esa.log.

View Memory Metrics for Rules
This topic tells ESA rule writers how to view memory metrics for rules. You can see estimated
memory usage for each rule running on a server, and you can use this information to modify your
rule statements and conditions if they use too much memory.

Rules can sometimes consume more memory than you expect, causing your ESA to slow down
or stop. To see approximately how much memory a rule is using, you can configure memory
metrics. Memory metrics allow you to view an estimated memory usage for each rule in the
Health & Well System Stats browser (so you will need permissions to access this module). You
can use this information to modify your rules to be more efficient. 

At a high level, you will need to complete the following steps to use the memory metrics to
troubleshoot memory usage for rules:
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1. Ensure that the memory metrics feature is enabled (via Explorer > CEP > Metrics
> EnableStats). The Memory Metrics feature is enabled by default.

2. Ensure you have the correct permissions to view the Health & Wellness module. For
information on roles and permissions, see Role Permissions. 

3. View the memory statistics in Health & Wellness.

4. (Recommended) Configure Health & Wellness ESA policies to send an email if memory
thresholds are exceeded. See "Manage Policies" in the System Maintenance Guide for
instructions on sending email notifications.

5. Use the memory metrics data to modify rules to be more efficient, if necessary.

Prerequisites

The following are requirements for using memory metrics:

l Memory Metrics feature is enabled (via Explorer > CEP >Metrics > EnableStats).

l The user must have the appropriate permissions to view Health & Wellness statistics. 

l (Recommended) Configure the ESA Health & Wellness policy to send an email when
memory thresholds are exceeded.

Procedures

View Memory Metrics in the Health & Wellness System Monitoring Module

1. In the Security Analytics menu, go to Administration > Health & Wellness > ESA >
System Monitoring

2. View the details for your ESA service.

3. Select Rules. 

4. You can view the average memory usage for each rule for the previous hour. 
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View Memory Metrics in the Health & Wellness System Stats Browser

1. In the Security Analytics menu, go to Administration > Health & Wellness > System
Stats Browser.

2. For component, select Event Stream Analysis. For category, enter ESA-Metrics.

The name of the rule is displayed in the Subitem field, and the memory usage is displayed in
the Value column.

3. To view the historical memory usage for the rule, click on the Historical Graph icon. 

Note: The Last Update field reflects when Health & Wellness polls ESA. However, the
Memory Metrics is not synchronized with the Health & Wellness polling. For example, if the
memory threshold is exceeded on 10/10/15 at 12 p.m., but Health & Wellness polls at 10/10/15
at 12:10 p.m., the Last Update field will display a timestamp of 10/10/15 12:10 p.m. 
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Enable or Disable the Memory Metrics Feature

1. In the Security Analytics menu, go to Administration > Services and select your ESA.

2. Once you've selected your ESA, click on Actions > View> Explore, and navigate to
CEP Metrics> Configuration as shown below.

3. Change the field EnabledStats to true or false depending on whether you want to enable or
disable the memory metrics feature.
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How ESA Generates Alerts
This topic provides a brief description of how an Event Stream Analysis (ESA) service runs
rules to generate alerts. The Security Analytics Event Stream Analysis (ESA) service service
runs rules that specify criteria for problem behavior or threatening events in your network. When
ESA detects an incident that matches rule criteria, it generates an alert.

To generate alerts, ESA performs the following functions:

1. Gathers data

2. Runs ESA rules against the data

3. Captures events that meet rule criteria

4. Generates alerts for those captured events

​You can use the Alerts module to gain visibility into your network and to detect problems in it.

Sensitive Data
This topic explains how ESA treats sensitive data, such as usernames or IP address, that it
receives from Security Analytics core. The Data Privacy Officer (DPO) role can identify meta
keys that contain sensitive data and should display obfuscated data. ESA will not display or store
sensitive meta. Consequently, ESA will not pass sensitive data to Incident Management.

Optionally, ESA can add an obfuscated version of the sensitive data to an event. For example,
the DPO identifies user_dst as sensitive. ESA can add an obfuscated version, such as user_dst_
hash, to an event. The obfuscated meta is not sensitive, so ESA will display and store it the
same way as any other non-sensitive meta.

For more information on the strategy and benefits of obfuscating data, see the Security
Analytics Data Privacy Management Guide.

This topic explains the following:

l How ESA treats sensitive data it receives from Security Analytics core

l How to prevent sensitive data leaks in an Advanced EPL rule

How ESA Treats Sensitive Data from Security Analytics Core

When ESA receives sensitive data from Security Analytics core, ESA passes on only the
obfuscated version of the data. ESA does not store or show sensitive data.

The following features are impacted:
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l Outputs – ESA does not forward sensitive data to outputs, which include alerts, notifications
and MongoDB storage.

l Advanced EPL rules – If an EPL statement creates an alias for a sensitive meta key,
sensitive data will leak. This topic illustrates how this happens so you can avoid it.

l Enrichments – If a sensitive meta key is used in the join condition, sensitive data will leak.
This topic illustrates how this happens so you can avoid it.

Advanced EPL Rule

If an EPL query statement renames a sensitive meta key, the data will not be protected.

ESA identifies a sensitive meta key by the name:

ip_src is the sensitive meta key.
ip_src_hash is the non-sensitive, obfuscated version.

To support data privacy, the sensitive meta key must not be renamed in an EPL query. If a
sensitive meta key is renamed, the data will no longer be protected.

For example, in a rule such as select ip_src as ip_alias..., ip_alias contains the sensitive data but
it is not protected because ESA only knows about ip_src, not ip_alias  In this case, IP
addresses would not be obfuscated. Real values would be displayed.

Enrichment Source

When a sensitive meta key is used in a join condition, sensitive data can be displayed.

The enrichment database, which is the other part of the join condition, has one column that
matches the sensitive meta key. This cross reference is to actual values not obscured values.
Consequently, actual values are displayed.

In the following example, both parts of the join condition are highlighted.

l ip_src contains sensitive data.

l ipv4 will be added to the alert and exposed as non-sensitive data

Because the ipv4 value is the same as the ip_src value, ipv4 contains and displays sensitive data. 
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ESA Rule Types
This topic describes each type of ESA rule, when to use them and the permissions each role has
with them. The following table lists each type, describes it and explains when to use it.

Rule
Type

Description When to Use

Rule

Builder

In the rule builder, you define

rule criteria in an easy-to-use

interface. 

Use the rule builder to create your first rules.

You choose many of the rule conditions

from lists.

Advanced

EPL

With the Event Processing Lan-

guage (EPL), you define rule

criteria by writing a query.

Use advanced EPL rules to define rule criteria

for in the EPL syntax.

RSA Live

ESA

RSA Live has a catalog of

ESA rules that you can down-

load and modify to run in your

network.

Download RSA Live ESA rules to leverage rules

that are already built. Modify the configurable

parameters to customize to meet your require-

ments.

Starter Pack Rules

A few sample Rule Builder rules come with Security Analytics and appear in the Rule
Library. Use starter pack rules to get comfortable working with rules before creating your own.
You can safely edit and deploy these sample rules.

Trial Rules Mode

For any type of rule, you can select the Trial Rule setting as an additional safeguard. Trial rules
get disabled if they exceed a memory threshold the administrator sets. Run a rule in trial mode to
monitor memory usage and to disable the rule automatically if it uses more memory than the
threshold allows.

Role Permissions
This topic lists all ESA permissions and shows which permissions are assigned to each pre-
configured Security Analytics role. User access is restricted based on roles and permissions
assigned to roles.
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l Administrators

l Operators

l Analyst

l Security Operations Center (SOC) Managers

l Malware Analysts (MA)

l Data Privacy Officer

There are four permissions for ESA:

1. Access Alerting Module – Is required for any permission

2. View Rules – Allows view-only permission for rules in the Rule Library

3. View Alerts – Allows view-only permission for alerts ESA generates

4. Manage Rules – Allows you to view, create, edit and delete rules

The following table lists permissions for ESA and the roles to which they are assigned. Use this
table to see how each role can work with rules and alerts.

Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Access Alerting

Module

Yes Yes Yes Yes Yes

View Rules Yes Yes Yes Yes

View Alerts Yes Yes Yes Yes

Manage Rules Yes Yes Yes Yes

For more information on roles and permissions, see the System Security and User
Management Guide.

Practice with Starter Pack Rules
Security Analytics comes with two starter pack rules so analysts can become familiar with how
rules look before you create your own rules. Use the starter pack rules to become familiar with
the Rule Builder and to practice editing and deploying a rule.

Starter pack rules are installed in the Rule Library, which will contain every rule you download
or create. The following figure shows the Rule Library after installation.
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These are the available starter pack rules:

l SAMPLE: P2P Software as Detected by an Intrusion Detection Device 

l SAMPLE: Non SMTP Traffic on TCP Port 25 Containing Executable

l SAMPLE: Whitelist - From outside of Germany, P2P Software as Detected by an
Intrusion Detection Device.

l SAMPLE: Blacklist - From inside countries that are not the US, Non-SMTP Traffic on
TCP Port 25 Containing Executable

l SAMPLE: User Added to Admin Group Same User su Sudo

Each name begins with SAMPLE to distinguish the rules that are installed with Security
Analytics from the rules you download and create.

Rule Library

The Rule Library shows the following information for a rule:

l Name summarizes the data or events the rule collects.

l Description explains the rule in more detail, although only the beginning shows in the Rule
Library.

l Trial Rule indicates if trial mode is enabled or disabled for the rule.

l Type shows the origin of the rule, built in Rule Builder or Advanced EPL or downloaded
from RSA Live.
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Procedure

1. In the Security Analytics menu, select Alerts > Configure.
The Configure view is displayed with the Rules tab open.

2. In the Rule Library, select a sample rule and click , or double-click a rule.

The rule is opened in Rule Builder.
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3. To practice with a starter pack rule, refer to the following topics for detailed descriptions
and procedures:

l To familiarize yourself with the Rule Builder user interface, see Rule Builder Tab for a
description of each field.

l To learn how to edit a rule, see Add a Rule Builder Rule for a step-by-step procedure.

l To deploy a starter pack rule, see Deploy Rules to Run on ESA to learn how to associate
the rule with an ESA service.

After you practice with starter pack rules, you will be able to download, create and deploy your
own rules.
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Work with Trial Rules
When rules use too much memory, your ESA service can become slow or unresponsive. To
ensure rules do not use excessive memory, you can enable trial rules for any type of rule. By
default, new rules you create and RSA Live rules you import are configured to be trial rules.
RSA recommends you disable the trial rule setting only after testing the new rule in your
environment during normal and peak network traffic. When you create a trial rule, you set a
global threshold of the percentage of memory that rules may use. If that configured memory
threshold is exceeded, all trial rules are disabled.

The Security Analytics Event Stream Analysis (ESA) service is capable of processing large
volumes of disparate event data from Concentrators. However, when working with Event Stream
Analysis, it is possible to create rules that use excessive memory. This can slow your ESA
service or even cause it to shut down unexpectedly. To ensure that this doesn't happen, you can
configure your rule as a trial rule. When you configure a trial rule, you also set global threshold
of the percentage of memory that rules may use. If that configured memory threshold is
exceeded, all trial rules are disabled automatically.

For suggestions on creating more efficient rules, see "Best Practices for Writing Rules" in Best
Practices

By default, new rules and RSA Live rules are configured as trial rules. As a best practice, when
you edit an existing rule, select the Trial Rule option, which allows you to:

l Deploy the rule with an added safeguard.

l Optionally, view a snapshot of memory utilization to understand if the rule creates memory
issues.

l Know if you must modify the rule criteria to improve performance.

Note: Run a rule as a trial rule long enough to assess the performance during normal and peak
network traffic. 

Deploy Rules as Trial Rules
This topic explains to administrators how to enable trial rules when creating new rules or editing
rules. Trial rules are automatically disabled if a specified total JVM memory
utilization threshold is exceeded.
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Procedure

To deploy rules as trial rules:

1. In the Security Analytics menu, go to Alerts > Configure. 
The Configure view is displayed with the Rules tab open.

2. From the Rule Library, choose to add or edit a rule. The rule builder is displayed in a new
Security Analytics tab.

3. To make a new or existing rule a trial rule, select  .

4. Add the rule conditions or modify the rule as needed. For instructions on editing rules,
see Add Rules to the Rule Library.

5. Click Save. 

6. Ensure that trial rules are enabled for your ESA and that you are satisfied with the thresholds
configured for trial rules. 
The memory threshold is set in the configuration file. To configure it, see "Change Memory
Threshold for Trial Rules" in the ESA Configuration Guide.
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The threshold is configured per ESA and is a percentage of Java Virtual Memory.
The configuration parameter, MemoryThresholdforTrialRules default is 85.

7. Optionally, you can set up the policies in Health and Wellness to send you an email
notification if the total JVM memory utilization threshold is exceeded.

The next time you deploy the rule, it runs in trial rule mode.

Note:  If a trial rule is disabled, you will need to go to the Alerts > Configure > Services tab
to re-enable the trial rules. For more instructions on re-enabling trial rules on a service,
see View ESA Stats and Alerts.

View Memory Metrics for Rules Using Trial Mode
This topic tells ESA rule writers how to view memory metrics when the memory threshold
configured for trial rules is exceeded.  If the memory threshold is exceeded, you can configure a
snapshot to be taken of the memory usage for ESA rules at the time that trial rules are disabled,
allowing you to investigate memory usage and edit the rules to be more efficient.

When you configure trial rules and enable the Memory Snapshot feature, if the memory
threshold is exceeded, all trial rules are disabled and a snapshot of the memory usage for all
ESA rules is taken at the time of disablement. This allows you to see how much memory was
used so that you can modify your ESA rules to be more efficient. The memory snapshot can be
viewed in the Health & Wellness System Stats browser, so you will need permissions to access
this module. Once you view the details in the System Stats browser, you can modify the trial rule
syntax and re-enable the trial rules.

At a high level, you will need to complete the following steps to use the Memory Snapshot to
troubleshoot memory usage for rules:

1. Enable trial rules for any new rules you deploy. See Deploy Rules as Trial Rules.

2. Ensure that you have configured Health & Wellness ESA policies to send an email if
memory thresholds are exceeded.

3. Ensure you have the correct permissions to view the Health & Wellness module. For
information on roles and permissions, see Role Permissions.

4. Ensure that the Memory Snapshot feature is enabled (via the EnabledCaptureSnapshot
parameter via SA Explorer). The Memory Snapshot feature is disabled by default. See
"Enabling and Disabling the Memory Snapshot Feature" below. RSA recommends
you disable the feature once you have completed testing new rules.
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5. View the memory threshold statistics in Health & Wellness if the memory threshold is
triggered for trial rules.

6. Modify the rule or rules that triggered the alarm. For best practices for rule writing, see Best
Practices.

7. Re-enable the trial rules that were disabled when the memory threshold was triggered. For
instructions on re-enabling trial rules on a service, see View ESA Stats and Alerts.

8. Continue to test the trial rules. 

Note: Like any Debug tool, there can be exceptional overhead associated with using the
Memory Snapshot feature. When actively taking a snapshot, the Memory Snapshot feature can
add delays to your ESA services. The ESA service stops generating alerts while taking a
snapshot. RSA recommends you disable the feature once you have completed testing new
rules. If you disable the Memory Snapshot feature, trial rules will still be disabled when
memory usage exceeds configured thresholds, but the memory snapshot will not be taken, and
the statistics will not appear in the Health & Wellness System Stats browser.

Prerequisites

These are the requirements for viewing memory metrics:

l One or more ESA rules must be configured as a trial rule.

l Memory Snapshot must be enabled (via the EnabledCaptureSnapshot parameter via SA
Explorer).

l The user must have the appropriate permissions to view Health & Wellness statistics. 

l The user must have configured the ESA Health & Wellness policy to send an email when
memory thresholds are exceeded.

Procedures

View Memory Metrics

1. In the Security Analytics menu, go to Administration > Health & Wellness > System
Stats Browser.

2. For component, select Event Stream Analysis. For category, enter ESA-Metrics. 
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The name of the rule is displayed in the Subitem field, and the memory usage is displayed in the
Value column. 

Note: The Last Update field reflects when Health & Wellness polls ESA. However, the
Memory Snapshot only occurs when memory thresholds are exceeded, so this field does not
reflect when the snapshot was taken or updated. The snapshot remains static until the memory
threshold is exceeded again. For example, if the memory threshold is exceeded on 10/10/15 at
12 p.m., but Health & Wellness polls at 10/10/15 at 3 p.m., the Last Update field will display
a date of 10/10/15 3 p.m. 

Enable or Disable the Memory Snapshot Feature

1. In the Security Analytics menu, go to Administration > Services and select your ESA. 

2. Once you've selected your ESA, click on Actions > View> Explore, and navigate to
CEP Metrics as shown below. 
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3. Change the field EnabledCaptureSnapshot to true or false depending on whether you want to
enable or disable the Memory Snapshot feature. 
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Add Rules to the Rule Library
This topic explains how to add each type of rule to the rule library. You must add a rule to the
Rule Library before you can deploy it. Permission to manage rules is required for all tasks in this
section. To add rules, you can download them from ESA Live, create a rule via the Rule
Builder, or write advanced EPL rules.

For more details on each of these procedures, see:

l Download Configurable RSA Live ESA Rules

l Add a Rule Builder Rule

l Add an Advanced EPL Rule

In addition to deploying a rule, you can edit, duplicate, import, export, and remove a rule in the
Rule Library. For details on these procedures, see Working with RulesWorking with Rules

Download Configurable RSA Live ESA Rules
This topic explains how to download configurable rules from the Security Analytics Live
Content Management System so you can customize them to meet your needs.

RSA Live contains a catalog of rules. Each rule has configurable parameters so you can
customize the rule for your environment. If RSA Live has a rule to detect events that you want
to detect in your network, download the rule to save time. You can edit the configurable
parameters and save the rule in your Rule Library. 

This is a sample of how each RSA Live ESA rule is described on RSA Live:

Rule Name Description

Logins across Multiple

Servers

Detects logins from the same user across 3 or more separate serv-

ers within 5 minutes.

The time window and number of unique destinations are con-

figurable.

As the name shows, the rule looks for logins across multiple servers. The description explains
the rule criteria in more detail and specifies which parameters you modify.
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Note:When a rule description includes a configurable parameter, the default setting for the
parameter is used. In the sample rule, the description states 5 minutes. However, the time
window is configurable so 5 is the default number of minutes.

Prerequisites

These are the prerequisites for downloading configurable RSA Live ESA rules;

l Have permission to manage rules

l Create a Live Account. See the Live Services Management Guide for details.

l Set up Live on Security Analytics. See the Live Services Management Guidefor details.

Procedure

To download configurable RSA Live ESA rules:

1. In the Security Analytics menu, select Alerts > Configure.
The Rules tab is displayed.

2. In the options panel, click Get Rules from RSA Live.
The Search tab is displayed.

3. In Search Criteria, for Resource Type select RSA Event Stream Analysis Rule.

4. Specify any of the following criteria to find a rule to configure for your environment. 
For a detailed description of the search criteria, see "The Live Search View" in the Live
Services Management Guide.
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a. Keywords

b. Tags

c. Required Meta Keys

d. Generated Meta Values

e. Resource Created Date

f. Resource Modified Date

5. Click Search. Rules that match the search criteria are displayed in Matching Resources.

6. Select each rule to download and click Deploy. 
The Deployment Wizard is displayed

7. Follow the steps in the wizard. If you need more information, see "Deploy Resources in
Live" in the Live Services Management Guide.

When you finish the steps in the wizard, the selected rules are displayed in the Rule Library.

Customize an RSA Live ESA Rule

This topic explains how to configure parameters in an RSA Live ESA rule. When you download
an RSA Live ESA rule, the rule appears in the Rule Library which includes the following
columns:

l Name

l Description

l Trial Rule

l Type

The type is RSA Live ESA Rule.

Prerequisites

l Administrator, Operator, SOC Manager or DPO role permissions are required.

l Rules must be downloaded to the Rule Library.
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Procedure

To customize an RSA Live ESA rule:

1. In the Security Analytics menu, select Alerts > Configure > Rule.

2. In the Rule Library, select an RSA Live ESA Rule and click .

The RSA Live ESA Rule tab is displayed.

3. (Optional) Change the following fields:

l Rule Name

l Description

l Trial Rule (Enabled by default. RSA recommends you run a rule as a trial rule long enough to
assess the performance during normal and peak network traffic.)

l Severity

4. To configure the rule for your environment, in the Parameters section replace the default
in the Value Column.

5. Click Save

Add a Rule Builder Rule
This topic introduces a set of end-to-end procedures for adding a Rule Builder type rule.

Each ESA rule is designed to detect something in your network and to generate an alert for it:

l User activity that is not allowed, such as attempting to download software that is not
sanctioned

l Suspicious behavior, such as mass audit clearing

l Known malicious threats, such as worm propagation or a password-cracking tool

There are two methods to design a rule in ESA:

l Rule Builder is an easy-to-use interface. You provide a meta key and value, then select
choices from lists to complete the criteria.
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l Advanced EPL allows you to write queries in the Event Processing Language. You must
know EPL syntax.

If you know EPL, you can use either method. If you do not know EPL, you must use Rule
Builder. These topics explain the Rule Builder. 

Step 1. Name and Describe the Rule

This topic provides instructions to identify a rule, indicate if it is a trial rule and assign a severity
level. When you add a new rule, the first information to provide is a unique name and description
of what the rule detects. After you save the rule, this information is displayed in the Rule
Library. 

Prerequisites

You must have permission to manage rules. See Role Permissions.

Procedure

To name and describe a rule:

1. In the Security Analytics menu, select Alerts > Configure > Rule

2. In the Rule Library, select  > Rule Builder.

The New Rule tab is displayed.

3. Type a unique, descriptive name in the Rule Name field.
This name will appear in the Rule Library so be specific enough to distinguish the rule from
others.

4. In the Description field, explain which events the rule detects.
The beginning of this description will appear in the Rule Library

5. By default, new rules are configured as a Trial Rule. A trial rule automatically disables the
rule if all trial rules collectively exceed the memory threshold. If you are editing an existing
rule, you can select Trial Rule to safely test the rule edits.
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Use trial rule mode as a safeguard to see if a rule runs efficiently and to prevent downtime
caused by running out of memory. For more information, see Work with Trial Rules.

6. For Severity, classify the rule as Low, Medium, High or Critical.

Step 2. Build a Rule Statement

This topic provides instructions to define rule criteria in Rule Builder by adding statements. A
statement is a logical grouping of rule criteria in the Rule Builder. You add statements to define
what a rule detects. 

Example

The following graphic shows an example of a Rule Builder statement.

Every statement contains a key and value. Then, you build logic around the pair by selecting an
option in each other field.

Prerequisites

To build a rule statement, you must know the meta key and the meta value.
For a complete list of meta keys, go to Alerts > Configure > Settings > Meta Key References.

Procedure

To build a rule statement:

1. In the Security Analytics menu, select Alerts > Configure.

The Rules tab is displayed by default.
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2. In the Rule Library, click  > Rule Builder or edit an existing Rule Builder rule.

The Rule Builder view is displayed.

3. In the Conditions section, click   .

The Build Statement dialog is displayed.

4. Name the statement. Be clear and specific. The statement name will appear in the Rule
Builder.

5. From the drop-down list, select which circumstances the rule requires:

l if all conditions are met

l if one of these conditions are met

6. Specify the criteria for the statement:

a. For Key, type the name of the Meta Key.

b. For Operator specify the relationship between the meta key and the value you will
provide for it.
The choices are: is, is not, is not null, is greater than (>), is greater than or equal to (>=),
is less than (<), is less than or equal to (<=), contains, not contains, begins with, ends
with​

c. Type the Value for the meta key.
Do not add quotes around a value. Separate multiple values with a comma.
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d. The Ignore Case? field is designed for use with string and string array values. By
choosing the Ignore Case field, the query will treat all string text as a lowercase value.
This ensures that a rule that searches for the user named Johnson would trigger if the
event contains "johnson," "JOHNSON," or "JoHnSoN."

e. The Array?field indicates if the contents of the Value field represent one or more than
one value.

Select the Array checkbox if you entered multiple, comma-separated values in the Value
field. For example, "ec_activity is Logon, Logoff" requires you to select the Array
checkbox.

7. To use another meta key in the statement, click  , select Add Meta Condition and repeat

step 6. 

8. To add a whitelist, click  and select Add Whitelist Condition. .

9. To add a blacklist, click   and select Add a Blacklist Condition.

10. To save the statement, click Save. 

To Add a Whitelist

You use a whitelist to ensure that specified events are excluded from triggering the rule.
Whitelists can be based on geographic location or by customer-defined enrichment CSV
sources.  For example, if you want to create a rule that only triggers for IP addresses outside of
the US, you can create a whitelist of US IP addresses.

1. After you add a meta condition, click   and select Add Whitelist Condition.

2. In the EnterWhitelist Name field, select an enrichment source. Any enrichment source
loaded from a CSV or a named window in Esper can be used as source for a whitelist. 

3. If you used a GeoIP source for the whitelist, ipv4 is automatically entered for the
subcondition. Enter the meta value for the corresponding value field. For example, enter ipv4
is ip_src to ensure the GeoIP records are selected based upon the ip_src being found in the
GeoIP lookup database. In addition, if you used a GeoIP source for the whitelist, you might
want to add a subcondition to specify the geographic region to exclude from the rule
results. For example, to specify that the country code must be USA, enter "CountryCode is
US".
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To Add a Blacklist

You use a blacklist to ensure that specified events trigger the rule. Blacklists can be based on
geographic location or by customer-defined enrichment CSV sources. For example, you can
specify that the rule only includes results from Germany. 

1. After you add a meta condition, click   and select Add Blacklist Condition.

2. In the Enter Blacklist Namefield, select an enrichment source.  Any enrichment source
loaded from a CSV or a named window in Esper can be used as source for a blacklist. 

3. If you used a GeoIP source for the blacklist, ipv4 is automatically entered for the
subcondition. Enter the meta value for the corresponding value field. For example, enter ipv4
is ip_src to ensure the GeoIP records are selected based upon the ip_src being found in the
GeoIP lookup database.  In addition, if you used a GeoIP source for the blacklist, you might
want to add a subcondition to specify the geographic region to include in the rule results. For
example, to specify that the rule only includes results for Germany, enter "CountryCode
is DE".

Example: Blacklist

The following statement shows a blacklist statement for a rule that monitors for non-SMTP
traffic on TCP destination port 25 containing an executable from countries that are outside of the
United States. 
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 Statement Description

service is not 25 The traffic is not SMTP traffic. 

tcp_dstport is 25 The traffic is running on TCP port 25. 

extension is exe, com,vb,vb-

s,vbe,cmd,bat,ws,wsf,src,sh

The file extension is an executable.

GeoIpLookup The blacklist is based on a GeoIPLookup source.

ipv4 is ip_src The GeoIP records are selected based upon the ip_src

being found in the GeoIP lookup database. 

countryCode is not US  When looking up the IP address Event.ip_src in the

GeoIP database, the record it returns does not contain

"US" in the countryCode field.

Example: Ignoring Case, Strict Pattern Matching, and Using The Is Not Null Operator

The following example uses the ability to ignore case, exclude null values, and create a strict
pattern match to ensure that it returns the expected rule results. The following conditions make
up the rule:
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Rule Condi-
tion

Description

Failures This condition searches for five failed logins with a "followed by" con-

nector, meaning that the condition (Failures) must be followed by the next

condition (Success).

Success This condition searches for one successful login. 

ModifyPassword This condition searches for an instance where the password is modified.

GroupBy: user_

dst, device class

The GroupBy field ensures that all the previous conditions are grouped by

the user_dst meta (the user destination account) and device class. This is

important to the construction of the rule because the rule attempts to find a

case where a user has attempted to log into the same destination account

multiple times, finally logged in successfully, and then changed the pass-

word. Grouping by device class ensures that the user logged in from the

same machine attempted to log into an account multiple times. The rule

may give unexpected results if you do not group the results.

Occurs within

5 minutes

The time window for the events to occur is five minutes. If the events occur

outside of this time window, the rule does not trigger. 

Event Sequence:

Strict

The event sequence is configured for a strict pattern match. This means

that the pattern must match exactly as it is specifiedwith no intervening

events. 

Strict pattern matching allows you to ensure that the Esper engine only
generates alerts for rules that exactly match the pattern you want to find.
For example, a common rule might be to search for five failed logins
followed by a successful login. If you select a loose pattern match, this rule
will trigger if there are any number of successful logins between the failed
logins. Since the point of the rule is to find frequent and sequential login
attempts, a strict match is required to ensure that you get the results you
expect. 

Note: Each of these conditions is explained in further detail in the sections below. 

For each condition, a statement is built in the Rule Builder. The following statement makes up
the Failures condition:
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Rule
Statement

Description

ec-activity is

Logon

(ignore

case)

Identifies activity that attempts to log on to a system.

The Ignore Case field is designed for use with string and string array values.
By choosing the Ignore Case field, the query will treat all string text as a
lowercase value. You may want to use this field if you are unsure what case
may be used when logging a particular event. Because the case is ignored, the
rule can trigger if the activity is logged as Logon, logon, or LoGoN.

ec_outcome

is Failure

(ignore

case)

Identifies activity outcome logged as "failure." Because the case is ignored, the

rule can trigger if the activity is logged as "failure", "Failure," or "FaiLuRe."

user_dst is

not null

Ensures that the condition is only true if user_dst is populated.

The is not null operator allows you to ensure that a field returns a value. You
may want to use this field when a rule depends on a particular field returning a
value. For example, you want to create a rule that identifies the same user
attempting to log into the same destination account multiple times (potentially a
password-guessing attack). If the field that represents the user destination
account is empty, you don't want the rule to trigger. To ensure the field contains
a value, you use the is not null operator. 
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The following statement makes up the Success condition:

Rule State-
ment

Description

ec_activity is

Logon

Identifies logon activity. 

ec_outcome is Suc-

cess

Identifies a logon that is successful.

user_dst is not null Ensures that user destination account field must be populated for the con-

dition to be true. 

The following statement makes up the ModifyPassword condition:
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Rule State-
ment

Description

user_dst is not null Ensures the user destination account field must be populated for the con-

dition to be true. 

ec_subject is Pass-

word

Identifies a subject of Password. 

ec_activity is

Modify

Identifies activity where the password was modified. 

Example Results

When the alert fires for the example rule, you can see that the rule triggered for seven events,
and that each event contains a user. You can also see that the events follow a strict pattern: five
failed login events, followed by a successful login event, followed by a modification to the
account. 
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Drilling down into the Investigation module by clicking on the source for one of the events, you
can see the case for each of the string values. Because you used Ignore Case, the rule would
trigger if the string values were upper or lower case. 
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Example: Grouping the Rule Results

The Group By field allows you to group and filter rule results. For example, suppose that there
are three user accounts; Joe, Jane, and John and you use the Group By meta, user_dst. The
result will show events grouped under the accounts for Joe, Jane, and John.

You can also group by multiple keys, which can further filter rule results. For example, you
might want to group by user destination account and machine to see if a user logged into the
same destination account from the same machine attempts to log into an account multiple times.
To do this, you might group by device_class and user_dst.

The following example shows a rule grouped by device_class and user_dst. 

Rule Condi-
tion

Description

Failed Logins Identifies five failed login attempts (must be followed by the next condition;

i.e., the five failed logins must be followed by a successful login).

Successful

Login

Identifies one successful login. 
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Rule Condi-
tion

Description

Group By:

user_dst and

device_class

Groups the rule results by user_dst (user destination account) and device_

class (type of machine the user is logging in from). This allows the rule to

look for a user logged in from the same machine to the same destination

account, resulting in a much more targeted rule result. 

Occurs within 5

minutes with a

strict pattern

match

The events must occur within five minutes, and the pattern matching is

strict, meaning it must follow the pattern exactly for the rule to trigger. 

Example: Working with Numeric Operators

Numeric operators allow you to write rules against numeric values, such as specifying that a
value is greater than, less than, or equal to a specific value. This is useful particularly for cases
where you might want to specify a numeric threshold, i.e., payload is greater than 7000. 

The following example attempts to identify a data transfer to a particular destination through the
common ports where the transfer size is high and the payload is in a suspicious range.
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Rule Statement Description

ip_dst is 10.10.10.1 The destination port is 10.10.10.1.

ip_dstport is greater than or

equal to 1024

The destination port is in a commonly used port range, 1024

or greater.

size is greater than or equal to

10000

The size of the transfer is 10000 or greater, which is a sus-

piciously large transfer. 

payload is greater than 7000 The payload is between 7000 and 8000, which is a sus-

piciously large payload. 

payload is less than 8000 The payload is between 7000 and 8000, which is a sus-

piciously large payload. 

Step 3. Add Conditions to a Rule Statement

This topic provides instructions to add conditions, such as specifying a certain time frame, to a
rule statement. When you build a statement, you specify what a rule detects. You add conditions
to make further stipulations, such as how many times or when the criteria must occur.

Example

The following graphic shows an example of the conditions for Rule Builder
statements. Combined, the statements and conditions comprise the rule criteria.

This rule detects 5 failed logon attempts followed by one successful logon, which could be the
sign that someone has hacked into user account. This is the criteria for the rule:
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A. 5 failed logons are required.

B. 1 successful logon must follow the failures

C. A password was changed.

D. All events must occur within 5 minutes.

E. Group alerts by user (user_dst), because steps A and B must be performed on the same user
destination account. Also, group by machine (device_class) to ensure that the user logged in
from the same machine attempts to log into an account multiple times.

F. The match is a strict pattern, meaning that the pattern must match exactly with no
intervening events.  

Procedure

To add conditions to a rule statement:

1. In the Conditions section, select a statement and click  .

2. For Occurs, enter a value to specify how many occurrences are required to meet the rule
criteria.

3. If you have multiple statements, in the Connector field select a logical operator to join one
statement to another:

l followed by

l not followed by

l AND

l OR

4. Correlation Type applies only to followed by and not followed by. If you choose a
correlation type of SAME, select one meta to correlate on, and if you choose a correlation
type of JOIN, select two meta to correlate on. You may want to use JOIN if you are trying
to correlate on meta from two different data sources. For example, say you want to correlate
an AV alert with an IDS alert. See the examples below for a use case where two meta from
different sources are joined.

5. If events must happen within a specific timeframe, enter a number of minutes in the Occurs
Within field.

6. Choose whether the pattern must follow a Strict match or a Loose match. If you specify a
strict match, this means that the pattern must occur in the exact sequence you specified with
no additional events occurring in between. For example, if the sequence specifies five failed
logins (F) followed by a successful login (S), this pattern will only match if the user executes
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the following sequence: F,F,F,F,F,S. If you specify a loose match, this means that other
events may occur within the sequence, but the rule will still trigger if all of the specified
events also occur. For example, five failed login attempts (F), followed by any number of
intervening successful login attempts (S), followed by a successful login attempt might
create the following pattern: F,S,F,S,F,S,F,S,F,S which would trigger the rule despite the
intervening successful logins.  

7. Choose the fields to group by from the dropdown list. The Group by field allows you to
group and evaluate the incoming events. For example, in the rule that detects 5 failed logon
attempts followed by 1 successful attempt, the user must be the same, so user_dst is the
Group By meta key.​ You can also group by multiple keys. Using the previous example, you
might want to group by user and machine to ensure that the same user logged in from the
same machine attempts to log into an account multiple times. To do this, you might group by
device_class and user_dst.

Example

The following graphic shows an example of the conditions for a rule that allow you to evaluate
the same entities across multiple devices so you can accomplish complex use cases. For
example, you can create a rule that triggers if an IDS (Intrusion Detection System) alert is
followed by an AV(Anti-virus) alert for the same workstation. The work station key is not the
same between the two (IDS & AV) sources, so you can perform a JOIN in order to evaluate the
different entities.

In the IDS alert, the workstation is identified by the source IP address from the IDS alert, and
would be compared to the destination IP address from the AV alert.

This is the criteria for the rule:

A. An IDS alert occurs.

B. The destination IP address from the AV alert and source IP address for the workstation from
the IDS alert are joined to allow you to view the same entities across different sources.

C. An Antivirus alert follows the IDS alert.
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Add an Advanced EPL Rule
This topic provides instructions to define rule criteria by writing an EPL query. EPL is a
declarative language for handling high-frequency time-based event data. It is used to express
filtering, aggregation, and joins over possibly sliding windows of multiple event streams. EPL
also includes pattern semantics to express complex temporal causality among events.

Write an advanced EPL rule when rule criteria is more complex than what you can specify
in Rule Builder.

It is outside the scope of this guide to explain EPL syntax. 

l For EPL Documentation, see http://www.espertech.com/esper/documentation.php. 

l For the EPL Online Tool, see http://esper-epl-tryout.appspot.com/epltryout/mainform.htm

Prerequisites

The following are prerequisites for adding an advanced rule:

l You must know Event Processing Language (EPL).

l You must understand ESA Annotations to mark which EPL statements are linked to
generating alerts.

Procedure

To add an Advanced EPL rule:

1. In the Security Analytics menu, select Alerts > Configure.

2. In the Rule Library, select  > Advanced EPL.
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3. Type a unique, descriptive name in the Rule Name field.

This name will appear in the Rule Library so be specific enough to distinguish the rule from
others.

4. In the Description field, explain which events the rule detects.

The beginning of this description will appear in the Rule Library

5. Select Trial Rule to automatically disable the rule if all trial rules collectively exceed the
memory threshold.

Use trial rule mode as a safeguard to see if a rule runs efficiently and to prevent downtime
caused by running out of memory. For more information, see Work with Trial Rules.

6. For Severity, classify the rule as Low, Medium, High or Critical.

7. To define rule criteria, write a Query in EPL.

Note: For all meta key names, use an underscore not a period. For example, ec_
outcome is correct but ec.outcome is not.

8. For dynamic statement name generation in ESA, you must enclose the meta keys in curly
brackets and include this annotation in the syntax:

@Name("RIG {ip_src} {alias_host} {ec_activity}")

where,
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l RIG is the static part of the statement name

l {ip_src}, {alias_host}, {ec_activity} is the dynamic part of the statement name

Note: If any of the metas in the dynamic part of the statement name has a null value, it is
displayed as a static text.
If you want to view the meta along with the curly braces, for instance, {meta}, you can
use the "\\" character. For example, @Name("static text \\{ip_src\\}")

If a rule should generate an alert, include this ESA annotation in the syntax:

@RSAAlert

For more information on ESA Annotations, see ESA Annotations.

Event Processing Language (EPL)

This topic describes Event Processing Language (EPL), a declarative language for dealing with
high frequency time-based event data. ESA uses Event Processing Language (EPL), a
declarative language for dealing with high frequency time-based event data. It is used for
express filtering, aggregation, and joins over possibly sliding windows of multiple event streams.
EPL also includes pattern semantics to express complex temporal causality among events. It can
perform, but is not limited to, the following functions:

l Filter Event

l Alert Suppression

l Compute percentages or rations

l Average, count, min and max for a given time window

l Correlate events arriving in multiple stream

l Correlate events that arrive out of order

l On-Off Windows

l Followed-by and Not Followed-by support

l Regex filter support

Databases require explicit querying to return meaningful data and are not suited to push data as
it changes. The developer must implement the temporal and aggregation logic himself. By
contrast, the EPL engine provides a higher abstraction and intelligence and can be thought of as
a database turned upside-down. Instead of storing the data and running queries against stored
data, EPL allows applications to store queries and continuously run the data through. Response
from the EPL engine is real-time when conditions occur that match user defined queries.
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For the purposes of online help, basic statements are used to illustrate how to set up ESA;
however, for more information about writing EPL statements, the http://www.espertech.com site
provides tutorials and examples. 

Note: ESA supports Esper version 5.3.0.

ESA Annotations

This topic describes two annotations that Security Analytics provides to use in advanced
EPL rules.

@RSAAlert Annotation

The @RSAAlert annotation is used to mark which EPL statements are linked to generating
alerts. The @RSAAlert is optional in advanced rules and is useful only with statements that are
expected to generate ESA alerts.

Note: This annotation is not needed in all EPL statements, like those that create named
windows

For example, consider the following sequence of simplified events:

@RSAPersist Annotation

The @RSAPersist annotation is used to mark a named window as a ESA managed window for
persistence. By marking the named window as a ESA managed window, ESA periodically
writes the contents of the window to disk and restores them back if the window is un-deployed
and re-deployed. The systems take a snapshot just before the module is un-deployed and the
window is removed. Conversely, it restores the window contents from the snapshot just after the
module is re-deployed. This ensures that the contents of the window are not lost if the module
state is altered or if the ESA service goes down.​

For example, consider a named window, DHCPTracker that holds a mapping from IP addresses
to each assigned hostname.You can annotate the statement with the @RSAPersist annotation as:
@RSAPersist
create window DHCPTracker.std:unique(ip_src) as (ip_src string, alias_

host string);
insert into DHCPTracker select IP as ip_src, HostName as alias_

host from DHCPAssignment(ID=32);
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Note: All windows definitions are not suitable for persistence. @RSAPersist annotation
must be used with care. If the window has timed-records or if it depends on time based
constraints it is very likely that the reverted snapshots will not restore it to the correct state.
Also, any changes to the window definition will invalidate the snapshots and reset the window
to a blank state. The system does not do any semantic analysis to determine if the changes to
the window definition are conflicting or not. Note that other parts of a module (i.e. other than
the particular CREATE WINDOW call that defines the window) may change, without
invalidating the snapshots.

@UsesEnrichment (10.6.1.1 and later)

The @UsesEnrichment can be used in advanced EPL rules to reference enrichments. In order to
synchronize enrichments with ESA, all enrichment dependencies in EPL rules must be
referenced with the @UsesEnrichment annotation.

The @UsesEnrichment annotation uses the following format:
@UsesEnrichment(name= '<enrichment_name>')

For example, the following EPL references a whitelist enrichment:

@UsesEnrichment(name = 'Whitelist')

@RSAAlert

SELECT * FROM Event(ip_src NOT IN (SELECT ip_address FROM
Whitelist))

@Name

The @Name is the statement name defined in ESA advanced rules. It is used to dynamically
generate statement names in ESA alerts. The statement name of only an alert triggering
statement is displayed. This annotation has meta keys enclosed in curly brackets.

The @Name annotation uses the following format:

@Name("<static_part_of_statement_name> {meta_key1} {meta_
key2}…")

For example, the following EPL references meta keys ip_src and user_name whose values will
be dynamically generated.

@Name(“Login Event to {ip_src} by {user_name}”)

Note: You can specify any number of meta keys in the statement for dynamic statement name
generation.
The length of individual meta key is limited to 64, after which the value is truncated and
appended with “…”.
The length of the dynamic generation of statement name is limited to 128, after which the
value is truncated to 128 and appended with “…”. All the remaining values post truncation
will be treated as static values.
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Sample Advanced EPL Rules

Following are the examples of Advanced ESA rules. Each example has multiple ways of
implementing the same use-case.

Example #1: 

Create an user account and delete the same user account in 300s. User information is stored in
user_src meta.

EPL #1:

Rule Name CreateuseraccountFollowedbyDeletionof Useraccount1

Rule

Description

Create a user account followed by an action to delete the same user account in

300 seconds.

Rule Code

SELECT * FROM Event(ec_subject='User'
AND ec_outcome='Success'
AND user_src is NOT NULL
AND ec_activity IN ('Create', 'Delete')
).win:time(300 seconds)

match_recognize (partition by user_src
measures C as c, D as d
pattern (C D)

define
C as C.ec_activity='Create' ,
D as D.ec_activity='Delete');

Note

l Filter events needed for pattern in given time frame. Filter conditions should
be such that only required events are passed to match recognize function. In
this case, they are create and delete user account Events. i.e. Event(ec_
subject='User' AND ec_outcome='Success' AND user_src is NOT NULL
AND ec_activity IN ('Create', 'Delete')

l Partition by creates buckets. In this case, esper creates buckets per value of
user_src. And hence value of user_src is common between both events.

l Define pattern you want. Right now it is set to Create Followed by Delete.
You can do multiple creates followed by delete (C+ D). Pattern is very
similar to regular expression.

l Most efficient use case.
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EPL #2:

Rule Name CreateuseraccountFollowedbyDeletionof Useraccount2

Rule

Description

Create a user account followed by an action to delete the same user account in

300 seconds.

Rule Code

SELECT * from pattern[every (a= Event(ec_subject='User' AND
ec_outcome='Success' AND user_dst is NOT NULL AND ec_
activity IN ('Create'))

 ->

( Event(ec_subject='User' AND ec_outcome='Success' AND

user_dst is NOT NULL AND ec_activity IN ('Create') AND

user_src = a.user_src)

) )where timer:within(300 Sec) ]; 

Note

l Lets say same user is created twice and deleted once in that order. Then the
above pattern will fire 2 alerts.

l A thread is created for every User creation.

l There is no way to control threads. It is important to have time bonds and
preferably small intervals.

Example #2: 

Detect pattern where user created followed by login by same user and user is deleted in end. In
case of windows logs user info is stored in either user_dst or user_src depending on event.

user_src(create) = user_dst(Login) = user_src(Delete)

EPL #3:

Rule Name CreateUserLoginandDeleteUser

Rule

Description

Detect a pattern where a user creates a User account followed by login by the

same user followed by deletion of the User account. 

Rule Code

SELECT * FROM Event(ec_subject='User'
and ec_activity in ('Create','Logon','Delete')

and ec_theme in ('UserGroup', 'Authentication')
and ec_outcome='Success'
).win:time(300 seconds)

match_recognize (measures C as c, L as l, D as d
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pattern (C L D)
define
C as C.ec_activity = 'Create',
L as L.ec_activity = 'Logon' AND L.user_dst = C.user_

src,
D as D.ec_activity = 'Delete' AND D.user_src = C.user_src
);

Note

l Since user_src/user_dst is not common across all events we can't use
partition. It will be 1 single bucket running 1 pattern at a time. For example,
for user 1 and 2 if the stream of events are C1C2L1D1, C1L1C2D1, there
will be no alert because C1 thread got reset by C2. Alert will be fired only if
C1L1D1 are in order and no other event either from same user or other user
falls in between. 

l Another solution would be to use Named Window and merge user_dst and
user_src into single column and then run match recognize. (EPL #3). 

l Pattern can also be used. You might get more alerts than expected.
(EPL #4).

EPL #4: Using NamedWindows and match recognize

Rule Name CreateUserLoginandDeleteUser

Rule

Description

Detect a pattern where a user creates a User account followed by login by the

same user followed by deletion of the User account. 

Rule Code

@Name('NormalizedWindow') create window
FilteredEvents.win:time(300 sec) (user String, ecactivity
string, sessionid Long);

@Name('UsersrcEvents')  Insert into FilteredEvents  select
user_src as user, ec_activity as ecactivity, sessionid from
Event( ec_subject='User' and ec_activity in
('Create','Delete') and ec_theme in ('UserGroup',
'Authentication') and ec_outcome='Success' and user_src is
not null );

@Name('UsrdstEvents')  Insert into FilteredEvents  select
user_dst as user, ec_activity 

as ecactivity, sessionid from Event( ec_subject='User' and
ec_activity in (Logon’) and ec_theme in ('UserGroup',
'Authentication') and ec_outcome='Success' and user_dst is
not null  );
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@Name('Pattern')

@RSAAlert(oneInSeconds=0, identifiers={"user"})

select * from FilteredEvents

 match_recognize ( 
partition by user
measures C as c, L as l, D as d
pattern (C L+D)
define  C as C.ecactivity= ‘Create’,

 L as L.ecactivity= ‘Logon’,
D as D.ecactivity=’Delete’

);

EPL #5: Using Every @RSAAlert(oneInSeconds=0, identifiers={"user_src"})

SELECT a.time as time,a.ip_src as ip_src,a.user_dst as user_dst,a.ip_dst as ip_dst,a.alias_host
as alias_host from pattern[every (a=Event (ec_subject='User' and ec_activity='Create'
and ec_theme='UserGroup' and ec_outcome='Success') -> (Event(ec_subject='User' and
ec_activity='Logon' and ec_theme='Authentication' and user_src=a.user_dst) -> b=Event
(ec_subject='User' and ec_activity='Delete' and ec_theme='UserGroup' and user_
dst=a.user_dst))) where timer:within(300 sec)];

Rule Name CreateUserLoginandDeleteUser

Rule Descrip-

tion

Detect a pattern where a user creates a User account followed by login by the

same user followed by deletion of the User account. 

Example #3:

Excessive login failures from same sourceIP 

EPL #6: @RSAAlert(oneInSeconds=0, identifiers={"ip_src"})

Rule Name ExcessLoginFailure

Rule

Description

The same user tried logging in from the same Source IP and faced login

failures 

Rule Code

SELECT * FROM
Event(
ip_src IS NOT NULL AND ec_activity=’Logon’

AND ec_outcome = ‘Failure’ ).std:groupwin(ip_
src).win:time_length_batch(300 sec, 10) GROUP BY ip_
src HAVING COUNT(*) = 10;
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Note

l Creates window per ip_src

l Uses time_length_batch: Looks at events in batches(tumbling window).
Every event will be part of only 1 window. Window releases events either
when time elapses or count is reached.

l One of issues with tumbling windows that events occurring towards end of
batch might not lead to an alert.

In below sequence of events at t=301 even though 10 login failures occurred
for same login in last 300 secs there will be no alert because batch of events
was dropped at t=300

Time t Login Failures for Specific Users Alert Time Batch

0 0 0 1

295 6 0 1

299 3 0 1

301 1 0 2

420 6 0 2

550 3 0 2

600 0 0 3

720 6 0 3

850 3 0 3

900 1 1 3 ends and 4 begins

l Above problem can be resolved using win:time windows (EPL#7)instead of
win:time_length_batch windows.

l Outer group by is to control events when time elapses. Say you have 9
events at end of 60 secs, esper engine will push those 9 events to listener.
Group by and count will restrict it since count is not equal to 10.

l Time and count can be modified as needed.

EPL #7: @RSAAlert(oneInSeconds=0, identifiers={"ip_src"})

Rule Name ExcessLoginFailure

Rule Descrip-

tion

The same user tried logging in from the same Source IP and faced login

failures 
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Rule Code

SELECT * FROM
Event(
ip_src IS NOT NULL AND ec_activity=’Logon’ AND ec_

outcome = ‘Failure’ 
).std:groupwin(ip_src).win:time (300 sec) GROUP BY ip_

src HAVING COUNT(*) = 10

Note

l This is sliding window and hence once alert is fired for a set of events they
can be used for another alert as well till time has passed.

l If 10 events were involved in causing alert only last event will appear

l If < or > are used then you might see more than 1 alert. You should use
alert suppression accordingly.

Example #4:

Multiple failed logins from multiple different users from same source to same destination, a
single user from multiple different sources to same destination.

EPL #8: using groupwin , time_length_batch and unique

Rule Name MultiplefailedLogins

Rule

Description

There are multiple failed logins for the following cases:

- From multiple users from same source to same destination.

- Single user from multiple sources to the same destination. 

Rule Code

SELECT * FROM 
​  Event( ec_activity='Logon' AND ec_outcome='Failure' 

AND  ip_src IS NOT NULL AND  ip_dst IS NOT NULL
AND  user_dst IS NOT NULL ).std:groupwin(ip_src,ip_
dst).win:time_length_batch(300 seconds, 5}).std:unique
(user_dst) group by ip_src,ip_dst having count(*) = 5;

Note

l ip.dst and ip.src are common across all events.

l user_dst is unique for all events.

l Alert is fired when there are atleast 5 different users try to login from same
ip.src and ip.dst combination.

Example #5:

No Log traffic from a device in a given timeframe.
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EPL #9: using groupwin , time_length_batch and unique

Rule Name NoLogTraffic

Rule

Description

There is no log traffic observed from a device in a given time frame.

Rule Code

SELECT * FROM pattern [every a = Event(device_ip IN
('10.0.0.0','10.0.0.1') AND medium = 32) -> (timer:interval
(3600 seconds) AND NOT Event(device_ip = a.device_ip AND
device_type = a.device_type AND medium = 32))];

Note

l Rule only detects sudden loss of traffic. It won't alert if there is no traffic to
begin with. You need at least 1 event for rule to alert.

l List of device ip address or device hostnames as input. Only these systems
will be tracked.

l Time input is required. Alert is fired when time interval between events
exceeds input time.

Example #6:

Multiple Failed Logins NOT followed by a Lockout event by the same user.

EPL #10: using groupwin , time_length_batch and unique

Rule Name FailedloginswoLockout

Rule

Description

There are multiple failed logins that are not followed by Lockout event by the

same user.

Rule Code

SELECT * FROM pattern [every-distinct(a.user_dst,
a.device_ip, 1 msec) (a= Event(ec_activity='Logon'
and ec_outcome='Failure' and user_dst IS NOT NULL) -> 
[2]( Event( device_ip =a.device_ip and ec_
activity='Logon' and ec_outcome='Failure' and user_
dst=a.user_dst)

AND NOT Event( ( ec_activity='Logon' and ec_
outcome='Success' and device_ip = a.device_ip and
user_dst=a.user_dst) or (ec_activity='Lockout' and
device_ip = a.device_ip and user_dst=a.user_dst))))

where timer:within(60 seconds) -> (timer:interval(30
seconds) and not Event(device_ip=a.device_ip and
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user_dst=a.user_dst and ec_activity='Lockout')) ];

Note

l Above query detects the absence of a Lockout Event after the occurrence of
2 failed logins from same user.

l The occurrence of the multiple failed logins are timed and are assumed to
occur within a certain period of time. Also, in-practice the Lockout event is
assumed to occur within a short time after the occurrence of the last failed
login event because the threshold value of Failed logins per user is set in a
given domain.

l In current query, every distinct will suppress new thread for combination of
user and device for 1 millisec.

l Time allowed for 3 failed logins is 60 secs since 1st failed attempt. Wait
period for lockout event to occur is 30 secs

Example #7:

Custom functions to perform LIKE and REGEX operations for ARRAY elements.

EPL #11: @RSAAlert(oneInSeconds=0)

Rule Name MatchLikeRegex

Rule Descrip-

tion

There are custom functions to perform LIKE and REGEX comparisons of

array meta keys.

Rule Code

SELECT * FROM pattern[

e1=Event(matchLike(alias_host, "10.0.0.%")) AND

e2=Event(matchRegex(alias_host, "10\.0\.0\.1[0-9]
[0-9]"))

where timer:within(5 Minutes)];

Note:
1. “.” in meta keys should be replaced with (”_”).
2. All patterns should be time bound.
3. Use of appropriate tags in front of statements
a) @RSAPersist:
b) @RSAAlert:

For additional details you can refer to:
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l EPL Documentation: http://www.espertech.com/esper/documentation.php

l EPL Online Tool: http://esper-epl-tryout.appspot.com/epltryout/mainform.html

Working with Rules
This topic discusses additional procedures you can perform on rules. You may want to perform
any of the following procedures:

l Edit, Duplicate or Delete a Rule

l Filter or Search for Rules

l Import or Export Rules

Edit, Duplicate or Delete a Rule

This topic provides instructions to edit, duplicate, or delete an Event Stream Analysis (ESA)
rule. When you edit a rule, ESA applies the updated criteria going forward. No changes are
made to previously generated alerts.

Procedures

Edit a Rule

1. In the Security Analytics menu, select Alerts > Configure > Rules.
The Rules tab is displayed.

2. In the Rule Library, select the rule you want to edit and click .

Depending on the rule type, the respective rule tab is displayed.

3. Modify the required parameters.

4. Click Save.

Duplicate a Rule

1. In the Rule Library, select the rule you want to duplicate and click .
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2. The Duplicate a Rule dialog is displayed. The system adds Copy of in front of the rule name.

3. In the Name field, type a unique name for the duplicate rule and click OK.

A duplicate rule with the new name is added to the Rule Library.

Delete a Rule

1. In the Security Analytics menu, select Alerts > Configure > Rules.
The Rules tab is displayed.

2. In the Rule Library, select one or more rules and click  .

A warning dialog is displayed.

3. Click Yes.
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A confirmation message that the rule is deleted successfully is displayed and the selected
rule is deleted from the Rule Library.

Filter or Search for Rules

This topic shows analysts how to specify the type of rules that display in the Rule Library.

Prerequisites

Make sure that you understand the Rule Library view components. For more information, see
Rule Library Panel.

Procedures

Filter

1. In the Security Analytics menu, select Alerts > Configure.
The Rules tab is displayed by default.

2. In the Rule Library panel toolbar, click and select the severity and type of rules that

you would like to appear in the Rule Library list. The following figure shows the Filter drop-
down list.

The selected rule types appear in the list.

Search

1. In the Security Analytics menu, select Alerts > Configure.
The Rules tab is displayed by default.

2. In the Rule Library panel toolbar, type a rule name in the Filter field.
The Rule Library panel lists the rules that match the names entered in the Filter field.
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Import or Export Rules

The topic provides instructions to import ESA rules from a Security Analytics instance and
to export ESA rules to your hard drive so you can keep a local copy.

If you exported a rule in an earlier version of Security Analytics, the following conditions apply
when you import the rule in version 10.5 or later:

l Exported in version 10.3 – You cannot import rules to version 10.5.

l Exported in version 10.4 – Rule behavior depends if cross-correlation is disabled, which is the
default, or enabled:

l Disabled – You can import rules to version 10.5.

l Enabled – You must restart Security Analytics or make a minor change to the rule, save,
remove the minor change and save again. Either procedure generates the forwarding rule
that the 10.5 cross-site correlation feature requires.
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Procedures

Import ESA Rules

1. In the Security Analytics menu, select Alerts > Configure > Rules.
The Rules tab is displayed.

2. In the Rules Library toolbar, click   ​ > Import. 

The Import ESA Rules dialog is displayed.

3. Click Browse to browse and select the file containing the ESA rules.

4. Click Import. 

Add Rules to the Rule Library 80



Alerting Using ESA

Export

1. Select an ESA rule or multiple rules and click > Export in the Rule Library toolbar.

A warning dialog is displayed.

2. Click Yes.
The Export Rules dialog is displayed.

3. In the Enter File Name field, type a filename for the file with the ESA rules and click
Export.
The file is exported as a binary file to your machine.

Note: The binary file cannot be edited.
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Choose How to be Notified of Alerts
This topic explains the different notification methods and how to add a notification method to a
rule. Administrator, SOC Manager or DPO role permissions are required for all tasks in this
section.

When a rule triggers an alert, ESA can send a notification in the following ways:

l Email

l SNMP

l Syslog

l Script

To configure a notification, you configure these components: 

l Notification server – After you configure a notification server, you can add it to a rule. When
the rule triggers an alert, the rule will use that server to send alert notifications.

l Notifications – These are the outputs, which can be email, script, SNMP, and Syslog. When
you design a rule, you can specify the notification for an alert.

l Templates – The format of an alert notification is defined in a template.

Alert suppression and alert rate regulation are two features that Event Stream Analysis provides.
Alert suppression ensures that multiple emails are not sent out for the same alert. For example,
consider a rule to detect failed user logins. If you set the alert suppression to three minutes, you
will see only the alerts generated in that time frame. This is fewer than the number of alerts you
would see without alert suppression. Some alerts can be duplicates. With alert suppression,
emails are not sent for duplicate alerts. This ensures the inbox is not flooded with redundant alert
notifications.

Alert rate regulation is a preventive measure to ensure that alerts from misconstrued rules do not
flood the system. This ensures that ESA does not send more than the configured limit of emails
within one minute.

Notification servers, notifications, and templates are configured in the Administration System
view. For more information, see "Configure Notification Servers", "Configure Notification
Outputs", and "Configure Templates for Notifications" in the System Configuration Guide.
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Notification Methods
When a rule triggers an alert, ESA can send a notification in the following ways:

l Email

l SNMP

l Syslog

l Script

Email Notifications

Event Stream Analysis can send notifications to users through email about various system
events. 

To configure these email notifications, you need to:

l Configure the SMTP email server as an output provider. For instructions, see "Configure the
Email Settings as Notification Server" in the System Configuration Guide.

l Set up an email account to receive notifications. For instructions, see "Configure Email as a
Notification" in the System Configuration Guide.

l Configure a template for email notification. For instructions, see "Configure a Template" in
the System Configuration Guide.

SNMP

Event Stream Analysis can send events as an SNMP trap to a configured SNMP trap host.

Note:
The MIB file NETWITNESS-MIB.txt is located on the ESA RPM at the following location
/usr/share/snmp/mibs. With the MIB file, you will be able to identify the SNMP alerts
trigerred from ESA. And, the Trap OID value for ESA is 20.

To configure these SNMP notifications, you need to:

l Configure SNMP trap host settings as an output provider. For instructions, see "Configure the
SNMP Settings as Notification Server" in the System Configuration Guide.

l Configure SNMP trap settings as an output action. For instructions, see "Configure SNMP as
a Notification" in the System Configuration Guide.

l Configure a template for SNMP. For instructions, see "Configure a Template" in the System
Configuration Guide.​
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Syslog

Event Stream Analysis can send events and consolidate logs in Syslog format to a Syslog server.

To configure these Syslog notifications, you need to:

l Configure Syslog server settings as an output provider. For instructions, see "Configure the
Syslog Settings as Notification Server" in the System Configuration Guide.

l Configure Syslog message format as an output action. For instructions, see "Configure Syslog
as a Notification" in the System Configuration Guide.

l Configure a template for Syslog. For instructions, see "Configure a Template" in the System
Configuration Guide.

Script Alerter

Apart from the alert notifications ESA allows users to run scripts in response to ESA alerts. 

Scripts enable you to do custom integration with applications that exist in your environment. For
example, if you want to open an incident ticket from an application when a specific alert is
triggered, Script Alerter lets you write a script that calls the application API and have ESA
invoke it when the specific ESA rule is triggered. You can configure a FreeMarker template to
define what details you want to extract from the output of the ESA rule and pass it as command
line arguments to the script.

To use the Script Alert, you need to:

l Configure the user identity and other details that are required to execute the script. For
instructions, see "Configure Script as a Notification Server" in the System Configuration
Guide.

l Define the Script. For instructions, see "Configure Script as a Notification" in the System
Configuration Guide.

l Configure a template for the script. For instructions, see "Configure a Template" in the
System Configuration Guide.​

Add Notification Method to a Rule
This topic tells administrators how to add a notification, such as email, to a rule. ESA uses the
notification method when it generates an alert for an event that meets rule criteria.

You add a notification to a rule so ESA can let you know when a rule triggers an alert. Although
the notification fields are not required, it is a best practice to add a notification to a rule.

When you add a notification method to a rule, you select the following information:
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l Output

l Notification

l Notification Server

l Template

Prerequisites

l Your role must have permission to manage rules.

l The rule must exist.

l The notification method must be configured with a supported server and template:

l Click Administration > System > Global Notifications.

l For detailed procedures, see the System Configuration Guide.

Procedure

To add a notification method to a rule:

1. In the Security Analytics menu, select Alerts > Configure > Rules.

2. In the Rule Library, click  to add a new rule or select an existing rule and click  .

Depending on the rule type, the Rule Builder or Advanced EPL tab is displayed.
The Notifications section is the same for both tabs.

3. Click   and select the Output for the alert:

l Email

l SNMP

l Syslog

l Script

4. Double-click the Notification field and select the name of a previously configured output. 
For example, Level 1 Analyst could be the name of an email notification that goes to the L1-
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Analysts email distribution group.

5. Double-click the Notification Server field and select the server that sends the notification. 

6. Double-click the Template field and select a format for the alert.
The following figure shows the settings for a Syslog notification.

7. If you want to specify frequency, select Output Suppression, then enter the number
of minutes.

8. If you want to add another notification, repeat steps 3-7.

9. Click Save.
When ESA generates an alert for an event that matches the rule criteria, you will be notified
of the alert via each notification method added to the rule.
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Add a Data Enrichment Source
This topic tells how to add a previously configured enrichment source to a rule. When ESA
creates an alert, information from the source gets included in it.

Enrichments provide the ability to include contextual information into correlation logic and alert
output. Without enrichments, all information included in an ESA alert is from a Security
Analytics core service. With enrichments, you can request for look ups into a variety of sources
and include the results into the outgoing alerts. The following figure illustrates the enrichment
feature.

Enrichment configuration is made up of two logical units:

l Enrichment Sources – These are data stores of contextual information.

l Enrichment Connections – These act as connectors between alert meta and source columns.

ESA allows you to make connections between Event Processing Language (EPL) statements and
enrichment sources. Once the connections are established, the system joins the selected fields
from the alert output with the information in the sources and uses the matching data to enrich the
alert that is sent out. ESA can connect with the following sources:

l Esper Named Windows

l Relational Database tables

l MaxMindGeoIP Database

l RSA Warehouse Analytics Watchlists

Note: The geoIP enrichment source can neither be created nor deleted. It is provided out of
the box to the user.
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Sample Rule with Enrichment
The following sample rule illustrates the enrichment feature provided by ESA:
@RSAAlert @Name("simple") SELECT * FROM CoreEvent(ec_theme='Login
Failure')

The rule generates an alert for every logon failure and thus if the following (simplified) event
stream is received at ESA:

sessionid
ec_
theme

username ip_src ip_dst host_dst

1 Login Suc-

cess

dshrute 23.xx.23x.16

2 Login Fail-

ure

jhalpert 23.xx.23x.16 31.1x.x9.1x8 www.facebook.com

An alert with the following constituent events might be generated in response to the second
session:
{

"events": [
{

"username": "jhalpert",
"host_dst": "www.facebook.com",
"ip_dst": "31.1x.x9.1x8",
"sessionid": 2,
"ec_theme": "Login Failure",
"esa_time": 1406148964130,
"ip_src": "23.xx.23x.16"

}
]

}

The JSON output shows all the information available for inclusion into an ESA notification using
an appropriate FreeMarker
template. For instance, the template expression ${events[0].username} would evalute to
jhalpert.
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With enrichments, the same module, with the same event stream, can generate the alert shown
below. The system
can make multiple enrichment connections and pull contextual data to make the alert more
meaningful.

For example:
${events[0]["RSADataScienceLookup"][0].score} gives the “risk” score of the
destination domain computed by the RSA Warehouse Analytics module while ${events[0]
["orgchart"][0].supervisor} gives the name of the supervisor of the employee that the
alert pertains to (pulled from an HR database) and ${events[0]["LoginRegister"]
[0].username} gives the name of the user with the last successful logon from the same ip_
src (using a stream based Named Window).
{"events": [

{
"username": "jhalpert",
"host_dst": "www.facebook.com",
"GeoIpLookup": [
{

"city": "Cambridge",
"longitude": -71,
"countryCode": "US",
"areaCode": 617,
"metroCode": 506,
"region": "MA",
"dmaCode": 506,
"ipv4Obj": "/23.62.236.16",
"countryName": "United States",
"postalCode": "02142",
"ipv4": "23.62.236.16",
"latitude": 42,
"organization": "Verizon Business"

}
],
"RSADataScienceLookup": [

{
"model_id": "suspiciousDomains_1",
"_id": "EXEC_BATCH_1_20140630153740_facebook.com",
"score": 10,
"key": "www.facebook.com"

}
],
"orgchart": [

{
"supervisor": "mscott",
"name": "James Halpert",
"extension": 3692,
"location": "Scranton",
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"department": "Sales",
"id": "jhalpert"

}
],
"ip_dst": "31.13.69.128",
"sessionid": 2,
"LoginRegister": [

{
"username": "dshrute",
"ip_src": "23.62.236.16"

}
],
"ec_theme": "Login Failure",
"esa_time": 1406155218912,
"ip_src": "23.62.236.16"
}

]}

Configure a Database Connection
This topic provides information to configure a connection to an external database that can
provide additional information in alerts. You configure a database connection so you can then
configure the database as an enrichment source, to add further details to alerts. There are three
steps in the process:

1. Configure a connection to a database.

2. Configure the external database as an enrichment source.

3. Add the enrichment source to a rule

This topic explains Step 1.

Example

This example illustrates how adding a database as an enrichment source adds value to alerts.

A rule detects users that attempt to sign up for a stealth email service. Twenty-five users match
the rule criteria. Without the enrichment, the alert contains 25 User IDs. With the enrichment,
the alert also includes the following information for each User ID:

l Name

l Title

l Department

l Office Location
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Dependencies

When you configure a database, the following conditions apply:

l A reference to the database is deployed on every ESA, even if the ESA does not deploy rules
that use the database as an enrichment source. 

l If the server that hosts the database goes down, it impacts a deployment.

l An active deployment will continue to gather data and run rules but enrichments will not
appear in alerts.

l A new deployment will fail until you restart the host.

Procedure

To configure a database connection:

1. In the Security Analytics menu, select Alerts > Configure.

2. Click the Settings tab.

3. In the options panel, select Database Connections.

​The Database Connections panel is displayed.

4. Click  to add a database connection.
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5. In the Database Connection dialog, provide the following information.

Field Description

Enable Select Enable to enrich the alert with additional data. By default, Enable is
selected. Deselect Enable to exclude additional data from the alert.

Connection
Name

Type a name to identify the connection. When you add a database as an
enrichment source, this name appears in the list of Database Connections.

Description (Optional) Type a brief description about the database connection.

Driver
Class

Select an appropriate driver class for the database.
Two drivers come with Security Analytics, MongoDB and Postgres.
To import a new driver, click Upload.

In the Import Driver Class dialog, click Browse, select a new driver, and
click Import.

Database
URL or 
IP address

Type the URL or the IP address of the database to configure.

Add a Data Enrichment Source 94



Alerting Using ESA

Field Description

Username Type the username to access the Database.

Password Type the password to access the Database.

6. Click Save.

For related information, see Settings Tab

Enrichment Sources
This topic explains options for adding an external data source to provide additional information in
alerts. Enrichment sources provide additional information in alerts. For example, a database can
provide a name, department, and office location if a user matches rule criteria. There are three
types of enrichment sources:

l External DB Reference

l In-Memory Table

l Warehouse Analytics

Configure a Database as Enrichment Source

You can configure a database as an enrichment source so you can add it to a rule. Then the
Esper engine that analyzes events can access the information in the database to provide
additional information in the alert.

For example, a rule detects users that attempt to sign up for a stealth email service. Twenty-five
users match the rule criteria. The alert contains 25 User IDs. An external database would
enhance the alert by providing the following additional information for each User ID:

l Name

l Title

l Department

l Office Location

l Reports To

You can edit, duplicate, import or export a database connection.
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Prerequisites

You must configure a database connection. For more information, see Configure a Database
Connection.

Procedure

To configure database as an enrichment source:

1. In the Security Analytics menu, select Alerts > Configure.

2. Click the Settings tab.
The Settings tab is displayed.

3. In the options panel, select Enrichment Sources.
​The Enrichment Sources panel is displayed.

4. From the   drop-down menu, select External DB Reference. You have to add a DB

reference in order for the DB to be listed.
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The External DB Reference dialog is displayed.

5. Select Enable to enrich alert with additional data. This is selected by default. If disabled, the
alert will not be enriched with additional data​.

6. In the User-Defined Table Name field, type a name to identify or label the database
configuration.

7. In the Description field, type a brief description about the database configuration.

8. In the Database Connection drop-down menu, select the database connections defined.

9. In the Table Name field, enter database table name.

10. Click Save.

For details on parameters and their descriptions, see Settings Tab.

Configure In-Memory Table as Enrichment Source

This topic provides instructions on how to configure an in-memory table. When you configure an
in-memory table, you upload a .CSV file as an input to the table. You can associate this table
with a rule as an enrichment source. When the associated rule generates an alert, ESA will
enrich the alert with relevant information from the in-memory table.

For example, a rule could be configured to detect when a user tries to download freeware and to
identify the person by user ID in the alert. The alert could be enriched with additional
information from an in-memory table that contains details such as full name, title, office location
and employee number.
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An in-memory table is ideal for handling lightweight data. It is easy to set up and requires less
maintenance than a database. For example, the AllTech Company is a small organization so
the system administrator can maintain employee information in a .CSV file. If AllTech grows
into a very large company, the administrator would have to configure an external database
reference as an enrichment and associate the database with a rule.

Prerequisites

The column name in the .CSV file cannot have whitespace characters.

The first line of the .CSV file must be formatted this way for each column:
name_of_column_1 type_of_column_1

For example, these three columns are formatted correctly:
Last_Name string
First_Name string
Phone integer

Procedures

Configure an Adhoc In-Memory Table

1. In the Security Analytics menu, select Alerts > Configure.
The Configure view is displayed with the Rules tab open.

2. Click the Settings tab.

3. In the options panel, select Enrichment Sources.
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4. In the Enrichment Sources section, click  > In-Memory Table.

5. Describe the in-memory table:

a. Select Adhoc.

b. By default, Enable is selected. When you add the in-memory table to a rule, alerts will
be enriched with data from it.
If you add an in-memory table to a rule but do not want alerts to be enriched, deselect
the checkbox.

c. In the User-Defined Table Name field, type a name, such as Student Information, for
the in-memory table configuration.
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d. If you want to explain what the enrichment adds to an alert, type a Description such as:
When an alert is grouped by Rollno, this enrichment adds student information, such as
name and marks. 

6. In the Import Data field, select the .CSV file that will feed data to the in-memory table.

7. If you want to write an EPL query to define an advanced in-memory table configuration,
select Expert Mode.
The Table Columns are replaced by a Query field.

8. In the Table Columns section, click   to add columns to the in-memory table. 

9. If a valid file is selected in the Import Data field, the columns populate automatically.

Note: If you selected Expert mode, a Query field is displayed instead of Table Columns.

11. In the Key drop-down menu, select the field to use as the default key to join incoming events
with the in-memory table when using a CSV-based in-memory table as an enrichment. By
default, the first column is selected.  You can also later modify the key when you open the
in-memory table in enrichment sources.

12. In Max Rows drop-down menu, select the number of maximum number of rows that can
reside in the in-memory table at a particular instance.

13. Select Persist to preserve the in-memory table on disk when the ESA service stops and to
re-populate the table when the service restarts.

14. In Stored File Format field, do one of the following:

l Select Object, if you want to store the file in a binary format.

l Select JSON, if you want to store the file in a text format.
By default, Object is selected.

15. Click Save.
The adhoc in-memory table is configured. You can add it to rule as an enrichment or part of
the rule condition. See Add an Enrichment to a Rule.

When you add an in-memory table, you can add it to a rule as an enrichment or as a palrt of the
rule condition. For example, the following rule uses an in-memory table as a part of the rule
condition to create a whitelist, and it also uses an in-memory table of details in the user_dst file
to enrich the alert that is displayed. 

The rule shows the in-memory table as a whitelist rule condition:
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Next, the alert is enriched with the User_list in-memory table:

Therefore, the user_dst in-memory table is used to create a whitelist, and it is also used to enrich
the data in the alert if the alert is triggered. 

​​Add a Recurring in-Memory Table

1. In the Security Analytics menu, select Alerts > Configure.
The Configure view is displayed with the Rules tab open.

2. Click the Settings tab.

3. In the options panel, select Enrichment Sources.

4. Click  > In-Memory Table.

5. Describe the in-memory table:

a. Click Recurring.

b. By default, Enable is selected. When you add the in-memory table to a rule, alerts will
be enriched with data from it.
If you add an in-memory table to a rule but do not want alerts to be enriched, deselect
the checkbox.
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c. In the User-Defined Table Name field, type a name, such as Student Information, for
the in-memory table configuration.

d. If you want to explain what the enrichment adds to an alert, type a Description such as:
When an alert is grouped by Rollno, this enrichment adds student information, such as
name and marks.

6. Type the URL of the .CSV file that will feed data to the in-memory table. Click Verify to
validate the link and populate the columns in the .CSV file. You can add or remove columns
using the plus or minus button. 

7. If the server is configured behind another server, select Use Proxy.

8. If the server requires logon credentials, select Authenticated

9. For Recur Every, indicate how frequently ESA must check for the most recent .CSV:

a. Select Minute(s), Hour(s), Day(s), or Week.

b. If you select Week, select a day of the week. 

c. Click Date Range to select a Start Date and End Date for the recurring schedule.

10. In the Key drop-down menu, select the field to use as the default key to join incoming events
with the in-memory table when using a CSV-based in-memory table as an enrichment. By
default, the first column is selected.  You can also later modify the key when you open the
in-memory table in enrichment sources.

11. In Max Rows drop-down menu, select the number of rows that can reside in the in-memory
table at a particular instance.

12. Select Persist to preserve the in-memory table on disk when the ESA service stops and to
re-populate the table when the service restarts.

13. In Stored File Format field, do one of the following:

l Select Object, if you want to store the file in a binary format.

l Select JSON, if you want to store the file in a text format.
By default, Object is selected.

14. Click Save.
The recurring in-memory table is configured. You can add it to rule as an enrichment or part
of the rule condition. See Add an Enrichment to a Rule.
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Configure Warehouse Analytics as an Enrichment Source

This topic provides instructions on how to configure RSA Warehouse Analytics as an
enrichment source for ESA. Data analysts can leverage RSA Analytics Warehouse data to
analyze session and log data.

To configure Warehouse Analytics as an enrichment source:

1. In the Security Analytics menu, select Alerts > Configure.

2. Click the Settings tab.

3. In the options panel, select Enrichment Sources.

​The Enrichment Sources panel is displayed.
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4. From the   drop-down menu, select Warehouse Analytics.

5. Select Enable to enrich alerts with additional data. This is selected by default. If disabled,
the alerts will not be enriched with additional data​.

6. In the Name field, type a name to identify or label the Warehouse Analytics configuration.
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7. In the Description field, type a brief description about the Warehouse Analytics
configuration.

8. In the Warehouse Analytics Database URL field, type theMongoDb URL to the
Warehouse Analytics database.

9. In the Username field, type the username to access the MongoDB.

10. In the Password field, type the password to access the MongoDB.

11. Click Save.

For more information, see Settings Tab.

Add an Enrichment to a Rule
This topic tells how to add a previously configured enrichment source to a rule. When ESA
creates an alert, information from the source gets included in it.

Adding an enrichment to a rule allows you to request for look ups into a variety of sources and
include the results in the outgoing alerts, giving you a more detailed alert. This procedure
requires role permissions for Administrator, DPO, and SOC Manager.

Procedure

To add an enrichment to a rule:

1. In the Security Analytics drop-down menu, select Alerts > Configure.

2. In the Rule Library view, do one of the following:

l Double-click a rule.

l Select a rule and click  in the Rule Library toolbar.

The Rule Builder panel is displayed in a new Security Analytics tab.

3. In the Enrichments section, click   and select any of the following enrichment types: 

l In-Memory Table

l External DB Reference

l Warehouse Analytics

l GeoIP

Note: If you use a GeoIP source, ipv4 is automatically populated, and is not editable. 

​The enrichment types that you have selected are displayed in the table.
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4. For the added enrichment type, perform the following:

l In the Output column, select the type that you have configured.

l In the Enrichment Source drop-down list, select the enrichment source defined.

l In the ESA Event Stream Meta field, type the event stream meta key whose value will
be used as one operand of join condition.

l In the Enrichment Source Column Name field, type the enrichment source column
name whose value will be used as another operand of the join condition.

5. Select Debug. This will add a @Audit(‘stream’) annotation to the rule. This is useful when
debugging the esper rules.

6. Click Show Syntax to test if the defined ESA rule is valid.

7. Click Save.

For details on parameters and their descriptions, see Rule Builder Tab.​
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Deploy Rules to Run on ESA
This topic explains how to select an ESA and the rules to run on it. Administrator, SOC
Manager or DPO role permissions are required for all tasks in this section.

To create a deployment, you need to perform the steps described in Deployment Steps

How Deployment Works
A deployment consists of an ESA service and a set of ESA rules. When you deploy rules, the
ESA service runs them to detect suspicious or undesirable activity in your network. Each
ESA rule detects a different event, such as when a user account is created and deleted within
one hour.

The ESA service performs the following functions:

1. Gathers data in your network

2. Runs ESA rules against the data

3. Applies rule criteria to data

4. Generates an alert for the captured event

The following graphic shows this workflow:

In addition, you may want to perform other steps on your deployment, such as deleting an
ESA service in your deployment, editing or deleting a rule from your deployment, editing or
deleting a deployment, or showing updates to a deployment. For descriptions of these
procedures, see Additional Deployment Procedures
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Deployment Steps
This topic explains how to add a deployment, which includes an ESA service and a set of ESA
rules. You can add a deployment to organize and manage ESA services and rules. Think of the
deployment as a container for both components:

1. An ESA service

2. A set of ESA rules

For example, if you add a Spam Activity deployment it could include ESA London and a set of
ESA rules to detect suspicious email activity. 

To add a deployment, you need to complete the following procedures:

l Step 1. Add a Deployment

l Step 2. Add an ESA Service

l Step 3. Add and Deploy Rules

Step 1. Add a Deployment

Prerequisites

The following are required to add a deployment:

l The ESA service must be configured on the host. See "Configure ESA" in the Event Stream
Analysis (ESA) Configuration Guide.

l Rules must be in the Rule Library. See Add Rules to the Rule Library.

Procedure

To add a deployment:

1. In the Security Analytics menu, select Alerts > Configure.
The Rules tab is displayed.
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2. In the options panel, next to Deployments, select  > Add.

The Deployment view is displayed on the right.

3. Type a name for the deployment. The naming convention is up to you.
For example, it could indicate the purpose or identify an owner.

4. Press Enter.
The deployment is added.

Step 2. Add an ESA Service

The ESA service in a deployment gathers data in your network and runs ESA rules against the
data. The goal is to capture events that match rule criteria, then generate an alert for the
captured event.

You can add the same ESA to multiple deployments. For example, ESA London could be in the
these deployments simultaneously:

l Deployment EUR, which includes one set of ESA rules

l Deployment CORP, which includes another set of ESA rules
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When you remove an ESA from a deployment, the rules are also removed from the ESA. For
example, Deployment EUR could include ESA London and a set of 25 rules. If you remove ESA
London from Deployment EUR, the 25 rules are also removed from ESA London. Consequently,
if an ESA is not part of any deployment the ESA does not have any rules.

Procedure

To add an ESA service:

1. In the Security Analytics menu, select Alerts > Configure.
The Rules tab is displayed.

2. In the options panel, select a deployment:

3. In the Deployment view, click   in ESA Services.

The Deploy ESA Services dialog lists each configured ESA.

4. Select an ESA and click Save.
The Deployment view is displayed. The ESA is listed in the ESA Services section, with the
status Added.
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Step 3. Add and Deploy Rules

This topic explains how to add ESA rules to a deployment and then deploy the rules on ESA.
Each ESA rule has unique criteria. The ESA rules in a deployment determine which events ESA
captures, which in turn determine the alerts you receive.

For example, Deployment A includes ESA Paris and, among others, a rule to detect file transfer
using a non-standard port. When ESA Paris detects a file transfer that matches the rule criteria,
it captures the event and generates an alert for it. If you remove this rule from Deployment A,
ESA will no longer generate an alert for such an occurrence.

Procedure

To add and deploy rules:

1. In the Security Analytics menu, select Alerts > Configure.
The Rules tab is displayed.

2. In the options panel, select a deployment.

3. In the Deployment view, click   in ESA Rules.

The Deploy ESA Rules dialog is displayed and shows each rule in your Rule Library:

4. Select rules and click Save.
The Deployment view is displayed.

5. The rules are listed in the ESA Rules section.
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l In the Status column, Added is next to each new rule.

l In the Deployments section,  indicates there are updates to the deployment.

l The total number of rules in the deployment is on the right.

6. Click Deploy Now.
The ESA service runs the rule set.

Additional Deployment Procedures
In addition to deploying an ESA service and rules, you may want to perform other steps on your
deployment, such as deleting an ESA service in your deployment, editing or deleting a rule from
your deployment, editing or deleting a deployment, or showing updates to a deployment.

To perform these procedures, go to:

l Delete ESA Service in a Deployment

l Edit or Delete Rule in a Deployment

l Edit or Delete a Deployment

l Show Updates to a Deployment

Delete ESA Service in a Deployment

This topic provides instructions to delete an ESA service in a deployment. On a deployment with
a service, you can edit the rules which are applied to the service and delete the service from the
deployment.

Each of the following procedures starts in the Rules tab.

Procedure

To delete an ESA service:

1. In the Security Analytics menu, select Alerts > Configure > Rules.
The Rules tab is displayed.

2. In the options panel, under Deployments, select a deployment.

3. In the ESA Services panel, select a service and click   in the toolbar.

A confirmation dialog is displayed.
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4. Click Yes.
The service is deleted.

Edit or Delete Rule in a Deployment

On a deployment with rules, you can edit and delete rules to customize the deployment. Each of
the following procedures starts in the Rules tab.

Procedures

Edit a Rule

1. In the Security Analytics menu, select Alerts > Configure > Rules.
The Rules tab is displayed.

2. In the options panel, under Deployments, select a deployment.

3. In the ESA Rules panel, double-click a rule to open it in a new Security Analytics tab.

4. Modify the rule, then click Apply.
The rule is saved.

Delete a Rule

1. In the Security Analytics menu, select Alerts > Configure > Rules.
The Rules tab is displayed.

2. In the options panel, under Deployments, select a deployment.

3. In the ESA Rules panel, select a rule and click   in the toolbar.

A confirmation dialog is displayed.

4. Click Yes.
The rule is deleted.

Edit or Delete a Deployment

This topic explains how Security Analytics forwards a correlation rule to each ESA service in a
correlation group. In a correlation group, each ESA service must run the same set of rules.
When you add a rule to a correlation group, Security Analytics forwards the rule to each ESA in
the group.

To access the deployments:

1. In the Security Analytics menu, select Alerts > Configure.

The Configure view is displayed with the Rules tab open.
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2. In the options panel, under Deployments, select a deployment.

The Deployment view is displayed.

Edit a Deployment

1. In the options panel, under Deployments, select a deployment.

The Deployment view is displayed.

2. Select > Edit.

The deployment name is made available for editing.

Delete a Deployment

1. In the options panel, under Deployments, select a deployment.

The Deployment view is displayed.

2. Select > Delete.

A confirmation dialog is displayed.

3. Click Yes.

The deployment is deleted.
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Show Updates to a Deployment

This topic explains how to show updates, such as adding or deleting rules, to a deployment.
When you make a change to a deployment, the update icon ( ) appears next to the name of the
deployment.

Procedure

To show the updates to a deployment:

1. In the Security Analytics menu, select Alerts > Configure.
The Rules tab is displayed.

2. In the options panel, under Deployments click Show Updates on the far right.

3. Click Close.
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View ESA Stats and Alerts

When the ESA generates alerts, you can view details about how the rules performed, such as
statistics on the engine, rule, and alert, and you can also view information on which rules are
enabled or disabled. For instructions on viewing ESA stats, see View Stats for ESA Service

When your ESA generates alerts, you can view the results in the Alerts Summary page. This
enables you to see trends and understand both the volume and frequency of alerts. For
instructions on viewing alerts, see View a Summary of Alerts

View Stats for ESA Service
This topic describes how to view the deployment stats for an ESA service. This procedure is
useful when you are attempting to determine the effectiveness of a rule or troubleshoot a
deployment. 

Procedures

View ESA Stats

1. In the Security Analytics menu, select Alerts > Configure > Services.

2. From the ESA Services list on the left, select a service.
The deployment stats for the selected service are displayed.
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3. Review the following sections of ESA stats.
For a complete description of each statistic in each section, see Services Tab.

l Engine Stats

l Rule Stats

l Alert Stats

4. In the Deployed Rule Stats, review details about the rules deployed on the ESA.
For a complete description of each column in each section, see Services Tab.

l If the rule is enabled or disabled

l What the rule name is

l If the rule is running in Trial Rule mode

l Last detected

l Events matched

5. To get a snapshot of the rule memory, click Health & Wellness.

Enable or Disable Rules

1. In the Deployed Rule Stats panel, select a rule from the grid.

2. Click to enable the rule, or click to disable the rule.

The Services tab is refreshed to show the changes, which take effect immediately.

Refresh the Statistics

The Services tab does not update statistics automatically unless you enable or disable a rule. To
ensure you view current statistics:

1. Click  in the upper right corner to refresh the information.

2. View the updated information. 

View a Summary of Alerts
This topic describes how to view a summary of alerts. You can see a consolidated view of
alerts generated in a specified time range.

Procedure

To view a summary of alerts:
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1. In the Security Analytics menu, select Alerts > Summary.

If there is a default ESA service, the Summary view is displayed with the information for
that service.

If no default service has been selected, the Select an ESA Service dialog is displayed.

2. In the Select an ESA Service dialog, select a service and click Select.
The Summary view is displayed.

3. To choose a new service to view:

a. Click .

The Select an ESA Service dialog is displayed.

b. Select a service from the list and click Select.
The Summary view is displayed with the information for the chosen service.

4. To choose the timeframe of the summary, open the Time Range drop-down menu and select
a time range.
The Start Time and End Time fields reflect the new range.

5. To choose the timeline, open the Unit drop-down menu and select a unit of time.

119 View ESA Stats and Alerts



Alerting Using ESA

6. To refresh the information in the Summary view, click .

7. To view alerts in a list, click .

8. In the list view, you can see more details about each alert.

l Date-- date the alert was generated.

l Name--name of the alert.

l Severity-- severity of the alert. (low, medium, or high).

l # of Events-- the number of events associated with the alert.

l Alert ID-- unique ID for each alert.

l Statement - dynamically generated statement name.

Also, you can view a detailed summary of each alert generated by clicking an alert. The
following figure shows more details about the alert generated.
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l Description - description of the alert.

l Statement - dynamically generated statement name.

l Time - time the alert was generated as per the timezone set on Security Analytics UI.

l Severity - severity of the alert (low, medium, high).

l Date- date the event was executed .

l ID- event ID.

l Raw Content - detailed information of the event.

For more information, see Alerts Summary View.
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Behavior Analytics Automated Threat Detection
This topic discusses how to configure and use Behavior Analytics Automated Threat Detection.
Behavior Analytics Automated Threat Detection is a service you deploy on your
ESA installation that examines your HTTP traffic to determine the probability that malicious
activity is occurring in your environment.

For details on how to work with Behavior Analytics Automated Threat Detection, see the
following topics:

l Configure Behavior Analytics Automated Threat Detection

l Work with Behavior Analytics Automated Threat Detection Results

l Troubleshoot Behavior Analytics Automated Threat Detection

Understanding Behavior Analytics Automated Threat Detection
This topic provides an overview of Behavior Analytics Automated Threat Detection. Behavior
Analytics Automated Threat Detection is a service you deploy on your ESA. The Behavior
Analytics: Suspicious Domains module examines your HTTP traffic to detect domains likely to
be malware command and control servers connecting to your environment. Once Behavior
Analytics Automated Threat Detection examines your HTTP traffic, it generates scores based
on various aspects of your traffic behavior (such as the frequency and regularity with which a
given domain is contacted). If these scores reach a set threshold, an ESA alert is generated. This
ESA alert also triggers an alert in the Incident Manager. The alert in the Incident Manager is
enriched with data that helps you to interpret the scores to determine what mitigation steps to
take. 

This version of Behavior Analytics Automated Threat Detection provides scoring to detect
Command and Control communications. Command and control communications occur when
malware has compromised a system and is sending data back to a source. Often, Command and
Control malware can be detected via beaconing behavior. Beaconing occurs when the malware
regularly sends communications back to the Command and Control server to notify it that a
machine has been compromised and the malware is awaiting further instructions. The ability to
catch the malware at this stage of compromise can prevent any further harm from occurring to
the compromised machine and is considered a critical stage in the "kill chain."

This feature solves several common problems that occur when searching for malware:

l Ability to use algorithms rather than signatures. Because many malware creators have
begun using polymorphic or encrypted code segments which are very difficult to create a
signature for, this approach can sometimes miss malware.  Because Behavior Analytics
Automated Threat Detection uses a behavior-based algorithm, it is able to detect malware
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more quickly and effectively. 

l Ability to automate hunting. Hunting through data manually is an effective but extremely
time-consuming method of finding malware. Automating this process allows an analyst to use
his or her time more effectively. 

l Ability to find an attack quickly. Instead of batching and then analyzing the data, Behavior
Analytics Automated Threat Detection analyzes data as it is ingested by Security Analytics,
allowing for the attacks to be found in near real-time. 

Workflow

Behavior Analytics Automated Threat Detection works much like a filtering system. It checks to
see if certain behavior occurs (or certain conditions exist), and if that behavior or condition
occurs, it moves to the next step in the process. This helps to make the system efficient, and
frees up resources so that events which are determined to be non-threatening are not held in
memory. The following diagram provides a simplified version of the workflow. 
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1.) Packets or Logs are routed to the ESA. The HTTP packets or logs are parsed by the
Decoder or Log Decoder and sent to the ESA device.

2.)Whitelist is checked. If you created a whitelist via the Context Hub, the ESA checks this
list to rule out domains. If a domain in the event is whitelisted, the event is ignored.

3.) The domain profile is checked. Behavior Analytics Automated Threat Detection checks to
see if the domain is newly seen (approximately three days), has few source IP connections, has
many connections without a referer, or has connections with a rare user agent. If one or several
of these conditions is true, the domain is next checked for periodic beaconing. For a detailed
description of these domain profile scores, see "Work with Behavior Analytics Automated
Threat Detection Scores".

4.) The domain is checked for periodic beaconing. Beaconing occurs when the malware
regularly sends communications back to the command and control server to notify it that a
machine has been compromised and the malware is awaiting further instructions.  If the site
displays beaconing behavior, then the domain registration information is checked. 

5.) Domain registration information is checked. The Whois service is used to see if the
domain is recently registered or nearly expired. Domains that have a very short lifespan are
often hallmarks of malware. 

6.) Command and control (C2) aggregates scores. Each of the above factors generates a
separate score which is weighted to denote various levels of importance. The weighted scores
determine if an alert should be generated. If an alert is generated, the aggregated alerts appear
in the Incident Manager and can then be investigated further from there. Once the alerts begin to
appear in the Incident Manager, they continue to aggregate under the associated incident. This
makes it easier to sort through volumes of alerts that can be generated for a command and
control incident. 

If you are an analyst, you can view the alerts generated in the Alerts Summary module, or in the
Incident Manager module. If you use SecOps, you can view alerts in SecOps versions 1.2 and
1.3. 

Behavior Analytics Automated Threat Detection on Packets vs.
Web Proxy Logs
RSA Security Analytics provides you with the ability to perform Behavior Analytics Automated
Threat Detection using either packets or Web Proxy Logs. While packet data can be streamed
directly off of the wire into the Security Analytics installation and analyzed directly, if you have
the ability to use a web proxy in your installation there may be benefits to doing so. Because
some installations use network translation or SSL encryption, the true source IP of an outgoing
connection may be masked if you are observing it at the packet level. By using a web proxy you
gain the benefit of its ability to accelerate and decrypt SSL traffic as well as its ability to track
the true source IP addresses of traffic it monitors.
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Using Behavior Analytics Automated Threat Detection for Security Analytics 10.6.2 or later,
you can use only one detection method: packets or logs, but not both for the same ESA instance.
Multiple ESA instances may be used to aggregate data from both packet and web proxy log
sources, however.

Configure Behavior Analytics Automated Threat Detection
This topic tells administrators and analysts how to configure and work with Behavior Analytics
Automated Threat Detection. 

This procedure provides the steps needed to configure Behavior Analytics Automated Threat
Detection on your ESA. However, before you enable Behavior Analytics Automated Threat
Detection, it is important to note that there are many potential installation configurations which
may be installed on the ESA, including: Behavior Analytics Automated Threat Detection, ESA
Rules, and the Context Hub. Each of these may take up resources, so it is important to have
considered sizing before enabling this feature on your ESA.

Prerequisites

l If you are using Packet data, you must have configured a Decoder for HTTP packet data, and
you must have configured an HTTP Lua or Flex parser.

l If you are using web proxy log data, you must have configured the appropriate Log Decoder
with the correct parser for your web proxy.

l If you are using web proxy log data, you must have updated to the latest log parsers. The
following parsers are supported Blue Coat ProxySG SGOS (cacheflowelff), and Cisco
IronPort WSA (ciscoiportwsa) and Zscaler (zscalernss).

l You can use one mode per ESA appliance (either packets or logs, but not both).

l If you are using web proxy log data, for best results you should configure all web proxies the
same way (set to the same time zone, and use the same collection method--syslog or batch,
and if you use batch use the same batching cadence).

l You must have correctly configured the Incident Manager database.

l A connection from ESA appliance to the Whois service (same location as
RSA Live cms:netwitness.com:443) must be opened on port 443. Verify with your System
Administrator that this is completed.

l To whitelist a domain you need to enable the Context Hub service.

l You must have configured your Incident Manager database correctly. If you are unsure
whether the Incident Manager database is configured correctly, review "Step 2. Configure a
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Database for the Incident Management Service" in the "Incident Management Configuration
Guide"

Important: Behavior Analytics Automated Threat Detection requires a "warm-up" period that
acclimates the scoring algorithm to the traffic in your network. You should plan to configure
Behavior Analytics Automated Threat Detection so that the warm-up period can be run during
normal traffic. For example, starting Behavior Analytics Automated Threat Detection on a
Tuesday at 8:00 am in the timezone which contains the majority of your users allows the module
to accurately analyze a day of normal traffic.

Procedure: Configuring Behavior Analytics Automated Threat Detection

This procedure provides the steps needed to configure Behavior Analytics Automated Threat
Detection. 

The basic steps required are:

1. Configure Log Settings (for Log Customers only) Before you can use Behavior Analytics
Automated Threat Detection for Logs, you must configure several settings. Skip this step if
you plan to use Behavior Analytics Automated Threat Detection for Packets.

2. Create a whitelist (optional) using the Context Hub service. Creating a whitelist allows
you to ensure that commonly accessed websites are excluded from any Behavior Analytics
Automated Threat Detection scoring.

3. Enable Behavior Analytics Automated Threat Detection for your specified ESA. You
need to enable Behavior Analytics Automated Threat Detection for each ESA where you
want the service to run.

4. Configure WhoIs settings. The Whois Service allows you to get accurate data about
domains that you connect to. In order to ensure effective scoring, it is important that you
configure the Whois service settings.

5. Verify that the Whois Service is reachable from your environment. For Behavior
Analytics Automated Threat Detection to perform correctly, it is essential that the Whois
service is reachable. Once Behavior Analytics Automated Threat Detection is running, you
can verify the service is connecting.

6. Verify the C2 Incident Manager rule is enabled and monitor for activity. When using
Behavior Analytics Automated Threat Detection, a period of time is required for the scoring
algorithm to warm-up. After the warm-up period, verify the C2 rule is enabled on Incident
Manager and monitor to see if the rule is triggered. 
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7. Verify that the Rule in the Incident Manager is configured correctly. When you view
incidents in the Incident Manager, it's helpful if the incidents are grouped by the Suspected
C&C domain.

Step 1: (For Log Customers Only) Configure Log Settings

To configure Behavior Analytics Automated Threat Detection for Logs, you need to complete a
few extra configuration steps:

l Verify that the supported parsers are enabled for your Log Decoder.

l You must get the latest versions of the appropriate web proxy parser from RSA Live.

l Update the mapping on the Envision config file. This file is required to update the Log
Decoder to work with the new meta available via the parsers.

l Verify that the table-map.xml file got updated correctly.

l Verify that the indexes have been updated correctly.

To verify your parsers are running on your Log Decoder:

1. Go to Administration > Services > and select your Log Decoder.

2. Select your Log Decoder, then  > View > Config. 

3. In the Service Parsers Configuration pane is a list of enabled parsers.

4. Verify that the approriate web proxy parser is enabled.
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To get the latest parsers from RSA Live:

1. Go to Live > Search.

2. Enter a search term for one of the supported web proxy parsers.

3. Select the appropriate web proxy parser (for example, the Blue Coat ProxySG SGOS
(cacheflowelff) parser). Note: you should have taken steps to correctly configure logging to
occur on your web proxy parser correctly.

4. Click Deploy. The Deployment Wizard opens.
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5.

6. Under Services, select the Log Decoder as the Service.

7. Click Deploy to deploy the parser to your Log Decoder.

To Get the Latest Envision Config File:

1. Go to Live > Search.

2. Enter envision as the key word for the search.
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3. Select the latest Envision Config file, and click Deploy, and the Deployment Wizard opens.

4. Under Services, select your Log Decoder.

5. Click Deploy to deploy the Envision configuration file to the Log Decoder.

To Verify the Envision Configuration File was Updated Correctly:

1. Under Administration > Services > Log Decoder, Files, you can see the table-map.xml
file. This file is modified when you update the Envision Configuration file.

2. Search for the term, event.time. The field should now read, "event.time" flags ="None". This
means the event.time meta is now included in the mapping. Similarly, the fqdn flag should be
set to "None".

To Verify the Indices for the index-concentrator.xml File is Updated:

You will need to verify that the index-concentrator.xml file includes both the event.time and fqdn
meta.

1. Go to Administration > Services and select your Concentrator.

2. Select your Concentrator, then  > View > Config. 

3. In the Files directory, search for the index-concentrator.xml file.

4. Verify that the following entry exists in your index-concentrator.xml file. If not, you'll need
to ensure your Concentrator is upgraded to the correct version:
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<key description="FQDN" level="IndexValues" name="fqdn"
format="Text" valueMax="100000" defaultAction="Open"/><key
description="Event Time" format="TimeT" level="IndexValues"
name="event.time" valueMax="0" />

Step 2: Create a Domains Whitelist (Optional)

Note: This step is optional: if you use the Incident Manager to manage these incidents, you
can also create a whitelist by closing an incident as false-positive.
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This procedure is used when working with Behavior Analytics Automated Threat Detection to
ensure that certain domains do not trigger a threat score. Sometimes, a domain you access
regularly may trigger an Behavior Analytics Automated Threat Detection score. For example, a
weather service might have similar beaconing behavior as a Command and Control
communication, thus triggering an unwarranted negative score.  When this happens, it's called a
false positive. To prevent triggering a false positive with a specific domain you can add the
domain to a whitelist. Most domains do not need to be whitelisted because the solution only
alerts on very suspect behaviors. The domains you may want to whitelist are valid automated
services which few hosts connect to.

Note: You can have only one Context Hub service instance enabled in your Security Analytics
deployment. If your Context Hub service is running on a different ESA, you need to configure
it to connect to the ESA that runs the Context Hub service. For instructions, see " Configure
an ESA to Connect to the Context Hub on Another ESA" in the Event Stream Analysis
Configuration Guide.

1. From the Context Hub Service, you can create a list and manually add domains, or you can
upload a .CSV file containing a list of domains. 

a. From Administration > Services, select the Context Hub.

b. Select the Context Hub, then  > View > Config. 

c. Select the List tab to open the Lists for editing. 

d. In the left pane, click  to add a list. Enter a name for the list and then manually add

domains by clicking   in the right pane.

You can enter full domains, or you can use a wild card to include all sub-domains for a given
domain. For example, you can enter *.gov to whitelist all government IP addresses.
However, you cannot use other regex functions, such as [a-z]*.gov. This is because using
*.gov replaces an entire string, such as www.irs.gov.

Caution: The whitelist must be named Whitelisted Domains. Otherwise, the Context Hub will
not be able to process the list as a whitelist. 

e. Or, to import a .CSV file, click  , and in the Import File dialog box, navigate to the

.CSV file. Note that the file must be namedWhitelisted Domains. Choose from the
following delimiters: Comma, LF (Line Feed), and CR (Carriage Return) depending on
how you have separated the values in your file. Then click Upload. 

f. From the Context Hub Service, you can also modify an existing whitelist to add or remove
a domain.  
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g. In the right pane, List displays your existing domain whitelist.

h. ClickWhitelisted Domains. The values for the whitelist display in the right pane. 

i. To add a domain, click  and enter the domain name.

j. To remove a domain, select the domain and click  .

k. To import a .CSV file, click  , and in the Import File dialog box, navigate to the .CSV

file. Choose from the following delimiters: Comma, LF (Line Feed), and CR (Carriage
Return) depending on how you have separated the values in your file. Then click Upload. 

Step 3: Enable Behavior Analytics Automated Threat Detection and Enable the Whois

Lookup Service

1. From Administration > Services, select your ESA service and then   > View > Config. 

2. Click on the Advanced tab, and select Enable Automated Threat Detection , then choose
either Automated Threat Detection for Packets or Automated Threat Detection for Logs (if
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you want to perform C2 Detection on web proxy logs).
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1. Set a warm-up duration. A warm-up period is required to allow Behavior Analytics
Automated Threat Detection to acclimate to your traffic. During this time, alerting is
suppressed. Set the warm-up duration in hours. RSA recommends a warm-up period of 24
hours. After this warm-up period, alerts can be viewed. If the ESA restarts, this warm-up
period starts over, so the time is reset. To stop an existing warm-up, enter 0 for the Warm-up
Duration value, and click Apply.

Note: ​When you set the warm-up period, it should be run when typical traffic is running.
This enables Behavior Analytics Automated Threat Detection to create a scoring model
based on typical behavior in your network. For example, if you set the warm-up period to
run over a weekend, the Behavior Analytics Automated Threat Detection creates a model
based on traffic that is both lower than and different from typical weekday traffic. A better
solution would be to run the warm-up period on a weekday starting at 8 a.m. to ensure the
model reflects normal traffic.

2. Click Enable Live Whois Lookup to enable the Whois service for your ESA. This allows
your ESA service to obtain detailed information about the domain that triggers the Behavior
Analytics Automated Threat Detection score. By default, the Whois service users the same
User ID and password as your RSA Live User ID and password. If you have not configured
an RSA Live account, you will need to do so prior to enabling the Whois service.

Behavior Analytics Automated Threat Detection and Whois Live Lookup are now enabled on
your selected ESA. Once you enable the Whois Live Lookup, you can specify other Whois
Lookup settings from the Explorer by following the instructions in Step 3: Configure the Whois
Service Settings for your ESA.

Note: A rule is added to perform C2 detection. However, this rule "Suspect C&C" ESA rule,"
is not visible in the User Interface for editing. The rule is not editable, and to prevent
accidental deletion or modification, the rule is hidden from view. You can view the associated
Incident Manager rule and results in the Incident Manager, however.

Step 4: Configure Advanced WhoIs Service Settings for your ESA

If you did not configure the Whois Lookup service in the previous step or if you want to
configure advanced settings, you can do so now.

Warning: The Whois service is critical for accurate Behavior Analytics Automated Threat
Detection scoring. If you do not configure the Whois service, excessive alerting can occur.

1. From Administration > Services, select your ESA service and then   > View >

Explore. 

2. In the Explorer, click Service >Whois > whoisClient.
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3. Configure the following settings (note that only the first two parameters require modification.
RSA recommends you use the default settings for other parameters):

Parameter Description

whoisUserId Required only if you did not already enable the Whois
service. Enter the authentication credential for the RSA
Whois Server. This is the same as your RSA Live User
ID. If you have not configured an RSA Live account, you
will need to do so. 

The default value is "whois".

whoisPassword Required only if you did already enable the Whois
service. Enter the authentication credential for the RSA
Whois Server. This is the same as your RSA Live
password. If you have not configured an RSA Live
account, you will need to do so. 

The default value is null.

whoisUrl Optional: Enter the URL to obtain Whois data from the
RSA Whois Service. Note that the trailing slash ('/') is
required. Otherwise, requests will fail.

 The default value
is: "https://cms.netwitness.com/whois/query/"

whoisAuthUrl Optional: Enter the URL to obtain authentication tokens
from the RSA Whois Service.

The default value
is: 
"
https://cms.netwitness.com/authlive/authenticate/WHOIS”

whoisAuthTokenLifespanSeconds  Optional: Enter the time, in seconds, after which an
authentication token should be renewed.

The default value is 3300. 

whoisHttpsProxy

Optional: If HTTP requests require a proxy, set this to the
same value as is used for the RSA Live service. Only use
this parameter when insecureConnection is set to true. 

The default value is false.

(Requires an ESA restart to take effect.)
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Parameter Description

insecureConnection Optional:  Set this parameter to true to allow the HTTP
request to the RSA Whois Service ignore SSL certs.

Note: If the RSA Whois Service is accessed via a
proxy, this parameter should be set to true.

The default value is false.

(Requires an ESA restart to take effect.)

allowedRequests Optional: Enter how many queries you want to allow
before you start throttling the Whois service. This
parameter works with allowedRequestsIntervalSeconds,
where you set the interval for queries. For example, if you
set allowedRequests to 100 and
allowedRequestsIntervalSeconds to 60, you are allowed
100 requests in any 60 second interval.

The default value is 100.

(Requires an ESA restart to take effect.)

allowedRequestsIntervalSeconds Optional: If you set the allowedRequests parameter, you
need to also configure this setting to determine the
interval. This value should be tuned for your environment.

 The default setting is 60 seconds.

(Requires an ESA restart to take effect.)

queueMaxSize Optional: Specify the maximum size of the queue of the
domains whose information will be requested of the RSA
WhoisService.

The default is 100,000.

cacheMaxSize Optional: Specify the maximum number of cached Whois
entries. Once this limit is reached, the least recently used
entry will be removed to accommodate a new entry.

The default is 50,000.

(Requires an ESA restart to take effect.)
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Parameter Description

refreshIntervalSeconds Optional: Specify the number of seconds for the refresh
interval.  If requested Whois information is found in the
cache, and the cache entry has been there for more than
the specified number of seconds, the entry is removed
from the cache and the domain returned to the queue to be
looked up. (The cache entry is returned for the request that
identified it as stale.)

The default setting is  2,592,000 seconds (30 days).

waitForHTTPRequest Optional: Requires that the ESA wait for the
Whois service to respond before it can complete running
the EPL. This ensures that the Whois data is always
included in the results, but it can negatively impact
performance as the ESA pauses up to 30 seconds to wait
for the Whois service response.

If you do not configure this setting, and the response time
is slow, the ESA completes running the analysis for a
given event without the Whois data, and calculates the
score without the data.

The default setting is true. 

Step 5: Verify the Whois Service is Reachable from your Environment

After starting Behavior Analytics Automated Threat Detection, test that the WhoIs service is
reachable from your environment, and that the account information configured is valid. You can
see the count incrementing for the WhoIs calls in the Explorer.

To verify the Whois lookups are successful, go to ESA > Explore > Service >Whois >
whoisClient and confirm that the ServiceRequestCount and Response200ValidData parameters
are incrementing.

Step 6: Verify the Suspected Command & Control By Domain Rule is Enabled and Monitor

the Rule

Verify the Suspected Command & Command Control by Domain rule on the Incident Manager.

Note: You must have configured the Incident Manager database for the Suspected Command
& Control by Domain rule to display in the Incident Manager. If it does not display, follow the
steps to configure the database in Configure Incident Manager in the Incident Management
Configuration Guide.
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1. From Incidents > Configure, select Aggregation Rules.

2. Select the Suspected Command & Control Communication by Domain Rule, and double-
click to open it. 

3. Verify that Enabledis selected.

 The Rule displays a green Enabled button when it is enabled.

Result

Once you have enabled Behavior Analytics Automated Threat Detection, your ESA will begin to
perform analytics on the HTTP traffic. You can view detailed information for each incident in
the Incident Management queue. 

Step 7: Verify the Incident is grouped by the Suspected C & C Domain

In order to group incidents correctly, the Incident Manager should group the incidents by the
C&C Domain.

1. From Incidents > Configure, select Aggregation Rules.

2. Select the Suspected Command & Control Communication by Domain Rule, and double-
click to open it. 

3. Verify that the Group By field is set to Domain for Suspected C&C.
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Next Steps

Monitor the Incident Manager to see if the rule is triggered. If the rule is triggered, follow the
steps in the following section to investigate the domain associated with the triggered rule. 

Work with Behavior Analytics Automated Threat Detection Results

Work with Behavior Analytics Automated Threat Detection Results
This topic explains how to interpret and work with Behavior Analytics Automated Threat
Detection results. 

When you view the Behavior Analytics Automated Threat Detection results in the Incident
Manager, there are a number of different factors that are used to determine the overall score.
This section is designed to help you understand how these scores are generated and what they
mean. 

Understand Threat Detection Results

When you work with Behavior Analytics Automated Threat Detection, several scores are
aggregated together to make up the Command and Control Detection score. To better understand
how this score is triggered, it's a good idea to understand the elements that make up the final
score. 

When you receive a Command & Control Detection alert, you can view the following detailed
alert summary in the Incident Management module:
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Each icon represents a different score that makes up the total risk calculated. Note that the
scores are weighted, so each score represents a different proportion of the final score. For
example, The beacon behavior score might be 20% of the final score, while the domain age
might be 5%:

1. Beacon Behavior. Command and control detection seeks to find highly regular periodic
connections with a suspicious domain, so beaconing behavior has to do with how regularly
the source IP is connecting to the domain server. A high score means that connections
between this source IP and the domain are highly regular. 

2. Domain Age. Often, a Command and Control Server uses a new domain to create
connections, so if a domain is new to the network, it means it is more likely to be a command
and control domain. A high score indicates that this domain is relatively new on this network.
This score is derived from the Whois service. If your Whois service is not working, or if
ESA cannot connect with it, the icon displays in gray. If there is an issue with connectivity
or the Whois service returns a null value or a value in an unexpected format, then a default
value is used to estimate this score. This ensures that the overall scoring is more accurate. 

3. Expiring Domain. Often a Command and Control server uses an expiring domain to create
connections, so if a domain is soon to be expired, it is more likely to be a Command and
Control domain. This score is derived from the Whois service. If your Whois service is not
working, or if ESA cannot connect with it, the icon displays in gray. If there is an issue with
connectivity or the Whois service returns a null value or a value in an unexpected format,
then a default value is used to estimate this score. This ensures that the overall scoring is
more accurate. 

4. Rare Domain. A rare domain is one that that relatively few source IPs have been
connected to on a given network in the most recent week. If a domain is rarely used, the
possibility of it being a Command and Control domain is higher than if it is a commonly used
legitimate domain such as Google.com.

5. No Referers. A referer is an HTTP field that identifies the address of the web page that
linked to the resource being requested. For example, if I access my bank website from my
work website, the work website would appear as the referer.  Because people frequently link
to a site via a referer, a high score (meaning a low percentage of IPs connecting to this
domain have used referers) indicates that a Command and Control communication is more
likely. 

6. Rare User Agent. User agents identifies the client software originating the request. A high
score indicates that user agent associated with the IP address is not commonly used. Like the
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Rare Domain score, an uncommon user agent has a greater likelihood of being associated
with a Command and Control domain.

The icons display in different colors, and the colors help to visually indicate the level of risk.
See the table below for details.

Icon Meaning

Grey No score was generated because no data was

available. This may occur if the Whois service is

disabled or there is no data available to generate a

given score. 

Black The score indicator is weak. 

Orange  The score indicator is moderate.

Red The score indicator is high. 

Note: Suspected Command and Control alerts from packets and logs from the same domain
may be aggregated into the same incident.

What to Do Next

There are three possible paths you may want to follow once you have viewed threat scores:
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l Drill down for more details. For each score, there are multiple factors that make up a
score. You can view these details on the Event Details page.

l Investigate the domain in the Investigation module. You can go to the Investigations
screen to get more details about the domain and related incidents.

l Add domains to a whitelist. If you look at the details and determine that the domain in
question is not a threat, it's a good idea to add it a whitelist. This will ensure the domain no
longer triggers a Threat Detection score, and it helps to tune the accuracy of scoring.

Drill Down Into the Scores for More Details

Each event score is enriched with data to help you determine whether the communication with
the domain is malware and the severity of the attack if it is. For each of the scores listed above,
there are more details that are included in the details for each event.

To access these details:

1. From the Incidents queue, double-click on an Incident to view the Incident Details.

2. From the Alert Details section, double-click on an alert.

3. The Event Details page opens.

 From there, you can view details for the event, and for each detail, there is hover-over text to
help you interpret the data. You can see details such as the score range, the number of
occurrences for each time of score, the beaconing period, the information available from the
Whois registration data, etc. 

 For example, you can see from the following event details that the Rare Domain score was 100
(the highest score), but that there was only one IP associated with this domain, and there
were 24 occurrences in the previous week.   
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Investigate the Domain from the Investigation Module

From the Alert Details, you can also open the Investigations module to drill down into the
domain details. To do this, from the Alert Details click   > Investigate Destination
Domain. From there, you can search the days surrounding the event to see what else may have
occurred, and view other details about the event. 
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Reduce False Positives

 Sometimes, a domain you access regularly may trigger an Behavior Analytics Automated
Threat Detection score. For example, a weather service might have the same beaconing
behavior as a Command and Control communication, thus triggering an unwarranted negative
score.  When this happens, it's called a false positive. If, after investigating the event, you
discover it is a false-positive, you can mark it as a false-positive, which will add the domain to a
whitelist. Once the domain is added to the whitelist, it will not trigger an Behavior Analytics
Automated Threat Detection score. 

Note: If you use SecOps or another ticketing solution, you can manually add domains to the
white list using the Context Hub service. See "Step 2: Configure a Whitelist" in Configure
Behavior Analytics Automated Threat Detection. 

Procedure 

1. From the Incidents Detail page, you can mark a particular incident as a false-positive which
will automatically add it to the whitelist.  

1. From the Incident Manager, select the incident which triggered a false-positive score.
Click   > Edit Incident.

The Edit Incident dialog box displays. 

2. In the Edit Incident dialog box, click the Status field and select Closed-False Positive.
This adds the domain to the whitelist and closes the incident. Once the domain is added
to the whitelist, it is ignored when Behavior Analytics Automated Threat Detection
scoring occurs. 

Note: If you modify the status of an incident marked as false-positive, you can choose to
remove it from the whitelist.

Troubleshoot Behavior Analytics Automated Threat Detection
Behavior Analytics Automated Threat Detection is an analytics engine that examines your
HTTP data. It also makes use of other components, such as a WhoIs service and the Context
Hub, which can add complexity to your installation. This topic provides suggestions to help you
find issues if your Behavior Analytics Automated Threat Detection deployment does not provide
the results you expect.
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When you troubleshoot Behavior Analytics Automated Threat Detection, it is important to
factor in the mode used. If mixed mode is used (Behavior Analytics Automated Threat Detection
enabled on the same machine as ESA Rules, or Context Hub), you'll need to consider the
memory usage and i/o of these applications when troubleshooting. Generally, when mixed mode
installation is configured, Behavior Analytics Automated Threat Detection is enabled to use
approximately fifty percent of the memory available, whereas ESA Rules memory usage is
unbounded. Therefore, you may want to check your ESA Rules as a first step when
troubleshooting in mixed mode. 

If you are using mixed mode, you should also consider whether the ESA is configured for
Memory Pool or Event Time Ordering. Memory Pool can impact performance, while Event time
ordering can impact performance and memory usage. 

Possible Issues

Problem
Possible
Causes

Solutions

I'm seeing

too many

alerts (false

positives).

Several One possible cause is that the Whois lookup is failing or is not
configured. The Whois lookup is helpful in determining
whether a URL is valid, and if the connection fails or is not
properly configured, it can result in false positives.

There are a number of counters for the Whois Lookup service
you can view. 

1. From Administration > Services, select your ESA service
and then   > View > Explore. 

2. In the Explorer, click Service > Whois > whoisClient.

Below are a few useful counters to check:

l FailedLookupCount: Whenever a request to the RSA
Whois Service for Whois data fails, this count is
incremented.

l LookupEnqueueFailureCount: This counts any failed
attempts to add an entry to the cache. These failures will be
due to errors internal to the cache.

l Response401Count: This counts the requests to the RSA
Whois Server that failed with a status code of 401.
Requests with expired authentication tokens are included in
this count. This count is included in FailedLookupCount.
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Problem
Possible
Causes

Solutions

You may need to whitelist URLs. Sometimes the legitimate

behavior for a URL triggers an alert. One way to prevent this

from occurring is to add the URL to the whitelist. For instruc-

tions on doing this, see "Reduce False Positives" inWork with

Behavior Analytics Automated Threat Detection Results.

I'm not see-

ing any

alerts.

The ESA

requires a

"warm-up"

period when

you enable

Automated

Threat

Detection. 

When you enable Behavior Analytics Automated Threat Detec-

tion, there is a "warm-up" period, during which no alerts are

viewable. The default time period is 24 hours. After this 24

hour learning period, alerts can be viewed. If the ESA restarts,

this learning period starts over, and you will need to wait the

specified warm-up time to view alerts.

I'm seeing

performance

issues (more

resource

usage or a

drop in

throughput).

Several If you are having performance issues on an ESA that is also

running ESA rules, follow the troubleshooting steps for rules.

ESA rules are unbounded, whereas Behavior Analytics Auto-

mated Threat Detection is configured to use a specified amount

of resources (usually approximately 50%). For these

troubleshooting steps, go to Troubleshoot ESA.
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References
In the Alerts module, you configure and deploy ESA rules to get alerted about potential network
threats.

These topics explain the user interface in the Alerts module.

l New Advanced EPL Rule Tab

l Alerts Summary View

l Build a Statement Dialog

l Deploy ESA Rules Dialog

l Deploy ESA Services Dialog

l Rule Builder Tab

l Rules Tab

l Rule Syntax Dialog

l Select an ESA Service Dialog

l Services Tab

l Settings Tab

l Updates to the Deployment Dialog

New Advanced EPL Rule Tab
This topic describes the Advanced EPL Rule tab that you use to define rule criteria with an
Event Processing Language (EPL) query.

To access the Advanced EPL Rule tab:

1. In the Security Analytics menu, select Alerts > Configure.

The Configure view is displayed with the Rules tab open by default.

2. In the Rule Library toolbar, select > Advanced EPL.

The Advanced EPL Rule tab is displayed.

Below is a screen shot of the Advanced EPL Rule tab.
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Features

The following table lists the parameters in the Advanced EPL Rule tab.

Parameters Description

Rule Name Purpose of the ESA rule.

Description  Summary of what the ESA rule detects.

Trial Rule Deployment mode to see if the rule runs efficiently.

Severity  Threat level of alert triggered by the rule.

Query EPL query that defines rule criteria.

Notifications

In the Notifications section, you can choose how to be notified when ESA generates an alert for
the rule.

For more information on the alert notifications, see Add Notification Method to a Rule.

The following figure shows the Notifications section.
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Parameter Description

To add an alert notification type.

To delete the selected alert notification type.

Output Alert notification type. Options are:

l Email

l SNMP

l Syslog

l Script

Notification Name of previously configured output, such as an email dis-

tribution list.

Notification Server Name of server that sends the output.

Template Name of template for the alert notification.

Output Suppression of

every

Option to specify alert frequency.

Minutes Alert frequency in minutes.

Enrichments

In the Enrichments section, you can add a data enrichment source to a rule.

For more information on the enrichments, see Add an Enrichment to a Rule.
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The following figure shows the Enrichments section.

Parameter Description

To add an enrichment.

To delete the selected enrichment.

Output Enrichment source type. Options are:

l In-Memory Table

l External DB Reference

l Warehouse Analytics

l GeoIP

Enrichment Source Name of previously configured enrichment source, such as a .CSV

filename for an In-Memory Table.

ESA Event Stream
Meta

ESA meta key whose value will be used as one operand of join
condition.

Enrichment Source
Column Name

Enrichment source column name whose value will be used as the

other operand of the join condition.

Alerts Summary View
The Alerts Summary view provides a consolidated view of all the alerts generated in a particular
time range. You can specify a time range and represent alerts as graphs and charts in tabular
format. For example, if you want to view how many alerts of low, medium and high severity are
generated in a particular time range, you can use a chart for better clarity. You can also view
the number of alerts generated in a specific minute, hour or day.

On further drilling down, the view also provides event meta and event details on each alert
generated.

References 152



Alerting Using ESA

Note: In the User Interface (UI), the date or time displayed depends on the time zone profile
selected by the user.

In Security Analytics, the Alerts Summary view is displayed when you navigate to Alerts >
Summary and select an ESA service.

The following figure shows the various components of the Alerts Summary view.

Features

The Alerts Summary view consists of the following sections:
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l Alerts Summary

l Alert Timeline

l Alerts

l Alerts by Severity

Alerts Summary

The Alerts Summary section displays the time period in which alerts are generated. The
following figure displays the Alerts Summary section.

On the top left part of the section, the ESA service selected is displayed. You can select a time
period based on which you want alerts to be displayed. Some of the options available are
displayed in the following figure.

Based on the time period that you select, the start time and end time are displayed in the section.

Alert Timeline

The Alert Timeline section shows a graphical representation of the alerts generated during a
particular time period. The following figure displays the Alert Timeline section.
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You can perform the following using the Alert Timeline section:

l View alerts generated during a particular minute, hour or day by selecting the option from the
drop-down list of Unit.

l ​View details about each alert generated by clicking View Alerts. 

l View the number of alerts generated, severity level of the alerts and time they are generated
by hovering the mouse over a specific point on the graph.

Note: You can click the legends provided in the Alert Timeline based on the Severity. Also,
you can click and drag in the plot area to zoom in and view data.

Alerts

The Alerts section shows the alerts generated during a particular time period in tabular format.
The following figure displays the Alerts section.
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The following table lists the various columns in the Alerts section and their description.

Column Description

Name The name used to identify the alert.

Count The number of times the alert occurred.

Severity The severity level of the alert.

Last Detected The last time the alert was detected.

You can view details on each alert generated by clicking an alert and also export the logs related
to each event in the alert.

Alerts by Severity

The Alerts by Severity section shows a chart representation of the alerts based on the severity
level. The following figure displays the Alerts by Severity section.

You can view details on the alerts generated by clicking in the chart.

Build a Statement Dialog
The Build a Statement dialog allows you to construct a condition statement when creating a new
Rule Builder rule.

To access the Build a Statement dialog:

1. In the Security Analytics menu, select Alerts > Configure.

The Configure view is displayed with the Rules tab open.
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2. In the Rule Library toolbar, select  > Rule Builder.

A New Rule tab is displayed in Security Analytics.

3. In the Conditions section, click  .

The Build a Statement dialog is displayed.

Features

The following table describes the parameters in the Build a Statement dialog.

Parameter Description

Name Purpose of the statement.

Select Conditions the rule requires. There are two options:

l If all conditions are met

l If any of these conditions are met

Key  Key for ESA to check in the rule statement.
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Parameter Description

Evaluation

Type

Relationship between the meta key and value for the key:

l is

l is not

l is not null

l is greater than (>)

l is greater than or equal to (>=)

l is less than (<)

l is less than or equal to (<=)

l contains

l not contains

l begins with

l ends with

Value Value for ESA to look for in the key.

Ignore

Case?
This field is designed for use with string and array of string values. By
choosing the Ignore Case field, the query will treat all string text as a
lowercase value. This ensures that a rule that searches for the user
named Johnson would trigger if the event contains "johnson," "JOHNSON," or
"JoHnSoN."

 Array? Choice to indicate if contents of Value field represent one value or multiple
values:

l Select the box to  indicate multiple values.

l Clear the box to indicate one value.

Add a statement. You can add a meta condition, whitelist condition, or blacklist

condition. 

Delete selected statement.

Save Add statement to the Conditions section of the Rule Builder tab.

The following table shows the operators you can use in the Rule Builder:
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Operator Required Value Usage Example Meaning

is Singular string value The meta key is equal to

the value field.

user_dst is

John Doe.

user_dst is equal to the

string "John Doe".

is Array string value The meta key is equal to one

of the elements of the value

field.

user_dst is

John, Doe,

Smith.

user_dst  is equal either to the
string "John" or to the
string "Doe" or to the
string "Smith" (Note, the spaces
are stripped.).

is not Singular string value The meta key is not equal to

the value field.

size is not 200. size is not equal to the number

200 (size is a numeric value).

is not Array string value The meta key is not equal to

any of the elements of

the value field.

size is not 200,

300, 400.

size is equal neither to 200 nor to

300 nor to 400.

is not null N/A (looks for any value) The meta key value is not null. user_dst is not

null.

user_dst is a meta that contains a

value.

is greater

than (>)

Number The numeric value of the meta

key is greater than the number

in the value field.

payload is

greater than

7000.

payload is a numeric value that

is greater than 7000.

is greater

than or

equal to

(>=)

Number The numeric value of the meta

key is greater than or equal to

the number in the value field.

payload is

greater than or

equal to 7000.

payload is a numeric value that

is greater than or equal to 7000.

is less than

(<)

Number The numeric value of the meta

key is less than the number in

the value field.

ip_dstport is

less than 1024.

ip_dstport is a numeric value that
is less than the numeric
value 1024.

is less than

or equal to

(<=)

Number The numeric value of the meta

key is less than or equal to the

number in the value field.

ip_dstport is

less than or

equal to 1024.

ip_dstport is a numeric value that
is less than or equal to numeric
value 1024.

contains String The value field is a substring
of the meta key (This operator
is only available for a string-
valued meta key).

ec_outcome

contains failure.

ec_outcome is a string that con-

tains the substring "failure".

not con-

tains

String The value field is not a
substring of the meta key (This
operator is only available for a
string-valued meta key).

ec_outcome

not contains fail-

ure.

ec_outcome is a string that does

not contain the substring"fail-

ure".
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Operator Required Value Usage Example Meaning

begins

with

String The value field is the
beginning of the meta key 
(This operator is only available
for a string-valued meta key).

ip_dst begins

with 127.0.

ip_dst is a string that starts

with "127.0".

ends with String The value field is the end of
the meta key (This operator is
only available for a string-
valued meta key).

user_dst ends

with son.

user_dst is a string that ends

in"son".

Note: Terms in bold italic are Meta that may not exist in all customer enviroments.

Deploy ESA Rules Dialog
The Deploy ESA Rules dialog allows you to filter and select rules to deploy to an ESA service.

To access this dialog:

1. In the Security Analytics menu, select Alerts > Configure.
The Rules tab is displayed by default.

2. In the options panel, under the Deployment section, select or add a new deployment by

clicking > Add.

3. In the ESA Rules panel, click .

The Deploy ESA Rules dialog is displayed.

The following figure is an example of this dialog.
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Features

The following table describes the parameters of the Deploy ESA Rules dialog.

Parameters Description

Filters the list of rules based on severity and type. The text box beside this

icon filters based on rule name.

Rule Name Displays the name of the rule.

Description Describes the rule.

Trial Rule Indicates whether or not the rule is a trial rule.

Type Indicates the type of rule: RSA Live ESA, Advanced EPL, or Rule Builder.

Deploy ESA Services Dialog
The Deploy ESA Services dialog displays all ESA services available to be added to a
deployment.

To access this dialog:
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1. In the Security Analytics menu, select Alerts > Configure.
The Rules tab is displayed by default.

2. In the options panel, under the Deployment section, select or add a deployment.

3. In the ESA Services panel, click .

The Deploy ESA Services dialog is displayed.

The following figure is an example of this dialog.

Features

The following table describes the parameters of the Deploy ESA Services dialog.

Parameters Description

Name Displays the name of configured ESA services.

Deployment Displays the deployments to which the service has already been added.

Rule Builder Tab
The Rule Builder tab enables you to define a Rule Builder rule.

To access the Rule Builder tab:

1. In the Security Analytics menu, select Alerts > Configure.

The Configure view is displayed with the Rules tab open by default.
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2. In the Rule Library toolbar, select   > Rule Builder.

The Rule Builder tab is displayed.

The following figure shows the Rule Builder tab.

Features

The following table lists the parameters in the Rule Builder tab.

Parameters Description

Rule Name Purpose of the ESA rule.

Description  Summary of what the ESA rule detects.

Trial Rule Deployment mode to see if the rule runs efficiently.

Severity  Threat level of alert triggered by the rule.

The Rule Builder includes the following components:
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l Conditions section

l Notifications section

l Enrichments section

Conditions Section

In the Conditions section of the Rule Builder tab, you define what the rule detects.

The following figure shows the Conditions section.

The following table lists the parameters of the Conditions section.

Parameter Description

Add a statement.

Remove selected statement.

Edit selected statement.

Statement Logical group of conditions for one operation.

Occurs Alert frequency if the condition is met. This specifies that there must be at

least that many events that satisfy the criteria in order to trigger an alert. The

time window in minutes binds the Occurs count.
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Parameter Description

Connector Options to specify relationship among the statements:

l followed by

l not followed by

l AND

l OR
The Connector joins two statements with AND, OR, followed by, or not fol-

lowed by. When followed by is used, it specifies that there is a sequencing of

those events. AND and OR build one large criteria. The followed by creates

distinct criteria that occurs in sequence.

Correlation

Type

Correlation Type applies only to followed by and not followed by. If you

choose a correlation type of SAME, select one meta to correlate on, and if you

choose a correlation type of JOIN, select two meta to correlate on. You may

want to use JOIN if you are trying to correlate on meta from two different data

sources. For example, say you want to correlate an AV alert with an IDS alert.

Meta Enter the meta condition if choosing a correlation type of SAME or JOIN (as

described above).

Meta Enter the second meta condition if choosing a correlation type of JOIN (as
described above). For example, The destination IP address from the AV alert
and source IP address for the workstation from the IDS alert are joined to
allow you to view the same entities across different sources.

occurs

within

minutes

Time window within which the conditions must occur. 
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Parameter Description

Event

Sequence

Choose whether the pattern must follow a strict match or a loose match. If you
specify a strict match, this means that the pattern must occur in the exact
sequence you specified with no additional events occurring in between. For
example, if the sequence specifies five failed logins (F) followed by a
successful login (S), this pattern will only match if the user executes the
following sequence: F,F,F,F,F,S. If you specify a loose match, this means that
other events may occur within the sequence, but the rule will still trigger if all
of the specified events also occur. For example, five failed login attempts (F),
followed by any number of intervening successful login attempts (S), followed
by a successful login attempt might create the following pattern:
F,S,F,S,F,S,F,S,F,S which would trigger the rule despite the intervening
successful logins. 

Group By Select the meta key by which to group results from the dropdown list. For
example, suppose that there are three users; Joe, Jane, and John and you use
the Group By meta, user_dst (user_dst is the meta field for the user destination
account). The result will show events grouped under the user destination
accounts, Joe, Jane, and John.

You can also group by multiple keys. For example, you might want to group by
user and machine to see if a user logged in from the same machine attempts to
log into an account multiple times. To do this, you might group by device_class
and user_dst.

Notifications

In the Notifications section, you can choose how to be notified when ESA generates an alert for
the rule.

For more information on the alert notifications, see Add Notification Method to a Rule.

The following figure shows the Notifications section.

Parameter Description

To add an alert notification type.

To delete the selected alert notification.
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Parameter Description

Output Alert notification type. Options are:

l Email

l SNMP

l Syslog

l Script

Notification Name of previously configured output, such as an email dis-

tribution list.

Notification Server Name of server that sends the output.

Template Name of template for the alert notification.

Output Suppression of

every    

Option to specify alert frequency.

Minutes Alert frequency in minutes.

Enrichments

In the Enrichments section, you can add a data enrichment source to a rule.

For more information on the enrichments, see Add an Enrichment to a Rule.

The following figure shows the Enrichments section.

Parameter Description

To add an enrichment.

To delete the selected enrichment.
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Parameter Description

Output Enrichment source type. Options are:

l In-Memory Table

l External DB Reference

l Warehouse Analytics

l GeoIP

Enrichment Source Name of previously configured enrichment source, such as a .CSV file-

name for an In-Memory Table.

ESA Event Stream

Meta

ESA meta key whose value will be used as one operand of join condition.

Enrichment Source

Column Name

Enrichment source column name whose value will be used as the other

operand of the join condition.

For an in-memory table, If you configured a key when creating a .CSV-
based enrichment, this column automatically populates with the selected
key. However, you can change it if you like. 
For a GeoIP enrichment source, ipv4 is automatically selected. 

Rules Tab
This topic describes the Rules tab, which you use to manage ESA rules and deployments.

The Rules tab is displayed when you select Alerts > Configure in the Security Analytics menu.

The following figure shows the Rules tab.
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Features

The Rules tab is divided into three sections:

l Options Panel

l Rule Library Panel

l Deployment Panel

Options Panel

In the options panel of the Rules tab, you can perform the following:

l View ESA rules in the Rule Library 

l Create deployments

The following figure shows the options panel in the Rules tab.
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Features

There are two sections in the options panel: Rules and Deployments.

Rules Section

The Rules section contains two options. Rule Library is selected by default, and when it's
selected, the Rule Library view is displayed within the tab. Get Rules From RSA
Live navigates to the Live Search view, where you can search for rules.

Deployments Section

The Deployments section lists deployments and indicates whether there are updates to the
deployments. From this section, deployments can be added, deleted, edited, and refreshed.
Selecting a deployment from the list displays the Deployment panel within the tab. The following
table describes the features of this section.

Feature Description

Displays a drop-down menu from which you can choose to add, edit, or

delete a deployment. You can also refresh the list of deployments to see

if there are any new updates to the list.

Indicates whether there are any updates to the deployment.

Indicates the number of rules in the deployment.

Rule Library Panel

This topic describes the components of the Rule Library panel. You can perform the following
tasks using the Rule Library panel:

l Add an ESA rule

l Delete an ESA rule

l Edit an ESA rule
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l Duplicate an ESA rule

l Import ESA rules

l Export an ESA rule

l Filter the ESA rules list

To access this view, in the Security Analytics menu, select Alerts > Configure. The Rules tab
is displayed and the Rule Library panel is on the right.

Features

The following figure shows the Rule Library panel.

The Rule Library panel includes the following components:
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l Rule Library toolbar

l Rule Library list

Rule Library Toolbar

The Rule Library toolbar allows you to add, delete, edit, duplicate, filter, export, and
import ESA rules. The following figure shows the icons for these actions.

Rule Library List

The following figure shows the Rule Library list.

The Rule Library list shows all the ESA rules that have been downloaded from RSA Live or
created in the Advanced EPL and Rule Builder tabs. The following table lists the columns in the
Rule Library list and their description.

Column Description

Rule Name Purpose of the ESA rule.

Description Summary of what the ESA rule detects.

Trial Rule Deployment mode to see if the rule runs efficiently.
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Column Description

Type The type of rule.

Actions (
)

Menu to delete, edit, duplicate, or export the selected rule.

Severity Threat level of alert triggered by the rule.

Email Indicates whether an alert notification for the rule is sent by email. This column

is not visible by default.

Snmp Indicates whether an alert notification for the rule is sent using SNMP. This

column is not visible by default.

Syslog Indicates whether an alert notification for the rule is sent using Syslog. This

column is not visible by default.

Script Indicates whether an alert notification for the rule executes a script. This

column is not visible by default.

Last Modi-

fied

The date and time when the ESA rule was last modified. This column is not vis-

ible by default.

To display columns which aren't visible by default, hover over the title of a column and click
the v on the right. This opens a drop-down menu in which you can sort the contents of the
column or choose which columns you want to see in the Rule Library list.
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Deployment Panel

This topic provides an overview of the Deployment panel. The Deployment panel enables you to
create and configure the deployments. The Deployment panel includes the following sections:

l ESA Services

l ESA Rules

The following figure shows the Deployment panel.

Features

ESA Services

Using the ESA Services section, you can manage each ESA service in the deployment.

In the ESA Services section, you can perform the following.

Task Description

Add an ESA service to the deployment. 

Remove the selected ESA service from the deployment.

Show Updates Open the Updates to the Deployment dialog.

Deploy Now Deploy current set of rules.

The following table lists the parameters of the ESA Services section.
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Parameter Description

Status Indicates if the deployment status is Added, Deployed, Updated,

or Failed.

Name Name of the ESA service.

Address IP address of the host where the ESA service is installed.

Version Version of the ESA service.

Last Deployment

Date

The date and time when the ESA service was last deployed.

ESA Rules

In the ESA Rules section, you manage rules in the deployment. This section lists all rules that
are currently in the deployment. 

In the ESA Rules section, you can perform the following.

Task Description

Open the Deploy ESA Rules dialog, where you

can select a rule.

Remove the selected ESA rules from the deploy-

ment.

Filter the list of rules.

Search for a rule.

The following table lists the parameters of the ESA Rules section.
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Parameter Description

Status Indicates the rule status:

l Deployed - the rule is deployed.

l Updated - the rule has been updated since the last deployment.

l Added - the rule has been added since the last deployment.

l Failed - the deployment failed.

Rule Name Purpose of the ESA rule.

Trial Rule Deployment mode to see if the rule runs efficiently.

Severity Threat level of alert triggered by the rule.

Output The type of the ESA rule.

Email, SNMP, Syslog,

Script

Indicates which notification types are used for alerts generated by

the rules.

Last Modified The date and time when the ESA rule was last modified.

Rule Syntax Dialog
This topic describes the features of the Rule Syntax dialog. The Rule Syntax dialog displays the
EPL syntax of conditions, statements, and debugging parameters, and provides a warning when
the syntax is invalid.

To access this dialog:

1. In the Security Analytics menu, select Alerts > Configure.

2. In the Rule Library view, do one of the following:
a. Click and select Advanced EPL or Rule Builder.

b. Double-click an existing rule.

c. Select an existing rule and click in the Rule Library toolbar.

d. In the row of an existing rule, select > Edit.

The new or existing rule is displayed in a new tab, available to edit.

3. Click Show Syntax at the bottom of the tab.

The following figure is an example of the Rule Syntax dialog.
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Features

The following table describes the Rule Syntax dialog parameters.

Parameters Description

Rule is valid or Validation

error in rule

Indicates whether the rule syntax is valid or needs to be

changed.

Rule Name Displays the name of the rule.

Text Displays the EPL syntax of conditions, statements, and debug-

ging parameters if the rule is valid.
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Select an ESA Service Dialog
This topic describes the features of the Select an ESA Service Dialog. The Select an ESA
Service dialog displays all available ESA services. Selecting a service allows you to view a
summary of the service in the Summary view.

To access this dialog, in the Security Analytics menu, select Alerts > Summary. If the Select

an ESA Service dialog is not displayed automatically, click  .

The following figure is an example of this dialog.

Features

The following table describes the features of the Select an ESA Service dialog.

Parameters Description

Select Displays the Summary view for the selected service.

Default Service Designates a default service. The Summary view will automatically display

for the default service.

Name Displays the name of the ESA service.

Address Displays the address of the ESA service.
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Parameters Description

Type Displays the type of service.

Services Tab
This topic provides an overview of the Alerts > Configure > Services tab The Services tab
provides details of the ESA services added to Security Analytics. 

The following figure shows the Services tab:

The Services tab has the following sections:

l ESA Services panel 

l General Stats panel 

l Deployed Rule Stats panel 

Features

ESA Services Panel

The ESA Services panel lists the name of each ESA service added to Security Analytics.
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General Stats Panel

The General Stats panel provides information on the Esper engine, rules and alerts.

The General Stats panel contains the following sections:

l Engine Stats 

l Rule Stats

l Alert Stats

​​The following figure shows the General Stats panel.

The table lists and describes the parameters in each section.

Sections Parameter Description

Engine

Stats

Esper Ver-

sion

Esper version running on the ESA service

Time Time when the last event was sent to Esper Engine

Events

Offered

Number of events analyzed by the ESA service since the last ser-

vice start

Offered Rate Current events offered rate on the ESA service

Rule Stats Rules

Enabled

Number of rules enabled.

Rules Dis-

abled

Number of the rules disabled

Events

Matched

Total number of events matched to all rules on the ESA service
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Sections Parameter Description

Alert Stats Email Number of email notifications sent by the ESA service

SNMP Number of SNMP notifications sent by the ESA service

Syslog Number of Syslog notifications sent by the ESA service

Script Number of Script notifications sent by the ESA service

Storage Total number of alerts stored in database

Message Bus Total number of alerts sent to the message bus

Deployed Rule Stats Panel

The Deployed Rule Stats panel provides details on the rules that are deployed on
the ESA service.

​​The following figure shows the Deployed Rule Stats panel.

The table lists the various parameters in the view and their description.

Parameters Description

Indicates the rule is enabled. Enables a rule that was disabled.

Indicates the rule is disabled. Disables a rule that was enabled.

Health & Wellness Displays a snapshot of memory usage when trial rules get disabled
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Parameters Description

Enable Indicates whether the rule is enabled or disabled.

Green icon indicates rule is enabled.

White icon indicates rule is disabled.

Name Name of the ESA rule.

Trial Rule Indicates if the rule is running in trial rule mode.

Last Detected The last time alert was triggered for the rule.

Events Matched The total number of events that matched the rule.

Settings Tab
This topic describes the components of the Settingstab. In the Settingstab, you can perform the
following tasks:

l View a list of meta keys

l Configure a data enrichment source

l Add a connection to an external database

The following figure shows the Meta Key References section in the Settings tab.
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Features

Meta Key References

The Meta Key References section lists each meta key and the type of value the key requires.

Enrichment Sources

In the Enrichment Sources section, you can configure the following external data sources:

l GeoIP

l External Database Reference

l In-Memory Table

l Warehouse Analytics

The following figure shows the Enrichment Sources section in the Settings tab.
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Database Connections

In the Database Connections section, you can configure a connection to an external database so
ESA can access that data.
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The following figure shows the Database Connections section in the Settings tab.

In the Database Connections section you can perform the following:

l Add a Database Connection

l Delete a Database Connection

l Edit a Database Connection

l Duplicate a Database Connection

l Import a Database Connection

l Export a Database Connection

Updates to the Deployment Dialog
The Updates to the Deployment dialog displays changes to the deployment, such as adding
a rule or service. Deployment updates are indicated by the update icon ( ) next to the name of
the deployment in the Rules tab options panel. 

To access this dialog:

1. In the Security Analytics menu, select Alerts > Configure.
The Rules tab is displayed by default.

2. In the options panel, under the Deployments section, select or add a deployment.
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3. In the Deployment panel, click Show Updates.
The Updates to the Deployment dialog is displayed.

The following figure is an example of this dialog.

Features

The Updates to the Deployment dialog displays the number of updates at the top of the
dialog. The following table describes the parameters of this dialog.

Parameters Description

Date Displays the day and time of the update.

User Displays the user who made the update.

Action Describes the update.
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