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Introduction

The instructions in this guide apply to the upgrade of virtual hosts to RSA NetWitness Platform11.2
exclusively. See the RSA NetWitness Platform Physical Host Upgrade Guide for instructions on how to
upgrade your 10.6.6.x physical hosts to 11.2. Go to the Master Table of Contents to find all NetWitness
Platform Logs & Network 11.x documents.

NetWitness Platform 11.2 is a major release that affects all products in the NetWitness Platform. The
components of the platform are the NetWitness Server (Admin server, Config server, Integration server,
Investigate server, Orchestration server, Respond server, Security sever, and Source server), Archiver,
Broker, Concentrator, Context Hub, Decoder, Endpoint Hybrid, Endpoint Log Hybrid, ESA Primary,
ESA Secondary, Log Collector, Log Decoder, Malware Analysis, Reporting Engine, UEBA, Warchouse
Connector, and Workbench.

Refer to the NetWitness Platform Getting Started Guide to become familiar with the major changes to
the 11.x User interface. Refer to the NetWitness Platform Deployment Guide to become familiar with
the major platform changes in 11.x.

Go to the Master Table of Contents to find all NetWitness Platform Logs & Network 11.x documents.

Note: The Reporting Engine is installed on the NW Server host, Workbench is installed on the
Archiver host, and Warehouse Connector can be installed on the Decoder host or Log Decoder host.

CentOS6 to CentOS7 Upgrade

NetWitness Platform 11.2 is a major release that involves upgrading to a newer version of the operating
system (CentOS6 to CentOS7). In addition, the 11.2 platform environment has been improved greatly to
accommodate current and future physical and virtual deployment types. These changes require an
upgrade to the new environment and an upgrade of the functionality.

7 Introduction
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RSA NetWitness® Platform 11.2 Upgrade Path

The earliest supported upgrade path for RSA NetWitness® Platform 11.2 is Security Analytics 10.6.6.x.
If you are running a version of NetWitness Platform that is prior to 10.6.6.x, you must update to 10.6.6.x
before you can upgrade to 11.2. See the RSA Security Analytics 10.6.6 Update Guide
(https://community.rsa.com/docs/DOC-85119) on RSA Link.

Supported Host Upgrade Path

Y ou must upgrade a host to the same host type:

o Same Series RSA Physical Appliance to Same Series RSA Physical Appliance (that is, Series 4 to
Series 4, Series 5 to Series 5).
RSA does not support third-party physical hosts in 11.2.

e On-Prem Virtual to On-Prem Virtual

Caution: The 11.2 upgrade does not support mixed-platform upgrades (for example, it does not support
physical to virtual).

Hardware, Deployments, Services, and Features Not Supported in 11.2

RSA does not support upgrade of the following hardware, deployments, services, and features to 11.2.
o RSA All-in-One (AIO) Appliance

o Multiple NetWitness Server Deployment

« IPDB service

o Malware Analysis service co-located on the SA Server (upgrade of Malware Analysis Enterprise is
supported in 11.2.)

o Standalone Warehouse Connector service (Upgrade of a co-located Warehouse Connector is
supported in 11.2.)

o Custom Health & Wellness policy in 10.6.x for the Context Hub Service
After you upgrade to NetWitness 11.2, your custom policy is not present. In its place, there is the out-
of-the-box Context Hub Server Monitoring Policy in the user interface, which is specific for version
11.2.

o Defense Information Strategic Agency-Security Technical Information Guide (DISA-STIG) hardened
deployments.

o Warehouse Analytics (Data Science)

Introduction 8
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Event Stream Analysis (ESA) Upgrade Considerations

In RSA NetWitness® Platform 11.2, RSA changed how ESA Correlation Rules store and transmit the
alerts the system generates. In 11.2, ESA sends all alerts to a central Alert system. The local MongoDB
storage in ESA 10.6.6.x has been removed.

Caution: If you do not use Incident Management in 10.6.6.x, carefully consider whether or not to
upgrade to version 11.2.

The following guidelines should help you determine whether or not to upgrade your ESA hosts to 11.2.
In your 10.6.6.x deployment, if you have:
o One ESA host, with or without Incident Management configured: Upgrade to 11.2.

o Multiple ESA hosts configured to use Incident Management: The system will continue to aggregate
alerts centrally. If the system is correctly sized and operating as intended in 10.6.6.x, you can upgrade
to version 11.2.

o Multiple ESA hosts without configuration to use Incident Management and you are connecting to
individual ESA hosts to view alerts: Do not upgrade to version 11.2.

Note: If you did not use Incident Management in 10.6.6.x, you cannot view the 10.6.6.x ESA alerts in
the 11.2 Respond component without running a migration script. Use the ESA Alert Migration script to
migrate these alerts to the location in 11.2 that will allow Respond to view them. See the ES4 Alert
Migration Instructions knowledge base article (https://community.rsa.com/docs/DOC-84102) in

RSA Link for instructions on how to run this script.

Upgrade Phases

RSA recommends that you stagger host upgrades as described in this section. The update to CentOS7
and the need of a physical or iDRAC access cause the 11.2 upgrade to take more time than most
upgrades.

Caution: If you stagger the upgrade, you:

* Must upgrade the hosts in Phase 1 first, in the order shown.

* May not have all the features operational until you update your entire deployment.

» Will not have service administrative features available until you upgrade all the hosts in your
deployment.

Phase 1

You perform Phase 1 first. You must upgrade the hosts in the following order:
1. Security Analytics Server host

2. Event Stream Analysis hosts

3. Malware Analysis hosts

0 Introduction
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4. Broker hosts (if you do not have a Broker, upgrade your Concentrator hosts)
The 11.2 NW Server cannot communicate with 10.6.6.x core services for the new Investigate
functionality. This is why you must upgrade the Broker or Concentrator hosts in Phase 1.

Phase 2

Upgrade the rest of your hosts.

RSA recommends that you follow the order in Phase 2 to reduce:
o Functionality loss during investigation.

o Downtime that results in the loss of network and log capture.

Note: Other than Log Collection hosts with downstream event destinations, there is no technical
reason to upgrade your hosts in the order shown in Phase 2.

This is the Phase 2 host upgrade order recommended by RSA.
1. Decoder hosts

2. Concentrator hosts

3. Archiver hosts
4

. Log Collection hosts - Log Collectors on Log Decoder hosts (LDs), Virtual Log Collectors (VLCs)
and Legacy Windows Collectors (LWCs)
Before you upgrade a log collection host, you must prepare it for the upgrade. Part of this preparation
ensures that no event data remains in the queues. This requires you to keep the downstream
destinations of event data (Log Collectors, Virtual Log Collectors and Log Decoders) up and
functioning properly.

If you have event data destinations downstream from the Log Decoder, you must prepare and
upgrade Log Collectors in the following order.

a. LDs (one LD at a time)
b. VLCs and LWCs

If you do not have event data destinations downstream from the Log Decoder, you can prepare and
upgrade multiple LDs, VLCs, and LWCs together.

5. All other hosts

See "Running in Mixed Mode" under "The Basics" in the RSA NetWitness Platform Hosts and Services
Getting Started Guide for:

o Functionality gaps encountered while running in this mode.

o Examples of staggered upgrades.

Go to the Master Table of Contents to find all NetWitness Platform Logs & Network 11.x documents.

Introduction 10
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Investigate in Mixed Mode

Mixed mode occurs when some services are upgraded to 11.2 and some are still on 11.0.0.x or 10.6.6.x
This happens when you upgrade to 11.2 in phases.

Note: You must follow the host upgrade sequence as shown in Upgrade Phases to ensure complete
Investigate functionality. The 11.2 Investigate server is installed when you upgrade the SA Server, but
Broker hosts need to be upgraded to 11.2 to access the Event Analysis view. If the Broker is not
upgraded, analysts see a warning icon next to the Broker, and no data aggregated to that Broker can be
displayed.

After you upgrade all services to 11.2, when an analyst conducts an investigation, Role-Based Access
Control (RBAC) of downloads works consistently to limit access to restricted data.

In mixed mode (that is, some services are upgraded to 11.2 and some are still at 11.0.0.x or 10.6.6.x),
when an analyst conducts an investigation, RBAC is not applied uniformly to viewing and downloads.

If the sdk.packets setting has not been disabled on the 10.6.6.x or 11.0.0.x services, analysts with
SDK meta and roles permissions in place to restrict viewing and reconstructing an event's content can
download the PCAP of an event that has content restrictions. Other types of downloads appear to be
successful, then generate errors due to insufficient permissions, and the data is still protected.

During a phased update, you can disable the sdk.packets setting on 10.6.6.x and 11.0.x.x services to
limit the analyst from downloading any PCAPs or logs during mixed mode. After you update all services
to 11.2 and re-enable sdk.packets, RBAC works consistently across all services.

The following table identifies what you can see and download in Investigate when your NW Server at
version 11.2 is connected to services at a lower version.

Can Can
. User Role
Connecting Download Download
Affected With
Service Restricted Restricted
View Restricted
Version Content Content
Content

Successfully | with Errors

Events View  Analyst RBAC PCAP File archive is
permitted downloaded but
items cannot unzip

11.2 Broker -> Event Analyst RBAC  PCAP File archive is

10.6.6.x Reconstruction permitted downloaded but

Concentrator ->  View items cannot unzip

10.6.6.x Network

Decoder/Log Event Analyst RBAC PCAP Error Retrieving

Decoder Analysis View permitted Payload from
items Service for

Payload, Request
Payload, Response
Payload
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Can Can
. User Role
Connecting Download Download
Affected With
Service Restricted Restricted
View Restricted
Version Content Content
Content

Successfully | with Errors

11.2 Broker -> Event Analystand RBAC  PCAP Files archive is
11.2 Concentrator Reconstruction Data Privacy permitted downloaded but
->11.2 View Officer items cannot unzip
Decoder/Log PCAPs and logs are
Decoder downloaded as zero
bytes
11.2 Broker -> Events View  Analyst RBAC  None Files archive is
11.0.0.x permitted downloaded but
Concentrator -> items cannot unzip
LG N i onl s PCAPs and logs are
Decoder/Log downloaded as zero
Decoder bytes
Event Analyst RBAC  None File archive is
Reconstruction permitted downloaded but
View items cannot unzip

PCAPs and logs are
downloaded as zero

bytes
Event Analyst RBAC  None Error Retrieving
Analysis View permitted Payload from
items Service for

Payload, Request
Payload, Response
Payload

PCAPs and logs are
downloaded as zero
bytes

Introduction 12
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Virtual Host Upgrade Workflow

The following diagram illustrates the RSA NetWitness® Platform 11.2 Virtual Host upgrade workflow.

RS = NetWitness Platform® 11.2 VM Upgrade Workflow
Phase 1 — Upgrade SA Server, ESA, and Malware
Phase 2 — Upgrade All Other Hosts

Troubleshoot
backup script
errors

Perform
Priz:\re Bac(l:()l:(pf::ate Migrate T Post
Upgrade
Upgrade Upgrade Tasks
Open Firewalls || Before each phase: 1. Back up 10.6.5.x Data. 1. Set up NW Server. Do Global Tasks.
for new ports. || 1. Create host backup list. 2. Deploy Same 10.6.5.x VM Stackin 11.1. || 2. set up ESA.
2. Set up SSH authentication. (Creates 11.1 base image). 3. Install ESA in NW UI. Do Core Services
Only do other || 3. Test for space. 3. Copy VMDK Files & Add to New VM. 4. Set up MA. Tasks.
tasks applicable || 4, Run backup script. 4, Retain MAC Address of Migrated VMs. 5. Install MA in NW UL
to your 5. Restore 10.6.5 Backup to 11.1.0.0 VMs. || 6. Set up Brkr/Conc. Only do other
deployment. 7. Install Brkr/Conc in Ul. | | tasks applicable
8. Set up Other hosts. to your
9. Install other hosts in UI. | | deployment.

Contact Customer Support

Refer to the Contact RSA Customer Support page (https://community.rsa.com/docs/DOC-1294) in RSA
Link for instructions on how to get help on RSA NetWitness Platform 11.2.

13 Introduction
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Upgrade Preparation Tasks

Complete the following tasks to prepare for the upgrade to NetWitness Platform 11.2. These tasks are
organized by the following categories.

o Global
« Respond
« Reporting Engine

Global

Y ou must complete these tasks regardless of how you deploy NetWitness Platform and which
components you use.

Task 1 - Review Core Ports and Open Firewall Ports
The following tables list new ports in 11.2.

Caution: Make sure that the new ports are implemented and tested before upgrading so that upgrade
does not fail due to missing ports.

NW Server Host

NW Hosts NW Server TCP 4505, 4506 Salt Master Ports

NW Hosts NW Server TCP 27017 MongoDB

Admin Workstation NW Server TCP 15671 RabbitMQ Management UI

NW Hosts NW Server TCP 15671 RabbitMQ Management Ul
ESA Host
m Destination Host | Destination Ports

NW Server, ESA Primary TCP 27017 MongoDB

NW Endpoint,

ESA Secondary

Endpoint Hybrid or Endpoint Log Hybrid

Endpoint Hybrid or Endpoint Log Hybrid NW Server TCP 5672 Message Bus

Endpoint Server NW Server TCP 27017 MongoDB

Upgrade Preparation Tasks 14
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All NetWitness Platform core ports are listed in the "Network Architecture and Ports" topic in the RSA
NetWitness® PlatformDeployment Guide in case you need to reconfigure NetWitness Platform services
and firewalls. Go to the Master Table of Contents to find all NetWitness Platform Logs & Network 11.x
documents.

Task 2 - Record Your 10.6.6.X admin user Password

Record your 10.6.6.x admin user password. You will need it to complete the upgrade.

Task 3 - Create a Backup of /etc/fstab File

Copy the /etc/fstab file from all VMs to your local machine (backup host or remote machine).

Note: You need this file to restore a VM with external storage mounts.

15 Upgrade Preparation Tasks
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Task 4 - Make Sure Password Strength Settings Check Boxes Are Setin 10.6.6.x

Note: You can skip this task if you do not want to migrate the password strength setting to 11.2.

The check box to the left of the Password Strength Settings in the Administration > Security >
Settings tab must be set in 10.6.6.x or these settings will not be migrated to 11.2.

Complete the following task to make sure that the Password Strength Settings check boxes are set in
10.6.6.x.

1. In Security Analytics 10.6.6.x, go to the Administration > Security > Settings tab.

2. Make sure that the required check boxes to the left of the Password Strength Settings are set and
click Apply.
The following example shows the required check boxes as set (required in 10.6.6.x before upgrading
to 11.2).

& Administration © = Hosts B Services M Event Sources @ Health & Wellness

Users Roles Sl External Group Mapping  PKI Settings  Login Banner

Password Strength

Minimum Required

[ Minimum Password Length 6 o Characters
[V Uppercase Characters (ER Characters
¥ Lowercase Characters 1 4| Characters
[] Decimal Digits 0o o Characters
[[] Special Characters o 4 Characters
(@578 =" 000", )

Characters

[ Men-Latin Alphabetic Characters 0

<>

[¥ Password May Not Contain Username

Apply

Upgrade Preparation Tasks 16
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Respond

Task 5 - Check Aggregation Rules Match Conditions for “Domain” or “Domain for
Suspected C&C”

Make a note of any Incident Management aggregation rules that have match conditions using Domain or
Domain for Suspected C&C in the drop-down list in the rule builder. In NetWitness Platform 11.2, you
will need to add back these conditions after you after you upgrade to 11.2 as described in the Respond
Post Update Tasks.

Check the following for each aggregation rule:

1. In Security Analytics 10.6.6.x, go to Incidents > Configure > Aggregation Rules tab and edit the
rules to view the matching conditions.

2. In the Match Conditions section, look for Domain or Domain for Suspected C&C listed in the
drop-down lists for the conditions.

A Incidents AQueve | MAlerts | Remediation  %Configure

AggregationRules  Notifications Integration ~ Retention Scheduler [Nz IE IS ARSI VISIue Y Y

Enabled 4
Name* Verify Domain for Suspected C&C field
Description This rule match Conditions for Domain & Domain for Suspected C&C in rule builder
Match Conditions® ® Query Builder O Advanced
Al of these v 4 Add Condition - - Add Group
Domain ~ isequalto v -
Domain for Suspected CBC ~ ~| is equal to ~ -
Action ® Groupinto anincident O Suppress the Alert
Grouping Options® Group By Domain & v
Domain for Suspected C&C ©
Time Window: 1 C Hours v
Incident Options Title ${ruleName} for ${groupByValue1} @
Summary
Categories v
Assignee v
Priority Use the following to set the priority for incident: Critical mc
(® Average of Risk Score across all of the Alerts High E-c
© Highest Risk Scare available across all of the Alerts (el ~
Low B
© Number of Alerts in the time window
Move sl fust scale
v
1 2 50 s 100

Security Analytics 2 admin | Last login : | € English (United States) | GMT+00:00 | 10.6.50

3. Make a note of the rule name and the entire condition that uses Domain or Domain for Suspected
C&C, including operators and values.
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Task 6 - Set Data Retention Run Interval to =2 24 Hours

In Security Analytics 10.6.x , the Data Retention run interval does not have any minimum value check.
In 11.2, RSA added a validation check to make sure that it is run at least every 24 hours. When you
upgrade to 11.2, if this value is less than 24 hour, the Respond service will not start.

Complete the following task to ensure that the Respond service starts after upgrading to 11.2.

1. In Security Analytics 10.6.6.x, go to ADMIN > Services.
.ﬁ -

3. Inthe Incident Management Explore view, go to Service > Configuration >
dataRetentionConfiguration.

2. Select the Incident Management service, and then select > View > Explore.

4. Make sure that the FrequencyInHours parameter is > 24.

A Administration ©® = Hosts £ services N\ Event Sources W Health & Wellness 2= system i security

- Change Service | SA-Incident Management |  Explore &

‘com.rsa.netwitness.im/Service/Configuration/dataRetentionConfiguraticv  SA - Incident Management (Incident Management)

= SA - Incident Manage...

oo et = ExecutionHour 0
[notificationEngine alid true
Clroles Enabled false
[Odatabase [FrequencylnHours 24
[integrationMessageBus RetentionPeriodinDays 90
[TJruleEngine I

[OnotificationSettings
[reporting

[3ssl
[JdataRetentionConfiguration

B[ Jstatus

Security Analytics 2 admin | Lastlogin : Tuesday, May 15,2018 11:33:56 AM UTC | @Enghsh (United States) | GMT+00:00 | 10.6.x.x

Upgrade Preparation Tasks 18
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Reporting Engine

(Conditional) Task 7 - Unlink External Storage

If the Reporting Engine has external storage [such as Storage Area Network (SAN) or Network
Attached Storage (NAS) for storing reports] you must perform the follow steps to unlink the storage.

In these steps:
e /home/rsasoc/rsa/soc/reporting-engine/ is the Reporting Engine home directory.

e /externalStorage/ is where the external storage is mounted.

1. SSH to the Reporting Engine host and log in with your root credentials.
2. Stop the Reporting Engine service.

stop rsasoc re

3. Switch to rsasoc user.

Su rsasoc

4. Change to the Reporting Engine the home directory.
cd /home/rsasoc/rsa/soc/reporting-engine/

5. Unlink the resultstore directory mounted to external storage.
unlink /externalStorage/resultstore

6. Unlink the formattedReports directory mounted to external storage.
unlink /externalStorage/formattedReports
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Backup Instructions

Backing up your configuration data for all your hosts from 10.6.6.x is the first step in upgrading from
Security Analytics 10.6.6.x releases to NetWitness Platform 11.2.

Note: 1.) It is important that you place Custom Certificate files and any other certificate authority
(CA) files in the /root/customcerts folder to ensure that these certificate files are backed up.
Your custom certificate files that are placed in this directory will be automatically restored during the
upgrade process. After upgrading to 11.2, your custom certificate files will be located in
/etc/pki/nw/trust/import. For more information about backing up these types of files, see step
1 in For All Host Types. 2.) Disable your Public Key Infrastructure (PKI) settings before starting the
backup.

Caution: These services are not supported in the 10.6.6.x backup and upgrade process.
- IPDB

- All in One servers

- Malware Analysis Co-Located on the Security Analytics Server

- Standalone Warehouse Connector

- Warehouse Analytics (Datascience)

The following types of hosts can be backed up and are automatically restored during the upgrade
process:

o Security Analytics Admin Server

o Standalone Malware Analysis

o Archiver

o Broker

o Event Stream Analysis (including Context Hub and Incident Management database)
o Concentrator

o Log Decoder (including Local Log Collector and Warehouse Connector, if installed)
o Log Hybrid

o Network Decoder (including Warehouse Connector, if installed)

o Network Hybrid

o Virtual Log Collector

The following types of files are automatically backed up but must be restored manually after the upgrade
process:

o PAM configuration files: For information about restoring the PAM configuration files, refer to "Task 5
- Reconfigure Plugable Authentication Module (PAM) in 11.2.", in the "Global" section of the Post¢
Upgrade Tasks.

e /etc/pfring/mtu.conf and /etc/init.d/pf ring: To restore these files you must manually
retrieve them. The /etc/pfring/mtu.conf files will be located in
/var/netwitness/database/nw-backup/restore/etc/pfring/mtu.conf, and the
/etc/init.d/pf ring files will be located in /var/netwitness/database/nw-
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backup/restore/etc/init.d/pf ring. For information about how to restore these files, see "
(Conditional) Task 2 - Restore Files for 10G Decoder" in the "Hardware Related Tasks" section of
Post Upgrade Tasks.

The following diagram shows the high-level task flow of the steps you perform to back up your hosts.

Check backup

Crzeite 1 SiHat Set up requirements Check for Back up your
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e hosts to back
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up.

types of hosts.

The following sections describe each of these tasks:

o Task 1 - Set up an External Host for Backing up Files

o Task 2 - Create a List of Hosts to Back up

o Task 3 - Set up Authentication Between Backup and Target Hosts

o Task 4 - Check for Backup Requirements for Specific Types of Hosts
o Task 5 - Check for Adequate Space for the Backup

o Task 6 - Back up Your Host Systems

o Post Backup Tasks

Task 1 - Set up an External Host for Backing up Files

Y ou must set up an external host to use for backing up files. The host must be running CentOS 6 with
connectivity through SSH to the Security Analytics stack of hosts.

Note: If you are not able to use an external host for backing up files, contact RSA Customer Support
(https://community.rsa.com/docs/DOC-1294) for assistance.

Ensure that the host names for the systems to be backed up are resolvable on the backup host machine,
either by DNS or listed in the /etc/hosts file.

Note: These scripts are designed to run on CentOS 6 only. You must execute these scripts on CentOS
6 machines.

There are several scripts that you run during the backup process. You must download the zip file that
contains the scripts (nw-backup-v4.1.zip or later) from RSA Link at this location:
https://community.rsa.com/docs/DOC-81514 and copy it over to your CentOS 6 backup system. Extract
the zip file to access the scripts. The scripts are:

e get-all-systems.sh: Creates the all-systems file, which contains a list of all your Security
Analytics Servers and host systems to be backed up.

Caution: When performing a mixed-mode upgrade, retain a master copy of the all-systems file
upgrade until all the hosts in your deployment are upgraded to 11.2. You cannot run the get-all-
systems.sh a second time because the NW Server, the first host that must be upgraded in mixed
mode, will have CentOS7 as an operating system .

21 Backup Instructions


https://community.rsa.com/docs/DOC-1294
https://community.rsa.com/docs/DOC-81514

Virtual Host Upgrade Guide

o ssh-propagate.sh: Automates sharing keys between the systems you are backing up and the
backup host system so that you are not prompted for passwords multiple times.

e nw-backup.sh: Performs the backup of your hosts.

e azure-mac-retention.psl: Applies only if you are using AZURE. See the AZURE Deployment
Guide on for more information. Go to the Master Table of Contents to find all NetWitness Platform
Logs & Network 11.x documents.

Note: If you have used the 10.6.x versions of the backup and restore scripts on your 10.6.6 hosts, you
must still run all the scripts listed here.

Note: Do NOT use the scripts in the nw-backup-v4.1.zip file for regular backups. These scripts
are specifically designed for upgrading from 10.6.6.x to 11.2.

Note: The backup scripts do not support backing up data for STIG-hardened hosts.
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Task 2 - Create a List of Hosts to Back up

The script that you use to back up your files depends on the all-systems and all-systems-master-
copy files, which contain a list of the hosts that you want to back up. The all-systems-master-
copy file contains a list of all your hosts. The al1-systems file is used for each backup session, and
contains only those hosts which are being backed up for a particular session. You run the get-all-
systems. sh script to generate these files. RSA recommends that you back up your hosts in groups, and
not all at once. The recommended order and grouping of hosts for backup sessions is shown in the
following diagram:

1
SA Servers
SA Hosts
Malware Hosts

Concentrators

_.:'I_
Log Collectors, VLCs, and Decoders
(includes Log and Packet Decoders)

Limit each backup session to five hosts to ensure that you do not run out of space for the backup files.
You create all-systemns files for your backup sessions by using the all-systems-master-copy file
as a reference and then manually editing the al1-systems file to contain specific hosts.

To generate the all-systems and the all-systems-master-copy files:

1. From the host on which you are running the backup process, make the get-all-systems. sh script
executable by running the following command:
chmod u+x get-all-systems.sh

2. At the root level, run the get-all-systems. sh script:
./get-all-systems.sh <IP-Address-of-SA-Admin-Server>
Y ou will be prompted for the password for each host system once per host.
This script saves the all-systems file and the all-systems-master-copy file to
/var/netwitness/database/nw-backup/.
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3. Validate that the al1-systems and all-systems-master-copy files were generated and that
they contain the right hosts.

4. Editthe all-systems file to contain only the systems you are backing up. You can do this by using
the all-systems-master-copy file as a reference, and then opening the al1-systems file in an

editor (such as vi) and modifying it to include only the systems you want to back up. RSA

recommends that you comment out the hosts that you do not want to back up (add the number sign (#)

to the beginning of the line that contains the host that will not be backed up).

The following examples shows how to comment out the 10.6.6 Security Analytics Server:
loghybrid, loghyb,172.16.0.1,45fe9del-1a82-49d7-9bbl-7ac5fald18d8,10.6.6.0
#inwserver ,nwservl06,172.31.255.23,67a9a0eb-1300-4fba-838f-
Tbe4d8cf5e65,10.6.6.0

Note: If you use vi, be sure to include the path to the location of the al11-systems file.

Here is an example of an al1-systems-master-copy file

nwserver, my-nw-server,10.0.0.1,af922b9f-cd61-49cd-afdc-a48e558cec3e,10.6.6.0
archiver, my-nw-archiver,10.0.0.2,a65c1236-5e46-4117-8529-8ea837074bd0,10.6.6
concentrator, my-nw-concentrator,10.0.0.3,dc620e94-bcf5-4d51-83fe-
c003cdfcd7a6,10.6.6.0
esa,my-nw-esa,10.0.0.4,8b608c0d-a7f9-40c0-baee-8407dec774ab,10.6.6.0
logdecoder, my-nw-logdecoder,10.0.0.5,c8be5d45-e19e-4a8d-90ce-
1cb2fe60077a,10.6.6.0
malwareanalysis,my-nw-malwareanalysis,10.0.0.6,2edc9585-7081-48c3-8f8c-
e0d02aala2fd,10.6.6.0

packetdecoder, my-nw-packetdecoder,10.0.0.7,a8£2£574-3dd0-4b65-9cf7-
d8141b78a192,10.6.6.0
vlic,my-nw-vlc,10.0.0.8,3ffefcd4e-0b31-4951-bb77-dea5869fa98c,10.6.6.0

broker, my-nw-broker,10.0.0.9, 0b65e7ce-61d5-4177-9647-c56ccfb0£737,10.6.6.0

And here is an example of an all-systems file that could be used in the first backup session, where
only the Security Analytics Server, ESA host, and Malware Analysis host are backed up:

nwserver, my-nw-server,10.0.0.1,af922b9f-cd61-49cd-afdc-a48e558cec3e,10.6.6.0
#archiver, my-nw-archiver,10.0.0.2,a65¢c1236-5e46-4117-8529-
8ea837074bd0,10.6.6.0

#concentrator, my-nw-concentrator,10.0.0.3,dc620e94-bcf5-4d51-83fe-
c003cdfcd7a6,10.6.6.0
esa,my-nw-esa,10.0.0.4,8b608c0d-a7£9-40c0-baee-8407dec774ab,10.6.6.0
#logdecoder, my-nw-logdecoder,10.0.0.5,c8be5d45-e19e-4a8d-90ce-
lcb2fe60077a,10.6.6.0

malwareanalysis, my-nw-malwareanalysis,10.0.0.6,2edc9585-7081-48c3-8f8¢c-
e0d02aala2fd,10.6.6.0

#packetdecoder, my-nw-packetdecoder,10.0.0.7,a8f2f574-3dd0-4b65-9¢cf7-
d8141b78a192,10.6.6.0

#vlc, my-nw-v1ic,10.0.0.8,3ffefc4e-0b31-4951-bb77-dea5869fa98¢c,10.6.6.0
#broker, my-nw-broker,10.0.0.9,0b65e7ce-61d5-4177-9647-c56ccfb0£737,10.6.6.0

Troubleshooting Information

o Be sure to save copies of the all-systems and all-systems-master-copy files in a safe
location. Follow these recommendations:
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e Do not edit the all-systems-master—-copy file.

o If you create several different versions of the al11-systems file (for example, for several backup
sessions), be sure that each version of the file lists only those hosts that are currently being backed
up, and the other hosts are commented out. For more information, see Post Backup Tasks.

If any host systems are down while you are running the get-all-systems. sh script, the script
creates a list of hosts for which it cannot find information. After the script completes and the a11-
systemns file is created, you must edit the al1-systems file manually and add the missing
information for these hosts.

The get-all-systems.sh script generates a list of hosts that were defined in the Security
Analytics user interface. Ensure that all hosts and services are provisioned properly. If any hosts or
services are not provisioned properly, they will not be backed up. RSA recommends that when you
add hosts and services to Security Analytics, you use the Security Analytics user interface to ensure
that they are provisioned properly. However, if there are any hosts or services that were not defined
in the user interface, you must add them to the al1-systems file manually.

At the end of the get-all-systems. sh script, the script will check for any differences between the
systems that the Security Analytics Server has listed, and the ones for which the script was able to
find all the required information. If any Node ID’s or system names are listed as missing, verify the
existence of those systems, that their services are all running, and that they are properly
communicating with the Security Analytics Server. (Any Windows Legacy Collectors or AWS Cloud
Collectors will not be added to the a11-systems file, and may account for discrepancies. DO NOT
add these items to the all-systems file manually.)

If the syntax in the al1-systems file is incorrect, the script will fail. For example, if there is an
extra space at the beginning or the end of a host entry, the script will fail.
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Task 3 - Set up Authentication Between Backup and Target Hosts

RSA recommends that you run the ssh-propagate. sh script to automate sharing keys between the
backup host and the host systems.

Note: If you have SSH keys that are protected with pass phrases, you can use ssh-agent to save
time. For more information, refer to the man page for ssh-agent.

Complete the following task to set up authentication between backup and target hosts.

1. On the external backup host system, make the ssh-propagate. sh script executable by running the
following command:
chmod u+x ssh-propagate.sh

2. At the root directory, run the following command, where <path-to-all-systems-file> is the
path to the directory where the all-systems file is stored:
ssh-propagate.sh <path-to-all-systems-file>

3. You are prompted for the password once per host, but you will not need to enter it repeatedly later
during the backup process.

Task 4 - Check for Backup Requirements for Specific Types of Hosts

After you create the all-systems file to use for backup, you must check to see if any of the hosts
listed in the file have requirements that must be met before you run the backup process.

For All Host Types

Perform the following steps for all host types.

1. On the Security Analytics Server, place Custom Certificate files and any other certificate authority
(CA) files in the /root/customcerts folder to ensure that these certificate files are backed up.
Y our custom certificate files that are placed in this directories will be automatically restored during
the upgrade process. After upgrading to 11.2, your custom certificate files will be located in
/etc/pki/nw/trust/import
You can convert CA certificates and keys to different formats to make them compatible with specific
types of servers or software using OpenSSL. For example, you can convert a normal PEM file that
would work with Apache to a PFX (PKCS#12) file and use it with Tomcat or IIS. To convert the
files, SSH to the Security Analytics Server and run the following command strings to perform the
conversions listed.

Convert a DER file (.crt .cer .der) to PEM

openssl x509 -inform der -in certificate.cer -out certificate.pem
Convert a PEM file to DER

openssl x509 -outform der -in certificate.pem -out certificate.der
Convert a PEM Certificate File and a Private Key to PKCS#12 (.pfx .p12)

openssl pkcsl2 -export -out certificate.pfx -inkey privateKey.key -in
certificate.crt -certfile CACert.crt

Convert a PKCS#12 File (.pfx .p12) Containing a Private Key and Certificates to PEM
openssl pkcsl2 -in keyStore.pfx -out keyStore.pem -nodes
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Note: Add the following qualifier to the command string to:
-nocerts convert private keys exclusively.
-nokeys convert certificates exclusively.

2. Manually record any custom configurations made to CentOS 6 (for example, driver customizations)
for restoration after you update to CentOS 7. Custom configurations to CentOS 6 are not
automatically backed up and restored.

For ESA Hosts with Mongo Databases

The default 10.6.x Mongo database password is netwitness. If you have customized this password,
you could encounter an error while running the backup script. You can either use your custom Mongo
database password during the backup, or you could change that password back to netwitness before
running the nw-backup. sh script.

1. Find out if the Mongo database password is netwitness or if it has been modified.

2. If it has been modified, either change it back to netwitness, or be sure you know what the
customized password is so that you can enter it during the backup.

For Decoder, Concentrator, or Broker Hosts: Stop Data Capture and Aggregation

In addition to the tasks described in For All Host Types, for Decoder, Concentrator, or Broker hosts, stop
data capture and aggregation on all the systems that you are backing up. For instructions, refer to
"Appendix B. Stopping and Restarting Data Capture and Aggregation."

Log Collectors (LC) and Virtual Log Collectors (VLCs): Run prepare-for-
migrate.sh
Caution: This task stops log collection so you must perform this step immediately before you upgrade

to minimize the loss of event collection. Complete this task in accordance with the backup and upgrade
tasks in this guide.

Prerequisites

Y ou need the following information before you prepare LCs and VLCs for upgrade.

o If Lockbox was initialized on the LC and VLC, you must know the Lockbox password. It is required
to reconfigure the Lockbox after the upgrade.

« If you set the password for Logcollector user for RabbitMQ, you must know the password so you
can set it again after the upgrade.

Prepare LCs and VLCs for Upgrade
Complete the following task to prepare Log Collectors and Virtual Log Collectors for the upgrade.
1. SSH to the Log Collector.

2. Submit the following command string.
# /opt/rsa/nwlogcollector/nwtools/prepare-for-migrate.sh --prepare
This command:
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« Stops the Puppet Agent service.

o Disables the file collection accounts (“sftp” and all users in the group “upload’) used for
uploading log files to the Log Collector. The log files accumulate on the event sources until the
Log Collector has been upgraded to 11.2.

« Stops all the collection protocols in the Log Collector service.
o Saves the list of Plugin accounts and RabbitMQ accounts.

o Configures the RabbitMQ server so that new events cannot be published to it any longer.
Consumers of events in the queues, such as shovels and Log Decoder Event Processors, will
continue to run.

o Waits until the Log Collector queues are empty.
o Stops the Log Collector service.

o Creates a marker file indicating that the Log Collector has been successfully prepared for
upgrade.

Troubleshooting Information
The prepare-for-migrate.sh script:
o Sends informational, warning, and error messages to the console.

o Saves a session log in the /var/log/backup/ directory.

You must fix any of the following errors and resume the preparation. Contact RSA Customer Support
(https://community.rsa.com/docs/DOC-1294) for assistance.

o Log Collector queues with events but without consumers are found.
o Unable to stop the Puppet Agent service.

o Unable to stop a collection protocol in the Log Collector service.

« Unable to block event publishers to the RabbitMQ server.

o Unable to or taking too long for queue events to be consumed. The script makes 30 attempts waiting
for the events to be consumed. After each attempt, it sleeps for 30 seconds.

o Unable to stop the Log Collector service.

For more information about troubleshooting, see Appendix A. Troubleshooting.

For Integrations with Web Threat Detection, Archer Cyber Incident & Breach
Response or NetWitness Endpoint - List RabbitMQ Usernames and Passwords

On the 10.6.6.x Security Analytics Server host, you must get a list of all RabbitMQ usernames and
passwords so that after you perform the 11.2. upgrade, you can restore RabbitMQ user accounts.

To get a list of RabbitMQ usernames and passwords, run the following command:

rabbitmgctl list users >> /root/rabbitmg users.txt
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To restore RabbitMQ user accounts, refer to "Task 2 - For Integrations with Web Threat Detection,
NetWitness SecOps Manager or NetWitness Endpoint Configure Mutually Authenticated SSL" in Post
Upgrade Tasks.

For Bluecoat Event Sources

Bluecoat ProxySG event sources use FTPS protocol to upload log files to the Log Collector (LC) and
Virtual Log Collector (VLC). The event source documentation contains the steps to configure VSFTPD
service on the LC and VLC.

o If key material exists in the /root/vsftpd/ directory in 10.6.6.x, this material area will be backed
up and restored. If the material was in another location, you must back it up and restore it
manually.

o Ifthe /etc/vsftpd/vsftpd.conf file exits in 10.6.6.x, it is backed up and restored.

Task 5 - Check for Adequate Space for the Backup

You can run the backup test script to check the amount of disk space that is required for the backup using
the -t option described in Test Options. You run the script without actually backing up files or stopping
any services. RSA recommends that you perform this step to ensure that you provide adequate space for
the backup so that the backup captures all your data.

Complete the following task to check for adequate disk space.

1. Make the backup script executable by running the following command:
chmod u+x nw-backup.sh

2. Run the following command at the root directory level:
./nw-backup.sh -t
The output displays the amount of disk space that is required for the backup.

Note: The . /nw-backup.sh -t command runs with the -d option by default.
However, if you are looking for more accurate disk space results, you can override the -
d option by using -D. Using the -D option will show how much space is required on each
host for the data that will be backed up, but does not show how much space is available.
If there is not enough space available, the -D option will throw an error. If you want to
know how much space is available on the target host, you must run the df -h command
on the host.

The following figure shows an example of the output from using the -t option.
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Task 6 - Back up Your Host Systems

Before you run the backup script to do the actual backup, be sure that you have plenty of space. To back
up your hosts, you run the nw-backup. sh script using the —u option. This option is required for
upgrading to 11.2.

Note: The script will stop services as it runs. However, you can stop services manually before you run
the script if needed.

When you run the backup script, you can choose from several options that are described in the following
sections.

Usage

./nw-backup.sh [-u -t -d -D -1 -x -e] <external-mnt> -b <backup file path>

General Options

-u : This option is required for upgrading to 11.2. Enables the upgrade flag
to run backup for upgrading to 11.2. It also enables disk space check (-d),
backing up reporting engine reports (-r) and stores backup content locally (-
1) . Default: (no)

-d : enables disk space check in 'fast' mode (quick estimate of space using
uncompressed data). Default: (no)

-D : enables disk space check in 'full' mode (estimate of space using

compressed data, ~10X slower). Default: (no)

-1 : stores backup content locally on each host (automatically set if -u is
used) . Default: (no)

-e <path to mount point> : copies backup files of all devices onto an external
mount point. Default: (/mnt/external backup)

-x : move all backup files to an external mount point. Default: (no) - COPY
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-b <path to write backups> : path to the location for storing backup files on
a backup server. For upgrading to 11.2, please use the default location!
Default: (/var/netwitness/database/nw-backup)

Note: Do not change the backup path in upgrade (-u) mode.

Note: When you run a backup with the —u option, all services are stopped. If you need to continue to
use the 10.6.x machine after running the backup, reboot the 10.6.x system so that services are
restarted.

Advanced Content Selection Options

-c : back up Colocated Malware Analysis on SA servers. Default: (no)
-i : back up IPDB data (/var/netwitness/ipdbextractor). Default: (no)
-m : back up Malware Analysis File Repository. Default: (no)

-r : back up Reporting Engine Report Repository (automatically set if -u is
used) . Default: (no)

-v : back up system logs (/var/log). Default: (no)
-y : back up YUM Web Server & RPM Repository. Default: (no)
-5 : If set: DISABLES back up of SMS RRD files. Default: (not-set)

-C : If set: DISABLES back up of Context-Hub configuration and database.
Default: (not-set)

-E : If set: DISABLES back up of ESA Mongo database. Default: (not-set)

Test Options

-t : performs script test run for disk space check only. Services are not
stopped and excludes execution of backup. Can be combined with (-d) or (-D)
and other flags. Default: (-t)

For example, the command:

./nw-backup.sh

would run the backup with options as set in the Header of the script itself.

OR, the command:

./nw-backup.sh -ue /mnt/external backup

would run a normal backup using the backup path defined in the script, with the following options:

-u : enables the upgrade flag to run backup for upgrading to 11.2. It also
enables disk space check (-d), backing up reporting engine reports (-r) and
stores backup content locally (-1). Default: (no)

-e : Copy the backup files to external mount point, mounted on /mnt/external
backup

For Help: ./nw-backup.sh -h
When you run the script, the following text is displayed at the top of the script:
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Caution: RSA nw-backup script backs up configuration files, data, and logs on the options provided
in the script. It tars the content, with options to store the backup files on the backup server, move or
copy them to external storage on a mount point (USB/NFS/SMB), or SCP them back to the target host.
This backup script has been qualified on the following versions of Security Analytics:

10.6.6.x

Use of this script on any other versions of the product may not give expected results and may not be

supported by RSA Customer Service.

Note: All non-RSA custom files, scripts, Cronjobs and other important files should be placed in

/root, /home/'user', OR /etc to be included in the backup.

Complete the following task to back up your hosts.

1.

Ensure that the a11-systems file contains only the hosts to back up. For information, see Task 2 -
Create a List of Hosts to Back up.

Make the backup script executable by running the following command:
chmod u+x nw-backup.sh

Begin the backup process by running the following command at the root directory level:
./nw-backup.sh -u

Note: You must use the —u option so that your files will be restored correctly during the upgrade to
11.2. Do NOT make any changes to the header of the backup script for the backup path because
the path is specific to the upgrade, and that data needs to be in a specific place.

When the text "Backup completed with no errors" is displayed, the backup has completed
successfully.

A log file, with a name similar to the following example, is created in the backup directory which
provides information on the files being backed up:
rsa-nw-backup-2018-03-15.1og

When the backup has completed, to ensure that the intended files were backed up, you can run the
following command to see a list of all the files that were backed up:
tar -tzvf hostname-ip-address-backup.tar.gz

The following archive files are created:

For all hosts:

<hostname-IPaddress>-root.tar.gz
<hostname-IPaddress>-backup.tar.gz

tar checksum files
<hostname-IPaddress>-network.info.txt

For Security Analytics Servers:
<hostname-IPaddress>-root.tar.gz
<hostname-IPaddress>-backup.tar.gz
<hostname-IPaddress>-mongodb.tar.gz

tar checksun files
<hostname-IPaddress>-network.info.txt

For ESA Hosts:

<hostname-IPaddress>-root.tar.gz
<hostname-IPaddress>-backup.tar.gz
<hostname-IPaddress>-mongodb.tar.gz

<hostname-IPaddress>-controldata-mongodb.tar.gz
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tar checksumn files
<hostname-IPaddress>-network.info.txt

The archived files are located in the /var/netwitness/database/nw-backup directory. If any of
the tar files appear smaller than expected, open them to be sure that the files were properly backed up.

Post Backup Tasks

Task 1 - Save a Copy of the a11-systems File and the Backup Tar files

Make copies of the all-systems file, the all-systems-master-copy file, and the backup tar files
and put the copies in a secure location. You cannot regenerate these files after you upgrade the Security
Analytics Server (specifically the Admin service) to 11.2.

Task 2 - Ensure Required Backup Files Were Generated

After you run the backup scripts, several files are generated. These files are required for the 11.2
upgrade process. Before you begin the upgrade process, you must ensure that the required backup files
are on the hosts that you are upgrading, and that you perform the following tasks.

The following files are generated on all hosts by the backup scripts:
e all-systems

e all-systems-master-copy

e appliance info

e service info

e <hostname>-<host-IP-address>-backup.tar.gz

e <hostname>-<host-IP-address>-backup.tar.gz.sha256
e <hostname>-<host-IP-address>-root.tar.gz

¢ <hostname>-<host-IP-address>-root.tar.gz.sha256

e <hostname>-<host-IP-address>-network.info.txt

In addition to the files listed above, the following files will be generated on the Security Analytics Server
and ESA hosts:

e <hostname>-<host IP address>-mongodb.tar.gz

e <hostname>-<host IP address>-mongodb.tar.gz.sha256

The backup script will also generate the following controldata-mongodb.tar.gz files.

Note: The backup script copies the following files from all ESA hosts to the Security Analytics
Server's backup path .

e <esa hostname>-<esa hostip>-controldata-mongodb.tar.gz

e <esa hostname>-<esa hostip>-controldata-mongodb.tar.gz.sha256
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Task 3 - (Conditional) For Multiple ESA Hosts, Copy mongodb tar files to Primary
ESA Host

If you have multiple ESA host systems in your enterprise, copy the following two files from each ESA
host to the /opt/rsa/database/nw-backup/ directory on the Primary ESA host system (the host that
has the ContextHub service running on it) :

e <hostname>-<host-IP-address>-mongodb.tar.gz

¢ <hostname>-<host-IP-address>-mongodb.tar.gz.sha256

Task 4 - Ensure All Required Backup Files are on Each Host

Before you upgrade to 11.2., ensure that the appropriate files exist on the hosts that you are upgrading as
described in the following lists.

Note: The default paths for backup files are:

- Security Analytics Servers:/var/netwitness/database/nw-backup
- ESA hosts:/opt/rsa/database/nw-backup

- Malware hosts: /var/lib/rsamalware/nw-backup

Required Files for NetWitness Servers

e all-systems-master-copy

¢ <hostname>-<host-IP-address>-backup.tar.gz

e <hostname>-<host-IP-address>-backup.tar.gz.sha256

e <hostname>-<host-IP-address>-root.tar.gz

¢ <hostname>-<host-IP-address>-root.tar.gz.sha256

e <hostname>-<host-IP-address>-network.info.txt

e <hostname>-<host-IP-address>-mongodb.tar.gz

e <hostname>-<host-IP-address>-mongodb.tar.gz.sha256

e <esa-hostname>-<esa-host-IP-address>-controldata-mongodb.tar.gz

e <esa-hostname>-<esa-host-IP-address>-controldata-mongodb.tar.gz.sha256

Required Files for ESA Hosts

e all-systems-master-copy

e <hostname>-<host-IP-address>-backup.tar.gz

e <hostname>-<host-IP-address>-backup.tar.gz.sha256
e <hostname>-<host-IP-address>-root.tar.gz

e <hostname>-<host-IP-address>-root.tar.gz.sha256

e <hostname>-<host-IP-address>-network.info.txt
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<hostname>-<host-IP-address>-mongodb.tar.gz

<hostname>-<host-IP-address>-mongodb.tar.gz.sha256

Required Files for All Other Hosts

all-systems-master-copy
<hostname>-<host-IP-address>-backup.tar.gz
<hostname>-<host-IP-address>-backup.tar.gz.sha256
<hostname>-<host-IP-address>-root.tar.gz
<hostname>-<host-IP-address>-root.tar.gz.sha256

<hostname>-<host-IP-address>-network.info.txt

Note: The following files are located in the <hostname>-<host-IP-address>-backup.tar.gz
tar on all hosts:
appliance info
service info
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Note: The paths to the location of the backup and restore files for iptables, NAT configurations, user
accounts, and crontab entries are shown in the following list:

Backup paths:

BUPATH=/opt/rsa/database/nw-backup for the ESA Correlation Engine
BUPATH=/var/lib/rsamalware/nw-backup for the Malware Service
BUPATH=/var/netwitness/database/nw-backup for all other services

Restore locations:

BUPATH/restore/etc/sysconfig for Iptable rules

BUPATH/restore/etc/sysconfig for NAT configurations

BUPATH/restore/etc for Crontab entries

BUPATH/restore/etc for User Accounts (users are located in the passwd file, and groups are
located in the group file. These are not restored during the upgrade process but can be restored
manually.

BUPATH/restore/etc/ntp.conf for NTP configurations (must be restored using the NetWitness
Platform UI)
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Migrate Disk Drives from 10.6.6.x to 11.2

These instructions tell you how to upgrade virtual hosts from 10.6.6.x to 11.2.

Caution: 1) You cannot perform the migration if you have a snapshot for your VM.

2). Run the backup immediately before you upgrade hosts for each phase so that the data is not out-
dated.

3.) This guide applies to virtual host upgrades exclusively. If have both physical and virtual hosts in
your deployment, see the RS4 NetWitness® Platform 11.2 Physical Host Upgrade Instructions for the
steps you must complete to upgrade physical hosts. Go to the Master Table of Contents to find all
NetWitness Platform Logs & Network 11.x documents.

Note: The machines must be in VMware ESX.

There are five tasks you must complete to migrate your Virtual Machine (VM) deployment disk drives
from 10.6.6.x to 11.2:

Task 1 - Back up data in your 10.6.6.x VMs.

Task 2 - Deploy the same VM Stack in 11.2 as you have in 10.6.6.x.

Task 3 - Copy the VMDK Files and add them as a hard disk to the new VMs.
Task 4 - Retain MAC address of upgraded SA Server VM.

Task 5 - Restore backup data in 10.6.6.x to 11.2 VMs.

Task 1 - Back Up Data in 10.6.6.x VMs

1. Prepare Log Collector for the migration:
a. Log in to the Log Collector using root credentials.

b. Gotothe /opt/rsa/nwlogcollector/nwtools/ directory and run the following command.
sh prepare-for-migrate.sh --prepare

See Virtual Log Collector Host (VLC) for detailed instructions on how to upgrade the VLC.

2. Download the . zip file that contains the 10.6.6.x backup scripts from RSA Link
https://community.rsa.com/docs/DOC-81514)) to the external backup host.

Note: You must set up an external host to use for backing up files. The host must be running
CentOS 6 with connectivity through SSH to the NetWitness Platform stack of hosts.

3. Run the following commands from the nw-backup/scripts directory (see Backup Instructions for
a detailed descriptions of the backup scripts).

./get-all-systems.sh <SA-IP>
./ssh-propagate.sh <path-to-backup-directory/all-systems>

./nw-backup.sh -u
(if you have a Malware VM, substitute -m -u for -u in this command string (for example, . /nw-
backup.sh -m -u).
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Task 2 - Deploy Same 10.6.6.x VM Stack in 11.2

Y ou must set up the same virtual host stack in 11.2 that you had in 10.6.6.x. See the RS4 NetWitness®
Platform 11.2 Virtual Host Installation Guide for instructions.Go to the Master Table of Contents to find
all NetWitness Platform Logs & Network 11.x documents.

The following steps are the high-level steps on how to deploy an OV A host in the ESXi environment.
Download the 11.2 OVA, from RSA Link Download Central to a local directory.

1. Log on to the ESXi environment.

2. In the File drop-down, select Deploy OVF Template.

The Deploy OVA Template dialog is displayed.

Browse your local directory for the 11.2 OV As you downloaded.
Select the to deploy in the virtual environment , and click Next.

Select the appropriate Configuration for the VM and click Next.

S

Power on the VM, go to Console, and log in to the machine.
The VM now has the 11.2 base image required to run the Setup Program (that is, nwsetup-tui).

Task 3 - Copy VMDK Files and Add Them as Hard Disk to New VMs

1. Power off both the 10.6.6.x and 11.2 VMs.
2. Go to the desired ESX server, click the Configuration tab > Storage.
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3. Right-click the required datastore and click Browse Datastore.

i -
@ Add Hardware - |_X§_|
Select Existing Disk
Which existing disk do you want to use as this virtual disk?
f
Device Tvpe @ BrowseE_atastore_s (==
Select a Disk _|
Select Existing Look in: Datastores -
Advanced Opti I &
Ready to Com T | e | — T
B datastorel (7) 1.63TB 1.53 TB
File type: Compatble Virtual Disks (*.vmdk, *.dsk, *.raw) LI Cancel
=< Back Next = Cancel
4 4

4. Navigate to the existing 10.6.6.x VM in the datastore.

5. Select all the VMDK files in the datastore, right-click, and click Copy.

Caution: Do not copy the base VMDK file (for example, Data 106_SA) because it contains
CentOS6.

Y ou must copy all the numbered VMDXK files. For example, if the 10.6.6.x VM name is Data
106_sA, you would copy all the Data 106 SA 1, Data 106 SA 2, Data 106 SA 3, etc files.
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File Edit View Inventory Administration Plug-ins Help

g 8 & Home b g mventory b B Mventory

& &
Bl - IR MainlineESX65 Vi1
O Uata_ESk>_106_|
@ Data_Esx5_106_5a  RICRGISIN S .
) Data_ESX6_LD i & L¢g B B B X @
{3 Data_ESX6_SA Lot L
tastorel (7)] Data_ESX5_106_SA
Manufacturer: Folders | Search| [datastore1 (7)] L _106_:
Model: Name Gl Size | Provisioned Size | Type | Path
CPU Cores: Data_ESX5_106_LD
2 . sdd.sf Data_ESX5_106_SA.nviam 8.48 KB Non-volatile... [datastorel (7)] Data_ESX|
b v ) Data_ESX5_LD 82 Data_ESX5_106_SAvmdk 8,066,048.00 16,777,220.00 K VirtualDisk  [datastorel (7)] Data_ES
License: E B':';dug;l?s = [] Data ESXS_106_SAvmsd 0.00 KB File [datastorel (7)] Data_ESX
¥ Data_FSX5_106_5A @ Data_ESX5_106_SAvmx 3.26 KB Virtual Mach... [datastorel (7)] Data_ESx
Processor Sockets: . Sl
Cores per Socket: [1 Data_ESX5_106_SAvm 0.26 KB File datastorel (7)] Data_ESX
Logieal Processorsd &5 Data_ESX5_106_SA_Lvmdk 20,636,670.0 50,331,650.00 K Virtual Disk [datastorel (7)] Data_ES»
Hyperthreading: =] 9,699,328.00 142,606,300.00 Virtual Disk  [datastorel (7)] Data_ES»
Number of NICs: =] 2,281,472.00  218,103,800.00 Virtual Disk _[datastorel (7)] Data_ES»
State: ) £ Data_ESX5_106_SA_4vmdk 2,088,960.00 PR - (7)] Data_ES»
virtual Mxh‘gﬂgﬂd anf ol vmware.log 178.82 KB . 2 ”LE” o [datastorel (7)] Data_ESX
Mot Enabiedd ] vmware-1.log 23131 k8B 0 1o feley [datastorel (7)] Data_ESX
VMware EVC Mode:
] vmware-2.log 177.07 KB Cut [datastorel (7)] Data_ESX
vSphere HA State ] vmware-3.log 174.74 KB Copy [datastorel (7)] Data_ESX
Host Configured fe Paste
Active Tasks: Inflate =
Host Profile: < I 1 D
Image Profie: 4 object selected 33.10 GB Download..
Profile C H ———— — e — Move to...
DirectPath 1/0: ‘NGt supported | Rename
T This host is currently managed by vCenter Server New Folder
Reconnect vSphere Client to this vCenter Server... Delete from Disk
&t New Virtual Machine Disassociate host from vCenter Server...
il Enter Maintenance Mode
B> Reboot
B shutdown
Abbod e PO vy a Addd Aooa Adbod oenbh —add ob o bbb bd ooy A A bbbododda Abadd

6. Navigate to the new 11.2 VM in the datastore.

7. Right-click and click Paste.

103120413 - vSphere Client 0
File Edit View Inventory Administration Plug-ins Help

T ECEEEm—h—

(<> |@ Home & Inventory > B Inventory

‘ 8 &
ElE| - inli Y —‘H =
& Data_ESXS5_106_LD M.am!meEsx:.: k) patastore Browser - [dat @
B Data_ESX5_106 SA el ICLG] S — =
@ Data_ESX6 LD e a B B 8B B X | @
@ Data_ESX6_SA e
FS— Foiders | search | [datastore1 (7)] Data_ESX6_SA
Model: =/ Name > Size | Provisioned Size | Type [Path
CPU Cores: 7] Data_ESXS_106_LD
Rl s LE sdd. ©5 Data_ESX5_106_SA_lvmdk 20,636,670.0 50,331,650.00 K Virtual Disk  [datastorel (7)] Data_ESX
Fiooesson{ype: i) Data_ESX6_LD 5 Data_ESX5_106_SA 2vmdk 9,699,328.00  142,606,300.00 Virtual Disk  [datastorei (7)] Data_ESx
License: _ggtgdlé’;l()s =5 £ Data_ESX5_106_SA_3vmdk 2,281,472.00 218,103,800.00 Virtual Disk  [datastorel (7)] Data_ESX
" { Data ESXS_106_SA &5 Data_ESX5_106_SA_4vmdk 2,088,960.00 5,242,880.00 KB Virtual Disk  [datastore1 (7)] Data_ESx
Processor Sockets: e e
Cores per Socket: Data_ESX6_SA.nviam 8.48 KB Non-volatile... [datastorel (7)] Data_ESX
Logical Brocesord ©5 Data_ESX6_SA.vmdk 1,300,480.00  204,800,000.00 Virtual Disk  [datastorel (7)] Data_ESX
Hyperthreading: [1 Data_ESX6_SAvmsd 0.00 KB File [datastorel (7)] Data_ESX
Number of NICs: @ Data_ESX6_SAvmx 3.05KB Virtual Mach... [datastorel (7)] Data_ESX
State: £ vmwarelog 178.09 KB Virtual Mach... [datastore1 (7)] Data_ESX
W;“?' th':“:d anf 1 vmware-Liog 159.56 KB Virtual Mach... [datastorel (7)] Data_ES¥
e it vmware-2.log 172.91 KB Virtual Mach... [datastorel (7)] Data_E5X
] vmware-3.log 68.48 KB Virtual Mach... [datastorel (7)] Data_ESX
vSphere HA State
Host Configured f
Active Tasks:
Host Profile: < n ,
Image Profile:
Profie Complance:; ——— S ————
DirectPath 1/0: ot supported
T This host is currently managed by vCenter Server
Reconnect vSphere Client to this vCenter Server...
& New Virtual Machine Disassociate host from vCenter Server...
ﬁ Enter Maintenance Mode
[ Reboot
B shutdown

Note: You must wait until all the VMDK files from the previous VM are completely copied into
the datastore of the new VM.

8. Select the 11.2 VM, click Edit Settings > Add.
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9. In the dialog box, click HardDisk > Next.
@Add Hardware - = | DS

Device Type
What sort of device do you wish to add to your virtual machine?

gg:ggg{e Choose the type of device you wish to add.
Create a Disk

Advanced Options () Serial Port

Ready to Complete

BB Ethernet Adapter
& Hard Disk

< Back | Next > | Cancel

10. Click Already existing hard disk > Next.
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11. Click Browse and browse to the datastore location to which you copied the vindk files.

i - - -
@ Add Hardware . - |A
Select Existing Disk
Which existing disk do you want to use as this virtual disk?
f
Device Type @ Browse_lzfitastores (==
Select a Disk _|
Select Existing Look in: Datastores ¥
Advanced Opti I =
ey ey Name | Capadity | Free space
B datastorel (7) 1.63TB 1.53 B
File type: Compatible Virtual Disks (*.vmdk, *.dsk, *.raw) LI Cancel
< Back | Next = Cancel
|

L

12. Select the VMDK file from the 11.2 VM that you want to add as a disk.
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@ Add Hardware

Ready to Complete

Review the selected options and dlick Finish to add the hardware.

Device Type = =

Select a Disk e

Select Existing Disk Hardware type: Hard Disk

Advanced Options Create disk: Use existing disk

Ready to Complete | vityal Device Node: SCSI (0:1)
Disk fie path: [datastorel (7)] Data_ESX6_SA/Data_ESX5_106_SA_1.vmdk
Disk mode: Persistent

< Back | Finish | Cancel

13. Repeat steps 8 through 12 for each disk you want to add.
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(%) Data_ESX5_106_SA - Virtual Machine Properties =B8] X |
Hardware | options | Resources| Virtual Machine Version: 7
— Disk File
I~ Show Al Devices Add... | Remove | [[datastore1 (7)] Data_ESX5_106_SA/Data_ES>
Hardware | Summary | — Disk Provisioning
M Memory 16384 MB B Al Fronen
@ CcPuUs 8 Provisioned Size: | 53. IGB - |
Video card Video card Maximum Size (GBY: 1569.88
& VMCI device Deprecated i
© 5C51 controller 0 L5I Logic Parallel Virtual Device Node
@ CD/DVD drive 1 CD/DVD Drive 1 |SCS1 (0:4) Hard disk 5 ]
= Hard disk 1 Virtual Disk e
& Hard disk 2 virtual Disk [~ Independen
& Hard disk 3 virtual Disk Independent disks are not affected by
= Hard disk 4 Virtual Disk C perctent
= Hard disk 5 Virtual Disk Changes are immediately and
BB MNetwork adapter 1 VM Network o )
Nonnersisie
Changes to this disk are discarded when

0K Cancel

[

b o —— = [

14. Click OK.
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Task 4 - Retain MAC Address of Upgraded SA Server VM

To retain the MAC address of migrated Security Analytics (SA) Server Virtual Machine (VM):

Note: These steps apply to the SA Server VM (created with "Automatic" MAC address assignment
selected) to the 11.2 NetWitness Server. For VMs with a Static MAC address, you can change the
MAC address by going to Edit Settings for a VM and typing in the MAC address.

1. Log in to vCenter server.
Note: The supported versions of vCenter is 5.5 through 6.5 inclusive.
2. (Conditional) If they are powered on, Power Off both VMs (NetWitness 10.6.6.x and 11.2).
3. Click Summary tab, right-click Datastore and browse for the datastore location.
4. Go to the VM folder and download the . vmx file of 10.6.6.x and 11.2 to the local repository.
By default, the VM generated with the MAC address is created in the format (as shown in the below
figure).
' ] , T — o A
{2] RSANW _11.0 MAG_200 - Virtual Machine Properties | —— ==l
Hardware Iopﬁms | Resources | Virtual Machine Version; vmx-03
—Device Status
™ Show All Devices Add... | Remove | ¥ Connected
Hardware | Summary | ¥ Connectat power on
Bl Memory 32768 MB
— Adapter T
[ ceus : C i t :pete VMXMET 3
Video card Video card e
= VMCIdevice Restricted e
@ SCSI controller 0 Paravirtual
. . . IDD:D::Z‘B:ZB:?B:ZE
% CD/DVD drive 1 Client Device
= Hard disk1 Virtual Disk ¥ Automatic 7 Manua
BB MNetwork adapter1 VM Network |
— DirectPath IjO
Status: Inactive &)
To activate DirectPath 10, go to the Resources tab and
gelect Memory Settings to reserve all guest memory.,
— Metwork Connection
Metwork label:
WM Metwork LI
Help | 0K Cancel |
Yy
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Note: 00:0¢:29:XX:YY:ZZ — 00:0c:29 is the unique identifier for an automatically generated
MAC address. 00:50:56:XX:YY:ZZ — 00:50:56 is the unique identifier for a static or manually
generated MAC address. This is valid only if the vCenter is not deployed. If vCenter is deployed,
this MAC address denotes the unique identifier for an automatically generated MAC address.

5. Using a text editor, copy the uuid.location and ethernet0.generatedAddress values from
10.6.6.x .vmx file into the 11.2 .vmx file.

Note: If you deployed the 10.6.6.x stack on the ESX server directly (not through VCenter), you
must copy the value for uuid.bios in addition to uuid.location and
ethernet0.generatedAddress from 10.6.6.x .vimx file into the 11.2 .vmmx file.

6. Remove both the 10.6.6.x and the 11.2 VMs from inventory.
a. Navigate to the vCenter server.
b. Right-click both the 10.6.6.x and the 11.2 VMs.
c. Select Remove from Inventory.

7. Upload the modified 11.2 .vmx file to the datastore location by replacing it with the existing .vimx
file.

8. From the datastore, right- click the 11.2 .vmx file and select Add to Inventory.

9. Navigate to the vCenter server and Power On the 11.2 VM.
The following message is displayed.
The virtual machine might have been moved or copied. In order to configure certain
management and networking features, VMware ESX needs to know if this virtual machine was
moved or copied. If you don't know, answer "I Copied it."

%) 10.31.244.70 - vSphere Client

Fle Edit ¥ew Inventory Administration Plug-ins Help
[« =] ‘E} Home b g Inventory b Gl Inventory
R EICEY

=3 rsanw-11.0.0.0.675.el7-436_
() 244APP144_MAGARAI_SA

[ 244APP145_NAGARAI_IW Getting Started 2 ce s
[l 244APP146_NAGARAI_LC close tab [X]
[l 244APP147_MAGARAI_LD

What is a Virtual Machine?
(T 244AFF148_NAGARAI_FD
(3 2HMAPP143_NAGARAI_CO Avirtual machine is a software computer that, like a
([ 244APP1S0_NAGARAD_BR. physical computer, runs an operating system and
[ 244APPISI_NAGARAD ESA applications. An operating system installed on a virtual
Cf Z44AFPIS3_NAGARAD WC machine is called a guest operating system.
(s 244APF154_MAGARAI_ARCHIVER
(s 244APF155_MAGARAI_IFDE Because every virtual machine is an isolated computing
(T 244APF191_NAGARAT environment, you can use virtual machines as desktop or it
(3 244AFF206_5A_DEV workstation environments, as testing environments, or fo = Host
(1 Cisco_lronport 35 consolidate server applications.
NAG_Chefiode_169
% NAG_ChefServer_1a0 Virtual machines run on hosts. The same host can run - =
(3 NAG_ChePwork_1a7 many virtual machines. ﬁ o
Radar7z4_Demo
D «

| @ rsanw-11.0.0.0,675.el7-x86_64_1 I

Basic Tasks vSphere Clisnt
Recent Tasks

Marne | Target | Status | Details | Tnitisted by | Requested Stark Ti.., = | Stark Time | Completed Time:

¥ Power Onvirtualmach... G rsane-11.0.0.0. 0% ) root 7I7i2017 2:54:33 AW 71712017 2:54:33 AM

¥ Register vitualmachine  [J @ Completed root FFZ0IT 25419 AW FIFZ0I7 2SR AN Fi7[2017 215419 AW

¥ Maripulats file paths @ Completed root 72017 25406 AW FIF[2017 25406 AW Fi7[2017 2:54:06 AM

¥ Unregister virtual mach.., &) rsane-11.0.0.0. @  Completed root 7[7j2017 2:53046 AW TI7[2017 2:53:48 AN Fj7[2017 215346 AM

5_'1 Powveer OFF virbual mach,.. @1 rsar-11,0.0.0., @ Completed roat FI7I2017 2:15%:37 AM 7712017 2:53:137 AM FI7I2017 2:53:41 AM
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10. Right-click the VM and select Guest > Answer Question.
The following figure is displayed.

Fle Edt View Inventory Administration Plugins Help
I+ |Eﬁ Home b gF] Tnvertory b [l Inventory
R RN )

ElE

(1 249APP194_NAGARAI_SA
(3 244APP145_NAGARAI_MW
(3 244APP146_NAGARAI_LC
(@ 244APP147_NAGARA) LD What is a Virtual Machine?
(3 244APP148_NAGARAI_PD .
& g:::g;:;i,::g:gij,gs Avirtual machine is a software computer that, like a Virtual Machines /\ﬁ .
@ - - phys.lta\. computer, ru Bl (5] virtual Machine Question M= E3
(f 244AFFISL_NAGARAD ESA applications. An operatin
(3 2440PP153_NAGARAI_WC machine is called & gues ¥irtual Machine Message
(3 244APP154_NAGARA]_ARCHIVER X This virtual machine might hawve been moved or copied. In order ko configure certain
(3 244APP15S_NAGARAI_IPDE Because every virtual m: management and networking Features, YMware ESX needs to know if this virtual machine was
s 244APP191_NAGARA] environment, you can us moved or copied. IF you don't know, answer "button.uuid.copiedTheyr",
(3 244PP206_5A_DEY workstation environment " Cancel
(1 Cisco_Tronport_98 consolidate server applic
3 NAG_Chefiods_183 _ © IMoved I
3 NaG_Chefserver_190 Virtual machines run on I Copied It
(s MAG_Chefwark_187 many virtual machines.
(3 QRadar724_Demo —IOK
{5 QRadarabe
(B[ rsanw-11.0.0.0.675 l7-x36_64_1
Basic Tasks vSphere Client
Recent Tasks
Name | Target | Status | Details | Tnifiated by | Requested Stark Ti... = | Stark Time | Completed Time
¥4 Power Onvitualmach.., @& rsanw-11.0.0.0., 0% ) roat FAN2017 23520 AN FF[2017 2:35:29 AM
@ Register virkual machine E 10.31.244.70 @  Completed rook TI7I2017 2:35:12 AW FI7I2017 2:35:12 AM
@ IManipulate File paths @ Completed rook FI7[2017 2:35:01 AM FI7I2017 2:35:01 AM
¥ Unregister virtuslmach,. (G rsane-11.00.0. @ Completed roat FTN017 23030 A F(F[2017 23430 AM 7[7j2017 2:34:30 AM
#Y Power OFf wirtusl mach... G rsanw-11.0.0.0.. @&  Completed roat FITN017 23018 AN F(F[2017 234009 AN 7[7J2017 2:34:22 AM
¥4 answer virtual machine... (31 rsanw-11.0.0.0.. @ Completed roat 772017 2;30:05 AW 7(7[2017 Zi3005 AV 7[7JZ017 2:30:05 AM
%Y Power On vitualmach... (&1 rsanw-11.0.0.0.. & Completed roat 772017 2:29:54 AWM 7(7[2017 Zi2%S4 AN 7[7)2017 2:30:05 AM
¥4 Regster vitualmachine  [§ @ Completed roat FF2017 22945 AN F(7[2017 ZI2RAS AN 7[7[2017 2:29:45 AM
¥4 Manipulate file paths @ Completed roat FF2017 22915 AN F(7[2017 ZI2RIS AN 7[7(2017 2:29:15 AM
@ Unregisker virtual mach. .. @ rsanw-11.000.0., @ Completed root TiTI2017 2:28:496 AM Ti7[2017 2:28:46 AM FITIZ017 2128146 AM
I e AFF et dmek  Bh eear el 0AN @ memrtabad TRNITRBR T AW TATIRNT 2i0mAT 0 TN 2R

11. Select I Moved It.

12. Click OK.
The MAC address is retained to the MAC address from 10.6.6.x to 11.2.
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Task 5

Complete

- Restore Backup Data in 10.6.6.x to 11.2 VMs

the following steps to Power On the 11.2 VM.

1. Copy backed-up data from the nw-backup directory to the 11.2 VMs.
o For the NW Server (SA Server in 10.6.6.x):

Note: See Virtual Log Collector Host (VLC) for detailed instructions on how to upgrade the
VLC.

a.

b.

Create the nwhome directory under /tmp.

Mount VolGroup00-nwhome on /tmp/nwhome/.
mount /dev/mapper/VolGroup00-nwhome /tmp/nwhome/

Copy the contents of /tmp/nwhome/ directory to /var/netwitness/.
cp -r /tmp/nwhome/* /var/netwitness/

Mount VolGroup02-redb on /var/netwitness/database.
mount /dev/mapper/VolGroup02-redb /var/netwitness/database/

Note: Make sure that the /var/netwitness/database/nw-backup directory exists with
backup tarballs of the appliance.

Unmount VolGroup00-nwhome from /tmp/nwhome/.
umount /tmp/nwhome

o For the Archiver, Broker, Concentrator, Log Decoder/Log Collector, and Network Decoder:

1.

2.
3.
4.

Note: If your 10.6.6.x Decoder or Log Decoder had multiple network interfaces:

Power Off the 11.2 VM 11.2 Decoder or Log Decoder VM.

Go to Edit Settings for the VM and add the required number of Ethernet Adapters.
Power On the VM.

Add the ethernet adapters before restoring the backup data.

Create the nwhome directory under /tmp.

Create a temporary mount VolGroup0O-nwhome on /tmp/nwhome/.
mount /dev/mapper/VolGroup0O0-nwhome /tmp/nwhome/

Copy the contents of /tmp/nwhome/ directory to /var/netwitness/.
cp -r /tmp/nwhome/* /var/netwitness/

Unmount VolGroup00-nwhome from /tmp/nwhome/.
umount /tmp/nwhome

o For Malware Analysis (Co-located Malware Not Supported in 11.2 Upgrade):

a.

b.

Create the apps directory under /tmp/.

Create a temporary mount VolGroupOl-apps On /tmp/apps/.
mount /dev/mapper/VolGroupOl-apps /tmp/apps/
mkdir /var/netwitness/database

Copy the nw-backup directoryto /var/netwitness/.
cp -r /tmp/apps/nw-backup /var/netwitness/database
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d.

Unmount VolGroup0l-apps from /tmp/apps/.
umount /tmp/apps

o For Event Stream Analysis:

a.

b.

Create the apps directory under /tmp/

Create a temporary mount VolGroupOl-apps On /tmp/apps/.
mount /dev/mapper/VolGroupOl-apps /tmp/apps/
mkdir /var/netwitness/database

Copy the nw-backup directory to /var/netwitness.
cp -r /tmp/apps/nw-backup /var/netwitness

Unmount VolGroup0l-apps from /tmp/apps/.
umount /tmp/apps

2. Mount the disks.

Note: If you have configured any external mount points on the VMs in the stack for any of the
following directories, re-mount the external mount points in place of the following mounts.

o For the NW Server:

mount
mount

/dev/mapper/VolGroup0l-ipdbext /var/netwitness/ipdbextractor/
/dev/mapper/VolGroup02-redb /var/netwitness/database/

Note: Make sure that the /var/netwitness/database/nw-backup directory exists with backup
tarballs of the appliance.

o For the Log Decoder/Log Collector:

Note:

The following mounts are not required for the Virtual Log Collector.

mount
mount
mount
mount
mount
mount

/dev/mapper/VolGroupOl-decoroot /var/netwitness/logdecoder
/dev/mapper/VolGroupOl-index /var/netwitness/logdecoder/index
/dev/mapper/VolGroupOl-sessiondb /var/netwitness/logdecoder/sessiondb
/dev/mapper/VolGroup0l-metadb /var/netwitness/logdecoder/metadb
/dev/mapper/VolGroupOl-logcoll /var/netwitness/logcollector
/dev/mapper/VolGroupOl-packetdb /var/netwitness/logdecoder/packetdb

o For the Network Decoder:

mount
mount
mount
mount

mount

/dev/mapper/VolGroupOl-decoroot /var/netwitness/decoder
/dev/mapper/VolGroup0Ol-sessiondb /var/netwitness/decoder/sessiondb
/dev/mapper/VolGroupOl-index /var/netwitness/decoder/index
/dev/mapper/VolGroupOl-metadb /var/netwitness/decoder/metadb
/dev/mapper/VolGroupOl-packetdb /var/netwitness/decoder/packetdb

o For the Concentrator:

mount
mount

/dev/mapper/VolGroupOl-concroot /var/netwitness/concentrator
/dev/mapper/VolGroupOl-sessiondb

/var/netwitness/concentrator/sessiondb

mount /dev/mapper/VolGroup0Ol-index /var/netwitness/concentrator/index
mount /dev/mapper/VolGroupOl-metadb /var/netwitness/concentrator/metadb
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o For the Archiver:
mount /dev/mapper/VolGroupOl-archiver /var/netwitness/archiver
mount /dev/mapper/VolGroup02-workbench /var/netwitness/workbench

o For the Broker:
mount /dev/mapper/VolGroupOl-broker /var/netwitness/broker

3. Add the following mount entries to /etc/fstab.

o For the NW Server:
/dev/mapper/VolGroup0l-ipdbext /var/netwitness/ipdbextractor/ xfs
defaults,noatime, nosuid 1 2
/dev/mapper/VolGroup02-redb /var/netwitness/database/ xfs
defaults,noatime, nosuid 1 2

o For the Log Decoder/Log Collector:

Note: The following mounts are not required for the Virtual Log Collector.

/dev/mapper/VolGroup0Ol-decoroot /var/netwitness/logdecoder ext4
defaults,noatime, nosuid 1 2

/dev/mapper/VolGroupO0l-index /var/netwitness/logdecoder/index xfs
defaults,noatime, nosuid 1 2

/dev/mapper/VolGroup0Ol-sessiondb /var/netwitness/logdecoder/sessiondb xfs
defaults,noatime, nosuid 1 2

/dev/mapper/VolGroupOl-metadb /var/netwitness/logdecoder/metadb xfs
defaults,noatime, nosuid 1 2

/dev/mapper/VolGroup0l-logcoll /var/netwitness/logcollector xfs
defaults,noatime, nosuid 1 2

/dev/mapper/VolGroupOl-packetdb /var/netwitness/logdecoder/packetdb xfs
defaults,noatime, nosuid 1 2

o For the Network Decoder:
/dev/mapper/VolGroupOl-decoroot /var/netwitness/decoder exti
defaults,noatime,nosuid 1 2
/dev/mapper/VolGroupOl-sessiondb /var/netwitness/decoder/sessiondb xfs
defaults,noatime, nosuid 1 2
/dev/mapper/VolGroupOl-index /var/netwitness/decoder/index xfs
defaults,noatime,nosuid 1 2
/dev/mapper/VolGroupOl-metadb /var/netwitness/decoder/metadb xfs
defaults,noatime, nosuid 1 2
/dev/mapper/VolGroupOl-packetdb /var/netwitness/decoder/packetdb xfs
defaults,noatime, nosuid 1 2

o For the Concentrator:
/dev/mapper/VolGroupOl-concroot /var/netwitness/concentrator ext4
defaults,noatime, nosuid 1 2
/dev/mapper/VolGroupOl-sessiondb /var/netwitness/concentrator/sessiondb
xfs defaults,nosuid,noatime 1 2
/dev/mapper/VolGroup0l-index /var/netwitness/concentrator/index xfs
defaults,noatime, nosuid 1 2
/dev/mapper/VolGroupOl-metadb /var/netwitness/concentrator/metadb xfs

defaults,noatime, nosuid 1 2
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o For the Archiver:
/dev/mapper/VolGroupOl-archiver /var/netwitness/archiver xfs
defaults,nosuid, noatime 1 2
/dev/mapper/VolGroup02-workbench /var/netwitness/workbench xfs
defaults,nosuid, noatime 1 2

o For the Broker:
/dev/mapper/VolGroupOl-broker /var/netwitness/broker xfs
defaults,nosuid, noatime 1 2
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Set Up Virtual Hosts in 11.2

There two phases to set up your 11.2 virtual stack that you must complete in the order shown.

o Phase 1 - Set Up NW Server, Event Stream Analysis, Malware Analysis, and Broker or Concentrator
Hosts

Note: For Event Stream Analysis, if you had C2 modules enabled in 10.6.6.x, the modules will
enter a warm-up after you upgrade the Event Stream Analysis service to 11.2 and they will not be
available until the warm up completes.

o Phase 2 - Set Up The Rest of the Component Hosts

Phase 1 - Set Up NW Server, Event Stream Analysis, Malware Analysis,

and Broker or Concentrator Hosts

Task 1 - Set Up 11.2 NetWitness Server

Follow the instructions under Set Up 11.2 NW Server Host.

Task 2 -SetUp 11.2 ESA

Caution: If you had C2 modules enabled in 10.6.6.x, the modules will enter a warm-up after you
upgrade the Event Stream Analysis service to 11.2 and they will not be available until the warm up
completes.

Follow the instructions under Set Up 11.2 Non-NW Server Host to set up your ESA hosts.

1. Set up your primary ESA host through the Setup program and install ESA Primary on the host in the
user interface on the Admin Hosts view.

Note: If you have multiple ESA hosts in your enterprise, you must upgrade the ESA Primary host,
where all the mongodb (Mongo Database) backup tar files are located, first, before you upgrade
ESA Secondary hosts.

2. (Conditional) If you have a secondary ESA host, set it up through the Setup program and install ESA
Secondary on the host in the user interface on the Admin Hosts view.

Task 3 - Set Up 11.2 Malware Analysis

Follow the instructions under Set Up 11.2 Non-N'W Server Host.

Task 4 - Set Up 11.2 Broker or Concentrator

Follow the instructions under Set Up 11.2 Non-NW Server Host.
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Note: If you do not have a Broker, upgrade your Concentrator hosts. The 11.2 NW Server cannot
communicate with 10.6.6.x core services for the new Investigate functionality. This is why you must
upgrade the Broker or Concentrator hosts in Phase 1.

Phase 2 - Set Up The Rest of the Component Hosts

See Appendix B. Stopping and Restarting Data Capture and Aggregation for instructions on how to stop
and restart data capture and aggregation when upgrading the Decoder, Concentrator, and Log Collection
hosts.

Decoder and Concentrator Hosts

1. Stop data capture and aggregation.
2. Complete the steps in Set Up 11.2 Non-NW Server Host.

3. Restart data capture and aggregation.

Log Decoder Host

1. Make sure you have prepared the Log Collector as described in the "Log Collectors (LC) and Virtual
Log Collectors (VLCs): Run prepare-for-migrate.sh" in the Backup Instructions.

2. Stop data capture on the Log Decoder.
3. Complete the steps in Set Up 11.2 Non-NW Server Host.
4. Restart data capture on Log Decoder.

Note: After you upgrade, you will restart log collection after completing the Task 30 - Update
Incident Rules Identified in the Domain in the Matching Conditions Upgrade Preparation Task in
the Post Upgrade Tasks

Virtual Log Collector Host

1. Make sure you have prepared the Virtual Log Collector as described in the "Log Collectors (LC) and
Virtual Log Collectors (VLCs): Run prepare-for-migrate.sh" in the Backup Instructions.

2. Back up your 10.6.6.x VLC by editing the a11-systems file on host where you performed the
backup.

a. Make sure your all-systems file contents has this information before you perform this step.
vlc,<host-name>,<IP-address>,<UUID>,10.6.6.x%

b. Run the following command to create backup.
./nw-backup.sh -u
See Backup Instructions for detailed procedures on how to back up the host.

3. Make sure the backup host contains the VLC backup in the following format.
<hostname>-<IPaddress>-root.tar.gz
<hostname>-<IPaddress>-root.tar.gz.sha256
<hostname>-<IPaddress>-backup.tar.gz
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8.

10.

<hostname>-<IPaddress>-backup.tar.gz.sha256
<hostname-IPaddress>-network.info.txt

all-systems-master-copy

Power off the 10.6.6.x VLC so that a new 11.2 VM can be created with the same network
configuration.

Deploy a fresh Non-NW Server host using the 11.2 NetWitness Platform ova.

Connect to the VM console of the new VLC.

Update the network configuration to be the same as the 10.6.6.x VLC.
This information is stored in the <hostname-IPaddress>-network.info.txt 10.6.6.x VLC
backup file.

Note: Make sure IPv6 is disabled.

a. Editthe /etc/sysconfig/network-scripts/ifcfg-eth0 file and update the settings.
Contents of i fcfg-eth0 should be as follows.
TYPE=Ethernet
DEFROUTE=yes
NAME=ethO
UUID=<uuid>
DEVICE=ethO
DNSl=<nameserver from <hostname>-<ipaddress>-network-info.txt>
DNS2=<nameserver from <hostname>-<ipaddress>-network-info.txt>
BOOTPROTO=static
IPADDR=<ipaddress from <hostname>-<ipaddress>-network-info.txt>
NETMASK=<netmask from <hostname>-<ipaddress>-network-info.txt>
GATEWAY=<gateway from <hostname>-<ipaddress>-network-info.txt>
NM CONTROLLED=no
ONBOOT=yes

b. Submit the following command string.
systemctl restart network.service

Create the backup directory.
# mkdir -p /var/netwitness/database/nw-backup/

Copy the backup from the backup host from /var/netwitness/database/nw-backup to the new
VLC in the /var/netwitness/database/nw-backup directory.

Complete the steps 2 through 12 inclusive in Set Up 11.2 Non-SA Server Host for the rest of the

NetWitness Platform components . Make sure that you select Log Collector for the service in step
12.

Set Up 11.2 NW Server Host

Make sure that you have backed up 10.6.6.x data for the SA Server host. You must follow the
instructions in Backup Instructions to back up the host.
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Caution: Run the backup immediately before upgrading the SA Server to 11.2 so that the data is as
recent as possible. You must create the all-systems file before you upgrade the SA Server because
you cannot do this after the SA Server has been upgraded to 11.2.

Complete the following steps to set up the 11.2 NW Server host.

1. Loginto 11.2 NW Server VM's console and run the nwsetup-tui command.
This initiates the Setup program and the EULA is displayed.

Note: 1.) When you navigate through the Setup program prompts, use the down and up arrows to
move among fields, use Tab key to move to and from commands (such as <Yes>, <No>, <OK>,
and <Cancel>. Press the Enter key to register your command response and move to the next
prompt.

2.) The Setup program adopts the color scheme of the desktop or console you use access the host.

2. Tab to Accept and press Enter.

The Is this the host you want for your 11.2 NW Server prompt is displayed.

Caution: If you choose the wrong host for the NW Server and complete the upgrade, you must
repeat steps 1 through 11 of Set Up 11.2 NW Server Host to correct this error.

3. Tabto Yes and press Enter.

Choose No if you already upgraded the NW Server to 11.2.
The Install or Upgrade prompt is displayed.
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4. Use down arrow to select 2 Upgrade (From Previous Vers.), tab to OK, and press Enter.

The Backup path prompt is displayed.

Caution: The backup path in the following prompt must be the same as the path in which your
backup is stored. For example, the backup script assigns /var/netwitness/database/nw-backup as
the default path. If you used the default backup path during backup and did not change it
subsequently, you must keep /var/netwitness/database/nw-backup as the path in the following
prompt.

5. Tab to OK and press Enter if want to keep this path. If not, edit the path, tab to OK and press Enter
to change it.
This table lists the backup and restore paths by host/service.

Host Backup Path Restore Path

Malware /var/lib/rsamlware/nw-backup /var/netwitness/malware
analytics_ server/nw-
backup/restore

Event /opt/rsa/database/nw-backup /var/netwitness/database/nw-

Stream backup/restore

Analysis

NW Server /var/netwitness/database/nw- /var/netwitness/restore

backup
All Other /var/netwitness/database/nw- /var/netwitness/database/nw-
Hosts backup backup/restore
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7.

The Master Password prompt is displayed.

The following list of characters are supported for Master Password and Deployment Password:
e Symbols:! @ #% "+,

o Numbers : 0-9

o Lowercase Characters : a-z

Uppercase Characters : A-Z

No ambiguous characters are supported for Master Password and Deployment Password. For
example:
space { } [J()/\'"" " ~;:.<>-

Type in the Password, down arrow to Verify, retype the password, tab to OK, and press Enter.

P e

The Deployment Password prompt is displayed.
Type in the Password, down arrow to Verify, retype the password, tab to OK, and press Enter.

The Update Repository prompt is displayed.
You must use the same repo that you used for the NW Server hosts for all hosts.
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8. Use the down and up arrows to select 2 An External Repo (on an externally-managed server).

The External Update Repo URI prompt is displayed.
Refer to Appendix D. Create External Repository for instructions. Go to the Master Table of
Contents to find all NetWitness Platform Logs & Network 11.x documents.

9. Enter the base URL of the NetWitness Platform external repo (for example,
http:/testserver/netwitness-repo)and click OK.

The Disable or use standard Firewall configuration prompt is displayed.

10. Tab to No (default), and press Enter to use the standard firewall configuration. Tab to Yes, and
press Enter to disable the standard firewall configuration.
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o Ifyouselect Yes, confirm your selection or No to use the standard firewall configuration.

Warning: you chose to disable the default NetWitness

firewall configuration which means you must set up
firewall rules manually.

Select "Yes" to confirm that you will set up firewall
rules manually.

< Yes >

The Install or Upgrade prompt is displayed (Recover does not apply to the installation. It is for 11.2
Disaster Recovery).

11. Select 1 Upgrade Now, tab to OK, and press Enter.
Start Install/Upgrade
A1l the required information has been gathered.

Select "1 Upgrade Now" to start the installation
on this host.

| JiUpgrade Now

2 Restart

< Exit >

When Installation complete is displayed, you have upgraded the 10.6.6.x SA Server to the 11.2 NW
Server.

Note: Ignore the hash code errors similar to the errors shown in the following screen shot that are

displayed when you initiate the nwsetup-tui command. Yum does not use MDS5 for any security
operations so they do not affect the system security.

)
ned due to action :nothing)

ot:code for hash md5 was not found.

<module>

1_constructor

Complete the NW Server before you upgrade any of the non-SA Server hosts to 11.2.
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Set Up 11.2 Non-NW Server Host

Make sure that you Back up your 10.6.6.x data for the host. You must follow the instructions in
Backup Instructions to back up the host.

Caution: Run the backup immediately before upgrading the host to 11.2 so that the data is as recent as
possible.

Complete the following steps to set up an 11.2 Non-NW Server host.

1. Loginto 11.2 non-NW Server VM console and run the nwsetup-tui command.
This initiates the Setup program and the EULA is displayed.

2. Tab to Accept and press Enter.

The Is this the host you want for your 11.2 NW Server prompt is displayed.

Caution: If you choose the wrong the host for the NW Server and complete the upgrade, you must
repeat steps 1 through 11 of Set Up 11.2 NW Server Host to correct this error.

3. Tab to No and press Enter.

The Install or Upgrade prompt is displayed (Recover does not apply to the installation. It is for 11.2
Disaster Recovery).
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4. Use down arrow to select 2 Upgrade (From Previous Vers.), tab to OK, and press Enter.

The Backup path prompt is displayed.

5. Tab to OK and press Enter if want to keep this path. If not, edit the path, tab to OK and press Enter
to change it.

This table lists the backup and restore paths by host/service.

Host Backup Path Restore Path

Malware /var/lib/rsamlware/nw-backup /var/netwitness/malware
analytics server/nw-
backup/restore

Event /opt/rsa/database/nw-backup /var/netwitness/database/nw-

Stream backup/restore

Analysis

NW Server /var/netwitness/database/nw- /var/netwitness/restore

backup
All Other /var/netwitness/database/nw- /var/netwitness/database/nw-
Hosts backup backup/restore

The Deployment Password prompt is displayed.

Note: You must use the same deployment password that you used when you upgraded the NW
Server.
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6. Type in the Password, down arrow to Verify, retype the password, tab to OK, and press Enter.

El i i o

The Update Repository prompt is displayed.

7. Use the down and up arrows to select 2 An External Repo (on an externally-managed server), tab
to OK, and press Enter.

The External Update Repo URL prompt is displayed.
The repositories give you access RSA updates and CentOS updates.

8. Enter the base URL of the NetWitness Platform external repo (for example,
http://testserver/netwitness-repo)and click OK. Refer to Appendix D. Create External Repository
for instructions on how to create this repo and its external repo URL so you can enter it in the
following prompt.
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The NW Server IP Address is displayed.
9. Type the IP address of the NW Server, tab to OK, and press Enter.

The Disable or use standard Firewall configuration prompt is displayed.

10. Tab to No (default), and press Enter to use the standard firewall configuration. Tab to Yes, and press
Enter to disable the standard firewall configuration.

o Ifyouselect Yes, confirm your selection.

o If you select No, the standard firewall configuration is applied.

The Install or Upgrade prompt is displayed (Recover does not apply to the installation. It is for 11.2
Disaster Recovery).
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11. Select 1 Upgrade Now, tab to OK, and press Enter.

Start Install/Upgrade =
All the required information has been gathered.

Select "1 Upgrade Now" to start the installation
on this host.

2 Restart

< Exit >

When Installation complete is displayed, you have upgraded the host to the 11.2.
12. Install the service on this host:

a. Log into NetWitness Platform and click ADMIN > Hosts.
The New Hosts dialog is displayed with the Hosts view grayed out in the background.

Note: If the New Hosts dialog is not displayed, click Discover in the Hosts view toolbar.

b. Click on the host in the New Hosts dialog and click Enable.
The New Hosts dialog closes and the host is displayed in the Hosts view.

c. Select that host in the Hosts view (for example, Event Stream Analysis) and click & Install ~
The Install Services dialog is displayed.

d. Select the appropriate service (for example, ESA Primary) and click Install.

RSA RESPOND INVESTIGATE MONITOR CONFIGURE ADMIN @]admm ® @

+ c == & LB Install 45 Update ¥ QF Discover @B Rebaot Host Filter X

Name e Host Services  Current Version = Update Version Status

Up-to-Date

=] NW Server lp-address i )
~ Event Stream Analysis Ip-address Install Services g—- Event Stream Analysis
S = at st type and click to complete th

A iired if the incorrect Host Type is selected ate

Version: 11.1.0.0 Hardware
Platform:

Public Key Hash

public-key

ying 1-4of4

Cloud Gateway

ESA Primary

ESA Secondary

You have completed the upgrade of the non-N'W Server host in NetWitness Platform
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Note: When you upgrade a Respond host from 10.6.6.x to 11.2, it takes a period of time for
Respond to come back online. This is caused by Respond indexing data while it is restored.
The size of the data in the Mongo database will determine the time.
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Update or Install Legacy Windows Collection

Refer to the RSA NetWitness Legacy Windows Collection Guide. Go to the Master Table of Contents to

find all NetWitness Platform Logs & Network 11.x documents.

Note: After you update or install Legacy Windows Collection, reboot the system to ensure that Log
Collection functions correctly.

Update or Install Legacy Windows Collection
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Post Upgrade Tasks

This topic contains the tasks you must complete after you upgrade your hosts from 10.6.6.x to 11.2.
These tasks are organized by the following categories.

o General

e NW Server

o RSA NetWitness® Endpoint

« RSA NetWitness® Endpoint Insights

o Event Stream Analysis

o Investigate

o Log Collection

o Decoder and Log Decoder

o Reporting Engine

e Respond

e RSA Archer® Cyber Incident & Breach Response
o User and Entity Behavior Analytics (UEBA)

o Backup

General

Task 1 - Make Sure Port 15671 Is Configured Correctly

Port 15671 is new in 11.x, but you do not need to open a firewall for this port. Make sure that 15671, and
all ports, are configured as shown in the "Network Architecture and Ports" topic in the RSA NetWitness®
Platform Deployment Guide. Go to the Master Table of Contents to find all NetWitness Platform Logs &
Network 11.x documents.

(Conditional) Task 2 - Restore Custom Analysts Roles

If you had custom analyst roles in 10.6.6.x, you must reinstate them in 11.2. See "Add a Role and Assign
Permissions" in the RSA NetWitness PlatformSystem Security and User Management Guide. Go to the
Master Table of Contents to find all NetWitness Platform Logs & Network 11.x documents.
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NW Server

Task 3 - Migrate Active Directory (AD)

The first time you log into the NetWitness Platform 11.2 User Interface, you must click on the Migrate
button to complete the migration of AD.

1. Log in to NetWitness Platform 11.2 with your admin user credentials.

2. In the NetWitness Platform 11.2 menu, select ADMIN > SECURITY and click the Settings tab.
The following dialog is displayed.

External Authentication Migration

10.6.x authentication providers and external role mappings are not migrated. To migrate these settings click on Migrate button.

3. Click Migrate.
The migration is complete and the dialog closes.

Task 4 - Modify Migrated AD Configuration to Upload Certificate

If you authenticated through Active Directory (AD) server, and enabled SSL for the AD connection in
10.6.6.x, you must modify the migrated AD configuration to upload the Active Directory server
certificate.

Complete the following procedure to modify the migrated AD configuration to upload the certificate.
1. In the NetWitness Platform 11.2 menu, select ADMIN > Security and click the Settings tab.

2. Under Active Directory Settings, select an AD configuration and click .
The Edit Configuration dialog is displayed.

3. Go to the Certificate File field, click Browse, and select a certificate from your network.

4. Click Save.

Task 5 - Reconfigure Pluggable Authentication Module (PAM) in 11.2

Y ou must reconfigure PAM after you upgrade to 11.2. See "Configure PAM Login Capability" in the
RSA NetWitness® Platform System Security and User Management Guide for instructions. Go to the
Master Table of Contents to find all NetWitness Platform Logs & Network 11.x documents.

You can refer to your 10.6.6.x PAM configuration files in the /ete directory in the your 10.6.6.x backup
data for guidance.
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Task 6 - Restore NTP Servers

You must use the NetWitness Platform 11.2 user interface to restore NTP server configurations. NTP
server configuration information is located in $SBUPATH/restore/etc/ntp.conf. Use the NTP server
name and hostname from the /var/netwitness/restore/etc/ntp.conf file. See "Configure NTP
Servers" in the RSA NetWitness® Platform System Configuration Guide for detailed instructions on how
to add NTP servers. Go to the Master Table of Contents to find all NetWitness Platform Logs &
Network 11.x documents.

Task 7 - Restore Licenses for Environments without FlexNet Operations-On
Demand Access

If your environment does not have access to FlexNet Operations-On Demand, you need to re-download
your NetWitness Platform licenses. Refer to "Step 1. Register the NetWitness Server" in the RSA4
NetWitness Platform Licensing Management Guide for instructions on how to re-download licenses. Go
to the Master Table of Contents to find all NetWitness Platform Logs & Network 11.x documents.

Task 8 - Remap Virtual NW Server License to 10.6.6.x MAC Address

If you are upgrading a Security Analytics server running on a virtual machine, change the 11.2 NW
Server virtual host to the 10.6.6.x MAC address to retain licensing. Refer to "Licensing: Step 1. Register
the NetWitness Server" in the RSA NetWitness Platform Licensing Management Guide for instructions
on remapping a license to a new MAC address." Go to the Master Table of Contents to find all
NetWitness Platform Logs & Network 11.x documents.

(Conditional) Task 9 - If You Disabled Standard Firewall Config - Add Custom
IPtables

During the upgrade, you have the option of using these rules or disabling them. If you disabled them,
follow these instructions as a baseline to create a user-managed firewall rule sets on all the hosts for
which you disabled the standard firewall configuration.

Note: You can refer to the SBUPATH/restore/etc/sysconfig/iptables and
$BUPATH/restore/etc/sysconfig/ip6tables in the restore folder of the backup to update the
ip6tables and iptables files. The /etc/netwitness/firewall.cfqg file contains the standard
iptables firewall rules.

1. SSH to each host and log in with your root credentials.

2. Update the following ip6tables and iptables files with the custom firewall rules.
/etc/sysconfig/iptables
/etc/sysconfig/ip6tables

3. Reload the iptables and ip6tables services.
service iptables reload
service ipb6btables reload
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(Conditional) Task 10 - Specify SSL Ports If You Never Set Up Trusted
Connections

Complete this task only if you never set up Trusted Connections. You would not have set up Trusted
Connections if you:

o Used the base ISO image for 10.3.2 or earlier.
o Updated the system using RPMs exclusively to get to 10.6.6.

NetWitness Platform 11.2 cannot communicate with the core services for these customers because they
are using a non-SSL port 500XX. You must update the Core service ports to an SSL port in the Edit
Service dialog.

1. Inthe NetWitness Platform 11.2 menu, select ADMIN > Services.

2. Select each core service and change there ports from Non-SSL to SSL ports.

Broker 50003 56003
Concentrator 50005 56005
Decoder 50004 56004
Log Decoder 50002 56002

3. Click 4 (Edit) from the Services view toolbar.
The Edit Service dialog is displayed.

4. Change the port from Non-SSL to SSL as shown in the table and click Save (for example, change the
Broker port from 50003 to 56003).

Edit Service

Service Broker

Host nwappliance13731

Mame nwappliance13731 - Brol

Connection Details

Port 58003

Test Connection
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Task 11 - (Conditional) Correct Audit Log Templates That Are Not Updated in
Logstash Output Conf File

Problem: When a user updates from 10.6.6 to 11.2 and 11.0.0.0 to 11.2, if they have a global auditing set
up, audit log templates are not getting updated in Logstash output conf file.

Workaround: If global auditing is configured, you need to edit one of the syslog entries in the Global
notifications servers and click save to apply the latest Audit log configuration.

If you had global auditing configured in 11.0.x, you must complete the following procedure to apply the
latest Global Auditing configuration.

1. Inthe NetWitness Platform 11.2 menu, select ADMIN > System > Global Notifications.
The Global Notifications view is displayed.

2. Click the Servers tab, select any syslog server.

3. Click 4 (edit icon) and click Save.

RSA NetWitness® Endpoint

Task 12 - Reconfigure Endpoint Alerts Via Message Bus

1. On the NetWitness Endpoint Server, modify the virtual host configuration in the C:\Program

Files\RSA\ECAT\Server\ConsoleServer.exe file to reflect the following configuration.
<add key="IMVirtualHost" value="/rsa/system" />

Note: In NetWitness Platform 11.2, the virtual host is /rsa/system. For 10.6.6.x and earlier
versions, the virtual host is /rsa/sa.

2. Restart the API Server and Console Server.
3. SSH to the NW Server and log in with root credentials.

4. Submit the following command to add all certificates to the truststore.
orchestration-cli-client --update-admin-node

5. Submit the following command to restart the RabbitMQ server.
systemctl restart rabbitmg-server
The NetWitness Endpoint account should automatically be available on RabbitMQ.

6. Import the /etc/pki/nw/ca/nwca-cert.pemand /etc/pki/nw/ca/ssca-cert.pen files from
the NW Server and add them to the Trusted Root Certification stores in the Endpoint Server.

Task 13 - Reconfigure Recurring Feed Configured from Legacy Endpoint Because
Java Version Changed

You must reconfigure the Legacy Endpoint recurring feed due to the change in Java version. Complete
the following step to fix this problem.
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1. Import the NetWitness Endpoint CA certificate into the NetWitness Platform Trusted store as
described in "Export the NetWitness Endpoint SSL Certificate" under the "Configure Contextual
Data from Endpoint via Recurring Feed" topic in the RS4 NetWitness Endpoint Integration Guide to
import the certificate.

Go to the Master Table of Contents to find all NetWitness Platform Logs & Network 11.x
documents.

RSA NetWitness® Endpoint Insights

(Optional) Task 14 - Install Endpoint Hybrid or Endpoint Log Hybrid

See:

RSA NetWitness Platform 11.2 Physical Host Installation Guide for instructions for installation on a
physical host.

RSA NetWitness Platform 11.2 Virtual Host Installation Guide for instructions for installation on a virtual
host.

Event Stream Analysis Tasks (ESA)

Task 15 - Reconfigure Automated Threat Detection for ESA

If you used Automated Threat Detection in 10.6.6.x, you must complete the following steps to
reconfigure it using the ESA Analytics service in 11.2.
1. Inthe NetWitness Platform 11.2 menu, select ADMIN > System > ESA Analytics.
The Suspicious Domains modules, Command and Control (C2) for Network data and C2 for Logs,
require a whitelist named “domains_whitelist”.

2. Conditional - If your previous Automated Threat Detection whitelist appears on the Lists tab of the
Context Hub service:

a. Click ADMIN > Services, select the Context Hub service, in the action commands ( -
drop-down menu, click View > Config > Lists tab).

)

b. Rename your old Automated Threat Detection whitelist to “domains whitelist” for the
Suspicious Domains module.
For more information, see the NetWitness Platform Automated Threat Detection Guide and the

"Configure ESA Analytics" section of the NetWitness Platform ESA Configuration Guide. Go to the
Master Table of Contents to find all NetWitness Platform Logs & Network 11.x documents.
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Task 16 - For Integrations with Web Threat Detection, Archer Cyber Incident &
Breach Response or NetWitness Endpoint Configure Mutually Authenticated SSL

If you integrate with Web Threat Detection, Archer Cyber Incident & Breach Response or NetWitness
Endpoint, you must configure Mutually Authenticated SSL on each integrated system so that the
application can authenticate itself when connecting to the RabbitMQ message bus.

Note: Use the RabbitMQ usernames and passwords that were obtained when you backed up your
10.6.6.x data (see Backup Instructions).

1. Create a user on the host system that is integrating with NetWitness Platform by logging into the host
and running the following rabbitmgctl command.
> rabbitmgctl add user <username> <password>
For example:

> rabbitmgctl add user wtd-incidents incidents

2. Set permissions for users by running the following command (use the username from step 1):

> rabbitmgctl set permissions -p /rsa/system <username> ".*", " *x" v xv
For example:
> rabbitmgctl set permissions -p /rsa/system wtd-incidents ".*", ", x" v kv

Task 17 - Enable Threat - Malware Indicators Dashboard

In 11.2.0, the 10.6.6.x Threat -Indicators Dashboard was renamed to Threat - Malware Indicators
Dashboard. If you used this dashboard in 10.6.6.x, you must:

1. Enable the Threat - Malware Indicators Dashboard in 11.2.

2. Set datasource for new dashlets.
See "Dashlets" in RSA Link (https://community.rsa.com/docs/DOC-81463) for a description of
Dashlets in the context of NetWitness Platform.

Investigate

Task 18 - Make Sure Customized User Roles Have 1nvestigate-server Permissions
for Event Analysis Access

After you upgrade to 11.2.0.0, any customized user role does not have investigate-server.*
permission enabled by default. Complete the following procedure to make sure that the appropriate user
roles have permission to access Event Analysis.

1. Log in to NetWitness Platform 11.2.0.0 with your Admin user credentials and go to ADMIN >
Security.

2. Click the Roles tab.
3. Select the roles that need investigate-server.* permissions and click 4 (Edit icon).

4. Select the Investigate-server tab under under Permissions.
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5. If the investigate-server checkbox is not set, set it for the users that require Event Analysis access.
Permissions

< Integration-server | Investigate [EINESCIS]-al-Tgn B

Assigned Description ~
B L Investigate-server

4 investigate-server.®

6. Click Save.

Log Collection

Task 19 - Reset Stable System Values for Log Collector after Upgrade

Complete the following tasks to reset stable system values for the Log Collector after you upgrade it to
11.2 to ensure that all collection protocols resume normal operation.

Reset Stable System Values for the Lockbox

The Lockbox stores the key for encrypting event source and other passwords for the Log Collector. The
Log Collector service cannot open the Lockbox because of the stable system value changes. As a result,
you must Reset Stable System Values for the Lockbox . See "Log Collection: Step 3. Set Up a Lockbox"
in the RSA NetWitness® PlatformLog Collection Configuration Guide for instructions. Go to the Master
Table of Contents to find all NetWitness Platform Logs & Network 11.x documents.

Update Log Collector Service RabbitMQ User Account Password

If the logcollector service RabbitMQ user account password was changed, you must reenter it after the
11.2 upgrade.

1. Inthe NetWitness Platform 11.2 menu, select ADMIN > Services.

2. Select the Log Collector service.

3. Click - (Actions) > View > Explore.
4. Right click event-broker > Properties.

5. Select passwd from the drop-down list, enter newpw=><newpassword> in Parameters (where
<newpassword> is the RabbitMQ user account password), and click Send.

%, Change Service | @@

= IP-address Log Coll... ¢/ || revenuoroker 10.31.204.88 . Log Coliector
config

B el 10.31.204.88 - Log Collector (LOG_COL... =
destination
B[ Jconnections
destinations hd

@[ Jdevicesppliance P )
= idbaai Properties for IP-address Log Collector (LOG_COLLECTOR)/event-broker. X
B config
[ destiration passwd ~ | Parameters newpw=newpassword m
Message Help

D destinations | Change the management password

Clsources security.roles: logcollection.manage
parameters:
B oldpw - <string, optional> The old management password. v
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(Optional for Upgrades from 10.6.6.x with FIPS enabled for Log Collectors, Log
Decoders and Network Decoders)
Task 20 - Enable FIPS Mode

FIPS is enabled on all services except Log Collector, Log Decoder, and Decoder. FIPS cannot be
disabled on any services except Log Collector, Log Decoder, and Decoder. For information about how to
enable FIPS for these services, see the "Sys Maintenance: Activate or Deactivate FIPS" topic in the RS4
NetWitness® PlatformSystem Maintenance Guide. Go to the Master Table of Contents to find all
NetWitness Platform Logs & Network 11.x documents.

Decoder and Log Decoder

(Conditional) Task 21 - Enable Metadata for GeolP2 Parser

By default, the GeolP2 parser generates less metadata than the GeolP parser did. After updating to 11.2,
if you require any of the additional metadata, you must enable them (once only) for each Decoder. This
can also be altered post-upgrade. Keep in mind that the isp and org meta fields usually produce an
equivalent value to domain.

To enable metadata:
1. Goto ADMIN > Services.

2. In the Administration services view, select a Log Decoder or a Decoder.

3. Click the settings icon ( e ) and select View > Config. The Parsers Configuration panel is
displayed, from which you can select GeolP2 to enable the desired metadata.

For more information about GeolP2 parsers, see the "GeolP2 and GeolP Parsers" topic in the Decoder
and Log Decoder Configuration Guide.

Reporting Engine

Task 22 - Restore the CA certificates for External Syslog Servers for Reporting
Engine

You must restore CA certificates after the upgrade from the back up you made prior to the upgrade. The
Backup script backs up the 10.6.6.x CA certificates into the /usr/1ib/jvm/java-1.8.0-openjdk-
1.8.0.111-0.bl5.el6 8.x86 64/jre/lib/security/cacerts directory.

Complete the following procedure to restore the CA certificates in 11.2.

1. SSH to the NW Server host.

2. Export the CA certificates.
keytool -export -alias <alias name> -keystorepath to keystore file -rfc -

file path to certificate file

3. Copy the CA pem into /etc/pki/nw/trust/import directory.
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(Conditional) Task 23 - Restore External Storage for Reporting Engine

If you have external storage for the Reporting Engine (such as SAN or NAS for storing reports), you
must restore the mount you unlinked before the upgrade. See "Reporting Engine: Add Additional Space
for Large Reports" in the RS4 NetWitness® Platform Reporting Engine Configuration Guide for
instructions. Go to the Master Table of Contents to find all NetWitness Platform Logs & Network 11.x
documents.

Respond

Task 24 - Restore Respond Service Custom Keys

In 10.6.6.x, if you added custom key for use in the groupBy clause, the alert rules.json file was
modified. The alert rules.json file contains aggregation rule schema. RSA moved the alert
rules. json file to the following new location:
/var/lib/netwitness/respond-server/scripts
1. Copy the custom keys from /opt/rsa/im/fields/alert rules.json file in the backup
directory.
This directory is where the alert rules.json file is restored from the 10.6.6.x backup.

2. Gotothe /var/lib/netwitness/respond-server/data/aggregation rule schema.json

in11.2.
This is the new file for 11.2.

3. Editthe /var/lib/netwitness/respond-server/data/aggregation rule schema.json
to include the custom keys you copied in step one.
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Task 25 - Restore Customized Respond Service Normalization Scripts

RSA re-factored the Respond service normalization scripts in 11.2 and moved them to the following new
location:

/var/lib/netwitness/respond-server/scripts

If you customized these scripts in 10.6.6.x, you must:

1. Go to the to the /opt/rsa/im/scripts directory.
This directory is where the following Respond service normalization scripts are restored from the
10.6.6.x backup.
data privacy map.Jjs
normalize alerts.js
normalize core alerts.js
normalize ecat alerts.js
normalize ma alerts.js
normalize wtd alerts.js

utils.js
2. Copy any custom logic from the 10.6.6.x scripts.

3. Gotothe /var/lib/netwitness/respond-server/scripts directory.
This directory is where NetWitness Platform 11.2 stores the re-factored scripts.

4. Edit the new scripts to include the custom logic you copied in step 2 from the 10.6.6.x scripts.

5. Copy any custom logic from /opt/rsa/im/fields/alert rules.json file.
The alert rules.json file contains aggregation rule schema.

Task 26 - Add Respond Notification Settings for Custom Roles

Respond Notification Setting permissions enable Respond Administrators, Data Privacy Officers, and
SOC Managers to access Respond Notification Settings (CONFIGURE > Respond Notifications),
which enable them to send email notifications when incidents are created or updated.

To access these settings, you will need to add additional permissions to your existing built-in NetWitness
Platform user roles. You will also need to add permissions to your custom roles. See the “Respond
Notification Settings Permissions” topic in the NetWitness Respond Configuration Guide. For detailed
information about user permissions, see the System Security and User Management Guide. Go to the
Master Table of Contents to find all NetWitness Platform Logs & Network 11.x documents.

Task 27 - Manually Configure Respond Notification Settings

The Incident Management notification settings in NetWitness Platform 10.6.6.x to 11.2 are different from
the Respond notification settings available in 11.2, so your existing 10.6.6.x to 11.2 settings will not
migrate to 11.2.

NetWitness Respond notification settings enable email notifications to be sent to SOC Managers and the
Analyst assigned to an incident when an incident is created or updated.

To manually configure the Respond Notification Settings, go to CONFIGURE > Respond
Notifications. See the “Configure Respond Email Notification Settings” procedure in the NetWitness
Respond Configuration Guide.
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Notification Servers from 10.6.6.x to 11.2 will not display in the Email Server drop-down list. The email
servers must be edited and saved in the Global Notification Servers panel (ADMIN > System > Global

Notifications > Server tab).

1. Inthe NetWitness Platform 11.2 menu, select ADMIN > System > Global Notifications > Server

tab.

2. Go to CONFIGURE > Respond Notifications. The Respond Notifications Settings view is

displayed.

Click the Servers tab.

S

For each of your email notification servers:

a. Select the Email notification server and click E

RSA SPOND VESTIGATE MONITOR CONFIGURE ADMIN

Info Global Notifications
Updates .
Output Servers Template:
Licensing -
to-E e v
Emai
Enable  Name ~ Output Description
obal fications
I v Respond Notification Email

Legacy Notifications

System Logging

b. In the Define Email Notification Server dialog, click Save.

Define Email Notification Server

Enable ™
Name * Respond Notification
Description

Server IP Or Hostname *
Server Port 25

SSL O

From Email Address # email.address@rsa.com
Username

Password FEEERAEE

Max Alerts Per Minute 500

Max flert Wait Queue g

SlZel

Cancel Save

Notice that the email notification servers do not appear in the EMAIL SERVER drop-down list.
Click the Email Server Settings link. You will see the Global Notifications panel.

x

Last Modified Actions

5 16:46:02 -3

L]

7. Go back to CONFIGURE > Respond Notifications. Your servers will appear in the EMAIL

SERVER drop-down list.

Post Upgrade Tasks

78



Virtual Host Upgrade Guide

Custom Incident Management notification templates cannot be migrated to 11.2. No custom
templates are supported in 11.2.

Task 28 - Update Default Incident Rule Group By Values

Four of the default incident rules now use ”Source IP Address™ as the Group By value. To update the
default rules, change the Group By value of the following default rules to “Source IP Address”:

o High Risk Alerts: Reporting Engine
o High Risk Alerts: Malware Analysis

High Risk Alerts: NetWitness Endpoint
High Risk Alerts: ESA

1. Go to CONFIGURE > Incident Rules and click the link in the Name column for the rule that you
want to update. The Incident Rule Details view is displayed.

2. In the Group By field, select the new Group By value.
3. Click Save to update the rule.

Task 29 - Add Group By Field to Incident Rules
The Group By field is not required in 10.6.6, but it is required in 11.2. After you upgrade to

11.2, some incident rules will not have a Group By field, so you must add them to the rules or the rules
will not work and they will not create incidents.

Complete the following steps for each incident rule:

1. In the NetWitness Platform 11.2 menu, select Go to CONFIGURE > Incident Rules and click the
link in the Name column for the rule that you want to update.

RSA RESPOND INVESTIGATE MONITOR CONFIGURE ADMIN

Live Content Incident Rules  Respond Notifications  ESA Rules  Subscriptions ~ Custom Feeds

Create Rule

I SELECT ORDER ENABLED NAME DESCRIPTION LAST MATCHED MATCHED ALERTS
> This incident rule captures network user behavior. 0
> ... This incident rule captures suspected communication with a Co... 0

This incident rule captures alerts generated by the RSA Malware... 0
This incident rule captures alerts generated by the RSA NetWitn...
This incident rule captures alerts generated by the RSA Reportin...
This incident rule captures alerts generated by the RSA ESA platf...
This incident rule captures alerts generated by IP addresses that...
This incident rule captures alerts generated by network users w...
... This incident rule captures alerts that are indicative of worm pro...
This incident rule captures alerts that identify common ICMP ho...
This incident rule captures any instance of an alert designed to ...

This incident rule captures alerts generated by the RSA Web Thr...
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2. In the Group By field, verify that a Group By value is selected. If not, select a Group By value.

RSA| RESPOND INVESTIGATE MONITOR CONFIGURE ADMIN @) admin iz)

Live Content Incident Rules Respond Notifications ESA Rules  Subscriptions Custom Feeds

BASIC SETTINGS O enaeLED
NAME®

User Watch List: Activity Detected

DESCRIPTION

This incident rule captures alerts generated by network users whose user names have been added as a "Source UserName" condition. To add more than one
Username to the watch list, simply add an additional Source Username condition.

MATCH CONDITIONS* QUERY MODE
Rule Builder

Any of these:
FIELD OPERATOR VALUE

Source Username " isequal to ¥ jsmith

FIELD OPERATOR VALUE

Source Username " isequal to ¥ jdoe

CHOOSE THE ACTION TAKEN IF THE RULE MATCHES AN ALERT
Group into an Incident O Suppress the Alert

GROUPING OPTIONS GROUP BY* Source Username

TIME WINDOW

ACTION*

4 Hours

Cancel Save

3. Click Save to update the rule.
For information about incident rules, see the NetWitness Respond Configuration Guide. Go to the
Master Table of Contents to find all NetWitness Platform Logs & Network 11.x documents.

Task 30 - Update Incident Rules Identified in the Domain in the Matching
Conditions Upgrade Preparation Task

Modify the incident rules that you identified in the Task 5 - Check Aggregation Rules Match Conditions
for “Domain” or “Domain for Suspected C&C” upgrade preparation task, which contained Domain or
Domain for Suspected C&C in the matching conditions in rule builder.

For each rule that you previously identified:

1. Inthe NetWitness Platform 11.2 menu, select CONFIGURE > Incident Rules and click the link
in the Name column for the rule that you want to update.

Post Upgrade Tasks 80


https://community.rsa.com/docs/DOC-81328

Virtual Host Upgrade Guide

RSA RESPOND INVESTIGATE MONITOR CONFIGURE ADMIN @:} admin

Live Content Incident Rules Respond Notifications  ESA Rules  Subscriptions  Custom Feeds
I SELECT ORDER ENABLED NAME DESCRIPTION LAST MATCHED MATCHED ALERTS INCIDENTS
» This incident rule captures network user behavior. 0
> ... This incident rule captures suspected communication with a Co... 0
This incident rule captures alerts generated by the RSA Malware... 0
This incident rule captures alerts generated by the RSA NetWitn...
This incident rule captures alerts generated by the RSA Reportin...
This incident rule captures alerts generated by the RSA ESA platf...
This incident rule captures alerts generated by IP addresses that...
This incident rule captures alerts generated by network users w...
. This incident rule captures alerts that are indicative of worm pro...
This incident rule captures alerts that identify common ICMP ho...
This incident rule captures any instance of an alert designed to ...

This incident rule captures alerts generated by the RSA Web Thr...

2. Inthe Match Conditions section, in the blank fields, select Domain and Domain for Suspected CC
in the drop-down list and then select the conditions that you previously identified in the pre-upgrade
tasks.

RSA RESPOND INVESTIGATE MONITOR CONFIGURE ADMIN
Live Content  Incident Rules  Respond Notifications  ESA Rules  Subscriptions  Custom Feeds

BASIC SETTINGS ENABLED
NAME*

Verify Domain for Suspected C&C field

DESCRIPTION

This rule match Conditions for Domain & Domain for Suspected C&C in rule builder

MATCH CONDITIONS* QUERY MODE
Rule Builder

All of these

FIELD

CHOOSE THE ACTION TAKEN IF THE RULE MATCHES AN ALERT
Group into an Incident O Suppress the Alert

ACTION®

3. Click Save to update the rule.
For information about incident rules, see the NetWitness Respond Configuration Guide. Go to the
Master Table of Contents to find all NetWitness Platform Logs & Network 11.x documents.
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RSA Archer® Cyber Incident & Breach Response

Task 31 - Reconfigure Archer® Cyber Incident & Breach Response Integration

For information on how to reconfigure Archer® Cyber Incident & Breach Response for Event Stream
Analysis, Reporting Engine, and Respond, see RSA Archer Integration Guide. Go to the Master Table of
Contents to find all NetWitness Platform Logs & Network 11.x documents.

User and Entity Behavior Analytics (UEBA)

(Optional) Task 32 - Install UEBA

UEBA is new a new feature as of NetWitness Platform 11.2.
See:

RSA NetWitness Platform 11.2 Physical Host Installation Guide for instructions for installation on a
physical host.

RSA NetWitness Platform 11.2 Virtual Host Installation Guide for instructions for installation on a virtual
host.

Go to the Master Table of Contents to find all NetWitness Platform Logs & Network 11.x documents.

Backup

Task 33 - Remove Backup-Related Files from Host Local Directories

Caution: 1) You must retain a copy of all backup files on an external host. 2) Validate that you have
all your data from your backup restored in 11.2 before you remove the backup-related files from the
local directories on your 11.2 hosts.

Backup . tar Files

After all the hosts are upgraded to 11.2, you must remove:

« the backup files from the local directories on the hosts.

o all the files from nw-backup and restore directories on the hosts.

m Backup Path Restore Path

Malware /var/lib/rsamlware/nw-backup /var/netwitness/malware analytics
server/nw-backup/restore

Event Stream /opt/rsa/database/nw-backup /var/netwitness/database/nw-

Analysis backup/restore

NW Server /var/netwitness/database/nw- /var/netwitness/restore
backup
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n Backup Path Restore Path

All Other /var/netwitness/database/nw- /var/netwitness/database/nw-
Hosts backup backup/restore
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Appendix A. Troubleshooting

This section describes solutions to problems that you may encounter during installations and upgrades. In
most cases, NetWitness Platform creates log messages when it encounters these problems.

Note: If you cannot resolve an upgrade issue using the following troubleshooting solutions, contact
Customer Support (https://community.rsa.com/docs/DOC-1294).

This section has troubleshooting documentation for the following services, features, and processes.
o Command Line Interface (CLI)

o Backup Script

« Event Stream Analysis

o Log Collector Service (nwlogcollector)

o Orchestration

e NW Server

o Reporting Engine

o NetWitness UEBA
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Command Line Interface (CLI)

Command Line Interface (CLI) displays: "Orchestration failed."

Mixlib::ShellOut::ShellCommandFailed: Command execution failed.
STDOUT/STDERR suppressed for sensitive resource
in/var/log/netwitness/config-management/chef-solo.log

Entered the wrong deploy admin password in nwsetup-tui.

Retrieve your deploy admin password password.

1. SSH to the NW Server host.
security-cli-client --get-config-prop --prop-hierarchy
nw.security-client --prop-name deployment.password

SSH to the host that failed.

2. Run the nwsetup-tui again using correct deploy admin password.

ERROR com.rsa.smc.sa.admin.web.controller.ajax.health.
AlarmsController - Cannot connect to System Management Service

NetWitness Platform sees the Service Management Service (SMS) as down after
successful upgrade even though the service is running.

Restart SMS service.
systemctl restart rsa-sms

You receive a message in the User Interface to reboot the host after you update and
reboot the host offline.

[ sA server IP-Address n version-number Reboot Host

You cannot use CLI to reboot the host. You must use the User Interface.

Reboot the host in the Host View in the User Interface.
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Backup (nw-backup Script)

Error
Message

Cause

Solution

Error

Cause

Solution

WARNING: Incorrect ESA Mongo admin password for host <hostname>.

ESA Mongo admin password contains special characters (for example,
@#$% qwerty’).

Change the ESA Mongo admin password back to the original default of ‘netwitness’
before running backup.

Backup errors caused by the immutable attribute setting. Here is an example of an error
that can be displayed:

Backing up NetWitness Config (/etc/netwitness) files from: s :rl
WARNING: Errors occurred backing up NetWitness Configuration files.
Verify contents of saserverl-192. lb" 2.102- etc netwitness

Located in /var/netwit i-a = >/ -backup,/2 -83-081/saserve 2.168.2.102-backup.tar.gz
E’acl-lng up SA UI Web § r

If you have any files that have the immutable flag set (to keep the Puppet process from
overwriting a customized file), the file will not be included in the backup process and an
error will be generated.

On the host that contains the files with the immutable flag set, run the following command

to remove the immutable setting from the files:
chattr -i <filename>
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Error creating Network Configuration Information file due to duplicate or bad entries in
primary network configuration file:
/etc/sysconfig/network-scripts/ifcfg-eml

Verify contents of /var/netwitness/logdecoder/packetdb/nw-backup/2018-02-
23/85-BROK-36-10.25.53.36-network.info.txt

There are incorrect or duplicate entries for any one of the following fields: DEVICE,
BOOTPROTO, IPADDR, NETMASK or GATEWAY, that were found from reading the
primary Ethernet interface configuration file from the host being backed up.

Manually create a file at the backup location on the external backup server, as well as the
backup location local to the host where other backups have been staged. The file name
should be of the format <hostname>-<hostip>-network.info.txt, and should contain

the following entries:
DEVICE=<devicename> ; # from the host's primary ethernet interface
config file

BOOTPROTO=<bootprotocol> ; # from the host's primary ethernet
interface config file

IPADDR=<value> ; # from the host's primary ethernet interface config
file

NETMASK=<value> ; # from the host's primary ethernet interface
config file

GATEWAY=<value> ; # from the host's primary ethernet interface
config file

search <value> ; # from the host's /etc/resolv.conf file

nameserver <value> ; # from the host's /etc/resolv.conf file
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Event Stream Analysis

ESA service crashes after you upgrade to 11.2.0.0 from a FIPS enabled setup.

ESA service is pointing to an invalid keystore.

1. SSH to the ESA Primary host and log in.

2. Inthe /opt/rsa/esa/conf/wrapper.conf file, replace the following line
wrapper.java.additional.5=-

Djavax.net.ssl.keyStore=/opt/rsa/esa/../carlos/keystore
with:

wrapper.java.additional.5=-
Djavax.net.ssl.keyStore=/opt/rsa/carlos/keystore

3. Submit the following command to restart ESA.

systemctl restart rsa-nw-esa-server

Note: If you have multiple ESA hosts and you encounter that same problem, repeat
steps 1 through 3 inclusive on each secondary ESA host.
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Log Collector Service (nwlogcollector)

Log Collector logs are posted to /var/log/install/nwlogcollector install.log on the host
running the nwlogcollector service.

<timestamp>.NwLogCollector PostInstall: Lockbox Status Failed to
open lockbox: The lockbox stable value threshold was not met because
the system fingerprint has changed. To reset the system fingerprint,

open the lockbox using the passphrase.

The Log Collector Lockbox failed to open after the update.

Log in to NetWitness Platform and reset the system fingerprint by resetting the stable
system value password for the Lockbox as described in the "Reset the Stable System
Value" topic under "Configure Lockbox Security Settings" topic in the Log Collection
Configuration Guide, Go to the Master Table of Contents to find all NetWitness Platform

Logs & Network 11.x documents.

<timestamp> NwLogCollector PostInstall: Lockbox Status : Not Found

The Log Collector Lockbox is not configured after the update.

If you use a Log Collector Lockbox, log in to NetWitness Platform and configure
the Lockbox as described in the "Configure Lockbox Security Settings" topic in the Log
Collection Configuration Guide. Go to the Master Table of Contents to find all NetWitness

Platform Logs & Network 11.x documents.
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<timestamp>: NwLogCollector PostInstall: Lockbox Status : Lockbox
maintenance required: The lockbox stable value threshold requires
resetting. To reset the system fingerprint, select Reset Stable
System Value on the settings page of the Log Collector.

You need to reset the stable value threshold field for the Log Collector Lockbox.

Log in to NetWitness Platform and reset the stable system value password for the Lockbox
as described in "Reset the Stable System Value" topic under "Configure Lockbox Security
Settings" topic in the Log Collection Configuration Guide. Go to the Master Table of
Contents to find all NetWitness Platform Logs & Network 11.x documents.

You have prepared a Log Collector for upgrade and no longer want to upgrade at this time.

Delay in upgrade.

Use the following command string to revert a Log Collector that has been prepared for
upgrade back to resume normal operation.

# /opt/rsa/nwlogcollector/nwtools/prepare-for-migrate.sh —--revert
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NW Server

These logs are posted to /var/netwitness/uax/logs/sa.log onthe NW Server Host.

After upgrade, you notice that Audit logs are not getting forwarded to the configured
Global Audit Setup;

or,

The following message seen in the sa. log.
Syslog Configuration migration failed. Restart jetty service to fix
this issue

NW Server Global Audit setup migration failed to migrate from 10.6.6.x to 11.2.0.0.

1. SSH to the NW Server.

2. Submit the following command.

orchestration-cli-client --update-admin-node

Orchestration

The orchestration server logs are posted to /var/log/netwitness/orchestration-
server/orchestration-server.log onthe NW Server Host.

1. Tried to upgrade a non-NW Server host and it failed.
2. Retried the upgrade for this host and it failed again.

You will see the following message in the orchestration-server.log.
"'file' wvirtual returned False: cannot import name HASHES""

Salt minion may have been upgraded and never restarted on failed non-NW Server host

1. SSH to the non-NW Server host that failed to upgrade.

2. Submit the following commands.

systemctl unmask salt-minion
systemctl restart salt-minion

3. Retry the upgrade of the non-NW Server host.
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Reporting Engine Service

Reporting Engine Update logs are posted to to/var/log/re_install.log file on the host running the
Reporting Engine service.

<timestamp> : Available free space in /var/netwitness/re-
server/rsa/soc/reporting-engine [ ><existing-GB ] is less than the
required space [ <required-GB> ]

Update of the Reporting Engine failed because you do not have enough disk space.

Free up the disk space to accommodate the required space shown in the log message. See
the "Add Additional Space for Large Reports" topic in the Reporting Engine Configuration
Guide for instructions on how to free up disk space. Go to the Master Table of Contents to
find all NetWitness Platform Logs & Network 11.x documents.
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NetWitness UEBA

The User Interface is not accessible.

Y ou have more than one NetWitness UEBA service existing in your NetWitness
deployment and you can only have NetWitness UEBA service in your deployment.

Complete the following steps to remove the extra NetWitness UEBA service.

L.

SSH to NW Server and run the following commands to query the list of installed
NetWitness UEBA services.

# orchestration-cli-client --list-services|grep presidio-airflow
Service: ID=7e682892-b913-4dee-ac84-ca2438e522bf,

NAME=presidio-airflow, HOST=xxx.xxxX.xxx.xxx:null, TLS=true
Service: ID=3ba35fbe-7220-4e26-a2ad-9eld4ab5e%el5,
NAME=presidio-airflow, HOST=xxx.xxxX.xxx.xxx:null, TLS=true

From the list of services, determine which instance of the presidio-airflow service
should be removed (by looking at the host addresses).

Run the following command to remove the extra service from Orchestration (use the

matching service ID from the list of services):
# orchestration-cli-client --remove-service --id <ID-for-
presidio-airflow-form-previous-output>

Run the following command to update node 0 to restore NGINX:
# orchestration-cli-client --update-admin-node

Log in to NetWitness Platform, go to ADMIN > Hosts, and remove the extra
NetWitness UEBA host.
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Appendix B. Stopping and Restarting Data Capture
and Aggregation

RSA recommends that you stop network and log capture and aggregation before upgrading a Decoder,
Concentrator, and Broker host to 11.2.0.0. If you do this, you must restart network and log capture and
aggregation after updating these hosts.

Stop Data Capture and Aggregation

Stop Network Capture

1. Log in to NetWitness Platform and go to ADMIN > Services.
The Services view is displayed.

2. Select each Decoder service.

& services ¥

% Change Service | I SIT-DEC1 - Decoder

® Stop Capture i HostTasks @ Shutdown Service (O Shutdown Appliance Service (U Reboot

Decoder Service Information Appliance Service Information
SIT-DEC1 (Decoder) SIT-DEC1 (Host)
414 MB (2.57% of 16081 MB) 24876 KB (0.15% of 16081 MB)

51%

Decoder User Information Host User Information

-

r

NETWITNESS

3. Under - (actions), select View > System.

4. In the toolbar, click Stop Capture.

Stop Log Capture

1. Log in to NetWitness Platform and go to ADMIN > Services.
The Services view is displayed.
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2. Select each Log Decoder service.

& services

&

£ Change Service | I SIT-DEC1 - Decoder |

® Stop Capture i Host Tasks (O Shutdown Service (O Shutdown Appliance Service (O Reboot

Decoder Service Information Appliance Service Information
SIT-DEC1 (Decoder) SIT-DEC1 (Host)
414 MB (2.57% of 16081 MB)

Decoder User Information Host User Information

-

g

NETWITNESS

3. Under - (actions), select View > System.

4. TIn the toolbar, click Stop Capture

Stop Aggregation
1. Log in to NetWitness Platform and go to ADMIN > Services.

2. Select the Broker service.

3. Under - (actions), select View > Config.

4. The General tab is displayed.

@ @ admin &

# Change Service | EBBROKER-Broker | Config ©

General Files Appliance Service Configuration

ation Configuration

® Stop Aggregation Name Config Value

] i tion Settings
Address Port Rate Max - Stop consuming session from the list of attached
¥ ip-address 56005 1 7091 0 =

Cuetrarm Carnfio irs
System Lonngurat

Name Config Value

2 admin | @)English (United States) | GMT+00:00 Send Us Feedback |

S
. B ' Stop Aggregation
5. Under Aggregated Services click P .
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Start Data Capture and Aggregation

Restart network and log capture and aggregation after updating to 11.2.0.0.

Start Network Capture

L.

4.

Log in to NetWitness Platform and go to ADMIN > Services.

The Services view is displayed.

Select each Decoder service.

. Under - (actions), select View > System.

. ® Start Capture
In the toolbar, click

Start Log Capture

1.

4.

Log in to NetWitness Platform and go to ADMIN > Services.

The Services view is displayed.

Select each Log Decoder service.

o

Under : (actions), select View > System.

) = Start Capture
In the toolbar, click

Start Aggregation

1.

2.

Log in to NetWitness Platform and go to ADMIN > Services.

The Services view is displayed.
For each Concentrator and Broker service.

a. Select the service.

b. Under - (actions), select View > Config.

Pt .
c. In the toolbar, click »' Start Aggregation
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Appendix C. Using iDRAC

Many customers have remote sites with limited physical access and limited bandwidth from the
administrator's desktop. If this the case, you may want to use iDRAC with the ISO Image shared out
from an NFS share that is local to the devices being upgraded or installed. This also gives you the ability
to use an existing NetWitness device as the sharing host.

For example:
o You have a Concentrator and Decoder at a site in a remote geographic location.
o The bandwidth is relatively low to that site from the administrator's site.

« Shipping a USB stick and arranging to have person to go plug it into the boxes while you upgrade is
not practical.

In this situation, you can:
1. Install the nfs-utils RPM.
2. Configure the NFS share.

3. Configure iDRAC to connect to that share.
Make sure that you update your iDRAC firmware supported Windows and Linux operating systems.
Download and run the Dell Update Packages for supported Windows and Linux operating systems
from the Dell Support website at http://www.support.dell.com. For more information, see the Dell
Update Package User's Guide available on the Dell Support website at http://topics-
cdn.dell.com/pdf/dell-update-packages-v17.10.00_User's%20Guide_en-us.pdf.

4. Boot to the virtual media that contains the ISO file and continue with the upgrade.

Configure NFS Server - NFS Server config File

1. Install NFS and its common utilities using yum.
yum install nfs-utils

2. Configure the NFS service to run at boot.
chkconfig nfs on

3. Configure the rpcbind service to run at boot.

This service is required by NFS and must be running before NFS can be started.
chkconfig rpcbind on

4. Start the rpcbind service.
service rpcbind start

5. Start the NFS service.
service nfs start

6. Create a directory for our first export.
mkdir /exports/files

7. Open the NFS exports file into a text editor.
vi /etc/exports
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10.

11.

12.

To export the directory to everyone with read-only access, add the following line.
/exports/files * (ro)

Save your changes and exit the editor.
wq!

Export the directory defined above.
exportfs -a

Disable firewall rules while performing upgrades.
service iptables stop

Copy install media that contains the ISO file to /exports/files directory.

Boot iDRAC to NFS Configuration

Note: You must verify that the iDRAC firmware is at least 1.57.57 for Series 4 (R620).

1.
2.

S

Log in to the iDRAC interface.

Attach media using Remote File Share.
<server ip>:/export/files/11.2.0.0.iso
For example: 10.10.10.10:/exports/files/rsa-11.2.0.0.1948.el7-usb.1iso

Click Connect.
Launch Console.
From the next boot menu, select Virtual DVD/CD.

Reboot the device.
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Appendix D. Create External Repository

Complete the following procedure to set up an external repository (Repo).

Note: 1.) You need an unzip utility installed on the host to complete this procedure. 2.) Y ou must know
how to create a web server before you complete the following procedure.

1. Log in to the web server host.

2. Create a directory to host the NW repository (netwitness-11.2.0.0.zip), for example ziprepo
under web-root of the web server. For example, if /var/netwitness is the web-root, submit
the following command string.
mkdir -p /var/netwitness/<your-zip-file-repo>

3. Create the 11.2.0.0 directory under /var/netwitness/<your-zip-file-repo>.
mkdir -p /var/netwitness/<your-zip-file-repo>/11.2.0.0

4. Create the 0s and RSA directories under /var/netwitness/<your-zip-file-
repo>/11.2.0.0.
mkdir -p /var/netwitness/<your-zip-file-repo>/11.2.0.0/0S
mkdir -p /var/netwitness/<your-zip-file-repo>/11.2.0.0/RSA

5. Unzip the netwitness-11.2.0.0.zip file into the /var/netwitness/<your-zip-file-
repo>/11.2.0.0 directory.
unzip netwitness-11.2.0.0.zip -d /var/netwitness/<your-zip-file-
repo>/11.2.0.0
Unzipping netwitness-11.2.0.0.zip results in two zip files (05S-11.2.0.0.zip and RSA-
11.2.0.0.zip) and some other files.

6. Unzip the:

a. 05-11.2.0.0.zipintothe /var/netwitness/<your-zip-file-repo>/11.2.0.0/0S
directory.
unzip /var/netwitness/<your-zip-file-repo>/11.2.0.0/0S-11.2.0.0.zip -d
/var/netwitness/<your-zip-file-repo>/11.2.0.0/0S
The following example illustrates how the Operating System (OS) file structure will appear after
you unzip the file.
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20-Nowv-2016 12:49 1.IM
02-0¢t-2017 10:07 4.6M
02-0¢t-2017 10:05 1.5M
20-Nowv-2016 14:43 502K
20-Nowv-2016 14:43 15K
19-Dec-2017 12:30 160K
25-MNov-2015 10:39 204K
03-Oct-2017 10:04 BIK
13-Feb-2018 05:10 706K
10-Aug-2017 10:52 421K
25-Jan-2018 17:56 51K
10-Aug-2017 10:53 258K
03-0¢t-2017 10:04 66K

b. RSA-11.2.0.0.zip into the /var/netwitness/<your-zip-file-repo>/11.2.0.0/RSA

directory.
unzip /var/netwitness/<your-zip-file-repo>/11.2.0.0/RSA-11.2.0.0.zip -d

/var/netwitness/<your-zip-file-repo>/11.2.0.0/RSA
The following example illustrates how the RSA version update file structure will appear after you
unzip the file.

o Parent Directory :
[#) MeeaCli-8.02.21-1 noarch.rpm 03-Oct-2017 10:07 1.2M
@ .2.0.19-15.¢/7 03-0ct-2017 10:07 173K

i ils-994-51 |7 4.2 ? 22-Jan-2018 09:03 203K
[P bzip2-1.0.6-13.6l7.x86 64.pm 03-0e1-2017 10:07 52K
[?) cifs-utils-6.2-10.¢17.x86_64.com 10-Aug-2017 11:14 85K
[?) device-mapper-multipath-0.4.9-11 1 el7_42.x86_64.rpm 25-Jan-2018 17:56 134K
[?) dusimasg-2.76-2.e17_4.2.x86 64.rpm 02-Oct-2017 19:36 277K
[ elasticsearch-5.6 9.rpm 17-Apr-2018 09:37 32M
@zﬂnsdﬂ.ﬁ;ullmmﬁﬁ_&rm 03-Oct-2017 10:07 17K
@ cer-4.6.0-2 el 7.x8 27-Feb-2018 09:11 1.3M
[?) ltop-2.1.0-1.¢17 x86_64.rpm 14-Feb-2018 19:23 102K
[ i20e-2c-2.3.6.12-1dkms noarch, 04-May-2018 11:08 399K
[?) ipmitool 1.5.18-56]7 X86 64.rpm 10-Aug-2017 12:41 441K
[P iptables-services-1.4.21-18 3 |7 4.x86_64.rpm 08-Mar-2018 09:20 51K
[? ixebe-ze-5.0.4.12-dkms noarch.rpm 04-May-2018 11:08 374K

The external URL for the repo is http://<web server IP address>/<your-zip-file-
repo>.

7. Use the http://<web server IP address>/<your-zip-file-repo> inresponse to Enter
the base URL of the external update repositories prompt from NW 11.2.0.0 Setup program
(nwsetup-tui) prompt.
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