Article Number
000036036
Applies To
RSA Product Set: NetWitness Endpoint
RSA Product/Service Type: NetWitness Endpoint
RSA Version/Condition: 4.4.0.0
Platform: Windows
Platform (Other): MSSQL Database
Issue
When installing NW Endpoint, during the SQL Database install phase, the error below is displayed in the pop-up box and the Installer prompts to retry or cancel.
The text of the Error:
"Error -2146232060 while executing SQL script ECAT_FULL_VERSION.SQL at line 146493 Connection Timeout Expired.
The timeout period elapsed while attempting to consume the pre-login handshake acknowledgment.
This could be because the pre-login handshake failed or the server was unable to respond back in time. [...]"
Screenshot of pop up box:
Image description
Cause
This is a generic MSSQL install error during the database install phase. For this particular KB article, it is due to the ECAT SQL Agent job "Capture_LiveFeedBackMetrics" was not able to be added to the SQL Agent job list.
The most probable cause of this issue is due to the SA account been disabled or removed from the Database Logins.
To verify, You can check the install.log which is located in the C:\Users\<username>\AppData\Local\Temp folder
(where username is the account of the user who is running the NWE Install program)
Example of the path from lab system:
C:\Users\DLPuser\AppData\Local\Temp
After locating the log file, open it with your favorite text editor program, scroll to the end and you will get more details on what caused the error message.
Re-creating SQL Agent job: ECAT_CaptureLiveFeedbackMetrics] errorNbr [-2146232060] 2018-02-15 20:00:32.768 Message box (Retry/Cancel): Error -2146232060 while executing SQL script ECAT_FULL_VERSION.SQL at line 146493 Connection Timeout Expired. The timeout period elapsed while attempting to consume the pre-login handshake acknowledgment. This could be because the pre-login handshake failed or the server was unable to respond back in time.
The ECAT_CaptureLiveFeedbackMetrics job is owned by the SA account, In order for the install to complete, this job has to be scheduled in the Agent job list.
Resolution
Enable or add the default SA account.
Workaround
Caution:
Making any modifications to the Microsoft SQL database other than what is specified in the NetWitness Endpoint documentation is not supported and may result in errors when installing the NetWitness Endpoint product.
Adding the note from the Netwitness Endpoint Installation Guide 4.4 below:
Note the pages containing the required database settings are found on pages 25-26, and 30-39