Article Number
000001548
Applies To
RSA Product Set: NetWitness Logs & Packets, Security Analytics
RSA Product/Service Type: Administration Server, UI
RSA Version: 11.0
Issue
After upgrading to RSA NetWitness Logs & Packets 11.0 (10.6.4.0, 10.6.4.1, 10.6.4.2 à 11.0.0.0) the Active Directory users are no longer able to log in.
Cause
The issue occurs if 11.0.0.0 customers have migrated authentication providers and users by clicking on the Migrate button within the UI (AdminàSecurityàSettings) after upgrade from 10.6.4.0 to 10.6.4.1 and then from 10.6.4.2 to 11.0.0.0 and before applying the 11.0.0.1 patch.
Resolution
This issue has been fixed in version 10.6.4.3 and later.
Workaround
- Connect to the Administration Server via SSH.
- Run the command below at the command line. The prompt for a password will be for the deploy_admin user password. This password was specified during the bootstrap process of the Administration Server.
mongo -u deploy_admin -p --authenticationDatabase admin --eval 'db.getSiblingDB("security-server").user.updateMany({ type: "Pam" }, { $set: { type: "Unknown", accountProviderId: null } })'
Example Output from the Command:
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