Article Number
000001805
Applies To
RSA Product Set: NetWitness Endpoint RSA Product/Service Type: NetWitness Endpoint RSA Version/Condition: 4.3.x.x, 4.4.x.x Platform: Windows Platform (Other): SQL 2014 Standard/Enterprise, SQL 2012 Standard/Enterprise |
Issue
Modules are downloaded and written to the \Files directory according to the settings specified in the Global Parameters page as shown below.
Cause
In most cases this is due to AV software quarantining or deleting the file in question although there are other potential causes of this error such as lack of drive space.
Resolution
To correct this error requires that you first inventory the files in the \Files directory and then compare the files on disk to those in the database. Finally, any files that are present in the database but are not present on disk will be removed from the database. RSA has provided a simple tool (ExportEcatRelFiles.exe) that will inventory the \Files directory and export the relative path of these files to a text file. Once this is complete, run the attached query “Delete Entries From MachineDownloaded.sql” to remove unwanted entries from the database.
- In a command prompt, execute ExportEcatRelFiles.exe using the following syntax:
ExportEcatRelFiles.exe <path to \Files directory> <output filename>
Workaround
NONE.