Article Number
000032190
Applies To
RSA Product Set: Security Analytics
RSA Product/Service Type: Security Analytics UI, Security Analytics Server, Core Appliance
RSA Version/Condition: 10.5.x
Platform: CentOS
Platform (Other): Puppet, RabbitMQ, collectd
O/S Version: EL6
Issue
Stats in the host tab in Security Analytics GUI not
visible screenshot below:
Image description
Cause
When provisioning or re-provisioning an appliance in the Security Analytics UI, sometimes the collectd and rabbitmq processes may not be in sync or there is an issue with the queue creation on the RabbitMQ federated link. This can cause the stats to not display properly.
Resolution
There is two options to resolve the issue.
Let puppet reset the services configuration (rabbitmq, collectd, mcollective)
- Connect to the affected appliance via SSH as the root user.
- Stop all related services.
/etc/init.d/puppet stop
/etc/init.d/collectd stop
/etc/init.d/mcollective stop
/etc/init.d/rabbitmq-server stop
- Issue the command below.
puppet agent -t
The output from the command above should look similar to the example below.
Notice: /Stage[main]/Rabbitmq/Service[rabbitmq-server]/ensure: ensure changed 'stopped' to 'running'
Info: /Stage[main]/Rabbitmq/Service[rabbitmq-server]: Unscheduling refresh on Service[rabbitmq-server]
Notice: /Stage[main]/Yumconfig/Exec[disable-Centos-Repos]/returns: executed successfully
Notice: /Stage[main]/Collectd/Service[collectd]/ensure: ensure changed 'stopped' to 'running'
Info: /Stage[main]/Collectd/Service[collectd]: Unscheduling refresh on Service[collectd]
Notice: /Stage[main]/Mcollective/Service[mcollective]/ensure: ensure changed 'stopped' to 'running'
Info: /Stage[main]/Mcollective/Service[mcollective]: Unscheduling refresh on Service[mcollective]
Notice: Finished catalog run in 39.71 seconds
- Refresh the browser showing the Administration -> Hosts page in the Security Analytics UI and confirm that the stats are populated.
Reset the puppet certificatesIf the steps above do not resolve the issue, contact RSA Support and quote this article number for assistance in resetting the puppet certificates.