Article Number
000001261
Applies To
RSA Product Set: NetWitness Platform
RSA Product/Service Type: Core Appliance
RSA Version/Condition: 11.3.2.0
Platform: CentOS
O/S Version: 7
Issue
When one PSU is failed on R730/R740/R640 model, Power Supply Failure" alarm does not fire in 11.3.2 Health & Wellness while R620 model is no issue.
Here are some examples between problematic host and working host.
- R640 model: Problematic host
# ipmitool sdr type "Power Supply"
PS Redundancy | 77h | ok | 7.1 | Redundancy Lost
Status | 85h | ok | 10.1 | Presence detected
Status | 86h | ok | 10.2 | Presence detected, Power Supply AC lost
System Stats Browser detected Power Supply Status as "ok" as shown below and this is unexpected value. Expected value is "Presence detected".
- R730 model: Problematic host
# ipmitool sdr type "Power Supply"
PS Redundancy | 74h | ok | 7.1 | Fully Redundant
Status | 62h | ok | 10.1 | Presence detected
Status | 63h | ok | 10.2 | Presence detected
System Stats Browser detected Power Supply Status as "ok" as shown below and this is unexpected value. Expected value is "Presence detected".
# ipmitool sdr type "Power Supply"
PS Redundancy | 74h | ok | 7.1 | Fully Redundant
Status | 62h | ok | 10.1 | Presence detected
Status | 63h | ok | 10.2 | Presence detected
System Stats Browser detected Power Supply Status as "Presence detected" as shown below and this is expected value.
Cause
PSU monitoring script(/usr/lib/collectd/python/nwsysinfo.py) in 11.3.2 does not have code checking mechanism that is implemented with respect to Series 5 or above versions.
Resolution
This issue has been resolved in NetWitness version 11.4.0.1 and above.
Workaround
You need to follow the steps below on the NW server and for one of the core appliances for which this issue is observed in 11.3.2.x.
- Take a backup of /usr/lib/collectd/python/nwsysinfo.py
- Replace the file with the attached nwsysinfo.py
- Delete the existing nwsysinfo.pyc file.
- Restart collectd
Please make an observation if the stats are observed after this change.
If you are unsure of any of the steps above or experience any issues, contact RSA Support and quote this article number for further assistance.