This website uses cookies. By clicking Accept, you consent to the use of cookies. Click Here to learn more about how we use cookies.
Accept
Reject

NetWitness Community

  • Home
  • Products
    • NetWitness Platform
      • Advisories
      • Documentation
        • Platform Documentation
        • Known Issues
        • Security Fixes
        • Hardware Documentation
        • Threat Content
        • Unified Data Model
        • Videos
      • Downloads
      • Integrations
      • Knowledge Base
    • NetWitness Cloud SIEM
      • Advisories
      • Documentation
      • Knowledge Base
    • NetWitness Detect AI
      • Advisories
      • Documentation
      • Knowledge Base
    • NetWitness Investigator
    • NetWitness Orchestrator
      • Advisories
      • Documentation
      • Knowledge Base
      • Legacy NetWitness Orchestrator
        • Advisories
        • Documentation
  • Community
    • Blog
    • Discussions
    • Events
    • Idea Exchange
  • Support
    • Case Portal
      • Create New Case
      • View My Cases
      • View My Team's Cases
    • Community Support
      • Getting Started
      • News & Announcements
      • Community Support Forum
      • Community Support Articles
    • Product Life Cycle
    • Support Information
    • General Security Advisories
  • Training
    • Blog
    • Certification Program
    • Course Catalog
    • New Product Readiness
    • On-Demand Subscriptions
    • Student Resources
    • Upcoming Events
  • Technology Partners
  • Trust Center
Sign InRegister Now
cancel
Turn on suggestions
Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type.
Showing results for 
Search instead for 
Did you mean: 
NetWitness Knowledge Base
Find answers to your questions and identify resolutions for known issues with knowledge base articles written by NetWitness experts.
cancel
Turn on suggestions
Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type.
Showing results for 
Search instead for 
Did you mean: 
Announcement Banner

Users are unable to open Netwitness Support Cases via email. Please open support cases via portal or by phone

View Details
  • NetWitness Community
  • Knowledge Base
  • NwHost update failing with ports unavailable error
  • Options
    • Subscribe to RSS Feed
    • Bookmark
    • Subscribe
    • Email to a Friend
    • Printer Friendly Page
    • Report Inappropriate Content

The content you are looking for has been archived. View related content below.

NwHost update failing with ports unavailable error

Article Number

000001205

Applies To

RSA Product Set: RSA NetWitness Platform
RSA Product/Service Type: Core Appliance
RSA Version/Condition: 11.3.2.0
Platform: CentOS
O/S Version: 7
 

Issue

When below update command ran in NwAdminServer for nwhost update that fails with below error.

upgrade-cli-client --upgrade --host-addr <nwhostIP> --version 11.3.2.0
2020-10-27 09:41:18.108  INFO 42330 --- [main] c.r.n.i.o.client.LaunchHelper: Task [prepare host '10.10.10.1' for upgrade '11.3.2.0'] running (polling 597 more times)...
2020-10-27 09:41:30.146 ERROR 42330 --- [main] c.r.n.i.o.client.OrchestrationClient: Task [prepare host '10.10.10.1' for upgrade '11.3.2.0'] stopped with errors!
2020-10-27 09:41:30.147 ERROR 42330 --- [main] c.r.n.i.o.c.OrchestrationApplication: Requested operation failed, aborting...
[2020-10-27T09:41:30+00:00] <42327> (ERROR) Failed, aborting...
[2020-10-27T09:41:30+00:00] <42157> (ERROR) Failed, aborting...


NwAdminServer /var/log/netwitness/orchestration-server/orchestration-server.log
2020-10-27 09:41:21,513 [cfg-mgmt-0] ERROR TaskManagement|Execution of '5f97eb32a7a95b14e69888d8' failed
java.lang.IllegalStateException: Pre-update check failed on host 42f84310-f0f3-41ab-925d-adc0b9241e05, required ports unavailable for communication

Cause

This error is due to the salt-minion service stopped in NwHost.

Resolution

Please follow the below instructions to complete the update.
  1. Login to putty of NwHost and start salt-minion service using below command.
    systemctl start salt-minion.service
     
  2. Run update below command again in NwAdminServer to complete update successfully.
    upgrade-cli-client --upgrade --host-addr <nwhostIP> --version 11.3.2.0
Tags (12)
  • Customer Support Article
  • KB Article
  • Knowledge Article
  • Knowledge Base
  • NetWitness
  • NetWitness Platform
  • NW
  • RSA NetWitness
  • RSA NetWitness Platform
  • RSA Security Analytics
  • Security Analytics
  • SIEM
0 Likes
Was this article helpful? Yes No
No ratings

In this article

Version history
Last update:
‎2022-02-10 01:59 PM
Updated by:
Administrator nwinfotech Administrator

Related Content

Powered by Khoros
  • Blog
  • Events
  • Discussions
  • Idea Exchange
  • Knowledge Base
  • Case Portal
  • Community Support
  • Product Life Cycle
  • Support Information
  • About the Community
  • Terms & Conditions
  • Privacy Statement
  • Acceptable Use Policy
  • Employee Login
© 2022 RSA Security LLC or its affiliates. All rights reserved.