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RSA ECAT Console Server cannot locate database after upgrade from 4.1.1.0 to higher versions

Article Number

000001650

Applies To

RSA Product Set: ECAT
RSA Product/Service Type: Console Server
RSA Version/Condition: 4.1.1.0, 4.2.x, 4.3.x, 4.4.x
Platform: Windows
O/S Version: Server 2012 R2, Server 2008 R2

Issue

ECAT Server fails to start up.

ECAT server no longer communicates with Database after upgrading from 4.1.0.2 to 4.1.1.0
The ECAT ConsoleServer.log throws the following error:
 
[6] System.Data.SqlClient.SqlException:
A network-related or instance-specific error occurred while establishing a connection to SQL Server. 
The server was not found or was not accessible. 
Verify that the instance name is correct and that SQL Server is configured to allow remote connections.
(provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
SQL Error Code: 80131904


The ConsoleSever output window throws the following warning message:
 
Connecting to database ENTER_SERVER_AND_INSTANCE_NAME_HERE on ENTER_DATABASE_NAME_HERE ...

Screenshot of the ConsoleServerServiceOut.exe output:

Cause

This is due to a bug in the ECAT 4.1.1.0 Installer.
Instead of the database instance and database server name, the installer will insert placeholders.
ECAT server will use the placeholder value, instead of the real database name when trying to establish a connection to the database.


 

Resolution

Navigate to the <Drive>:\ECAT\Server folder.
There should be more than one copy of the ConsoleServer.exe.config file.
Find the one that has a placeholder value in it, and rename it to ConsoleServer.exe.config-not_working
If the good one has a different file extension, rename it to ConsoleServer.exe.config and re-start the ECAT Console Service.
 
Tags (12)
  • Customer Support Article
  • KB Article
  • Knowledge Article
  • Knowledge Base
  • NetWitness
  • NetWitness Platform
  • NW
  • RSA NetWitness
  • RSA NetWitness Platform
  • RSA Security Analytics
  • Security Analytics
  • SIEM
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Last update:
‎2022-02-10 01:24 PM
Updated by:
Administrator nwinfotech Administrator

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