Article Number
000001279
Applies To
RSA Product Set: ECAT, NetWitness Endpoint
RSA Product/Service Type: ECAT
RSA Version/Condition: 4.2.0.4,4.3.0.2
Platform: Windows
O/S Version: Server 2012 R2
Product Name: RSA-0015010
Product Description: RSA ECAT Host License (per host)
Issue
A runtime error has occurs when upgrading the UI from 4.2.0.4 to 4.3.0.2. Note this may be present on other upgrades, but this was the observed version. The error is listed below:
Runtime Error (at 193:2119):
Error on line 0, position 0: The system cannot find the path specified
Cause
This seems to be attempting to update a path/location that is either inaccessible or missing. The exact cause is currently unknown.
Resolution
There are two ways to try and remediate this. The first is shown below:
1. Uninstall fully the previous ECAT UI. Go into the software installer for that version of RSA ECAT and launch the installer.
2. Assuming the ECAT UI is the only item already installed, when hitting Next, deselect the UI under Custom Installation, and uninstall the product.
3. Complete the uninstallation.
4. Run the new NWE installer, select the UI, and complete the installation.
If the uninstall option above fails, the next option can be attempted:
- On a test machine, install the NWE UI, using the installer. If it errors, try different OS's until it completes.
- Copy the NWE UI folder (default location C:\Program Files\RSA\ECAT\UI) to the target machine, and overwrite the original ECAT UI folder.
- Launch the NWE UI (ECATUI.exe), and it should run like normal.
Workaround
If none of this works, contact RSA Customer Support for a copy of the NWE UI folder from the target version of the ECAT installer.