Article Number
000033203
Applies To
RSA Product Set: Security Analytics
RSA Product/Service Type: SA Security Analytics UI
RSA Version/Condition: 10.5.2, 10.6.0, 10.6.0.1
Issue
After upgrading to Security Analytics version 10.5.2 or 10.6.0.1, the licensing overview page shows no licenses, as in the image below:
Image description
SA.log file show error:
2016-07-01 17:24:36,274 [qtp684874119-256] ERROR com.rsa.smc.sa.admin.web.controller.ajax.AdminSystemLicensingController - null
java.lang.NullPointerException
at com.rsa.smc.sa.admin.service.entitlement.DefaultEntitlementService.getPerpetualDevices(DefaultEntitlementService.java:393)
at com.rsa.smc.sa.admin.web.controller.ajax.AdminSystemLicensingController.getOtherDevices(AdminSystemLicensingController.java:194)
at com.rsa.smc.sa.admin.web.controller.ajax.AdminSystemLicensingController$$FastClassBySpringCGLIB$$c11ab5d1.invoke(<generated>)
at org.springframework.cglib.proxy.MethodProxy.invoke(MethodProxy.java:204)
Cause
A problem has been detected in the Java code that does not render the licenses to show in the UI. It does not affect the actual licensing process itself; the services are still licensed correctly.
Resolution
Some of these issues have been addressed and are resolved in RSA Security Analytics version 10.6.1. If you are using metered licenses and have already upgraded to 10.6.1 and still see this we are aware of this and are planning on fixing this in a future release.