This website uses cookies. By clicking Accept, you consent to the use of cookies. Click Here to learn more about how we use cookies.
Accept
Reject

NetWitness Community

  • Home
  • Products
    • NetWitness Platform
      • Advisories
      • Documentation
        • Platform Documentation
        • Known Issues
        • Security Fixes
        • Hardware Documentation
        • Threat Content
        • Unified Data Model
        • Videos
      • Downloads
      • Integrations
      • Knowledge Base
    • NetWitness Cloud SIEM
      • Advisories
      • Documentation
      • Knowledge Base
    • NetWitness Detect AI
      • Advisories
      • Documentation
      • Knowledge Base
    • NetWitness Investigator
    • NetWitness Orchestrator
      • Advisories
      • Documentation
      • Knowledge Base
      • Legacy NetWitness Orchestrator
        • Advisories
        • Documentation
  • Community
    • Blog
    • Discussions
    • Events
    • Idea Exchange
  • Support
    • Case Portal
      • Create New Case
      • View My Cases
      • View My Team's Cases
    • Community Support
      • Getting Started
      • News & Announcements
      • Community Support Forum
      • Community Support Articles
    • Product Life Cycle
    • Support Information
    • General Security Advisories
  • Training
    • Blog
    • Certification Program
    • Course Catalog
    • New Product Readiness
    • On-Demand Subscriptions
    • Student Resources
    • Upcoming Events
  • Technology Partners
  • Trust Center
Sign InRegister Now
cancel
Turn on suggestions
Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type.
Showing results for 
Search instead for 
Did you mean: 
NetWitness Knowledge Base Archive
cancel
Turn on suggestions
Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type.
Showing results for 
Search instead for 
Did you mean: 
  • NetWitness Community
  • NetWitness Knowledge Base Archive
  • Configuring Context Hub Source
  • Options
    • Subscribe to RSS Feed
    • Bookmark
    • Subscribe
    • Email to a Friend
    • Printer Friendly Page
    • Report Inappropriate Content

Configuring Context Hub Source

Article Number

000035719

Applies To

RSA Product Set: NetWitness Endpoint, NetWitness Platform
RSA Product/Service Type: NetWitness Endpoint
RSA Version/Condition: 4.3.x., 4.4.x



 

Issue

Configuring the Data Source NW Endpoint for NetWitness Logs and Packets ESA.
The test connection fails.

Cause

The two most likely causes would be the REST API interface is not reachable from the ESA node, or the account that is used does not have sufficient permissions.

Resolution

The Context Hub connection handled by the NW Endpoint REST API.
The REST API, will get the data from the ECAT database. Each component has to be working and the account that is used by the Content Hub has to read rights to the database.

The first step is to logon to the NW Endpoint UI then from the menu.
Configure -> Monitoring and External Components. 
In the upper right-hand corner, there should be green check mark and if you hover over the box, a green check mark text will appear "API server is running correctly".
You can move on to next step.
(repair of API server is out of scope for this KB article)

Logon to the machine that is hosting the NW Endpoint Console Server.
Open up web browser and insert into address bar:

https://localhost/:9443/api/v2/swagger-ui
This will bring up the API server UI.
Next step is to enter the credentials of the account that is used and run a test by scrolling down to health: API Server Health click show/hide option and scroll down to "Try it out"
Scroll down to the Response Body panel, and if the account displays message "Invalid Username or Password" create an SQL account via the NW Endpoint UI
(Configure -> Manage Users and Roles)
The account is given read-only which should suffice.

Test again and this time the Response Body will contain details about the API server health.

If this step passes, next step is to verify that the API Interface is available from the Net Witness Logs and Packets ESA server.

From the console or putty session to on the ESA server to the  host running the Console server use curl to verify if connection can be made:

curl -v -k https://<FQDN or IP of ECAT server>:9443

If the commend times out, you need to contact the network team investigate why the host cannot reach the NW Endpoint Console Server.

Tags (27)
  • 4
  • 4.3
  • 4.3.x
  • 4.x
  • Customer Support Article
  • ECAT
  • Endpoint
  • KB Article
  • Knowledge Article
  • Knowledge Base
  • NetWitness
  • NetWitness Endpoint
  • NetWitness Platform
  • NW
  • NW Endpoint
  • NWE
  • RSA ECAT
  • RSA NetWitness
  • RSA NetWitness Endpoint
  • RSA NetWitness Platform
  • RSA Security Analytics
  • Security Analytics
  • SIEM
  • Version 4
  • Version 4.3
  • Version 4.3.x
  • Version 4.x
0 Likes
Was this article helpful? Yes No
Share
No ratings

In this article

Version history
Last update:
‎2021-08-26 01:15 PM
Updated by:
Administrator RSA-KB-Sync Administrator

Related Content

Powered by Khoros
  • Blog
  • Events
  • Discussions
  • Idea Exchange
  • Knowledge Base
  • Case Portal
  • Community Support
  • Product Life Cycle
  • Support Information
  • About the Community
  • Terms & Conditions
  • Privacy Statement
  • Acceptable Use Policy
  • Employee Login
© 2022 RSA Security LLC or its affiliates. All rights reserved.