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Exception System Error is displayed when attempting to perform a Malware Analysis investigation in RSA Security Analytics

Article Number

000030745

Applies To

RSA Product Set: Security Analytics
RSA Product/Service Type: Malware Analysis, Security Analytics UI
RSA Version/Condition: 10.4.x, 10.5.x
Platform: CentOS
O/S Version: 6

Issue

An Exception System Error page is displayed when navigating to the Investigation -> Malware Analysis page in the Security Analytics UI, which also displays the error message below.
java.lang.RunTimeException:
org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.NullPointerException
Image descriptionImage description

Cause

This issue occurs when a default Malware Analysis service has not been configured in the Security Analytics UI.

Workaround

To resolve the issue, define a default Malware Analysis service by performing the steps below.
  1. In the Security Analytics UI, navigate to the Administration -> Services page.
  2. Click on the red Actions button for the Malware Analysis service that you wish to be the default, and select View -> Config.
  3. Take note of the device number listed in the URL for the Config page, as shown in the screenshot below.
    Image descriptionImage description
  4. Navigate directly to the following URL, replacing <deviceNumber> with the number from Step 3:  https://<securityAnalyticsServer>/investigation/<deviceNumber>/malware
  5. On the Summary page that loads, click on the device name underneath the Summary of Events heading, as shown in the example below.
    Image descriptionImage description
  6. Under the Malware Services section of the dialog box that appears, click on the service you wish to be the default and click on the Default Service button.
    Image descriptionImage description

After making this change, you will be able to navigate to the Investigation -> Malware Analysis page without seeing the Exception System Error message.

If you are unsure of any of the steps above or experience any issues, contact RSA Support and quote this article number for further assistance.
Tags (25)
  • Appliance
  • Core Appliance
  • Customer Support Article
  • KB Article
  • Knowledge Article
  • Knowledge Base
  • Malware
  • Malware Analysis
  • NetWitness
  • NetWitness Appliance
  • NetWitness Platform
  • NetWitness UI
  • NW
  • NW Appliance
  • RSA NetWitness
  • RSA NetWitness Platform
  • RSA NetWitness UI
  • RSA Security Analytics
  • RSA Security Analytics UI
  • Security Analytics
  • Security Analytics UI
  • SIEM
  • UI
  • User Interface
  • Web Interface
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Version history
Last update:
‎2020-12-13 08:13 AM
Updated by:
Administrator RSA-KB-Sync Administrator

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