This website uses cookies. By clicking Accept, you consent to the use of cookies. Click Here to learn more about how we use cookies.
Accept
Reject

NetWitness Community

  • Home
  • Products
    • NetWitness Platform
      • Advisories
      • Documentation
        • Platform Documentation
        • Known Issues
        • Security Fixes
        • Hardware Documentation
        • Threat Content
        • Unified Data Model
        • Videos
      • Downloads
      • Integrations
      • Knowledge Base
    • NetWitness Cloud SIEM
      • Advisories
      • Documentation
      • Knowledge Base
    • NetWitness Detect AI
      • Advisories
      • Documentation
      • Knowledge Base
    • NetWitness Investigator
    • NetWitness Orchestrator
      • Advisories
      • Documentation
      • Knowledge Base
      • Legacy NetWitness Orchestrator
        • Advisories
        • Documentation
  • Community
    • Blog
    • Discussions
    • Events
    • Idea Exchange
  • Support
    • Case Portal
      • Create New Case
      • View My Cases
      • View My Team's Cases
    • Community Support
      • Getting Started
      • News & Announcements
      • Community Support Forum
      • Community Support Articles
    • Product Life Cycle
    • Support Information
    • General Security Advisories
  • Training
    • Blog
    • Certification Program
    • Course Catalog
    • New Product Readiness
    • On-Demand Subscriptions
    • Student Resources
    • Upcoming Events
  • Technology Partners
  • Trust Center
Sign InRegister Now
cancel
Turn on suggestions
Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type.
Showing results for 
Search instead for 
Did you mean: 
NetWitness Knowledge Base Archive
cancel
Turn on suggestions
Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type.
Showing results for 
Search instead for 
Did you mean: 
Announcement Banner

Scheduled Maintenance for the Case Portal during May 27-29

View Details
  • NetWitness Community
  • NetWitness Knowledge Base Archive
  • 'NWEAgent.exe /testnet' failed even dedicated network ports are opened
  • Options
    • Subscribe to RSS Feed
    • Bookmark
    • Subscribe
    • Email to a Friend
    • Printer Friendly Page
    • Report Inappropriate Content

'NWEAgent.exe /testnet' failed even dedicated network ports are opened

Article Number

000039987

Applies To

RSA Product Set: RSA NetWitness Platform
RSA Product/Service Type: Endpoint Advanced Agent
RSA Version/Condition: 11.6.x
 

Issue

NetWitness Endpoint Agent with NAT couldn't communicate with NetWitness Endpoint Server.
Network team confirmed that all ports for Endpoint server/agents are opened and network test tools(nmap) shows that it can communicate via the dedicated ports.
But 'NWEAgent.exe /testnet' results failure.


Image descriptionImage description

Cause

The agent with NAT is in the same Endpoint sources group with other non-NAT agents, and same policy is applied. 
Endpoint Agents with NAT should have an independent policy and group with Endpoint Server Forwarder configuration.

Resolution

  1. Go to UI - Admin - Endpoint Sources page, and click Policies tab.
  2. Create a new policy for the Agents with NAT. Make sure you select 'Endpoint Server Settings' and enter the correct Forwarder information.
    Image descriptionImage description

     

  3. Go to Groups tab, and create a new group with the agent with NAT and the policy you create at step2.
  4. Go to Agent Packager page(Admin - Services - Endpoint Server - Config - Agent Packager tab). And enter the Endpoint Server Forwarder, then click 'Generate Agent Packager'.
  5. Move the packager file to the agent machine.
  6. Remove the old NWEAgent.
    C:\> msiexec  /x {63AC4523-5F19-42F0-BC43-97C8B5373589}
  7. Run the AgentPackager.exe as administrator, then run the nwe-agent-package.exe.
  8. Check the connectivity with 'NWEAgent.exe /testnet'
Tags (28)
  • 11.x
  • Break Fix
  • Break Fix Issue
  • Broken
  • Customer Support Article
  • ECAT
  • Endpoint
  • Issue
  • Issues
  • KB Article
  • Knowledge Article
  • Knowledge Base
  • NetWitness
  • NetWitness Endpoint
  • NetWitness Platform
  • NW
  • NW Endpoint
  • NWE
  • Problem
  • RSA ECAT
  • RSA NetWitness
  • RSA NetWitness Endpoint
  • RSA NetWitness Platform
  • RSA Security Analytics
  • Security Analytics
  • SIEM
  • Version 11
  • Version 11.x
0 Likes
Was this article helpful? Yes No
Share
No ratings

In this article

Version history
Last update:
‎2021-12-17 06:50 AM
Updated by:
Administrator RSA-KB-Sync Administrator

Related Content

Powered by Khoros
  • Blog
  • Events
  • Discussions
  • Idea Exchange
  • Knowledge Base
  • Case Portal
  • Community Support
  • Product Life Cycle
  • Support Information
  • About the Community
  • Terms & Conditions
  • Privacy Statement
  • Acceptable Use Policy
  • Employee Login
© 2022 RSA Security LLC or its affiliates. All rights reserved.