This website uses cookies. By clicking Accept, you consent to the use of cookies. Click Here to learn more about how we use cookies.
Accept
Reject

NetWitness Community

  • Home
  • Products
    • NetWitness Platform
      • Advisories
      • Documentation
        • Platform Documentation
        • Known Issues
        • Security Fixes
        • Hardware Documentation
        • Threat Content
        • Unified Data Model
        • Videos
      • Downloads
      • Integrations
      • Knowledge Base
    • NetWitness Cloud SIEM
      • Advisories
      • Documentation
      • Knowledge Base
    • NetWitness Detect AI
      • Advisories
      • Documentation
      • Knowledge Base
    • NetWitness Investigator
    • NetWitness Orchestrator
      • Advisories
      • Documentation
      • Knowledge Base
      • Legacy NetWitness Orchestrator
        • Advisories
        • Documentation
  • Community
    • Blog
    • Discussions
    • Events
    • Idea Exchange
  • Support
    • Case Portal
      • Create New Case
      • View My Cases
      • View My Team's Cases
    • Community Support
      • Getting Started
      • News & Announcements
      • Community Support Forum
      • Community Support Articles
    • Product Life Cycle
    • Support Information
    • General Security Advisories
  • Training
    • Blog
    • Certification Program
    • Course Catalog
    • New Product Readiness
    • On-Demand Subscriptions
    • Student Resources
    • Upcoming Events
  • Technology Partners
  • Trust Center
Sign InRegister Now
cancel
Turn on suggestions
Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type.
Showing results for 
Search instead for 
Did you mean: 
NetWitness Knowledge Base Archive
cancel
Turn on suggestions
Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type.
Showing results for 
Search instead for 
Did you mean: 
  • NetWitness Community
  • NetWitness Knowledge Base Archive
  • Permissions for custom roles missing after upgrading to RSA Security Analytics 10.5.0.0
  • Options
    • Subscribe to RSS Feed
    • Bookmark
    • Subscribe
    • Email to a Friend
    • Printer Friendly Page
    • Report Inappropriate Content

Permissions for custom roles missing after upgrading to RSA Security Analytics 10.5.0.0

Article Number

000030761

Applies To

RSA Product Set: Security Analytics
RSA Product/Service Type: Security Analytics UI, Security Analytics Server
RSA Version/Condition: 10.5.0.0
Platform: CentOS
O/S Version: EL6
 

Issue

After upgrading from Security Analytics 10.4.x to 10.5, the permissions of roles created prior to the upgrade are missing.

Pre-upgrade:
Image descriptionImage description

Post-upgrade:
Image descriptionImage description

Cause

Security Analytics reads role permissions from the security-policy folder. This issue occurs because in version 10.5, the security-policy folder path is incorrectly set to /opt/rsa/jetty9/target/rsa/ when it should be /var/lib/netwintess/uax/. Due to this wrong path, the 10.4 custom permissions are not shown in the Security Analytics UI.
 

Resolution

This issue is permanently resolved in Security Analytics 10.5.0.1.

Workaround

To resolve the issue, we would need to copy the security-policy folder from /var/lib/netwintess/uax/ to /opt/rsa/jetty9/target/rsa/.
The steps are:
 
  1. Stop the puppet and jettysrv services.
    service puppet stop
    stop jettysrv
  2. Go to the /opt/rsa/jetty9/target/rsa/ directory.
    cd /opt/rsa/jetty9/target/rsa/
  3. Rename security-policy folder.
    mv security-policy security-policy.old
  4. Copy the security-policy folder from /var/lib/netwintess/uax/ to the /opt/rsa/jetty9/target/rsa/ directory.
    cp -pR /var/lib/netwitness/uax/security-policy/ security-policy/
  5. Start the puppet and jettysrv services.
    service puppet start
    start jettysrv

If you are unsure of any of the steps above or experience any issues, contact RSA Support and quote this article number for further assistance.
Tags (33)
  • Appliance
  • Broker
  • Broker Appliance
  • Core Appliance
  • Customer Support Article
  • Head Unit
  • HeadUnit
  • KB Article
  • Knowledge Article
  • Knowledge Base
  • NetWitness
  • NetWitness Appliance
  • NetWitness Broker
  • NetWitness Head Unit
  • NetWitness Platform
  • NetWitness Server
  • NetWitness UI
  • NW
  • NW Appliance
  • NwBroker
  • RSA NetWitness
  • RSA NetWitness Platform
  • RSA NetWitness UI
  • RSA Security Analytics
  • RSA Security Analytics UI
  • Security Analytics
  • Security Analytics Server
  • Security Analytics UI
  • SIEM
  • UI
  • UI Server
  • User Interface
  • Web Interface
0 Likes
Was this article helpful? Yes No
Share
No ratings

In this article

Version history
Last update:
‎2020-12-13 08:13 AM
Updated by:
Administrator RSA-KB-Sync Administrator

Related Content

Powered by Khoros
  • Blog
  • Events
  • Discussions
  • Idea Exchange
  • Knowledge Base
  • Case Portal
  • Community Support
  • Product Life Cycle
  • Support Information
  • About the Community
  • Terms & Conditions
  • Privacy Statement
  • Acceptable Use Policy
  • Employee Login
© 2022 RSA Security LLC or its affiliates. All rights reserved.